Sandbox.ModAPI Namespace

[Missing <summary> documentation for "N:Sandbox.ModAPI"]

Classes
 | Class | Description
Public class | MyAPIGateway | This is entry point for entire scripting possibilities in game
Structures
 | Structure | Description
Public structure | MyProductionQueueItem |
Interfaces
 | Interface | Description
Public interface | IMyAdvancedDoor |
Public interface | IMyAirtightDoorBase |
Public interface | IMyAirtightHangarDoor |
Public interface | IMyAirtightSlideDoor |
Public interface | IMyAssembler |
Public interface | IMyAttachableTopBlock |
Public interface | IMyBatteryBlock |
Public interface | IMyBeacon |
Public interface | IMyBlockGroup |
Public interface | IMyCameraBlock |
Public interface | IMyCargoContainer |
Public interface | IMyCockpit |
Public interface | IMyCollector |
Public interface | IMyConveyor |
Public interface | IMyConveyorSorter |
Public interface | IMyConveyorTube |
Public interface | IMyCryoChamber |
Public interface | IMyDecoy |
Public interface | IMyDoor |
Public interface | IMyExtendedPistonBase |
Public interface | IMyFunctionalBlock |
Public interface | IMyGasGenerator | Gas generator interface
Public interface | IMyGasTank |
Public interface | IMyGridProgram | The interface for the grid program provides extra access for the game and for mods. See MyGridProgram for the class the scripts actually derive from.
Public interface | IMyGridTerminalSystem |
Public interface | IMyGyro |
Public interface | IMyIngameScripting |
Public interface | IMyInventoryBag | Inventory bag spawned when character died, container breaks, or when entity from other inventory cannot be spawned then bag spawned with the item in its inventory.
Public interface | IMyJumpDrive |
Public interface | IMyLargeTurretBase |
Public interface | IMyLaserAntenna | ModAPI laserantenna block interface
Public interface | IMyLightingBlock |
Public interface | IMyMechanicalConnectionBlock |
Public interface | IMyMeteor |
Public interface | IMyMotorAdvancedRotor |
Public interface | IMyMotorAdvancedStator |
Public interface | IMyMotorBase |
Public interface | IMyMotorRotor |
Public interface | IMyMotorStator |
Public interface | IMyMotorSuspension |
Public interface | IMyOreDetector |
Public interface | IMyOxygenGenerator | Obsolete.
Public interface | IMyOxygenTank | Obsolete.
Public interface | IMyPassage |
Public interface | IMyPistonBase |
Public interface | IMyPistonTop |
Public interface | IMyProductionBlock |
Public interface | IMyProgrammableBlock |
Public interface | IMyProjector |
Public interface | IMyRadioAntenna |
Public interface | IMyReactor |
Public interface | IMyRefinery |
Public interface | IMyReflectorLight |
Public interface | IMyRemoteControl |
Public interface | IMyScriptBlacklist | Exposes blacklist functionality to allow mods to disallow parts of the scripting API that has been allowed by the system whitelist.
Public interface | IMyScriptBlacklistBatch | A handle which enables adding members to the blacklist in a batch. It is highly recommended that you try to group your changes into as few batches as possible.
Public interface | IMySensorBlock |
Public interface | IMyShipConnector |
Public interface | IMyShipController |
Public interface | IMyShipDrill |
Public interface | IMyShipGrinder |
Public interface | IMyShipToolBase |
Public interface | IMyShipWelder | Ship welder interface
Public interface | IMySmallGatlingGun |
Public interface | IMySmallMissileLauncher |
Public interface | IMySmallMissileLauncherReload |
Public interface | IMyTerminalActionsHelper |
Public interface | IMyTerminalBlock |
Public interface | IMyTerminalControls | This interface allows you to query, add or remove terminal controls for a block. The terminal controls are the controls that appear in the terminal screen when you select a block. You may add new controls, remove existing controls, or modify existing controls.
Public interface | IMyTextPanel |
Public interface | IMyThrust |
Public interface | IMyUpgradableBlock | interface to retrieve upgrade effects from block IMyUpgradableBlock
Public interface | IMyUserControllableGun |
Public interface | IMyWarhead |
Public interface | IMyWheel |
Delegates
 | Delegate | Description
Public delegate | CustomActionGetDelegate | Allows you to modify the actions associated with a block before it's displayed to user.
Public delegate | CustomControlGetDelegate | Allows you to modify the terminal control list before it is displayed to the user. Modifying controls will change which controls are displayed.
Enumerations
 | Enumeration | Description
Public enumeration | BuildCheckResult |
Public enumeration | MyWhitelistTarget | Determines what target a whitelisting entry does or should support.


BuildCheckResult Enumeration

[Missing <summary> documentation for "T:Sandbox.ModAPI.BuildCheckResult"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BuildCheckResult
Public Enumeration BuildCheckResult
public enum class BuildCheckResult
type BuildCheckResult
Members
Member name | Value | Description
OK | 0 |
NotConnected | 1 |
IntersectedWithGrid | 2 |
IntersectedWithSomethingElse | 3 |
AlreadyBuilt | 4 |
NotFound | 5 |
See Also

Reference

Sandbox.ModAPI Namespace


CustomActionGetDelegate Delegate

Allows you to modify the actions associated with a block before it's displayed to user.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CustomActionGetDelegate(
    IMyTerminalBlock block,
    List<IMyTerminalAction> actions
)
Public Delegate Sub CustomActionGetDelegate (
    block As IMyTerminalBlock,
    actions As List(Of IMyTerminalAction)
)
public delegate void CustomActionGetDelegate(
    IMyTerminalBlock^ block,
    List<IMyTerminalAction^>^ actions
)
type CustomActionGetDelegate =
    delegate of
        block : IMyTerminalBlock *
        actions : List<IMyTerminalAction> -> unit

Parameters

block
Type: Sandbox.ModAPIIMyTerminalBlock
The block actions are associated with
actions
Type: System.Collections.GenericList IMyTerminalAction
The list of actions for this block
See Also

Reference

Sandbox.ModAPI Namespace


CustomControlGetDelegate Delegate

Allows you to modify the terminal control list before it is displayed to the user. Modifying controls will change which controls are displayed.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CustomControlGetDelegate(
    IMyTerminalBlock block,
    List<IMyTerminalControl> controls
)
Public Delegate Sub CustomControlGetDelegate (
    block As IMyTerminalBlock,
    controls As List(Of IMyTerminalControl)
)
public delegate void CustomControlGetDelegate(
    IMyTerminalBlock^ block,
    List<IMyTerminalControl^>^ controls
)
type CustomControlGetDelegate =
    delegate of
        block : IMyTerminalBlock *
        controls : List<IMyTerminalControl> -> unit

Parameters

block
Type: Sandbox.ModAPIIMyTerminalBlock
The block that was selected
controls
Type: System.Collections.GenericList IMyTerminalControl
See Also

Reference

Sandbox.ModAPI Namespace


IMyAdvancedDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAdvancedDoor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAdvancedDoor : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAdvancedDoor,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAdvancedDoor
    Inherits IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyAdvancedDoor, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyAdvancedDoor : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAdvancedDoor,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAdvancedDoor =
    interface
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAdvancedDoor
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAdvancedDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAdvancedDoor Properties

The IMyAdvancedDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAdvancedDoor Interface
Sandbox.ModAPI Namespace


IMyAdvancedDoor Methods

The IMyAdvancedDoor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAdvancedDoor Interface
Sandbox.ModAPI Namespace


IMyAdvancedDoor Events

The IMyAdvancedDoor type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyAdvancedDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightDoorBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAirtightDoorBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightDoorBase : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAirtightDoorBase
    Inherits IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyAirtightDoorBase : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAirtightDoorBase =
    interface
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightDoorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAirtightDoorBase Properties

The IMyAirtightDoorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightDoorBase Interface
Sandbox.ModAPI Namespace


IMyAirtightDoorBase Methods

The IMyAirtightDoorBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightDoorBase Interface
Sandbox.ModAPI Namespace


IMyAirtightDoorBase Events

The IMyAirtightDoorBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyAirtightDoorBase Interface
Sandbox.ModAPI Namespace


IMyAirtightHangarDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAirtightHangarDoor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightHangarDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyAirtightHangarDoor, IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyAirtightHangarDoor
    Inherits IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyAirtightHangarDoor, IMyAirtightDoorBase, IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyAirtightHangarDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyAirtightHangarDoor, IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyAirtightHangarDoor =
    interface
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAirtightHangarDoor
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightHangarDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAirtightHangarDoor Properties

The IMyAirtightHangarDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightHangarDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightHangarDoor Methods

The IMyAirtightHangarDoor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightHangarDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightHangarDoor Events

The IMyAirtightHangarDoor type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyAirtightHangarDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightSlideDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAirtightSlideDoor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightSlideDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyAirtightSlideDoor, IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyAirtightSlideDoor
    Inherits IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyAirtightSlideDoor, IMyAirtightDoorBase, IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyAirtightSlideDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyAirtightSlideDoor, IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyAirtightSlideDoor =
    interface
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAirtightSlideDoor
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightSlideDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAirtightSlideDoor Properties

The IMyAirtightSlideDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightSlideDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightSlideDoor Methods

The IMyAirtightSlideDoor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightSlideDoor Interface
Sandbox.ModAPI Namespace


IMyAirtightSlideDoor Events

The IMyAirtightSlideDoor type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged | (Inherited from IMyDoor.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyAirtightSlideDoor Interface
Sandbox.ModAPI Namespace


IMyAssembler Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAssembler"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAssembler : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAssembler,
    IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAssembler
    Inherits IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyAssembler, IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyAssembler : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyAssembler,
    IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAssembler =
    interface
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAssembler
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAssembler type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CooperativeMode | Gets or sets whether this assembler should cooperate with other assemblers by adopting parts of their work queue. (Inherited from IMyAssembler.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentProgress | Gets the progress for the item currently in production. (Inherited from IMyAssembler.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleEnabled | Obsolete. (Inherited from IMyAssembler.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory | (Inherited from IMyProductionBlock.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Gets or sets the current work mode of this assembly, whether it's assembling or disassembling. (Inherited from IMyAssembler.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Repeating | Gets or sets whether this assembler should be perpetually repeating its work queue. (Inherited from IMyAssembler.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CurrentModeChanged | Called when the build mode changes.
Public event | CurrentProgressChanged | Called when the current item build progress changes.
Public event | CurrentStateChanged | Called when the state of the assembler changes.
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing | (Inherited from IMyProductionBlock.)
Public event | StoppedProducing | (Inherited from IMyProductionBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAssembler Properties

The IMyAssembler type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CooperativeMode | Gets or sets whether this assembler should cooperate with other assemblers by adopting parts of their work queue. (Inherited from IMyAssembler.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentProgress | Gets the progress for the item currently in production. (Inherited from IMyAssembler.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleEnabled | Obsolete. (Inherited from IMyAssembler.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory | (Inherited from IMyProductionBlock.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Gets or sets the current work mode of this assembly, whether it's assembling or disassembling. (Inherited from IMyAssembler.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Repeating | Gets or sets whether this assembler should be perpetually repeating its work queue. (Inherited from IMyAssembler.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAssembler Methods

The IMyAssembler type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAssembler Events

The IMyAssembler type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CurrentModeChanged | Called when the build mode changes.
Public event | CurrentProgressChanged | Called when the current item build progress changes.
Public event | CurrentStateChanged | Called when the state of the assembler changes.
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing | (Inherited from IMyProductionBlock.)
Public event | StoppedProducing | (Inherited from IMyProductionBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAssembler.CurrentModeChanged Event

A Sandcastle Documented Class Library

IMyAssemblerCurrentModeChanged Event

Called when the build mode changes.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyAssembler> CurrentModeChanged
Event CurrentModeChanged As Action(Of IMyAssembler)
 event Action<IMyAssembler^>^ CurrentModeChanged {
    void add (Action<IMyAssembler^>^ value);
    void remove (Action<IMyAssembler^>^ value);
}
abstract CurrentModeChanged : IEvent<Action<IMyAssembler>,
    EventArgs>

Value

Type: SystemAction IMyAssembler
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAssembler.CurrentProgressChanged Event

IMyAssemblerCurrentProgressChanged Event

Called when the current item build progress changes.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyAssembler> CurrentProgressChanged
Event CurrentProgressChanged As Action(Of IMyAssembler)
 event Action<IMyAssembler^>^ CurrentProgressChanged {
    void add (Action<IMyAssembler^>^ value);
    void remove (Action<IMyAssembler^>^ value);
}
abstract CurrentProgressChanged : IEvent<Action<IMyAssembler>,
    EventArgs>

Value

Type: SystemAction IMyAssembler
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAssembler.CurrentStateChanged Event

IMyAssemblerCurrentStateChanged Event

Called when the state of the assembler changes.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyAssembler> CurrentStateChanged
Event CurrentStateChanged As Action(Of IMyAssembler)
 event Action<IMyAssembler^>^ CurrentStateChanged {
    void add (Action<IMyAssembler^>^ value);
    void remove (Action<IMyAssembler^>^ value);
}
abstract CurrentStateChanged : IEvent<Action<IMyAssembler>,
    EventArgs>

Value

Type: SystemAction IMyAssembler
See Also

Reference

IMyAssembler Interface
Sandbox.ModAPI Namespace


IMyAttachableTopBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyAttachableTopBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAttachableTopBlock : IMyCubeBlock,
    IMyEntity, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAttachableTopBlock
    Inherits IMyCubeBlock, IMyEntity, IMyAttachableTopBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyAttachableTopBlock : IMyCubeBlock,
    IMyEntity, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
type IMyAttachableTopBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAttachableTopBlock type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyAttachableTopBlock Properties

The IMyAttachableTopBlock type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAttachableTopBlock Interface
Sandbox.ModAPI Namespace


IMyAttachableTopBlock.Base Property

IMyAttachableTopBlockBase Property

Gets the attached base block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyMechanicalConnectionBlock Base { get; }
ReadOnly Property Base As IMyMechanicalConnectionBlock
    Get
property IMyMechanicalConnectionBlock^ Base {
    IMyMechanicalConnectionBlock^ get ();
}
abstract Base : IMyMechanicalConnectionBlock with get

Property Value

Type: IMyMechanicalConnectionBlock
See Also

Reference

IMyAttachableTopBlock Interface
Sandbox.ModAPI Namespace


IMyAttachableTopBlock Methods

The IMyAttachableTopBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyAttachableTopBlock Interface
Sandbox.ModAPI Namespace


IMyAttachableTopBlock Events

The IMyAttachableTopBlock type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyAttachableTopBlock Interface
Sandbox.ModAPI Namespace


IMyBatteryBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyBatteryBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBatteryBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyBatteryBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyBatteryBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyBatteryBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyBatteryBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyBatteryBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyBatteryBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyBatteryBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyBatteryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentInput | (Inherited from IMyBatteryBlock.)
Public property | CurrentOutput | (Inherited from IMyBatteryBlock.)
Public property | CurrentStoredPower | (Inherited from IMyBatteryBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasCapacityRemaining | (Inherited from IMyBatteryBlock.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsCharging | (Inherited from IMyBatteryBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxStoredPower | (Inherited from IMyBatteryBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | OnlyDischarge | (Inherited from IMyBatteryBlock.)
Public property | OnlyRecharge | (Inherited from IMyBatteryBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | SemiautoEnabled | (Inherited from IMyBatteryBlock.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyBatteryBlock Properties

The IMyBatteryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentInput | (Inherited from IMyBatteryBlock.)
Public property | CurrentOutput | (Inherited from IMyBatteryBlock.)
Public property | CurrentStoredPower | (Inherited from IMyBatteryBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasCapacityRemaining | (Inherited from IMyBatteryBlock.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsCharging | (Inherited from IMyBatteryBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxStoredPower | (Inherited from IMyBatteryBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | OnlyDischarge | (Inherited from IMyBatteryBlock.)
Public property | OnlyRecharge | (Inherited from IMyBatteryBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | SemiautoEnabled | (Inherited from IMyBatteryBlock.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyBatteryBlock Interface
Sandbox.ModAPI Namespace


IMyBatteryBlock Methods

The IMyBatteryBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyBatteryBlock Interface
Sandbox.ModAPI Namespace


IMyBatteryBlock Events

The IMyBatteryBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyBatteryBlock Interface
Sandbox.ModAPI Namespace


IMyBeacon Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyBeacon"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBeacon : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyBeacon, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyBeacon
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyBeacon, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyBeacon : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyBeacon, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyBeacon =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyBeacon
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyBeacon type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | (Inherited from IMyBeacon.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyBeacon Properties

The IMyBeacon type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | (Inherited from IMyBeacon.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyBeacon Interface
Sandbox.ModAPI Namespace


IMyBeacon Methods

The IMyBeacon type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyBeacon Interface
Sandbox.ModAPI Namespace


IMyBeacon Events

The IMyBeacon type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyBeacon Interface
Sandbox.ModAPI Namespace


IMyBlockGroup Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyBlockGroup"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBlockGroup : IMyBlockGroup
Public Interface IMyBlockGroup
    Inherits IMyBlockGroup
public interface class IMyBlockGroup : IMyBlockGroup
type IMyBlockGroup =
    interface
        interface IMyBlockGroup
    end

The IMyBlockGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from IMyBlockGroup.)
Top
Methods
 | Name | Description
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyBlockGroup.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyBlockGroup Properties

The IMyBlockGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from IMyBlockGroup.)
Top
See Also

Reference

IMyBlockGroup Interface
Sandbox.ModAPI Namespace


IMyBlockGroup Methods

Methods
 | Name | Description
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyBlockGroup.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Top
See Also

Reference

IMyBlockGroup Interface
Sandbox.ModAPI Namespace


IMyBlockGroup.GetBlocks Method

IMyBlockGroupGetBlocks Method

Overload List
 | Name | Description
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocks(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Top
See Also

Reference

IMyBlockGroup Interface
Sandbox.ModAPI Namespace


IMyBlockGroup.GetBlocks Method (List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyBlockGroupGetBlocks Method (ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocks(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
Sub GetBlocks (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
void GetBlocks(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocks :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyBlockGroup Interface
GetBlocks Overload
Sandbox.ModAPI Namespace


IMyBlockGroup.GetBlocksOfType Method

IMyBlockGroupGetBlocksOfType Method

Overload List
 | Name | Description
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyBlockGroup.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyBlockGroup.)
Top
See Also

Reference

IMyBlockGroup Interface
Sandbox.ModAPI Namespace


IMyBlockGroup.GetBlocksOfType(T) Method (List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyBlockGroupGetBlocksOfTypeT Method (ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
where T : class

Sub GetBlocksOfType(Of T As Class) (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
generic<typename T>
where T : ref class
void GetBlocksOfType(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit  when 'T : not struct

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyBlockGroup Interface
GetBlocksOfType Overload
Sandbox.ModAPI Namespace


IMyCameraBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyCameraBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCameraBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraController
Public Interface IMyCameraBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyCameraBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyCameraController
public interface class IMyCameraBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraController
type IMyCameraBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCameraBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCameraController
    end

The IMyCameraBlock type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | AvailableScanRange | The maximum distance that this camera can scan, based on the time since the last scan. (Inherited from IMyCameraBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableRaycast | When this is true, the available raycast distance will count up, and power usage is increased. (Inherited from IMyCameraBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyCameraController.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Determines whether this camera is currently in use. (Inherited from IMyCameraBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | RaycastConeLimit | Returns the maximum positive angle you can apply for pitch and yaw. (Inherited from IMyCameraBlock.)
Public property | RaycastDistanceLimit | Returns the maximum distance you can request a raycast. -1 means infinite. (Inherited from IMyCameraBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanScan(Double) | Checks if the camera can scan the given distance. (Inherited from IMyCameraBlock.)
Public method | CanScan(Vector3D) | Checks if the camera can scan to the given target (Inherited from IMyCameraBlock.)
Public method | CanScan(Double, Vector3D) | Checks if the camera can scan to the given direction and distance. (Inherited from IMyCameraBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | Raycast(Vector3D) | Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | Raycast(Double, Vector3D) | Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | Raycast(Double, Single, Single) | Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TimeUntilScan | Returns the number of milliseconds until the camera can do a raycast of the given distance. (Inherited from IMyCameraBlock.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyCameraBlock Properties

The IMyCameraBlock type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | AvailableScanRange | The maximum distance that this camera can scan, based on the time since the last scan. (Inherited from IMyCameraBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableRaycast | When this is true, the available raycast distance will count up, and power usage is increased. (Inherited from IMyCameraBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyCameraController.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Determines whether this camera is currently in use. (Inherited from IMyCameraBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | RaycastConeLimit | Returns the maximum positive angle you can apply for pitch and yaw. (Inherited from IMyCameraBlock.)
Public property | RaycastDistanceLimit | Returns the maximum distance you can request a raycast. -1 means infinite. (Inherited from IMyCameraBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCameraBlock Interface
Sandbox.ModAPI Namespace


IMyCameraBlock Methods

The IMyCameraBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanScan(Double) | Checks if the camera can scan the given distance. (Inherited from IMyCameraBlock.)
Public method | CanScan(Vector3D) | Checks if the camera can scan to the given target (Inherited from IMyCameraBlock.)
Public method | CanScan(Double, Vector3D) | Checks if the camera can scan to the given direction and distance. (Inherited from IMyCameraBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | Raycast(Vector3D) | Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | Raycast(Double, Vector3D) | Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | Raycast(Double, Single, Single) | Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds. (Inherited from IMyCameraBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TimeUntilScan | Returns the number of milliseconds until the camera can do a raycast of the given distance. (Inherited from IMyCameraBlock.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCameraBlock Interface
Sandbox.ModAPI Namespace


IMyCameraBlock Events

The IMyCameraBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyCameraBlock Interface
Sandbox.ModAPI Namespace


IMyCargoContainer Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyCargoContainer"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCargoContainer : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyCargoContainer, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
Public Interface IMyCargoContainer
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCargoContainer,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCargoContainer : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyCargoContainer, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
type IMyCargoContainer =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCargoContainer
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCargoContainer type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyCargoContainer Properties

The IMyCargoContainer type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCargoContainer Interface
Sandbox.ModAPI Namespace


IMyCargoContainer Methods

The IMyCargoContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCargoContainer Interface
Sandbox.ModAPI Namespace


IMyCargoContainer Events

The IMyCargoContainer type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyCargoContainer Interface
Sandbox.ModAPI Namespace


IMyCockpit Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyCockpit"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCockpit : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity, IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraController
Public Interface IMyCockpit
    Inherits IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyControllableEntity, IMyCockpit, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyCameraController
public interface class IMyCockpit : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity, IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCameraController
type IMyCockpit =
    interface
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyControllableEntity
        interface IMyCockpit
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCameraController
    end

The IMyCockpit type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets or sets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AttachPilot | Place a pilot in the cockpit seat.
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemovePilot | Removes an attached pilot. Call on server.
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyCockpit Properties

The IMyCockpit type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets or sets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCockpit.OxygenFilledRatio Property

IMyCockpitOxygenFilledRatio Property

Gets or sets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float OxygenFilledRatio { get; set; }
Property OxygenFilledRatio As Single
    Get
    Set
property float OxygenFilledRatio {
    float get ();
    void set (float value);
}
abstract OxygenFilledRatio : float32 with get, set

Property Value

Type: Single

Implements

IMyCockpitOxygenFilledRatio
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCockpit Methods

The IMyCockpit type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AttachPilot | Place a pilot in the cockpit seat.
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemovePilot | Removes an attached pilot. Call on server.
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCockpit.AttachPilot Method

IMyCockpitAttachPilot Method

Place a pilot in the cockpit seat.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AttachPilot(
    IMyCharacter pilot
)
Sub AttachPilot (
    pilot As IMyCharacter
)
void AttachPilot(
    IMyCharacter^ pilot
)
abstract AttachPilot :
        pilot : IMyCharacter -> unit

Parameters

pilot
Type: IMyCharacter
Character to place in seat
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCockpit.RemovePilot Method

IMyCockpitRemovePilot Method

Removes an attached pilot. Call on server.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemovePilot()
Sub RemovePilot
void RemovePilot()
abstract RemovePilot : unit -> unit
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCockpit Events

The IMyCockpit type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyCockpit Interface
Sandbox.ModAPI Namespace


IMyCollector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyCollector"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCollector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCollector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyCollector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyCollector, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCollector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyCollector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyCollector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCollector
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCollector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyCollector.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyCollector Properties

The IMyCollector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyCollector.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCollector Interface
Sandbox.ModAPI Namespace


IMyCollector Methods

The IMyCollector type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCollector Interface
Sandbox.ModAPI Namespace


IMyCollector Events

The IMyCollector type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyCollector Interface
Sandbox.ModAPI Namespace


IMyConveyor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyConveyor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyor : IMyCubeBlock,
    IMyEntity, IMyConveyor, IMyCubeBlock, IMyEntity
Public Interface IMyConveyor
    Inherits IMyCubeBlock, IMyEntity, IMyConveyor, IMyCubeBlock,
    IMyEntity
public interface class IMyConveyor : IMyCubeBlock,
    IMyEntity, IMyConveyor, IMyCubeBlock, IMyEntity
type IMyConveyor =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyConveyor
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyConveyor Properties

The IMyConveyor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyor Interface
Sandbox.ModAPI Namespace


IMyConveyor Methods

The IMyConveyor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyor Interface
Sandbox.ModAPI Namespace


IMyConveyor Events

The IMyConveyor type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyor Interface
Sandbox.ModAPI Namespace


IMyConveyorSorter Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyConveyorSorter"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyorSorter : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyConveyorSorter, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyConveyorSorter
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyConveyorSorter, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyConveyorSorter : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyConveyorSorter, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyConveyorSorter =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyConveyorSorter
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyorSorter type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrainAll | Determines whether the sorter should drain any inventories connected to it and push them to the other side - as long as the items passes the filtering as defined by the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode. (Inherited from IMyConveyorSorter.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Determines the current mode of this sorter. Use [!:SetWhitelist] or [!:SetBlacklist] to change the mode. (Inherited from IMyConveyorSorter.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddItem | Adds a single item to the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or fill the entire list in one go. (Inherited from IMyConveyorSorter.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFilterList | Gets the items currently being allowed through or rejected, depending on the Mode. (Inherited from IMyConveyorSorter.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsAllowed | Determines whether a given item type is allowed through the sorter, depending on the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode. (Inherited from IMyConveyorSorter.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveItem | Removes a single item from the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or clear the entire list in one go. (Inherited from IMyConveyorSorter.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetFilter | Changes the sorter to desired mode and filters the provided items. You can pass in null to empty the list. (Inherited from IMyConveyorSorter.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyConveyorSorter Properties

The IMyConveyorSorter type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrainAll | Determines whether the sorter should drain any inventories connected to it and push them to the other side - as long as the items passes the filtering as defined by the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode. (Inherited from IMyConveyorSorter.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Determines the current mode of this sorter. Use [!:SetWhitelist] or [!:SetBlacklist] to change the mode. (Inherited from IMyConveyorSorter.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyorSorter Interface
Sandbox.ModAPI Namespace


IMyConveyorSorter Methods

The IMyConveyorSorter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds a single item to the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or fill the entire list in one go. (Inherited from IMyConveyorSorter.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFilterList | Gets the items currently being allowed through or rejected, depending on the Mode. (Inherited from IMyConveyorSorter.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsAllowed | Determines whether a given item type is allowed through the sorter, depending on the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode. (Inherited from IMyConveyorSorter.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveItem | Removes a single item from the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or clear the entire list in one go. (Inherited from IMyConveyorSorter.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetFilter | Changes the sorter to desired mode and filters the provided items. You can pass in null to empty the list. (Inherited from IMyConveyorSorter.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyConveyorSorter Interface
Sandbox.ModAPI Namespace


IMyConveyorSorter Events

The IMyConveyorSorter type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyConveyorSorter Interface
Sandbox.ModAPI Namespace


IMyConveyorTube Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyConveyorTube"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyorTube : IMyCubeBlock,
    IMyEntity, IMyConveyorTube, IMyCubeBlock, IMyEntity
Public Interface IMyConveyorTube
    Inherits IMyCubeBlock, IMyEntity, IMyConveyorTube, IMyCubeBlock,
    IMyEntity
public interface class IMyConveyorTube : IMyCubeBlock,
    IMyEntity, IMyConveyorTube, IMyCubeBlock, IMyEntity
type IMyConveyorTube =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyConveyorTube
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyorTube type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyConveyorTube Properties

The IMyConveyorTube type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyorTube Interface
Sandbox.ModAPI Namespace


IMyConveyorTube Methods

The IMyConveyorTube type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyorTube Interface
Sandbox.ModAPI Namespace


IMyConveyorTube Events

The IMyConveyorTube type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyorTube Interface
Sandbox.ModAPI Namespace


IMyCryoChamber Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyCryoChamber"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCryoChamber : IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity,
    IMyCameraController, IMyCryoChamber, IMyCockpit, IMyShipController, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyCryoChamber
    Inherits IMyCockpit, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyControllableEntity, IMyCameraController, IMyCryoChamber, IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCryoChamber : IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity,
    IMyCameraController, IMyCryoChamber, IMyCockpit, IMyShipController, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyCryoChamber =
    interface
        interface IMyCockpit
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyControllableEntity
        interface IMyCameraController
        interface IMyCryoChamber
        interface IMyCockpit
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCryoChamber type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets or sets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full). (Inherited from IMyCockpit.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AttachPilot | Place a pilot in the cockpit seat. (Inherited from IMyCockpit.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemovePilot | Removes an attached pilot. Call on server. (Inherited from IMyCockpit.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyCryoChamber Properties

The IMyCryoChamber type exposes the following members.

Properties
 | Name | Description
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets or sets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full). (Inherited from IMyCockpit.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCryoChamber Interface
Sandbox.ModAPI Namespace


IMyCryoChamber Methods

The IMyCryoChamber type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AttachPilot | Place a pilot in the cockpit seat. (Inherited from IMyCockpit.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemovePilot | Removes an attached pilot. Call on server. (Inherited from IMyCockpit.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCryoChamber Interface
Sandbox.ModAPI Namespace


IMyCryoChamber Events

The IMyCryoChamber type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyCryoChamber Interface
Sandbox.ModAPI Namespace


IMyDecoy Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyDecoy"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyDecoy : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyDecoy, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyDecoy
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyDecoy, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyDecoy : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyDecoy, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyDecoy =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyDecoy
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyDecoy type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyDecoy Properties

The IMyDecoy type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyDecoy Interface
Sandbox.ModAPI Namespace


IMyDecoy Methods

The IMyDecoy type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyDecoy Interface
Sandbox.ModAPI Namespace


IMyDecoy Events

The IMyDecoy type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyDecoy Interface
Sandbox.ModAPI Namespace


IMyDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyDoor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyDoor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyDoor, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyDoor
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyDoor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyDoor, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyDoor =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged |
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyDoor Properties

The IMyDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyDoor Interface
Sandbox.ModAPI Namespace


IMyDoor Methods

The IMyDoor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyDoor Interface
Sandbox.ModAPI Namespace


IMyDoor Events

The IMyDoor type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | DoorStateChanged |
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyDoor Interface
Sandbox.ModAPI Namespace


IMyDoor.DoorStateChanged Event

IMyDoorDoorStateChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyDoor.DoorStateChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<bool> DoorStateChanged
Event DoorStateChanged As Action(Of Boolean)
 event Action<bool>^ DoorStateChanged {
    void add (Action<bool>^ value);
    void remove (Action<bool>^ value);
}
abstract DoorStateChanged : IEvent<Action<bool>,
    EventArgs>

Value

Type: SystemAction Boolean
See Also

Reference

IMyDoor Interface
Sandbox.ModAPI Namespace


IMyExtendedPistonBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyExtendedPistonBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyExtendedPistonBase : IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyExtendedPistonBase, IMyPistonBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyExtendedPistonBase
    Inherits IMyPistonBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyExtendedPistonBase, IMyPistonBase, IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyExtendedPistonBase : IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyExtendedPistonBase, IMyPistonBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyExtendedPistonBase =
    interface
        interface IMyPistonBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyExtendedPistonBase
        interface IMyPistonBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyExtendedPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyPistonTop, Boolean) | Attaches a specified nearby top part to the piston block (Inherited from IMyPistonBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | Notifies when the top grid is attached or detached (Inherited from IMyPistonBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached | (Inherited from IMyPistonBase.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyExtendedPistonBase Properties

The IMyExtendedPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyExtendedPistonBase Interface
Sandbox.ModAPI Namespace


IMyExtendedPistonBase Methods

The IMyExtendedPistonBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyPistonTop, Boolean) | Attaches a specified nearby top part to the piston block (Inherited from IMyPistonBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyExtendedPistonBase Interface
Sandbox.ModAPI Namespace


IMyExtendedPistonBase Events

The IMyExtendedPistonBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | Notifies when the top grid is attached or detached (Inherited from IMyPistonBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached | (Inherited from IMyPistonBase.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyExtendedPistonBase Interface
Sandbox.ModAPI Namespace


IMyFunctionalBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyFunctionalBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyFunctionalBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
Public Interface IMyFunctionalBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyFunctionalBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
type IMyFunctionalBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyFunctionalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged |
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyFunctionalBlock Properties

The IMyFunctionalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyFunctionalBlock Interface
Sandbox.ModAPI Namespace


IMyFunctionalBlock Methods

The IMyFunctionalBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyFunctionalBlock Interface
Sandbox.ModAPI Namespace


IMyFunctionalBlock Events

The IMyFunctionalBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged |
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyFunctionalBlock Interface
Sandbox.ModAPI Namespace


IMyFunctionalBlock.EnabledChanged Event

IMyFunctionalBlockEnabledChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyFunctionalBlock.EnabledChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> EnabledChanged
Event EnabledChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ EnabledChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract EnabledChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyFunctionalBlock Interface
Sandbox.ModAPI Namespace


IMyGasGenerator Interface

Gas generator interface

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGasGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGasGenerator
    Inherits IMyGasGenerator, IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGasGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGasGenerator =
    interface
        interface IMyGasGenerator
        interface IMyFunctionalBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGasGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier | Increase/decrese power consumption
Public property | ProductionCapacityMultiplier | Increase/decrese O2 produced
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyGasGenerator Properties

The IMyGasGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier | Increase/decrese power consumption
Public property | ProductionCapacityMultiplier | Increase/decrese O2 produced
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyGasGenerator Interface
Sandbox.ModAPI Namespace


IMyGasGenerator.PowerConsumptionMultiplier Property

IMyGasGeneratorPowerConsumptionMultiplier Property

Increase/decrese power consumption

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PowerConsumptionMultiplier { get; set; }
Property PowerConsumptionMultiplier As Single
    Get
    Set
property float PowerConsumptionMultiplier {
    float get ();
    void set (float value);
}
abstract PowerConsumptionMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGasGenerator Interface
Sandbox.ModAPI Namespace


IMyGasGenerator.ProductionCapacityMultiplier Property

IMyGasGeneratorProductionCapacityMultiplier Property

Increase/decrese O2 produced

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float ProductionCapacityMultiplier { get; set; }
Property ProductionCapacityMultiplier As Single
    Get
    Set
property float ProductionCapacityMultiplier {
    float get ();
    void set (float value);
}
abstract ProductionCapacityMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGasGenerator Interface
Sandbox.ModAPI Namespace


IMyGasGenerator Methods

The IMyGasGenerator type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGasGenerator Interface
Sandbox.ModAPI Namespace


IMyGasGenerator Events

The IMyGasGenerator type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyGasGenerator Interface
Sandbox.ModAPI Namespace


IMyGasTank Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyGasTank"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGasTank : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyGasTank, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGasTank
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGasTank : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyGasTank, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGasTank =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyGasTank
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGasTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyGasTank Properties

The IMyGasTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyGasTank Interface
Sandbox.ModAPI Namespace


IMyGasTank Methods

The IMyGasTank type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGasTank Interface
Sandbox.ModAPI Namespace


IMyGasTank Events

The IMyGasTank type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyGasTank Interface
Sandbox.ModAPI Namespace


IMyGridProgram Interface

The interface for the grid program provides extra access for the game and for mods. See MyGridProgram for the class the scripts actually derive from.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGridProgram
Public Interface IMyGridProgram
public interface class IMyGridProgram
type IMyGridProgram =  interface end

The IMyGridProgram type exposes the following members.

Properties
 | Name | Description
Public property | Echo | Gets or sets the action which prints out text onto the currently running programmable block's detail info area.
Public property | ElapsedTime | Obsolete. Gets or sets the amount of time elapsed since the last time this grid program was run.
Public property | GridTerminalSystem | Gets or sets the GridTerminalSystem available for the grid programs.
Public property | HasMainMethod | Determines whether this grid program has a valid Main method.
Public property | HasSaveMethod | Determines whether this grid program has a valid Save method.
Public property | Me | Gets or sets the programmable block which is currently running this grid program.
Public property | Runtime | Gets or sets the object used to provide runtime information for the running grid program.
Public property | Storage | Gets or sets the storage string for this grid program.
Top
Methods
 | Name | Description
Public method | Main | Invokes this grid program.
Public method | Save | If this grid program has state saving capability, calling this method will invoke it.
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyGridProgram Properties

The IMyGridProgram type exposes the following members.

Properties
 | Name | Description
Public property | Echo | Gets or sets the action which prints out text onto the currently running programmable block's detail info area.
Public property | ElapsedTime | Obsolete. Gets or sets the amount of time elapsed since the last time this grid program was run.
Public property | GridTerminalSystem | Gets or sets the GridTerminalSystem available for the grid programs.
Public property | HasMainMethod | Determines whether this grid program has a valid Main method.
Public property | HasSaveMethod | Determines whether this grid program has a valid Save method.
Public property | Me | Gets or sets the programmable block which is currently running this grid program.
Public property | Runtime | Gets or sets the object used to provide runtime information for the running grid program.
Public property | Storage | Gets or sets the storage string for this grid program.
Top
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Echo Property

IMyGridProgramEcho Property

Gets or sets the action which prints out text onto the currently running programmable block's detail info area.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<string> Echo { get; set; }
Property Echo As Action(Of String)
    Get
    Set
property Action<String^>^ Echo {
    Action<String^>^ get ();
    void set (Action<String^>^ value);
}
abstract Echo : Action<string> with get, set

Property Value

Type: Action String
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.ElapsedTime Property

IMyGridProgramElapsedTime Property

Note: This API is now obsolete.

Gets or sets the amount of time elapsed since the last time this grid program was run.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")]
TimeSpan ElapsedTime { get; set; }
<ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")>
Property ElapsedTime As TimeSpan
    Get
    Set
[ObsoleteAttribute(L"Use Runtime.TimeSinceLastRun instead")]
property TimeSpan ElapsedTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
[<ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")>]
abstract ElapsedTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.GridTerminalSystem Property

IMyGridProgramGridTerminalSystem Property

Gets or sets the GridTerminalSystem available for the grid programs.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyGridTerminalSystem GridTerminalSystem { get; set; }
Property GridTerminalSystem As IMyGridTerminalSystem
    Get
    Set
property IMyGridTerminalSystem^ GridTerminalSystem {
    IMyGridTerminalSystem^ get ();
    void set (IMyGridTerminalSystem^ value);
}
abstract GridTerminalSystem : IMyGridTerminalSystem with get, set

Property Value

Type: IMyGridTerminalSystem
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.HasMainMethod Property

IMyGridProgramHasMainMethod Property

Determines whether this grid program has a valid Main method.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasMainMethod { get; }
ReadOnly Property HasMainMethod As Boolean
    Get
property bool HasMainMethod {
    bool get ();
}
abstract HasMainMethod : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.HasSaveMethod Property

IMyGridProgramHasSaveMethod Property

Determines whether this grid program has a valid Save method.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasSaveMethod { get; }
ReadOnly Property HasSaveMethod As Boolean
    Get
property bool HasSaveMethod {
    bool get ();
}
abstract HasSaveMethod : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Me Property

IMyGridProgramMe Property

Gets or sets the programmable block which is currently running this grid program.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyProgrammableBlock Me { get; set; }
Property Me As IMyProgrammableBlock
    Get
    Set
property IMyProgrammableBlock^ Me {
    IMyProgrammableBlock^ get ();
    void set (IMyProgrammableBlock^ value);
}
abstract Me : IMyProgrammableBlock with get, set

Property Value

Type: IMyProgrammableBlock
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Runtime Property

IMyGridProgramRuntime Property

Gets or sets the object used to provide runtime information for the running grid program.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyGridProgramRuntimeInfo Runtime { get; set; }
Property Runtime As IMyGridProgramRuntimeInfo
    Get
    Set
property IMyGridProgramRuntimeInfo^ Runtime {
    IMyGridProgramRuntimeInfo^ get ();
    void set (IMyGridProgramRuntimeInfo^ value);
}
abstract Runtime : IMyGridProgramRuntimeInfo with get, set

Property Value

Type: IMyGridProgramRuntimeInfo
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Storage Property

IMyGridProgramStorage Property

Gets or sets the storage string for this grid program.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Storage { get; set; }
Property Storage As String
    Get
    Set
property String^ Storage {
    String^ get ();
    void set (String^ value);
}
abstract Storage : string with get, set

Property Value

Type: String
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram Methods

The IMyGridProgram type exposes the following members.

Methods
 | Name | Description
Public method | Main | Invokes this grid program.
Public method | Save | If this grid program has state saving capability, calling this method will invoke it.
Top
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Main Method

IMyGridProgramMain Method

Invokes this grid program.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Main(
    string argument
)
Sub Main (
    argument As String
)
void Main(
    String^ argument
)
abstract Main :
        argument : string -> unit

Parameters

argument
Type: SystemString
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridProgram.Save Method

IMyGridProgramSave Method

If this grid program has state saving capability, calling this method will invoke it.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IMyGridProgram Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyGridTerminalSystem"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGridTerminalSystem : IMyGridTerminalSystem
Public Interface IMyGridTerminalSystem
    Inherits IMyGridTerminalSystem
public interface class IMyGridTerminalSystem : IMyGridTerminalSystem
type IMyGridTerminalSystem =
    interface
        interface IMyGridTerminalSystem
    end

The IMyGridTerminalSystem type exposes the following members.

Methods
 | Name | Description
Public method | GetBlockGroups(ListIMyBlockGroup) |
Public method | GetBlockGroups(ListIMyBlockGroup, FuncIMyBlockGroup, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockGroupWithName |
Public method | GetBlocks(ListIMyTerminalBlock) |
Public method | GetBlocks(ListIMyTerminalBlock) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockWithId | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockWithName |
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyGridTerminalSystem Methods

The IMyGridTerminalSystem type exposes the following members.

Methods
 | Name | Description
Public method | GetBlockGroups(ListIMyBlockGroup) |
Public method | GetBlockGroups(ListIMyBlockGroup, FuncIMyBlockGroup, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockGroupWithName |
Public method | GetBlocks(ListIMyTerminalBlock) |
Public method | GetBlocks(ListIMyTerminalBlock) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockWithId | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlockWithName |
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlockGroups Method

IMyGridTerminalSystemGetBlockGroups Method

Overload List
 | Name | Description
Public method | GetBlockGroups(ListIMyBlockGroup) |
Public method | GetBlockGroups(ListIMyBlockGroup, FuncIMyBlockGroup, Boolean) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlockGroups Method (List(IMyBlockGroup))

IMyGridTerminalSystemGetBlockGroups Method (ListIMyBlockGroup)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockGroups(System.Collections.Generic.List{Sandbox.ModAPI.IMyBlockGroup})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlockGroups(
    List<IMyBlockGroup> blockGroups
)
Sub GetBlockGroups (
    blockGroups As List(Of IMyBlockGroup)
)
void GetBlockGroups(
    List<IMyBlockGroup^>^ blockGroups
)
abstract GetBlockGroups :
        blockGroups : List<IMyBlockGroup> -> unit

Parameters

blockGroups
Type: System.Collections.GenericList IMyBlockGroup

[Missing <param name="blockGroups"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockGroups(System.Collections.Generic.List{Sandbox.ModAPI.IMyBlockGroup})"]

See Also

Reference

IMyGridTerminalSystem Interface
GetBlockGroups Overload
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlockGroupWithName Method

IMyGridTerminalSystemGetBlockGroupWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyBlockGroup GetBlockGroupWithName(
    string name
)
Function GetBlockGroupWithName (
    name As String
) As IMyBlockGroup
IMyBlockGroup^ GetBlockGroupWithName(
    String^ name
)
abstract GetBlockGroupWithName :
        name : string -> IMyBlockGroup

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

Return Value

Type: IMyBlockGroup

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlocks Method

IMyGridTerminalSystemGetBlocks Method

Overload List
 | Name | Description
Public method | GetBlocks(ListIMyTerminalBlock) |
Public method | GetBlocks(ListIMyTerminalBlock) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlocks Method (List(IMyTerminalBlock))

IMyGridTerminalSystemGetBlocks Method (ListIMyTerminalBlock)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocks(
    List<IMyTerminalBlock> blocks
)
Sub GetBlocks (
    blocks As List(Of IMyTerminalBlock)
)
void GetBlocks(
    List<IMyTerminalBlock^>^ blocks
)
abstract GetBlocks :
        blocks : List<IMyTerminalBlock> -> unit

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock})"]

See Also

Reference

IMyGridTerminalSystem Interface
GetBlocks Overload
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlocksOfType Method

IMyGridTerminalSystemGetBlocksOfType Method

Overload List
 | Name | Description
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) | (Inherited from IMyGridTerminalSystem.)
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlocksOfType(T) Method (List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyGridTerminalSystemGetBlocksOfTypeT Method (ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)

Sub GetBlocksOfType(Of T) (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
generic<typename T>
void GetBlocksOfType(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface
GetBlocksOfType Overload
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.GetBlockWithName Method

IMyGridTerminalSystemGetBlockWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyTerminalBlock GetBlockWithName(
    string name
)
Function GetBlockWithName (
    name As String
) As IMyTerminalBlock
IMyTerminalBlock^ GetBlockWithName(
    String^ name
)
abstract GetBlockWithName :
        name : string -> IMyTerminalBlock

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

Return Value

Type: IMyTerminalBlock

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.SearchBlocksOfName Method

IMyGridTerminalSystemSearchBlocksOfName Method

Overload List
 | Name | Description
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | SearchBlocksOfName(String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) | (Inherited from IMyGridTerminalSystem.)
Top
See Also

Reference

IMyGridTerminalSystem Interface
Sandbox.ModAPI Namespace


IMyGridTerminalSystem.SearchBlocksOfName Method (String, List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyGridTerminalSystemSearchBlocksOfName Method (String, ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SearchBlocksOfName(
    string name,
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
Sub SearchBlocksOfName (
    name As String,
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
void SearchBlocksOfName(
    String^ name,
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract SearchBlocksOfName :
        name : string *
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.IMyTerminalBlock},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface
SearchBlocksOfName Overload
Sandbox.ModAPI Namespace


IMyGyro Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyGyro"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGyro : IMyGyro,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGyro
    Inherits IMyGyro, IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGyro : IMyGyro,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGyro =
    interface
        interface IMyGyro
        interface IMyFunctionalBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGyro type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | GyroOverride | (Inherited from IMyGyro.)
Public property | GyroPower | (Inherited from IMyGyro.)
Public property | GyroStrengthMultiplier |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pitch | (Inherited from IMyGyro.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Roll | (Inherited from IMyGyro.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Public property | Yaw | (Inherited from IMyGyro.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyGyro Properties

The IMyGyro type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | GyroOverride | (Inherited from IMyGyro.)
Public property | GyroPower | (Inherited from IMyGyro.)
Public property | GyroStrengthMultiplier |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pitch | (Inherited from IMyGyro.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Roll | (Inherited from IMyGyro.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Public property | Yaw | (Inherited from IMyGyro.)
Top
See Also

Reference

IMyGyro Interface
Sandbox.ModAPI Namespace


IMyGyro.GyroStrengthMultiplier Property

IMyGyroGyroStrengthMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyGyro.GyroStrengthMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float GyroStrengthMultiplier { get; set; }
Property GyroStrengthMultiplier As Single
    Get
    Set
property float GyroStrengthMultiplier {
    float get ();
    void set (float value);
}
abstract GyroStrengthMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface
Sandbox.ModAPI Namespace


IMyGyro.PowerConsumptionMultiplier Property

IMyGyroPowerConsumptionMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyGyro.PowerConsumptionMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PowerConsumptionMultiplier { get; set; }
Property PowerConsumptionMultiplier As Single
    Get
    Set
property float PowerConsumptionMultiplier {
    float get ();
    void set (float value);
}
abstract PowerConsumptionMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface
Sandbox.ModAPI Namespace


IMyGyro Methods

The IMyGyro type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGyro Interface
Sandbox.ModAPI Namespace


IMyGyro Events

The IMyGyro type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyGyro Interface
Sandbox.ModAPI Namespace


IMyIngameScripting Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyIngameScripting"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyIngameScripting
Public Interface IMyIngameScripting
public interface class IMyIngameScripting
type IMyIngameScripting =  interface end

The IMyIngameScripting type exposes the following members.

Properties
 | Name | Description
Public property | ScriptBlacklist | Provides the ability for mods to add and remove items from a type and member blacklist, giving the ability to remove even more API for scripts. Intended for server admins to restrict what people are able to do with scripts to keep their simspeed up.
Top
Methods
 | Name | Description
Public method | Clean |
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyIngameScripting Properties

The IMyIngameScripting type exposes the following members.

Properties
 | Name | Description
Public property | ScriptBlacklist | Provides the ability for mods to add and remove items from a type and member blacklist, giving the ability to remove even more API for scripts. Intended for server admins to restrict what people are able to do with scripts to keep their simspeed up.
Top
See Also

Reference

IMyIngameScripting Interface
Sandbox.ModAPI Namespace


IMyIngameScripting.ScriptBlacklist Property

IMyIngameScriptingScriptBlacklist Property

Provides the ability for mods to add and remove items from a type and member blacklist, giving the ability to remove even more API for scripts. Intended for server admins to restrict what people are able to do with scripts to keep their simspeed up.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyScriptBlacklist ScriptBlacklist { get; }
ReadOnly Property ScriptBlacklist As IMyScriptBlacklist
    Get
property IMyScriptBlacklist^ ScriptBlacklist {
    IMyScriptBlacklist^ get ();
}
abstract ScriptBlacklist : IMyScriptBlacklist with get

Property Value

Type: IMyScriptBlacklist
See Also

Reference

IMyIngameScripting Interface
Sandbox.ModAPI Namespace


IMyIngameScripting Methods

The IMyIngameScripting type exposes the following members.

Methods
 | Name | Description
Public method | Clean |
Top
See Also

Reference

IMyIngameScripting Interface
Sandbox.ModAPI Namespace


IMyIngameScripting.Clean Method

IMyIngameScriptingClean Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyIngameScripting.Clean"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clean()
Sub Clean
void Clean()
abstract Clean : unit -> unit
See Also

Reference

IMyIngameScripting Interface
Sandbox.ModAPI Namespace


IMyInventoryBag Interface

Inventory bag spawned when character died, container breaks, or when entity from other inventory cannot be spawned then bag spawned with the item in its inventory.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyInventoryBag : IMyEntity,
    IMyEntity
Public Interface IMyInventoryBag
    Inherits IMyEntity, IMyEntity
public interface class IMyInventoryBag : IMyEntity,
    IMyEntity
type IMyInventoryBag =
    interface
        interface IMyEntity
        interface IMyEntity
    end

The IMyInventoryBag type exposes the following members.

Properties
 | Name | Description
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyEntity.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Top
Events
 | Name | Description
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyInventoryBag Properties

The IMyInventoryBag type exposes the following members.

Properties
 | Name | Description
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyInventoryBag Interface
Sandbox.ModAPI Namespace


IMyInventoryBag Methods

The IMyInventoryBag type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyEntity.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Top
See Also

Reference

IMyInventoryBag Interface
Sandbox.ModAPI Namespace


IMyInventoryBag Events

The IMyInventoryBag type exposes the following members.

Events
 | Name | Description
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyInventoryBag Interface
Sandbox.ModAPI Namespace


IMyJumpDrive Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyJumpDrive"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyJumpDrive : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyJumpDrive, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyJumpDrive
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyJumpDrive, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyJumpDrive : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyJumpDrive, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyJumpDrive =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyJumpDrive
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyJumpDrive type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentStoredPower | Gets or sets the stored charge.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxStoredPower | (Inherited from IMyJumpDrive.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | (Inherited from IMyJumpDrive.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | Requests the jump drive to make a jump.
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyJumpDrive Properties

The IMyJumpDrive type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentStoredPower | Gets or sets the stored charge.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxStoredPower | (Inherited from IMyJumpDrive.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | (Inherited from IMyJumpDrive.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyJumpDrive Interface
Sandbox.ModAPI Namespace


IMyJumpDrive.CurrentStoredPower Property

IMyJumpDriveCurrentStoredPower Property

Gets or sets the stored charge.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentStoredPower { get; set; }
Property CurrentStoredPower As Single
    Get
    Set
property float CurrentStoredPower {
    float get ();
    void set (float value);
}
abstract CurrentStoredPower : float32 with get, set

Property Value

Type: Single

Implements

IMyJumpDriveCurrentStoredPower
See Also

Reference

IMyJumpDrive Interface
Sandbox.ModAPI Namespace


IMyJumpDrive Methods

The IMyJumpDrive type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | Requests the jump drive to make a jump.
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyJumpDrive Interface
Sandbox.ModAPI Namespace


IMyJumpDrive.Jump Method

IMyJumpDriveJump Method

Requests the jump drive to make a jump.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Jump(
    bool usePilot = true
)
Sub Jump (
    Optional usePilot As Boolean = true
)
void Jump(
    bool usePilot = true
)
abstract Jump :
        ?usePilot : bool
(* Defaults:
        let _usePilot = defaultArg usePilot true
*)
-> unit

Parameters

usePilot (Optional)
Type: SystemBoolean
Pass true to use the controlling player as a direction reference, false to use the default ship controller. Default true.
See Also

Reference

IMyJumpDrive Interface
Sandbox.ModAPI Namespace


IMyJumpDrive Events

The IMyJumpDrive type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyJumpDrive Interface
Sandbox.ModAPI Namespace


IMyLargeTurretBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyLargeTurretBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLargeTurretBase : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLargeTurretBase,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyCameraController
Public Interface IMyLargeTurretBase
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyLargeTurretBase, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyCameraController
public interface class IMyLargeTurretBase : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLargeTurretBase,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyCameraController
type IMyLargeTurretBase =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyLargeTurretBase
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyCameraController
    end

The IMyLargeTurretBase type exposes the following members.

Properties
 | Name | Description
Public property | AIEnabled | Checks is AI is enabled for turret (Inherited from IMyLargeTurretBase.)
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | Azimuth | Sets/gets azimuth of turret, this method is not synced, you need to sync azimuth manually (Inherited from IMyLargeTurretBase.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControl | (Inherited from IMyLargeTurretBase.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Elevation | Sets/gets elevation of turret, this method is not synced, you need to sync elevation manually (Inherited from IMyLargeTurretBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableIdleRotation | enable/disable idle rotation for turret, this method is not synced, you need to sync manually (Inherited from IMyLargeTurretBase.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyCameraController.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasTarget | Checks if the turret is locked onto a target (Inherited from IMyLargeTurretBase.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyLargeTurretBase.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Range | (Inherited from IMyLargeTurretBase.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Target |
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | ResetTargetingToDefault | resert targeting to default values (Inherited from IMyLargeTurretBase.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetTarget(IMyEntity) | Tracks target without position prediction (Inherited from IMyLargeTurretBase.)
Public method | SetTarget(Vector3D) | Targets given position (Inherited from IMyLargeTurretBase.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | SyncAzimuth | method used to sync azimuth, you need to call it to sync azimuth for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | SyncElevation | method used to sync elevation of turret , you need to call it to sync elevation for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | SyncEnableIdleRotation | method used to sync idle rotation and elevation, you need to call it to sync rotation and elevation for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | TrackTarget(IMyEntity) | Tracks entity with enabled position prediction (Inherited from IMyLargeTurretBase.)
Public method | TrackTarget(Vector3D, Vector3) | Tracks given target with enabled position prediction (Inherited from IMyLargeTurretBase.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyLargeTurretBase Properties

The IMyLargeTurretBase type exposes the following members.

Properties
 | Name | Description
Public property | AIEnabled | Checks is AI is enabled for turret (Inherited from IMyLargeTurretBase.)
Public property | AllowCubeBuilding | (Inherited from IMyCameraController.)
Public property | Azimuth | Sets/gets azimuth of turret, this method is not synced, you need to sync azimuth manually (Inherited from IMyLargeTurretBase.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControl | (Inherited from IMyLargeTurretBase.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Elevation | Sets/gets elevation of turret, this method is not synced, you need to sync elevation manually (Inherited from IMyLargeTurretBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableIdleRotation | enable/disable idle rotation for turret, this method is not synced, you need to sync manually (Inherited from IMyLargeTurretBase.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyCameraController.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasTarget | Checks if the turret is locked onto a target (Inherited from IMyLargeTurretBase.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsInFirstPersonView | (Inherited from IMyCameraController.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyLargeTurretBase.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Range | (Inherited from IMyLargeTurretBase.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Target |
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLargeTurretBase Interface
Sandbox.ModAPI Namespace


IMyLargeTurretBase.Target Property

IMyLargeTurretBaseTarget Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyLargeTurretBase.Target"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyEntity Target { get; }
ReadOnly Property Target As IMyEntity
    Get
property IMyEntity^ Target {
    IMyEntity^ get ();
}
abstract Target : IMyEntity with get

Property Value

Type: IMyEntity
See Also

Reference

IMyLargeTurretBase Interface
Sandbox.ModAPI Namespace


IMyLargeTurretBase Methods

The IMyLargeTurretBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | ControlCamera | (Inherited from IMyCameraController.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HandlePickUp | (Inherited from IMyCameraController.)
Public method | HandleUse | (Inherited from IMyCameraController.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnAssumeControl | (Inherited from IMyCameraController.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnReleaseControl | (Inherited from IMyCameraController.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | ResetTargetingToDefault | resert targeting to default values (Inherited from IMyLargeTurretBase.)
Public method | Rotate | (Inherited from IMyCameraController.)
Public method | RotateStopped | (Inherited from IMyCameraController.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetTarget(IMyEntity) | Tracks target without position prediction (Inherited from IMyLargeTurretBase.)
Public method | SetTarget(Vector3D) | Targets given position (Inherited from IMyLargeTurretBase.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | SyncAzimuth | method used to sync azimuth, you need to call it to sync azimuth for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | SyncElevation | method used to sync elevation of turret , you need to call it to sync elevation for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | SyncEnableIdleRotation | method used to sync idle rotation and elevation, you need to call it to sync rotation and elevation for other clients/server (Inherited from IMyLargeTurretBase.)
Public method | TrackTarget(IMyEntity) | Tracks entity with enabled position prediction (Inherited from IMyLargeTurretBase.)
Public method | TrackTarget(Vector3D, Vector3) | Tracks given target with enabled position prediction (Inherited from IMyLargeTurretBase.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLargeTurretBase Interface
Sandbox.ModAPI Namespace


IMyLargeTurretBase Events

The IMyLargeTurretBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyLargeTurretBase Interface
Sandbox.ModAPI Namespace


IMyLaserAntenna Interface

ModAPI laserantenna block interface

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLaserAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLaserAntenna, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyLaserAntenna
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyLaserAntenna, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyLaserAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLaserAntenna, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyLaserAntenna =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyLaserAntenna
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyLaserAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsOutsideLimits | Obsolete. Target is outside movement limits of antenna (Inherited from IMyLaserAntenna.)
Public property | IsPermanent | Connection is permanent (Inherited from IMyLaserAntenna.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | Other | Gets the antenna on the remote end of the connection.
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | RequireLoS | Determines whether this particular antenna requires line of sight to function. (Inherited from IMyLaserAntenna.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status of this antenna. (Inherited from IMyLaserAntenna.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetCoords | get target coordinates (Inherited from IMyLaserAntenna.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Connect | Connect to target defined by SetTargetCoords (Inherited from IMyLaserAntenna.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsInRange | Returns true if the specific laser antenna is within connection range.
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetTargetCoords | Set coordinates of target (Inherited from IMyLaserAntenna.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TransmitMessage | Sends a message to the programmable block associated with this antenna's partner (Inherited from IMyLaserAntenna.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyLaserAntenna Properties

The IMyLaserAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsOutsideLimits | Obsolete. Target is outside movement limits of antenna (Inherited from IMyLaserAntenna.)
Public property | IsPermanent | Connection is permanent (Inherited from IMyLaserAntenna.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | Other | Gets the antenna on the remote end of the connection.
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | RequireLoS | Determines whether this particular antenna requires line of sight to function. (Inherited from IMyLaserAntenna.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status of this antenna. (Inherited from IMyLaserAntenna.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetCoords | get target coordinates (Inherited from IMyLaserAntenna.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLaserAntenna Interface
Sandbox.ModAPI Namespace


IMyLaserAntenna.Other Property

IMyLaserAntennaOther Property

Gets the antenna on the remote end of the connection.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyLaserAntenna Other { get; }
ReadOnly Property Other As IMyLaserAntenna
    Get
property IMyLaserAntenna^ Other {
    IMyLaserAntenna^ get ();
}
abstract Other : IMyLaserAntenna with get

Property Value

Type: IMyLaserAntenna
See Also

Reference

IMyLaserAntenna Interface
Sandbox.ModAPI Namespace


IMyLaserAntenna Methods

The IMyLaserAntenna type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Connect | Connect to target defined by SetTargetCoords (Inherited from IMyLaserAntenna.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsInRange | Returns true if the specific laser antenna is within connection range.
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetTargetCoords | Set coordinates of target (Inherited from IMyLaserAntenna.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TransmitMessage | Sends a message to the programmable block associated with this antenna's partner (Inherited from IMyLaserAntenna.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLaserAntenna Interface
Sandbox.ModAPI Namespace


IMyLaserAntenna.IsInRange Method

IMyLaserAntennaIsInRange Method

Returns true if the specific laser antenna is within connection range.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsInRange(
    IMyLaserAntenna target
)
Function IsInRange (
    target As IMyLaserAntenna
) As Boolean
bool IsInRange(
    IMyLaserAntenna^ target
)
abstract IsInRange :
        target : IMyLaserAntenna -> bool

Parameters

target
Type: Sandbox.ModAPIIMyLaserAntenna

[Missing <param name="target"/> documentation for "M:Sandbox.ModAPI.IMyLaserAntenna.IsInRange(Sandbox.ModAPI.IMyLaserAntenna)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyLaserAntenna.IsInRange(Sandbox.ModAPI.IMyLaserAntenna)"]

See Also

Reference

IMyLaserAntenna Interface
Sandbox.ModAPI Namespace


IMyLaserAntenna Events

The IMyLaserAntenna type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyLaserAntenna Interface
Sandbox.ModAPI Namespace


IMyLightingBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyLightingBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLightingBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLightingBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyLightingBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyLightingBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyLightingBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyLightingBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyLightingBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyLightingBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyLightingBlock Properties

The IMyLightingBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLightingBlock Interface
Sandbox.ModAPI Namespace


IMyLightingBlock Methods

The IMyLightingBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLightingBlock Interface
Sandbox.ModAPI Namespace


IMyLightingBlock Events

The IMyLightingBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyLightingBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMechanicalConnectionBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMechanicalConnectionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMechanicalConnectionBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyMechanicalConnectionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMechanicalConnectionBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMechanicalConnectionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity
Public property | TopGrid | Gets the grid of the attached top part
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock Properties

The IMyMechanicalConnectionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity
Public property | TopGrid | Gets the grid of the attached top part
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock.Top Property

IMyMechanicalConnectionBlockTop Property

Gets the attached top part entity

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyAttachableTopBlock Top { get; }
ReadOnly Property Top As IMyAttachableTopBlock
    Get
property IMyAttachableTopBlock^ Top {
    IMyAttachableTopBlock^ get ();
}
abstract Top : IMyAttachableTopBlock with get

Property Value

Type: IMyAttachableTopBlock
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock.TopGrid Property

IMyMechanicalConnectionBlockTopGrid Property

Gets the grid of the attached top part

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyCubeGrid TopGrid { get; }
ReadOnly Property TopGrid As IMyCubeGrid
    Get
property IMyCubeGrid^ TopGrid {
    IMyCubeGrid^ get ();
}
abstract TopGrid : IMyCubeGrid with get

Property Value

Type: IMyCubeGrid
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock Methods

The IMyMechanicalConnectionBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock.Attach Method

IMyMechanicalConnectionBlockAttach Method

Overload List
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock.Attach Method (IMyAttachableTopBlock, Boolean)

IMyMechanicalConnectionBlockAttach Method (IMyAttachableTopBlock, Boolean)

Attaches the specified top part to the base

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Attach(
    IMyAttachableTopBlock top,
    bool updateGroup = true
)
Sub Attach (
    top As IMyAttachableTopBlock,
    Optional updateGroup As Boolean = true
)
void Attach(
    IMyAttachableTopBlock^ top,
    bool updateGroup = true
)
abstract Attach :
        top : IMyAttachableTopBlock *
        ?updateGroup : bool
(* Defaults:
        let _updateGroup = defaultArg updateGroup true
*)
-> unit

Parameters

top
Type: Sandbox.ModAPIIMyAttachableTopBlock

[Missing <param name="top"/> documentation for "M:Sandbox.ModAPI.IMyMechanicalConnectionBlock.Attach(Sandbox.ModAPI.IMyAttachableTopBlock,System.Boolean)"]

updateGroup (Optional)
Type: SystemBoolean
true to update grid groups
See Also

Reference

IMyMechanicalConnectionBlock Interface
Attach Overload
Sandbox.ModAPI Namespace


IMyMechanicalConnectionBlock Events

The IMyMechanicalConnectionBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface
Sandbox.ModAPI Namespace


IMyMeteor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMeteor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMeteor : IMyEntity,
    IMyEntity, IMyDestroyableObject, IMyDecalProxy
Public Interface IMyMeteor
    Inherits IMyEntity, IMyEntity, IMyDestroyableObject, IMyDecalProxy
public interface class IMyMeteor : IMyEntity,
    IMyEntity, IMyDestroyableObject, IMyDecalProxy
type IMyMeteor =
    interface
        interface IMyEntity
        interface IMyEntity
        interface IMyDestroyableObject
        interface IMyDecalProxy
    end

The IMyMeteor type exposes the following members.

Properties
 | Name | Description
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Integrity | (Inherited from IMyDestroyableObject.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UseDamageSystem | (Inherited from IMyDestroyableObject.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddDecals | (Inherited from IMyDecalProxy.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyEntity.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoDamage | (Inherited from IMyDestroyableObject.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnDestroy | (Inherited from IMyDestroyableObject.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Top
Events
 | Name | Description
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMeteor Properties

The IMyMeteor type exposes the following members.

Properties
 | Name | Description
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Integrity | (Inherited from IMyDestroyableObject.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UseDamageSystem | (Inherited from IMyDestroyableObject.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMeteor Interface
Sandbox.ModAPI Namespace


IMyMeteor Methods

The IMyMeteor type exposes the following members.

Methods
 | Name | Description
Public method | AddDecals | (Inherited from IMyDecalProxy.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyEntity.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoDamage | (Inherited from IMyDestroyableObject.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnDestroy | (Inherited from IMyDestroyableObject.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMeteor Interface
Sandbox.ModAPI Namespace


IMyMeteor Events

The IMyMeteor type exposes the following members.

Events
 | Name | Description
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMeteor Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedRotor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorAdvancedRotor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorAdvancedRotor : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyMotorAdvancedRotor, IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorAdvancedRotor
    Inherits IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity,
    IMyMotorAdvancedRotor, IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorAdvancedRotor : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyMotorAdvancedRotor, IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
type IMyMotorAdvancedRotor =
    interface
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorAdvancedRotor
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorAdvancedRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorAdvancedRotor Properties

The IMyMotorAdvancedRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorAdvancedRotor Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedRotor Methods

The IMyMotorAdvancedRotor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorAdvancedRotor Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedRotor Events

The IMyMotorAdvancedRotor type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorAdvancedRotor Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedStator Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorAdvancedStator"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorAdvancedStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorAdvancedStator, IMyMotorStator, IMyMotorBase, IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorAdvancedStator
    Inherits IMyMotorStator, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMotorAdvancedStator, IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyMotorAdvancedStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorAdvancedStator, IMyMotorStator, IMyMotorBase, IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMotorAdvancedStator =
    interface
        interface IMyMotorStator
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorAdvancedStator
        interface IMyMotorStator
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorAdvancedStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached | (Inherited from IMyMotorStator.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorAdvancedStator Properties

The IMyMotorAdvancedStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorAdvancedStator Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedStator Methods

The IMyMotorAdvancedStator type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorAdvancedStator Interface
Sandbox.ModAPI Namespace


IMyMotorAdvancedStator Events

The IMyMotorAdvancedStator type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached | (Inherited from IMyMotorStator.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyMotorAdvancedStator Interface
Sandbox.ModAPI Namespace


IMyMotorBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorBase
    Inherits IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyMotorBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMotorBase =
    interface
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity
Public property | RotorAngularVelocity | Gets the current angular velocity.
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged |
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorBase Properties

The IMyMotorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity
Public property | RotorAngularVelocity | Gets the current angular velocity.
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.DummyPosition Property

IMyMotorBaseDummyPosition Property

Gets the dummy position, to aid in attachment

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 DummyPosition { get; }
ReadOnly Property DummyPosition As Vector3
    Get
property Vector3 DummyPosition {
    Vector3 get ();
}
abstract DummyPosition : Vector3 with get

Property Value

Type: Vector3
Remarks
Gets the location where the top rotor piece will attach.
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.MaxRotorAngularVelocity Property

IMyMotorBaseMaxRotorAngularVelocity Property

Gets the maximum angular velocity this rotor is capable of.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxRotorAngularVelocity { get; }
ReadOnly Property MaxRotorAngularVelocity As Single
    Get
property float MaxRotorAngularVelocity {
    float get ();
}
abstract MaxRotorAngularVelocity : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.Rotor Property

IMyMotorBaseRotor Property

Note: This API is now obsolete.

Gets the attached rotor part entity

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyMechanicalConnectionBlock.Top")]
IMyCubeBlock Rotor { get; }
<ObsoleteAttribute("Use IMyMechanicalConnectionBlock.Top")>
ReadOnly Property Rotor As IMyCubeBlock
    Get
[ObsoleteAttribute(L"Use IMyMechanicalConnectionBlock.Top")]
property IMyCubeBlock^ Rotor {
    IMyCubeBlock^ get ();
}
[<ObsoleteAttribute("Use IMyMechanicalConnectionBlock.Top")>]
abstract Rotor : IMyCubeBlock with get

Property Value

Type: IMyCubeBlock
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.RotorAngularVelocity Property

IMyMotorBaseRotorAngularVelocity Property

Gets the current angular velocity.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 RotorAngularVelocity { get; }
ReadOnly Property RotorAngularVelocity As Vector3
    Get
property Vector3 RotorAngularVelocity {
    Vector3 get ();
}
abstract RotorAngularVelocity : Vector3 with get

Property Value

Type: Vector3
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.RotorGrid Property

IMyMotorBaseRotorGrid Property

Note: This API is now obsolete.

Gets the grid attached to the rotor part

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyMechanicalConnectionBlock.TopGrid")]
IMyCubeGrid RotorGrid { get; }
<ObsoleteAttribute("Use IMyMechanicalConnectionBlock.TopGrid")>
ReadOnly Property RotorGrid As IMyCubeGrid
    Get
[ObsoleteAttribute(L"Use IMyMechanicalConnectionBlock.TopGrid")]
property IMyCubeGrid^ RotorGrid {
    IMyCubeGrid^ get ();
}
[<ObsoleteAttribute("Use IMyMechanicalConnectionBlock.TopGrid")>]
abstract RotorGrid : IMyCubeGrid with get

Property Value

Type: IMyCubeGrid
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase Methods

The IMyMotorBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.Attach Method

IMyMotorBaseAttach Method

Overload List
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block
Top
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.Attach Method (IMyMotorRotor, Boolean)

IMyMotorBaseAttach Method (IMyMotorRotor, Boolean)

Attaches a specified nearby rotor/wheel to the stator/suspension block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Attach(
    IMyMotorRotor rotor,
    bool updateGroup = true
)
Sub Attach (
    rotor As IMyMotorRotor,
    Optional updateGroup As Boolean = true
)
void Attach(
    IMyMotorRotor^ rotor,
    bool updateGroup = true
)
abstract Attach :
        rotor : IMyMotorRotor *
        ?updateGroup : bool
(* Defaults:
        let _updateGroup = defaultArg updateGroup true
*)
-> unit

Parameters

rotor
Type: Sandbox.ModAPIIMyMotorRotor
Entity to attach
updateGroup (Optional)
Type: SystemBoolean
true to update grid groups
Remarks
The rotor to attach must already be in position before calling this method.
See Also

Reference

IMyMotorBase Interface
Attach Overload
Sandbox.ModAPI Namespace


IMyMotorBase Events

The IMyMotorBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged |
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorBase.AttachedEntityChanged Event

IMyMotorBaseAttachedEntityChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyMotorBase.AttachedEntityChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyMotorBase> AttachedEntityChanged
Event AttachedEntityChanged As Action(Of IMyMotorBase)
 event Action<IMyMotorBase^>^ AttachedEntityChanged {
    void add (Action<IMyMotorBase^>^ value);
    void remove (Action<IMyMotorBase^>^ value);
}
abstract AttachedEntityChanged : IEvent<Action<IMyMotorBase>,
    EventArgs>

Value

Type: SystemAction IMyMotorBase
See Also

Reference

IMyMotorBase Interface
Sandbox.ModAPI Namespace


IMyMotorRotor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorRotor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorRotor : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity, IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock,
    IMyEntity
Public Interface IMyMotorRotor
    Inherits IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorRotor : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity, IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock,
    IMyEntity
type IMyMotorRotor =
    interface
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorRotor Properties

The IMyMotorRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorRotor Interface
Sandbox.ModAPI Namespace


IMyMotorRotor.Base Property

IMyMotorRotorBase Property

Gets the attached stator/suspension block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyMotorBase Base { get; }
ReadOnly Property Base As IMyMotorBase
    Get
property IMyMotorBase^ Base {
    IMyMotorBase^ get ();
}
abstract Base : IMyMotorBase with get

Property Value

Type: IMyMotorBase
See Also

Reference

IMyMotorRotor Interface
Sandbox.ModAPI Namespace


IMyMotorRotor.Stator Property

IMyMotorRotorStator Property

Note: This API is now obsolete.

Gets the attached stator/suspension block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyAttachableTopBlock.Base")]
IMyMotorBase Stator { get; }
<ObsoleteAttribute("Use IMyAttachableTopBlock.Base")>
ReadOnly Property Stator As IMyMotorBase
    Get
[ObsoleteAttribute(L"Use IMyAttachableTopBlock.Base")]
property IMyMotorBase^ Stator {
    IMyMotorBase^ get ();
}
[<ObsoleteAttribute("Use IMyAttachableTopBlock.Base")>]
abstract Stator : IMyMotorBase with get

Property Value

Type: IMyMotorBase
See Also

Reference

IMyMotorRotor Interface
Sandbox.ModAPI Namespace


IMyMotorRotor Methods

The IMyMotorRotor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorRotor Interface
Sandbox.ModAPI Namespace


IMyMotorRotor Events

The IMyMotorRotor type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorRotor Interface
Sandbox.ModAPI Namespace


IMyMotorStator Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorStator"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyMotorStator
    Inherits IMyMotorStator, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyMotorStator =
    interface
        interface IMyMotorStator
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached |
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorStator Properties

The IMyMotorStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorStator Interface
Sandbox.ModAPI Namespace


IMyMotorStator Methods

The IMyMotorStator type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorStator Interface
Sandbox.ModAPI Namespace


IMyMotorStator Events

The IMyMotorStator type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached |
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyMotorStator Interface
Sandbox.ModAPI Namespace


IMyMotorStator.LimitReached Event

IMyMotorStatorLimitReached Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyMotorStator.LimitReached"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<bool> LimitReached
Event LimitReached As Action(Of Boolean)
 event Action<bool>^ LimitReached {
    void add (Action<bool>^ value);
    void remove (Action<bool>^ value);
}
abstract LimitReached : IEvent<Action<bool>,
    EventArgs>

Value

Type: SystemAction Boolean
See Also

Reference

IMyMotorStator Interface
Sandbox.ModAPI Namespace


IMyMotorSuspension Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyMotorSuspension"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorSuspension : IMyMotorSuspension,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyMotorSuspension
    Inherits IMyMotorSuspension, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorSuspension : IMyMotorSuspension,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyMotorSuspension =
    interface
        interface IMyMotorSuspension
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorSuspension type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Brake | Set/get brake applied to the wheel. (Inherited from IMyMotorSuspension.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | Damping | (Inherited from IMyMotorSuspension.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | Friction | (Inherited from IMyMotorSuspension.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Height | (Inherited from IMyMotorSuspension.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | InvertPropulsion | (Inherited from IMyMotorSuspension.)
Public property | InvertSteer | (Inherited from IMyMotorSuspension.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | MaxSteerAngle | Max steering angle in radians. (Inherited from IMyMotorSuspension.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Power | (Inherited from IMyMotorSuspension.)
Public property | Propulsion | (Inherited from IMyMotorSuspension.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | SteerAngle | Wheel's current steering angle (Inherited from IMyMotorSuspension.)
Public property | Steering | (Inherited from IMyMotorSuspension.)
Public property | SteerReturnSpeed | Speed at which wheel returns from steering. (Inherited from IMyMotorSuspension.)
Public property | SteerSpeed | Speed at which wheel steers. (Inherited from IMyMotorSuspension.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Strength | (Inherited from IMyMotorSuspension.)
Public property | SuspensionTravel | Suspension travel, value from 0 to 1. (Inherited from IMyMotorSuspension.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyMotorSuspension Properties

The IMyMotorSuspension type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Brake | Set/get brake applied to the wheel. (Inherited from IMyMotorSuspension.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | Damping | (Inherited from IMyMotorSuspension.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DummyPosition | Gets the dummy position, to aid in attachment (Inherited from IMyMotorBase.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | Friction | (Inherited from IMyMotorSuspension.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Height | (Inherited from IMyMotorSuspension.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | InvertPropulsion | (Inherited from IMyMotorSuspension.)
Public property | InvertSteer | (Inherited from IMyMotorSuspension.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRotorAngularVelocity | Gets the maximum angular velocity this rotor is capable of. (Inherited from IMyMotorBase.)
Public property | MaxSteerAngle | Max steering angle in radians. (Inherited from IMyMotorSuspension.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Power | (Inherited from IMyMotorSuspension.)
Public property | Propulsion | (Inherited from IMyMotorSuspension.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Rotor | Obsolete. Gets the attached rotor part entity (Inherited from IMyMotorBase.)
Public property | RotorAngularVelocity | Gets the current angular velocity. (Inherited from IMyMotorBase.)
Public property | RotorGrid | Obsolete. Gets the grid attached to the rotor part (Inherited from IMyMotorBase.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | SteerAngle | Wheel's current steering angle (Inherited from IMyMotorSuspension.)
Public property | Steering | (Inherited from IMyMotorSuspension.)
Public property | SteerReturnSpeed | Speed at which wheel returns from steering. (Inherited from IMyMotorSuspension.)
Public property | SteerSpeed | Speed at which wheel steers. (Inherited from IMyMotorSuspension.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Strength | (Inherited from IMyMotorSuspension.)
Public property | SuspensionTravel | Suspension travel, value from 0 to 1. (Inherited from IMyMotorSuspension.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorSuspension Interface
Sandbox.ModAPI Namespace


IMyMotorSuspension Methods

The IMyMotorSuspension type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyMotorRotor, Boolean) | Attaches a specified nearby rotor/wheel to the stator/suspension block (Inherited from IMyMotorBase.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorSuspension Interface
Sandbox.ModAPI Namespace


IMyMotorSuspension Events

The IMyMotorSuspension type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | (Inherited from IMyMotorBase.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyMotorSuspension Interface
Sandbox.ModAPI Namespace


IMyOreDetector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyOreDetector"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyOreDetector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOreDetector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyOreDetector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyOreDetector, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyOreDetector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOreDetector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyOreDetector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyOreDetector
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOreDetector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BroadcastUsingAntennas | (Inherited from IMyOreDetector.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Range | (Inherited from IMyOreDetector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyOreDetector Properties

The IMyOreDetector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BroadcastUsingAntennas | (Inherited from IMyOreDetector.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Range | (Inherited from IMyOreDetector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOreDetector Interface
Sandbox.ModAPI Namespace


IMyOreDetector Methods

The IMyOreDetector type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOreDetector Interface
Sandbox.ModAPI Namespace


IMyOreDetector Events

The IMyOreDetector type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyOreDetector Interface
Sandbox.ModAPI Namespace


IMyOxygenGenerator Interface

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyOxygenGenerator"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGasGenerator")]
public interface IMyOxygenGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOxygenGenerator,
    IMyGasGenerator, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
<ObsoleteAttribute("Use IMyGasGenerator")>
Public Interface IMyOxygenGenerator
    Inherits IMyGasGenerator, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyOxygenGenerator, IMyGasGenerator, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
[ObsoleteAttribute(L"Use IMyGasGenerator")]
public interface class IMyOxygenGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOxygenGenerator,
    IMyGasGenerator, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
[<ObsoleteAttribute("Use IMyGasGenerator")>]
type IMyOxygenGenerator =
    interface
        interface IMyGasGenerator
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyOxygenGenerator
        interface IMyGasGenerator
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOxygenGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier | Increase/decrese power consumption (Inherited from IMyGasGenerator.)
Public property | ProductionCapacityMultiplier | Increase/decrese O2 produced (Inherited from IMyGasGenerator.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyOxygenGenerator Properties

The IMyOxygenGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier | Increase/decrese power consumption (Inherited from IMyGasGenerator.)
Public property | ProductionCapacityMultiplier | Increase/decrese O2 produced (Inherited from IMyGasGenerator.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOxygenGenerator Interface
Sandbox.ModAPI Namespace


IMyOxygenGenerator Methods

The IMyOxygenGenerator type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOxygenGenerator Interface
Sandbox.ModAPI Namespace


IMyOxygenGenerator Events

The IMyOxygenGenerator type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyOxygenGenerator Interface
Sandbox.ModAPI Namespace


IMyOxygenTank Interface

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyOxygenTank"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGasTank")]
public interface IMyOxygenTank : IMyGasTank,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOxygenTank,
    IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
<ObsoleteAttribute("Use IMyGasTank")>
Public Interface IMyOxygenTank
    Inherits IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyOxygenTank, IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
[ObsoleteAttribute(L"Use IMyGasTank")]
public interface class IMyOxygenTank : IMyGasTank,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyOxygenTank,
    IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
[<ObsoleteAttribute("Use IMyGasTank")>]
type IMyOxygenTank =
    interface
        interface IMyGasTank
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyOxygenTank
        interface IMyGasTank
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOxygenTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetOxygenLevel | Obsolete. Gets the current oxygen level of this tank, as a value between 0 (empty) and 1 (full). (Inherited from IMyOxygenTank.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyOxygenTank Properties

The IMyOxygenTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOxygenTank Interface
Sandbox.ModAPI Namespace


IMyOxygenTank Methods

The IMyOxygenTank type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetOxygenLevel | Obsolete. Gets the current oxygen level of this tank, as a value between 0 (empty) and 1 (full). (Inherited from IMyOxygenTank.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOxygenTank Interface
Sandbox.ModAPI Namespace


IMyOxygenTank Events

The IMyOxygenTank type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyOxygenTank Interface
Sandbox.ModAPI Namespace


IMyPassage Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyPassage"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPassage : IMyCubeBlock,
    IMyEntity, IMyPassage, IMyCubeBlock, IMyEntity
Public Interface IMyPassage
    Inherits IMyCubeBlock, IMyEntity, IMyPassage, IMyCubeBlock,
    IMyEntity
public interface class IMyPassage : IMyCubeBlock,
    IMyEntity, IMyPassage, IMyCubeBlock, IMyEntity
type IMyPassage =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyPassage
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPassage type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyPassage Properties

The IMyPassage type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPassage Interface
Sandbox.ModAPI Namespace


IMyPassage Methods

The IMyPassage type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPassage Interface
Sandbox.ModAPI Namespace


IMyPassage Events

The IMyPassage type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPassage Interface
Sandbox.ModAPI Namespace


IMyPistonBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyPistonBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPistonBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyPistonBase
    Inherits IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyPistonBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyPistonBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyPistonBase =
    interface
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyPistonBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyPistonTop, Boolean) | Attaches a specified nearby top part to the piston block
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | Notifies when the top grid is attached or detached
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached |
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyPistonBase Properties

The IMyPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonBase Methods

The IMyPistonBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyPistonTop, Boolean) | Attaches a specified nearby top part to the piston block
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonBase.Attach Method

IMyPistonBaseAttach Method

Overload List
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyAttachableTopBlock, Boolean) | Attaches the specified top part to the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Attach(IMyPistonTop, Boolean) | Attaches a specified nearby top part to the piston block
Top
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonBase.Attach Method (IMyPistonTop, Boolean)

IMyPistonBaseAttach Method (IMyPistonTop, Boolean)

Attaches a specified nearby top part to the piston block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Attach(
    IMyPistonTop top,
    bool updateGroup = true
)
Sub Attach (
    top As IMyPistonTop,
    Optional updateGroup As Boolean = true
)
void Attach(
    IMyPistonTop^ top,
    bool updateGroup = true
)
abstract Attach :
        top : IMyPistonTop *
        ?updateGroup : bool
(* Defaults:
        let _updateGroup = defaultArg updateGroup true
*)
-> unit

Parameters

top
Type: Sandbox.ModAPIIMyPistonTop
Entity to attach
updateGroup (Optional)
Type: SystemBoolean
true to update grid groups
Remarks
The top to attach must already be in position before calling this method.
See Also

Reference

IMyPistonBase Interface
Attach Overload
Sandbox.ModAPI Namespace


IMyPistonBase Events

The IMyPistonBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | AttachedEntityChanged | Notifies when the top grid is attached or detached
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | LimitReached |
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonBase.AttachedEntityChanged Event

IMyPistonBaseAttachedEntityChanged Event

Notifies when the top grid is attached or detached

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyPistonBase> AttachedEntityChanged
Event AttachedEntityChanged As Action(Of IMyPistonBase)
 event Action<IMyPistonBase^>^ AttachedEntityChanged {
    void add (Action<IMyPistonBase^>^ value);
    void remove (Action<IMyPistonBase^>^ value);
}
abstract AttachedEntityChanged : IEvent<Action<IMyPistonBase>,
    EventArgs>

Value

Type: SystemAction IMyPistonBase
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonBase.LimitReached Event

IMyPistonBaseLimitReached Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyPistonBase.LimitReached"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<bool> LimitReached
Event LimitReached As Action(Of Boolean)
 event Action<bool>^ LimitReached {
    void add (Action<bool>^ value);
    void remove (Action<bool>^ value);
}
abstract LimitReached : IEvent<Action<bool>,
    EventArgs>

Value

Type: SystemAction Boolean
See Also

Reference

IMyPistonBase Interface
Sandbox.ModAPI Namespace


IMyPistonTop Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyPistonTop"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPistonTop : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity, IMyPistonTop, IMyAttachableTopBlock, IMyCubeBlock,
    IMyEntity
Public Interface IMyPistonTop
    Inherits IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyPistonTop,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyPistonTop : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity, IMyPistonTop, IMyAttachableTopBlock, IMyCubeBlock,
    IMyEntity
type IMyPistonTop =
    interface
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyPistonTop
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPistonTop type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Piston | Gets the attached piston block
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyPistonTop Properties

The IMyPistonTop type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Piston | Gets the attached piston block
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPistonTop Interface
Sandbox.ModAPI Namespace


IMyPistonTop.Base Property

IMyPistonTopBase Property

Gets the attached stator/suspension block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyPistonBase Base { get; }
ReadOnly Property Base As IMyPistonBase
    Get
property IMyPistonBase^ Base {
    IMyPistonBase^ get ();
}
abstract Base : IMyPistonBase with get

Property Value

Type: IMyPistonBase
See Also

Reference

IMyPistonTop Interface
Sandbox.ModAPI Namespace


IMyPistonTop.Piston Property

IMyPistonTopPiston Property

Gets the attached piston block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyPistonBase Piston { get; }
ReadOnly Property Piston As IMyPistonBase
    Get
property IMyPistonBase^ Piston {
    IMyPistonBase^ get ();
}
abstract Piston : IMyPistonBase with get

Property Value

Type: IMyPistonBase
See Also

Reference

IMyPistonTop Interface
Sandbox.ModAPI Namespace


IMyPistonTop Methods

The IMyPistonTop type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPistonTop Interface
Sandbox.ModAPI Namespace


IMyPistonTop Events

The IMyPistonTop type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPistonTop Interface
Sandbox.ModAPI Namespace


IMyProductionBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyProductionBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProductionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProductionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProductionBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProductionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProductionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProductionBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProductionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory |
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory |
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint?
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing |
Public event | StoppedProducing |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyProductionBlock Properties

The IMyProductionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory |
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory |
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.InputInventory Property

IMyProductionBlockInputInventory Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyProductionBlock.InputInventory"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyInventory InputInventory { get; }
ReadOnly Property InputInventory As IMyInventory
    Get
property IMyInventory^ InputInventory {
    IMyInventory^ get ();
}
abstract InputInventory : IMyInventory with get

Property Value

Type: IMyInventory
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.OutputInventory Property

IMyProductionBlockOutputInventory Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyProductionBlock.OutputInventory"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyInventory OutputInventory { get; }
ReadOnly Property OutputInventory As IMyInventory
    Get
property IMyInventory^ OutputInventory {
    IMyInventory^ get ();
}
abstract OutputInventory : IMyInventory with get

Property Value

Type: IMyInventory
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock Methods

The IMyProductionBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint?
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.AddQueueItem Method

IMyProductionBlockAddQueueItem Method

Overload List
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.AddQueueItem Method (MyDefinitionBase, MyFixedPoint)

IMyProductionBlockAddQueueItem Method (MyDefinitionBase, MyFixedPoint)

Adds a blueprint to the production queue

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddQueueItem(
    MyDefinitionBase blueprint,
    MyFixedPoint amount
)
Sub AddQueueItem (
    blueprint As MyDefinitionBase,
    amount As MyFixedPoint
)
void AddQueueItem(
    MyDefinitionBase^ blueprint,
    MyFixedPoint amount
)
abstract AddQueueItem :
        blueprint : MyDefinitionBase *
        amount : MyFixedPoint -> unit

Parameters

blueprint
Type: MyDefinitionBase
A MyBlueprintDefinition that defines the blueprint
amount
Type: MyFixedPoint
Amount of items
See Also

Reference

IMyProductionBlock Interface
AddQueueItem Overload
Sandbox.ModAPI Namespace


IMyProductionBlock.CanUseBlueprint Method

IMyProductionBlockCanUseBlueprint Method

Overload List
 | Name | Description
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint?
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.CanUseBlueprint Method (MyDefinitionBase)

IMyProductionBlockCanUseBlueprint Method (MyDefinitionBase)

Can this production block produce this blueprint?

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUseBlueprint(
    MyDefinitionBase blueprint
)
Function CanUseBlueprint (
    blueprint As MyDefinitionBase
) As Boolean
bool CanUseBlueprint(
    MyDefinitionBase^ blueprint
)
abstract CanUseBlueprint :
        blueprint : MyDefinitionBase -> bool

Parameters

blueprint
Type: MyDefinitionBase
A MyBlueprintDefinition that defines the blueprint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyProductionBlock.CanUseBlueprint(VRage.Game.MyDefinitionBase)"]

See Also

Reference

IMyProductionBlock Interface
CanUseBlueprint Overload
Sandbox.ModAPI Namespace


IMyProductionBlock.GetQueue Method

IMyProductionBlockGetQueue Method

Overload List
 | Name | Description
Public method | GetQueue | Gets the current production queue
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.GetQueue Method

IMyProductionBlockGetQueue Method

Gets the current production queue

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<MyProductionQueueItem> GetQueue()
Function GetQueue As List(Of MyProductionQueueItem)
List<MyProductionQueueItem>^ GetQueue()
abstract GetQueue : unit -> List<MyProductionQueueItem>

Return Value

Type: List MyProductionQueueItem
List of MyProductionQueueItems
See Also

Reference

IMyProductionBlock Interface
GetQueue Overload
Sandbox.ModAPI Namespace


IMyProductionBlock.InsertQueueItem Method

IMyProductionBlockInsertQueueItem Method

Overload List
 | Name | Description
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.InsertQueueItem Method (Int32, MyDefinitionBase, MyFixedPoint)

IMyProductionBlockInsertQueueItem Method (Int32, MyDefinitionBase, MyFixedPoint)

Inserts a blueprint into the production queue

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertQueueItem(
    int idx,
    MyDefinitionBase blueprint,
    MyFixedPoint amount
)
Sub InsertQueueItem (
    idx As Integer,
    blueprint As MyDefinitionBase,
    amount As MyFixedPoint
)
void InsertQueueItem(
    int idx,
    MyDefinitionBase^ blueprint,
    MyFixedPoint amount
)
abstract InsertQueueItem :
        idx : int *
        blueprint : MyDefinitionBase *
        amount : MyFixedPoint -> unit

Parameters

idx
Type: SystemInt32
Index of the item
blueprint
Type: MyDefinitionBase
A MyBlueprintDefinition that defines the blueprint
amount
Type: MyFixedPoint
Amount of items
See Also

Reference

IMyProductionBlock Interface
InsertQueueItem Overload
Sandbox.ModAPI Namespace


IMyProductionBlock Events

The IMyProductionBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing |
Public event | StoppedProducing |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.StartedProducing Event

IMyProductionBlockStartedProducing Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyProductionBlock.StartedProducing"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action StartedProducing
Event StartedProducing As Action
 event Action^ StartedProducing {
    void add (Action^ value);
    void remove (Action^ value);
}
abstract StartedProducing : IEvent<Action,
    EventArgs>

Value

Type: SystemAction
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProductionBlock.StoppedProducing Event

IMyProductionBlockStoppedProducing Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyProductionBlock.StoppedProducing"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action StoppedProducing
Event StoppedProducing As Action
 event Action^ StoppedProducing {
    void add (Action^ value);
    void remove (Action^ value);
}
abstract StoppedProducing : IEvent<Action,
    EventArgs>

Value

Type: SystemAction
See Also

Reference

IMyProductionBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyProgrammableBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProgrammableBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProgrammableBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProgrammableBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyProgrammableBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProgrammableBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProgrammableBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProgrammableBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyProgrammableBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProgrammableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasCompileErrors | Returns true if the script has compile errors (server only!)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsRunning | This programmable block is currently running its program. (Inherited from IMyProgrammableBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | ProgramData | Program contents. Automatically recompiles when set, if possible.
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | StorageData | Program storage (server only!)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TerminalRunArgument | Contains the value of the default terminal argument. (Inherited from IMyProgrammableBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | Recompile | Recompiles script
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Run | Runs with default terminal argument
Public method | Run(String) | Runs with specified argument
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | TryRun | Attempts to run this programmable block using the given argument. An already running programmable block cannot be run again. This is equivalent to running block.ApplyAction("Run", argumentsList); This should be called from an ingame script. Do not use in mods. (Inherited from IMyProgrammableBlock.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyProgrammableBlock Properties

The IMyProgrammableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasCompileErrors | Returns true if the script has compile errors (server only!)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsRunning | This programmable block is currently running its program. (Inherited from IMyProgrammableBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | ProgramData | Program contents. Automatically recompiles when set, if possible.
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | StorageData | Program storage (server only!)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TerminalRunArgument | Contains the value of the default terminal argument. (Inherited from IMyProgrammableBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.HasCompileErrors Property

IMyProgrammableBlockHasCompileErrors Property

Returns true if the script has compile errors (server only!)

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasCompileErrors { get; }
ReadOnly Property HasCompileErrors As Boolean
    Get
property bool HasCompileErrors {
    bool get ();
}
abstract HasCompileErrors : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.ProgramData Property

IMyProgrammableBlockProgramData Property

Program contents. Automatically recompiles when set, if possible.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProgramData { get; set; }
Property ProgramData As String
    Get
    Set
property String^ ProgramData {
    String^ get ();
    void set (String^ value);
}
abstract ProgramData : string with get, set

Property Value

Type: String
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.StorageData Property

IMyProgrammableBlockStorageData Property

Program storage (server only!)

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string StorageData { get; set; }
Property StorageData As String
    Get
    Set
property String^ StorageData {
    String^ get ();
    void set (String^ value);
}
abstract StorageData : string with get, set

Property Value

Type: String
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock Methods

The IMyProgrammableBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | Recompile | Recompiles script
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Run | Runs with default terminal argument
Public method | Run(String) | Runs with specified argument
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | TryRun | Attempts to run this programmable block using the given argument. An already running programmable block cannot be run again. This is equivalent to running block.ApplyAction("Run", argumentsList); This should be called from an ingame script. Do not use in mods. (Inherited from IMyProgrammableBlock.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.Recompile Method

IMyProgrammableBlockRecompile Method

Recompiles script

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Recompile()
Sub Recompile
void Recompile()
abstract Recompile : unit -> unit
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.Run Method

IMyProgrammableBlockRun Method

Overload List
 | Name | Description
Public method | Run | Runs with default terminal argument
Public method | Run(String) | Runs with specified argument
Top
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProgrammableBlock.Run Method

IMyProgrammableBlockRun Method

Runs with default terminal argument

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Run()
Sub Run
void Run()
abstract Run : unit -> unit
See Also

Reference

IMyProgrammableBlock Interface
Run Overload
Sandbox.ModAPI Namespace


IMyProgrammableBlock.Run Method (String)

IMyProgrammableBlockRun Method (String)

Runs with specified argument

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Run(
    string argument
)
Sub Run (
    argument As String
)
void Run(
    String^ argument
)
abstract Run :
        argument : string -> unit

Parameters

argument
Type: SystemString

[Missing <param name="argument"/> documentation for "M:Sandbox.ModAPI.IMyProgrammableBlock.Run(System.String)"]

See Also

Reference

IMyProgrammableBlock Interface
Run Overload
Sandbox.ModAPI Namespace


IMyProgrammableBlock Events

The IMyProgrammableBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyProgrammableBlock Interface
Sandbox.ModAPI Namespace


IMyProjector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyProjector"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProjector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProjector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProjector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyProjector, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProjector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyProjector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProjector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyProjector
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProjector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BuildableBlocksCount | Count of blocks which can be welded now (Inherited from IMyProjector.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProjecting | Checks if there is an active projection (Inherited from IMyProjector.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | ProjectedGrid | The grid currently being projected. Will return null if there is no active projection.
Public property | ProjectionOffset | (Inherited from IMyProjector.)
Public property | ProjectionOffsetX | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionOffsetY | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionOffsetZ | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotation | These values are not in degrees. 1 = 90 degrees, 2 = 180 degrees (Inherited from IMyProjector.)
Public property | ProjectionRotX | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotY | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotZ | Obsolete. (Inherited from IMyProjector.)
Public property | RemainingArmorBlocks | Number of armor blocks left to be welded (Inherited from IMyProjector.)
Public property | RemainingBlocks | Number of blocks left to be welded (Inherited from IMyProjector.)
Public property | RemainingBlocksPerType | A comprehensive list of blocks left to be welded (Inherited from IMyProjector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TotalBlocks | Total number of blocks in the projection (Inherited from IMyProjector.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Build | Adds the first component to construction stockpile and creates the block. This doesn't remove materials from inventory on its own.
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanBuild | Checks if it's possible to build this block.
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | LoadBlueprint | (Inherited from IMyProjector.)
Public method | LoadRandomBlueprint | (Inherited from IMyProjector.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetProjectedGrid | Allows you to set the currently projected grid
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateOffsetAndRotation | Call this after setting ProjectionOffset and ProjectionRotation to update the projection (Inherited from IMyProjector.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyProjector Properties

The IMyProjector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BuildableBlocksCount | Count of blocks which can be welded now (Inherited from IMyProjector.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProjecting | Checks if there is an active projection (Inherited from IMyProjector.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | ProjectedGrid | The grid currently being projected. Will return null if there is no active projection.
Public property | ProjectionOffset | (Inherited from IMyProjector.)
Public property | ProjectionOffsetX | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionOffsetY | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionOffsetZ | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotation | These values are not in degrees. 1 = 90 degrees, 2 = 180 degrees (Inherited from IMyProjector.)
Public property | ProjectionRotX | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotY | Obsolete. (Inherited from IMyProjector.)
Public property | ProjectionRotZ | Obsolete. (Inherited from IMyProjector.)
Public property | RemainingArmorBlocks | Number of armor blocks left to be welded (Inherited from IMyProjector.)
Public property | RemainingBlocks | Number of blocks left to be welded (Inherited from IMyProjector.)
Public property | RemainingBlocksPerType | A comprehensive list of blocks left to be welded (Inherited from IMyProjector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TotalBlocks | Total number of blocks in the projection (Inherited from IMyProjector.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector.ProjectedGrid Property

IMyProjectorProjectedGrid Property

The grid currently being projected. Will return null if there is no active projection.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyCubeGrid ProjectedGrid { get; }
ReadOnly Property ProjectedGrid As IMyCubeGrid
    Get
property IMyCubeGrid^ ProjectedGrid {
    IMyCubeGrid^ get ();
}
abstract ProjectedGrid : IMyCubeGrid with get

Property Value

Type: IMyCubeGrid
See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector Methods

The IMyProjector type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | Build | Adds the first component to construction stockpile and creates the block. This doesn't remove materials from inventory on its own.
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanBuild | Checks if it's possible to build this block.
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | LoadBlueprint | (Inherited from IMyProjector.)
Public method | LoadRandomBlueprint | (Inherited from IMyProjector.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetProjectedGrid | Allows you to set the currently projected grid
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateOffsetAndRotation | Call this after setting ProjectionOffset and ProjectionRotation to update the projection (Inherited from IMyProjector.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector.Build Method

IMyProjectorBuild Method

Adds the first component to construction stockpile and creates the block. This doesn't remove materials from inventory on its own.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Build(
    IMySlimBlock cubeBlock,
    long owner,
    long builder,
    bool requestInstant
)
Sub Build (
    cubeBlock As IMySlimBlock,
    owner As Long,
    builder As Long,
    requestInstant As Boolean
)
void Build(
    IMySlimBlock^ cubeBlock,
    long long owner,
    long long builder,
    bool requestInstant
)
abstract Build :
        cubeBlock : IMySlimBlock *
        owner : int64 *
        builder : int64 *
        requestInstant : bool -> unit

Parameters

cubeBlock
Type: IMySlimBlock

[Missing <param name="cubeBlock"/> documentation for "M:Sandbox.ModAPI.IMyProjector.Build(VRage.Game.ModAPI.IMySlimBlock,System.Int64,System.Int64,System.Boolean)"]

owner
Type: SystemInt64

[Missing <param name="owner"/> documentation for "M:Sandbox.ModAPI.IMyProjector.Build(VRage.Game.ModAPI.IMySlimBlock,System.Int64,System.Int64,System.Boolean)"]

builder
Type: SystemInt64

[Missing <param name="builder"/> documentation for "M:Sandbox.ModAPI.IMyProjector.Build(VRage.Game.ModAPI.IMySlimBlock,System.Int64,System.Int64,System.Boolean)"]

requestInstant
Type: SystemBoolean

[Missing <param name="requestInstant"/> documentation for "M:Sandbox.ModAPI.IMyProjector.Build(VRage.Game.ModAPI.IMySlimBlock,System.Int64,System.Int64,System.Boolean)"]

See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector.CanBuild Method

IMyProjectorCanBuild Method

Checks if it's possible to build this block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BuildCheckResult CanBuild(
    IMySlimBlock projectedBlock,
    bool checkHavokIntersections
)
Function CanBuild (
    projectedBlock As IMySlimBlock,
    checkHavokIntersections As Boolean
) As BuildCheckResult
BuildCheckResult CanBuild(
    IMySlimBlock^ projectedBlock,
    bool checkHavokIntersections
)
abstract CanBuild :
        projectedBlock : IMySlimBlock *
        checkHavokIntersections : bool -> BuildCheckResult

Parameters

projectedBlock
Type: IMySlimBlock

[Missing <param name="projectedBlock"/> documentation for "M:Sandbox.ModAPI.IMyProjector.CanBuild(VRage.Game.ModAPI.IMySlimBlock,System.Boolean)"]

checkHavokIntersections
Type: SystemBoolean

[Missing <param name="checkHavokIntersections"/> documentation for "M:Sandbox.ModAPI.IMyProjector.CanBuild(VRage.Game.ModAPI.IMySlimBlock,System.Boolean)"]

Return Value

Type: BuildCheckResult

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyProjector.CanBuild(VRage.Game.ModAPI.IMySlimBlock,System.Boolean)"]

See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector.SetProjectedGrid Method

IMyProjectorSetProjectedGrid Method

Allows you to set the currently projected grid

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetProjectedGrid(
    MyObjectBuilder_CubeGrid grid
)
Sub SetProjectedGrid (
    grid As MyObjectBuilder_CubeGrid
)
void SetProjectedGrid(
    MyObjectBuilder_CubeGrid^ grid
)
abstract SetProjectedGrid :
        grid : MyObjectBuilder_CubeGrid -> unit

Parameters

grid
Type: MyObjectBuilder_CubeGrid

[Missing <param name="grid"/> documentation for "M:Sandbox.ModAPI.IMyProjector.SetProjectedGrid(VRage.Game.MyObjectBuilder_CubeGrid)"]

See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyProjector Events

The IMyProjector type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyProjector Interface
Sandbox.ModAPI Namespace


IMyRadioAntenna Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyRadioAntenna"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRadioAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyRadioAntenna, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRadioAntenna
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyRadioAntenna, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyRadioAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyRadioAntenna, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRadioAntenna =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyRadioAntenna
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRadioAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | IgnoreAlliedBroadcast | Ignores broadcasts sent by friendly antenna that do not belong to you (Inherited from IMyRadioAntenna.)
Public property | IgnoreOtherBroadcast | Ignores broadcasts sent by neutral and enemy antenna (Inherited from IMyRadioAntenna.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsBroadcasting | Returns true if antena is broadcasting (read-only) (Inherited from IMyRadioAntenna.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Broadcasting/Receiving range (read-only) (Inherited from IMyRadioAntenna.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowShipName | Show shipname on hud (read-only) (Inherited from IMyRadioAntenna.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TransmitMessage | Broadcasts a message to all PB attached to the antenna system. Broadcast is delayed until the start of the next tick, and only one transmission can be sent per tick. Returns false if broadcasting failed for any reason. (Inherited from IMyRadioAntenna.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyRadioAntenna Properties

The IMyRadioAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | IgnoreAlliedBroadcast | Ignores broadcasts sent by friendly antenna that do not belong to you (Inherited from IMyRadioAntenna.)
Public property | IgnoreOtherBroadcast | Ignores broadcasts sent by neutral and enemy antenna (Inherited from IMyRadioAntenna.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsBroadcasting | Returns true if antena is broadcasting (read-only) (Inherited from IMyRadioAntenna.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Broadcasting/Receiving range (read-only) (Inherited from IMyRadioAntenna.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowShipName | Show shipname on hud (read-only) (Inherited from IMyRadioAntenna.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRadioAntenna Interface
Sandbox.ModAPI Namespace


IMyRadioAntenna Methods

The IMyRadioAntenna type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TransmitMessage | Broadcasts a message to all PB attached to the antenna system. Broadcast is delayed until the start of the next tick, and only one transmission can be sent per tick. Returns false if broadcasting failed for any reason. (Inherited from IMyRadioAntenna.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRadioAntenna Interface
Sandbox.ModAPI Namespace


IMyRadioAntenna Events

The IMyRadioAntenna type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyRadioAntenna Interface
Sandbox.ModAPI Namespace


IMyReactor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyReactor"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyReactor : IMyReactor,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyReactor
    Inherits IMyReactor, IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyReactor : IMyReactor,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyReactor =
    interface
        interface IMyReactor
        interface IMyFunctionalBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyReactor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentOutput | Current output of reactor in Megawatts (Inherited from IMyReactor.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxOutput | Maximum output of reactor in Megawatts (Inherited from IMyReactor.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerOutputMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyReactor.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyReactor Properties

The IMyReactor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentOutput | Current output of reactor in Megawatts (Inherited from IMyReactor.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxOutput | Maximum output of reactor in Megawatts (Inherited from IMyReactor.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerOutputMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyReactor.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyReactor Interface
Sandbox.ModAPI Namespace


IMyReactor.PowerOutputMultiplier Property

IMyReactorPowerOutputMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyReactor.PowerOutputMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PowerOutputMultiplier { get; set; }
Property PowerOutputMultiplier As Single
    Get
    Set
property float PowerOutputMultiplier {
    float get ();
    void set (float value);
}
abstract PowerOutputMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyReactor Interface
Sandbox.ModAPI Namespace


IMyReactor Methods

The IMyReactor type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyReactor Interface
Sandbox.ModAPI Namespace


IMyReactor Events

The IMyReactor type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyReactor Interface
Sandbox.ModAPI Namespace


IMyRefinery Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyRefinery"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRefinery : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyRefinery,
    IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRefinery
    Inherits IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyRefinery, IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyRefinery : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyRefinery,
    IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRefinery =
    interface
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyRefinery
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRefinery type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory | (Inherited from IMyProductionBlock.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing | (Inherited from IMyProductionBlock.)
Public event | StoppedProducing | (Inherited from IMyProductionBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyRefinery Properties

The IMyRefinery type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InputInventory | (Inherited from IMyProductionBlock.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRefinery Interface
Sandbox.ModAPI Namespace


IMyRefinery Methods

The IMyRefinery type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionBase, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CanUseBlueprint(MyDefinitionBase) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint(MyDefinitionId) | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetQueue(ListMyProductionItem) | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionBase, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRefinery Interface
Sandbox.ModAPI Namespace


IMyRefinery Events

The IMyRefinery type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StartedProducing | (Inherited from IMyProductionBlock.)
Public event | StoppedProducing | (Inherited from IMyProductionBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyRefinery Interface
Sandbox.ModAPI Namespace


IMyReflectorLight Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyReflectorLight"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyReflectorLight : IMyLightingBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyReflectorLight,
    IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyReflectorLight
    Inherits IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyReflectorLight, IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyReflectorLight : IMyLightingBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyReflectorLight,
    IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyReflectorLight =
    interface
        interface IMyLightingBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyReflectorLight
        interface IMyLightingBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyReflectorLight type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyReflectorLight Properties

The IMyReflectorLight type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyReflectorLight Interface
Sandbox.ModAPI Namespace


IMyReflectorLight Methods

The IMyReflectorLight type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyReflectorLight Interface
Sandbox.ModAPI Namespace


IMyReflectorLight Events

The IMyReflectorLight type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyReflectorLight Interface
Sandbox.ModAPI Namespace


IMyRemoteControl Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyRemoteControl"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRemoteControl : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity, IMyRemoteControl,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRemoteControl
    Inherits IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyControllableEntity, IMyRemoteControl, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyRemoteControl : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity, IMyRemoteControl,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRemoteControl =
    interface
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyControllableEntity
        interface IMyRemoteControl
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRemoteControl type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAutoPilotEnabled | Determines whether the autopilot is currently enabled. (Inherited from IMyRemoteControl.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AddWaypoint | Adds a new waypoint. (Inherited from IMyRemoteControl.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | ClearWaypoints | Removes all existing waypoints. (Inherited from IMyRemoteControl.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFreeDestination | Gets a destination and tries to fix it so that it does not collide with anything
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetNearestPlayer | Gets the nearest player's position.
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWaypointInfo | Gets basic information about the currently configured waypoints. (Inherited from IMyRemoteControl.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetAutoPilotEnabled | Enables or disables the autopilot. (Inherited from IMyRemoteControl.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyRemoteControl Properties

The IMyRemoteControl type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAutoPilotEnabled | Determines whether the autopilot is currently enabled. (Inherited from IMyRemoteControl.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | Gets if the ship is shooting selected weapons. (Inherited from IMyShipController.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller. (Inherited from IMyShipController.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller. (Inherited from IMyShipController.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator (Inherited from IMyShipController.)
Public property | RotationIndicator | Gets the current rotation direction indicator (Inherited from IMyShipController.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRemoteControl Interface
Sandbox.ModAPI Namespace


IMyRemoteControl Methods

The IMyRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | AddWaypoint | Adds a new waypoint. (Inherited from IMyRemoteControl.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | ClearWaypoints | Removes all existing waypoints. (Inherited from IMyRemoteControl.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFreeDestination | Gets a destination and tries to fix it so that it does not collide with anything
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetNearestPlayer | Gets the nearest player's position.
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWaypointInfo | Gets basic information about the currently configured waypoints. (Inherited from IMyRemoteControl.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetAutoPilotEnabled | Enables or disables the autopilot. (Inherited from IMyRemoteControl.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRemoteControl Interface
Sandbox.ModAPI Namespace


IMyRemoteControl.GetFreeDestination Method

IMyRemoteControlGetFreeDestination Method

Gets a destination and tries to fix it so that it does not collide with anything

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3D GetFreeDestination(
    Vector3D originalDestination,
    float checkRadius,
    float shipRadius = 0f
)
Function GetFreeDestination (
    originalDestination As Vector3D,
    checkRadius As Single,
    Optional shipRadius As Single = 0F
) As Vector3D
Vector3D GetFreeDestination(
    Vector3D originalDestination,
    float checkRadius,
    float shipRadius = 0f
)
abstract GetFreeDestination :
        originalDestination : Vector3D *
        checkRadius : float32 *
        ?shipRadius : float32
(* Defaults:
        let _shipRadius = defaultArg shipRadius 0f
*)
-> Vector3D

Parameters

originalDestination
Type: Vector3D
The final destination that the remote wants to get to.
checkRadius
Type: SystemSingle
The maximum radius until which this method should search.
shipRadius (Optional)
Type: SystemSingle
The radius of our ship. Make sure that this is large enough to avoid collision. A value of 0f will use the ship's WorldVolume radius.

Return Value

Type: Vector3D
Adjusted position
See Also

Reference

IMyRemoteControl Interface
Sandbox.ModAPI Namespace


IMyRemoteControl.GetNearestPlayer Method

IMyRemoteControlGetNearestPlayer Method

Gets the nearest player's position.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetNearestPlayer(
    out Vector3D playerPosition
)
Function GetNearestPlayer (
    <OutAttribute> ByRef playerPosition As Vector3D
) As Boolean
bool GetNearestPlayer(
    [OutAttribute] Vector3D% playerPosition
)
abstract GetNearestPlayer :
        playerPosition : Vector3D byref -> bool

Parameters

playerPosition
Type: Vector3D

[Missing <param name="playerPosition"/> documentation for "M:Sandbox.ModAPI.IMyRemoteControl.GetNearestPlayer(VRageMath.Vector3D@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyRemoteControl.GetNearestPlayer(VRageMath.Vector3D@)"]

Implements

IMyRemoteControlGetNearestPlayer(Vector3D)
See Also

Reference

IMyRemoteControl Interface
Sandbox.ModAPI Namespace


IMyRemoteControl Events

The IMyRemoteControl type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyRemoteControl Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklist Interface

Exposes blacklist functionality to allow mods to disallow parts of the scripting API that has been allowed by the system whitelist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyScriptBlacklist
Public Interface IMyScriptBlacklist
public interface class IMyScriptBlacklist
type IMyScriptBlacklist =  interface end

The IMyScriptBlacklist type exposes the following members.

Methods
 | Name | Description
Public method | GetBlacklistedIngameEntries | Gets the entries that have been blacklisted for the ingame scripts.
Public method | GetWhitelist | Gets the entries that have been whitelisted by the system. Each entry may represent a whole namespace, a single type and all its members, or a single member of a type.
Public method | OpenIngameBlacklistBatch | Opens a batch to add or remove members to the blacklist.
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyScriptBlacklist Methods

The IMyScriptBlacklist type exposes the following members.

Methods
 | Name | Description
Public method | GetBlacklistedIngameEntries | Gets the entries that have been blacklisted for the ingame scripts.
Public method | GetWhitelist | Gets the entries that have been whitelisted by the system. Each entry may represent a whole namespace, a single type and all its members, or a single member of a type.
Public method | OpenIngameBlacklistBatch | Opens a batch to add or remove members to the blacklist.
Top
See Also

Reference

IMyScriptBlacklist Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklist.GetBlacklistedIngameEntries Method

IMyScriptBlacklistGetBlacklistedIngameEntries Method

Gets the entries that have been blacklisted for the ingame scripts.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
HashSetReader<string> GetBlacklistedIngameEntries()
Function GetBlacklistedIngameEntries As HashSetReader(Of String)
HashSetReader<String^> GetBlacklistedIngameEntries()
abstract GetBlacklistedIngameEntries : unit -> HashSetReader<string>

Return Value

Type: HashSetReaderString

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklist.GetBlacklistedIngameEntries"]

See Also

Reference

IMyScriptBlacklist Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklist.GetWhitelist Method

IMyScriptBlacklistGetWhitelist Method

Gets the entries that have been whitelisted by the system. Each entry may represent a whole namespace, a single type and all its members, or a single member of a type.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DictionaryReader<string, MyWhitelistTarget> GetWhitelist()
Function GetWhitelist As DictionaryReader(Of String, MyWhitelistTarget)
DictionaryReader<String^, MyWhitelistTarget> GetWhitelist()
abstract GetWhitelist : unit -> DictionaryReader<string, MyWhitelistTarget>

Return Value

Type: DictionaryReaderString, MyWhitelistTarget

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklist.GetWhitelist"]

See Also

Reference

IMyScriptBlacklist Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklist.OpenIngameBlacklistBatch Method

IMyScriptBlacklistOpenIngameBlacklistBatch Method

Opens a batch to add or remove members to the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyScriptBlacklistBatch OpenIngameBlacklistBatch()
Function OpenIngameBlacklistBatch As IMyScriptBlacklistBatch
IMyScriptBlacklistBatch^ OpenIngameBlacklistBatch()
abstract OpenIngameBlacklistBatch : unit -> IMyScriptBlacklistBatch

Return Value

Type: IMyScriptBlacklistBatch

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklist.OpenIngameBlacklistBatch"]

See Also

Reference

IMyScriptBlacklist Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch Interface

A handle which enables adding members to the blacklist in a batch. It is highly recommended that you try to group your changes into as few batches as possible.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyScriptBlacklistBatch : IDisposable
Public Interface IMyScriptBlacklistBatch
    Inherits IDisposable
public interface class IMyScriptBlacklistBatch : IDisposable
type IMyScriptBlacklistBatch =
    interface
        interface IDisposable
    end

The IMyScriptBlacklistBatch type exposes the following members.

Methods
 | Name | Description
Public method | AddMembers | Adds only the specified members to the blacklist.
Public method | AddNamespaceOfTypes | Adds the entire namespace of one or more given types to the blacklist
Public method | AddTypes | Adds one or more specific types and all their members to the blacklist.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RemoveMembers | Removes types previously added with AddMembers(Type, String) to the blacklist.
Public method | RemoveNamespaceOfTypes | Removes namespaces previously added with AddNamespaceOfTypes(Type) from the blacklist.
Public method | RemoveTypes | Removes types previously added with AddTypes(Type) from the blacklist.
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch Methods

The IMyScriptBlacklistBatch type exposes the following members.

Methods
 | Name | Description
Public method | AddMembers | Adds only the specified members to the blacklist.
Public method | AddNamespaceOfTypes | Adds the entire namespace of one or more given types to the blacklist
Public method | AddTypes | Adds one or more specific types and all their members to the blacklist.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RemoveMembers | Removes types previously added with AddMembers(Type, String) to the blacklist.
Public method | RemoveNamespaceOfTypes | Removes namespaces previously added with AddNamespaceOfTypes(Type) from the blacklist.
Public method | RemoveTypes | Removes types previously added with AddTypes(Type) from the blacklist.
Top
See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.AddMembers Method

IMyScriptBlacklistBatchAddMembers Method

Adds only the specified members to the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddMembers(
    Type type,
    params string[] memberNames
)
Sub AddMembers (
    type As Type,
    ParamArray memberNames As String()
)
void AddMembers(
    Type^ type,
    ... array<String^>^ memberNames
)
abstract AddMembers :
        type : Type *
        memberNames : string[] -> unit

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklistBatch.AddMembers(System.Type,System.String[])"]

memberNames
Type: SystemString

[Missing <param name="memberNames"/> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklistBatch.AddMembers(System.Type,System.String[])"]

See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.AddNamespaceOfTypes Method

IMyScriptBlacklistBatchAddNamespaceOfTypes Method

Adds the entire namespace of one or more given types to the blacklist

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddNamespaceOfTypes(
    params Type[] types
)
Sub AddNamespaceOfTypes (
    ParamArray types As Type()
)
void AddNamespaceOfTypes(
    ... array<Type^>^ types
)
abstract AddNamespaceOfTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType

[Missing <param name="types"/> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklistBatch.AddNamespaceOfTypes(System.Type[])"]

See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.AddTypes Method

IMyScriptBlacklistBatchAddTypes Method

Adds one or more specific types and all their members to the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddTypes(
    params Type[] types
)
Sub AddTypes (
    ParamArray types As Type()
)
void AddTypes(
    ... array<Type^>^ types
)
abstract AddTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType

[Missing <param name="types"/> documentation for "M:Sandbox.ModAPI.IMyScriptBlacklistBatch.AddTypes(System.Type[])"]

See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.RemoveMembers Method

IMyScriptBlacklistBatchRemoveMembers Method

Removes types previously added with AddMembers(Type, String) to the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveMembers(
    Type type,
    params string[] memberNames
)
Sub RemoveMembers (
    type As Type,
    ParamArray memberNames As String()
)
void RemoveMembers(
    Type^ type,
    ... array<String^>^ memberNames
)
abstract RemoveMembers :
        type : Type *
        memberNames : string[] -> unit

Parameters

type
Type: SystemType
memberNames
Type: SystemString
See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.RemoveNamespaceOfTypes Method

IMyScriptBlacklistBatchRemoveNamespaceOfTypes Method

Removes namespaces previously added with AddNamespaceOfTypes(Type) from the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveNamespaceOfTypes(
    params Type[] types
)
Sub RemoveNamespaceOfTypes (
    ParamArray types As Type()
)
void RemoveNamespaceOfTypes(
    ... array<Type^>^ types
)
abstract RemoveNamespaceOfTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType
See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMyScriptBlacklistBatch.RemoveTypes Method

IMyScriptBlacklistBatchRemoveTypes Method

Removes types previously added with AddTypes(Type) from the blacklist.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveTypes(
    params Type[] types
)
Sub RemoveTypes (
    ParamArray types As Type()
)
void RemoveTypes(
    ... array<Type^>^ types
)
abstract RemoveTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType
See Also

Reference

IMyScriptBlacklistBatch Interface
Sandbox.ModAPI Namespace


IMySensorBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMySensorBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySensorBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySensorBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySensorBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMySensorBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMySensorBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySensorBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySensorBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMySensorBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySensorBlock type exposes the following members.

Properties
 | Name | Description
Public property | BackExtend | Gets or sets the back range of the sensor. (Inherited from IMySensorBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BottomExtend | Gets or sets the bottom range of the sensor. (Inherited from IMySensorBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetectAsteroids | Gets or sets if the sensor should detect asteroids or planets. (Inherited from IMySensorBlock.)
Public property | DetectEnemy | Gets or sets if the sensor should detect enemy players. (Inherited from IMySensorBlock.)
Public property | DetectFloatingObjects | Gets or sets if the sensor should detect floating objects (components, rocks). (Inherited from IMySensorBlock.)
Public property | DetectFriendly | Gets or sets if the sensor should detect friendly players. (Inherited from IMySensorBlock.)
Public property | DetectLargeShips | Gets or sets if the sensor should detect large ships. (Inherited from IMySensorBlock.)
Public property | DetectNeutral | Gets or sets if the sensor should detect neutral players. (Inherited from IMySensorBlock.)
Public property | DetectOwner | Gets or sets if the sensor should detect the block owner. (Inherited from IMySensorBlock.)
Public property | DetectPlayers | Gets or sets if the sensor should detect players. (Inherited from IMySensorBlock.)
Public property | DetectSmallShips | Gets or sets if the sensor should detect small ships. (Inherited from IMySensorBlock.)
Public property | DetectStations | Gets or sets if the sensor should detect large stations. (Inherited from IMySensorBlock.)
Public property | DetectSubgrids | Gets or sets if the sensor should detect subgrids (eg. connected by connector). (Inherited from IMySensorBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FieldMax | Gets or sets the sensor maximum field as a Vector3(R,T,Ba).
Public property | FieldMin | Gets or sets the sensor mininum field as a Vector3(-L,-Bo,-F).
Public property | Flags | (Inherited from IMyEntity.)
Public property | FrontExtend | Gets or sets the front range of the sensor. (Inherited from IMySensorBlock.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Gets if there is any entity currently being detected. (Inherited from IMySensorBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastDetectedEntity | (Inherited from IMySensorBlock.)
Public property | LeftExtend | Gets or sets the left range of the sensor. (Inherited from IMySensorBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRange | Gets the maximum range of the sensor in any direction. (Inherited from IMySensorBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PlayProximitySound | Gets or sets if the proximity sound plays when an entity is detected. (Inherited from IMySensorBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RightExtend | Gets or sets the right range of the sensor. (Inherited from IMySensorBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TopExtend | Gets or sets the top range of the sensor. (Inherited from IMySensorBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DetectedEntities | (Inherited from IMySensorBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StateChanged |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMySensorBlock Properties

The IMySensorBlock type exposes the following members.

Properties
 | Name | Description
Public property | BackExtend | Gets or sets the back range of the sensor. (Inherited from IMySensorBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BottomExtend | Gets or sets the bottom range of the sensor. (Inherited from IMySensorBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetectAsteroids | Gets or sets if the sensor should detect asteroids or planets. (Inherited from IMySensorBlock.)
Public property | DetectEnemy | Gets or sets if the sensor should detect enemy players. (Inherited from IMySensorBlock.)
Public property | DetectFloatingObjects | Gets or sets if the sensor should detect floating objects (components, rocks). (Inherited from IMySensorBlock.)
Public property | DetectFriendly | Gets or sets if the sensor should detect friendly players. (Inherited from IMySensorBlock.)
Public property | DetectLargeShips | Gets or sets if the sensor should detect large ships. (Inherited from IMySensorBlock.)
Public property | DetectNeutral | Gets or sets if the sensor should detect neutral players. (Inherited from IMySensorBlock.)
Public property | DetectOwner | Gets or sets if the sensor should detect the block owner. (Inherited from IMySensorBlock.)
Public property | DetectPlayers | Gets or sets if the sensor should detect players. (Inherited from IMySensorBlock.)
Public property | DetectSmallShips | Gets or sets if the sensor should detect small ships. (Inherited from IMySensorBlock.)
Public property | DetectStations | Gets or sets if the sensor should detect large stations. (Inherited from IMySensorBlock.)
Public property | DetectSubgrids | Gets or sets if the sensor should detect subgrids (eg. connected by connector). (Inherited from IMySensorBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | FieldMax | Gets or sets the sensor maximum field as a Vector3(R,T,Ba).
Public property | FieldMin | Gets or sets the sensor mininum field as a Vector3(-L,-Bo,-F).
Public property | Flags | (Inherited from IMyEntity.)
Public property | FrontExtend | Gets or sets the front range of the sensor. (Inherited from IMySensorBlock.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Gets if there is any entity currently being detected. (Inherited from IMySensorBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastDetectedEntity | (Inherited from IMySensorBlock.)
Public property | LeftExtend | Gets or sets the left range of the sensor. (Inherited from IMySensorBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxRange | Gets the maximum range of the sensor in any direction. (Inherited from IMySensorBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | PlayProximitySound | Gets or sets if the proximity sound plays when an entity is detected. (Inherited from IMySensorBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RightExtend | Gets or sets the right range of the sensor. (Inherited from IMySensorBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | TopExtend | Gets or sets the top range of the sensor. (Inherited from IMySensorBlock.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMySensorBlock.FieldMax Property

IMySensorBlockFieldMax Property

Gets or sets the sensor maximum field as a Vector3(R,T,Ba).

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 FieldMax { get; set; }
Property FieldMax As Vector3
    Get
    Set
property Vector3 FieldMax {
    Vector3 get ();
    void set (Vector3 value);
}
abstract FieldMax : Vector3 with get, set

Property Value

Type: Vector3
Remarks
X is Right Y is Top Z is Back
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMySensorBlock.FieldMin Property

IMySensorBlockFieldMin Property

Gets or sets the sensor mininum field as a Vector3(-L,-Bo,-F).

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 FieldMin { get; set; }
Property FieldMin As Vector3
    Get
    Set
property Vector3 FieldMin {
    Vector3 get ();
    void set (Vector3 value);
}
abstract FieldMin : Vector3 with get, set

Property Value

Type: Vector3
Remarks
-X is Left -Y is Bottom -Z is Front
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMySensorBlock Methods

The IMySensorBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DetectedEntities | (Inherited from IMySensorBlock.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMySensorBlock Events

The IMySensorBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | StateChanged |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMySensorBlock.StateChanged Event

IMySensorBlockStateChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMySensorBlock.StateChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<bool> StateChanged
Event StateChanged As Action(Of Boolean)
 event Action<bool>^ StateChanged {
    void add (Action<bool>^ value);
    void remove (Action<bool>^ value);
}
abstract StateChanged : IEvent<Action<bool>,
    EventArgs>

Value

Type: SystemAction Boolean
See Also

Reference

IMySensorBlock Interface
Sandbox.ModAPI Namespace


IMyShipConnector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyShipConnector"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipConnector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipConnector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipConnector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyShipConnector, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipConnector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipConnector, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipConnector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyShipConnector
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipConnector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | CollectAll | Gets or sets whether this connector should be pulling items into its inventory. (Inherited from IMyShipConnector.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsConnected | Obsolete. (Inherited from IMyShipConnector.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. (Inherited from IMyShipConnector.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OtherConnector |
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PullStrength | Gets or sets the currently configured strength of the pull when the connector is within range of another. (Inherited from IMyShipConnector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current status of the connector. (Inherited from IMyShipConnector.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | ThrowOut | Gets or sets whether this connector should throw out anything placed in its inventory. (Inherited from IMyShipConnector.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Connect | Attempts to connect. If Status is anything else but [!:ConnectorStatus.Connectable], this method does nothing. (Inherited from IMyShipConnector.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Disconnect | Disconnects this connector. (Inherited from IMyShipConnector.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleConnect | Toggles between [!:ConnectorStatus.Connected] and [!:ConnectorStatus.Unconnected], depending on the current status. Another connector must be in range for this method to have any effect. (Inherited from IMyShipConnector.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipConnector Properties

The IMyShipConnector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | CollectAll | Gets or sets whether this connector should be pulling items into its inventory. (Inherited from IMyShipConnector.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsConnected | Obsolete. (Inherited from IMyShipConnector.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. (Inherited from IMyShipConnector.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OtherConnector |
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PullStrength | Gets or sets the currently configured strength of the pull when the connector is within range of another. (Inherited from IMyShipConnector.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Status | Determines the current status of the connector. (Inherited from IMyShipConnector.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | ThrowOut | Gets or sets whether this connector should throw out anything placed in its inventory. (Inherited from IMyShipConnector.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipConnector Interface
Sandbox.ModAPI Namespace


IMyShipConnector.OtherConnector Property

IMyShipConnectorOtherConnector Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyShipConnector.OtherConnector"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyShipConnector OtherConnector { get; }
ReadOnly Property OtherConnector As IMyShipConnector
    Get
property IMyShipConnector^ OtherConnector {
    IMyShipConnector^ get ();
}
abstract OtherConnector : IMyShipConnector with get

Property Value

Type: IMyShipConnector
See Also

Reference

IMyShipConnector Interface
Sandbox.ModAPI Namespace


IMyShipConnector Methods

The IMyShipConnector type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Connect | Attempts to connect. If Status is anything else but [!:ConnectorStatus.Connectable], this method does nothing. (Inherited from IMyShipConnector.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Disconnect | Disconnects this connector. (Inherited from IMyShipConnector.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ToggleConnect | Toggles between [!:ConnectorStatus.Connected] and [!:ConnectorStatus.Unconnected], depending on the current status. Another connector must be in range for this method to have any effect. (Inherited from IMyShipConnector.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipConnector Interface
Sandbox.ModAPI Namespace


IMyShipConnector Events

The IMyShipConnector type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipConnector Interface
Sandbox.ModAPI Namespace


IMyShipController Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyShipController"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipController : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyControllableEntity
Public Interface IMyShipController
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyControllableEntity
public interface class IMyShipController : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyControllableEntity
type IMyShipController =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyControllableEntity
    end

The IMyShipController type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | Gets if the ship is shooting selected weapons.
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller.
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller.
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator
Public property | RotationIndicator | Gets the current rotation direction indicator
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipController Properties

The IMyShipController type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControllerInfo | (Inherited from IMyControllableEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EnabledDamping | (Inherited from IMyControllableEntity.)
Public property | EnabledHelmet | (Inherited from IMyControllableEntity.)
Public property | EnabledLeadingGears | (Inherited from IMyControllableEntity.)
Public property | EnabledLights | (Inherited from IMyControllableEntity.)
Public property | EnabledReactors | (Inherited from IMyControllableEntity.)
Public property | EnabledThrusts | (Inherited from IMyControllableEntity.)
Public property | Entity | (Inherited from IMyControllableEntity.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | ForceFirstPersonCamera | (Inherited from IMyControllableEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasFirstPersonCamera | Gets if this ship controller contains a first-person camera view.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | Gets if the ship is shooting selected weapons.
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastPilot | Get the last character that was piloting the controller.
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | MoveIndicator | Gets the current movement direction indicator
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Pilot | Get the character that is currently piloting the controller.
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PrimaryLookaround | (Inherited from IMyControllableEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Gets the current roll direction indicator
Public property | RotationIndicator | Gets the current rotation direction indicator
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.HasFirstPersonCamera Property

IMyShipControllerHasFirstPersonCamera Property

Gets if this ship controller contains a first-person camera view.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasFirstPersonCamera { get; }
ReadOnly Property HasFirstPersonCamera As Boolean
    Get
property bool HasFirstPersonCamera {
    bool get ();
}
abstract HasFirstPersonCamera : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.IsShooting Property

IMyShipControllerIsShooting Property

Gets if the ship is shooting selected weapons.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsShooting { get; }
ReadOnly Property IsShooting As Boolean
    Get
property bool IsShooting {
    bool get ();
}
abstract IsShooting : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.LastPilot Property

IMyShipControllerLastPilot Property

Get the last character that was piloting the controller.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyCharacter LastPilot { get; }
ReadOnly Property LastPilot As IMyCharacter
    Get
property IMyCharacter^ LastPilot {
    IMyCharacter^ get ();
}
abstract LastPilot : IMyCharacter with get

Property Value

Type: IMyCharacter
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.MoveIndicator Property

IMyShipControllerMoveIndicator Property

Gets the current movement direction indicator

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 MoveIndicator { get; }
ReadOnly Property MoveIndicator As Vector3
    Get
property Vector3 MoveIndicator {
    Vector3 get ();
}
abstract MoveIndicator : Vector3 with get

Property Value

Type: Vector3

Implements

IMyShipControllerMoveIndicator
Remarks
Set by MoveAndRotate, regardless if a movement happened.
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.Pilot Property

IMyShipControllerPilot Property

Get the character that is currently piloting the controller.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyCharacter Pilot { get; }
ReadOnly Property Pilot As IMyCharacter
    Get
property IMyCharacter^ Pilot {
    IMyCharacter^ get ();
}
abstract Pilot : IMyCharacter with get

Property Value

Type: IMyCharacter
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.RollIndicator Property

IMyShipControllerRollIndicator Property

Gets the current roll direction indicator

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float RollIndicator { get; }
ReadOnly Property RollIndicator As Single
    Get
property float RollIndicator {
    float get ();
}
abstract RollIndicator : float32 with get

Property Value

Type: Single

Implements

IMyShipControllerRollIndicator
Remarks
Set by MoveAndRotate, regardless if a movement happened.
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController.RotationIndicator Property

IMyShipControllerRotationIndicator Property

Gets the current rotation direction indicator

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector2 RotationIndicator { get; }
ReadOnly Property RotationIndicator As Vector2
    Get
property Vector2 RotationIndicator {
    Vector2 get ();
}
abstract RotationIndicator : Vector2 with get

Property Value

Type: Vector2

Implements

IMyShipControllerRotationIndicator
Remarks
Set by MoveAndRotate, regardless if a movement happened.
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController Methods

The IMyShipController type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | Close | (Inherited from IMyEntity.)
Public method | Crouch | (Inherited from IMyControllableEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | Die | (Inherited from IMyControllableEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | Down | (Inherited from IMyControllableEntity.)
Public method | DrawHud | (Inherited from IMyControllableEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetHeadMatrix | (Inherited from IMyControllableEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | Jump | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotate | (Inherited from IMyControllableEntity.)
Public method | MoveAndRotateStopped | (Inherited from IMyControllableEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | PickUp | (Inherited from IMyControllableEntity.)
Public method | PickUpContinues | (Inherited from IMyControllableEntity.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowInventory | (Inherited from IMyControllableEntity.)
Public method | ShowTerminal | (Inherited from IMyControllableEntity.)
Public method | SwitchDamping | (Inherited from IMyControllableEntity.)
Public method | SwitchHelmet | (Inherited from IMyControllableEntity.)
Public method | SwitchLeadingGears | (Inherited from IMyControllableEntity.)
Public method | SwitchLights | (Inherited from IMyControllableEntity.)
Public method | SwitchReactors | (Inherited from IMyControllableEntity.)
Public method | SwitchThrusts | (Inherited from IMyControllableEntity.)
Public method | SwitchWalk | (Inherited from IMyControllableEntity.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | Up | (Inherited from IMyControllableEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | Use | (Inherited from IMyControllableEntity.)
Public method | UseContinues | (Inherited from IMyControllableEntity.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipController Events

The IMyShipController type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipController Interface
Sandbox.ModAPI Namespace


IMyShipDrill Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyShipDrill"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipDrill : IMyShipDrill,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipDrill
    Inherits IMyShipDrill, IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipDrill : IMyShipDrill,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipDrill =
    interface
        interface IMyShipDrill
        interface IMyFunctionalBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipDrill type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrillHarvestMultiplier |
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipDrill.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipDrill Properties

The IMyShipDrill type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrillHarvestMultiplier |
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipDrill.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipDrill Interface
Sandbox.ModAPI Namespace


IMyShipDrill.DrillHarvestMultiplier Property

IMyShipDrillDrillHarvestMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyShipDrill.DrillHarvestMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float DrillHarvestMultiplier { get; set; }
Property DrillHarvestMultiplier As Single
    Get
    Set
property float DrillHarvestMultiplier {
    float get ();
    void set (float value);
}
abstract DrillHarvestMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyShipDrill Interface
Sandbox.ModAPI Namespace


IMyShipDrill.PowerConsumptionMultiplier Property

IMyShipDrillPowerConsumptionMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyShipDrill.PowerConsumptionMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PowerConsumptionMultiplier { get; set; }
Property PowerConsumptionMultiplier As Single
    Get
    Set
property float PowerConsumptionMultiplier {
    float get ();
    void set (float value);
}
abstract PowerConsumptionMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyShipDrill Interface
Sandbox.ModAPI Namespace


IMyShipDrill Methods

The IMyShipDrill type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipDrill Interface
Sandbox.ModAPI Namespace


IMyShipDrill Events

The IMyShipDrill type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipDrill Interface
Sandbox.ModAPI Namespace


IMyShipGrinder Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyShipGrinder"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipGrinder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipGrinder,
    IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipGrinder
    Inherits IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyShipGrinder, IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyShipGrinder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipGrinder,
    IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipGrinder =
    interface
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyShipGrinder
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipGrinder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipGrinder Properties

The IMyShipGrinder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipGrinder Interface
Sandbox.ModAPI Namespace


IMyShipGrinder Methods

The IMyShipGrinder type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipGrinder Interface
Sandbox.ModAPI Namespace


IMyShipGrinder Events

The IMyShipGrinder type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipGrinder Interface
Sandbox.ModAPI Namespace


IMyShipToolBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyShipToolBase"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipToolBase : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipToolBase, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipToolBase
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipToolBase : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipToolBase, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipToolBase =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipToolBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipToolBase Properties

The IMyShipToolBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipToolBase Interface
Sandbox.ModAPI Namespace


IMyShipToolBase Methods

The IMyShipToolBase type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipToolBase Interface
Sandbox.ModAPI Namespace


IMyShipToolBase Events

The IMyShipToolBase type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipToolBase Interface
Sandbox.ModAPI Namespace


IMyShipWelder Interface

Ship welder interface

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipWelder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipWelder,
    IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipWelder
    Inherits IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyShipWelder, IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyShipWelder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyShipWelder,
    IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipWelder =
    interface
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyShipWelder
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipWelder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HelpOthers | True if welder is set to helper mode (Inherited from IMyShipWelder.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyShipWelder Properties

The IMyShipWelder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HelpOthers | True if welder is set to helper mode (Inherited from IMyShipWelder.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipWelder Interface
Sandbox.ModAPI Namespace


IMyShipWelder Methods

The IMyShipWelder type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipWelder Interface
Sandbox.ModAPI Namespace


IMyShipWelder Events

The IMyShipWelder type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyShipWelder Interface
Sandbox.ModAPI Namespace


IMySmallGatlingGun Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMySmallGatlingGun"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallGatlingGun : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySmallGatlingGun,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySmallGatlingGun
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMySmallGatlingGun, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMySmallGatlingGun : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySmallGatlingGun,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySmallGatlingGun =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMySmallGatlingGun
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallGatlingGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallGatlingGun.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMySmallGatlingGun Properties

The IMySmallGatlingGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallGatlingGun.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallGatlingGun Interface
Sandbox.ModAPI Namespace


IMySmallGatlingGun Methods

The IMySmallGatlingGun type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallGatlingGun Interface
Sandbox.ModAPI Namespace


IMySmallGatlingGun Events

The IMySmallGatlingGun type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMySmallGatlingGun Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncher Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMySmallMissileLauncher"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallMissileLauncher : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySmallMissileLauncher
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMySmallMissileLauncher, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMySmallMissileLauncher : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySmallMissileLauncher =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMySmallMissileLauncher
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallMissileLauncher type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMySmallMissileLauncher Properties

The IMySmallMissileLauncher type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallMissileLauncher Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncher Methods

The IMySmallMissileLauncher type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallMissileLauncher Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncher Events

The IMySmallMissileLauncher type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMySmallMissileLauncher Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncherReload Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMySmallMissileLauncherReload"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallMissileLauncherReload : IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMySmallMissileLauncherReload, IMySmallMissileLauncher, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMySmallMissileLauncherReload
    Inherits IMySmallMissileLauncher, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMySmallMissileLauncherReload, IMySmallMissileLauncher, IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMySmallMissileLauncherReload : IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMySmallMissileLauncherReload, IMySmallMissileLauncher, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMySmallMissileLauncherReload =
    interface
        interface IMySmallMissileLauncher
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMySmallMissileLauncherReload
        interface IMySmallMissileLauncher
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallMissileLauncherReload type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMySmallMissileLauncherReload Properties

The IMySmallMissileLauncherReload type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallMissileLauncherReload Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncherReload Methods

The IMySmallMissileLauncherReload type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallMissileLauncherReload Interface
Sandbox.ModAPI Namespace


IMySmallMissileLauncherReload Events

The IMySmallMissileLauncherReload type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMySmallMissileLauncherReload Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyTerminalActionsHelper"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalActionsHelper
Public Interface IMyTerminalActionsHelper
public interface class IMyTerminalActionsHelper
type IMyTerminalActionsHelper =  interface end

The IMyTerminalActionsHelper type exposes the following members.

Methods
 | Name | Description
Public method | GetActions |
Public method | GetActionWithName |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetTerminalSystemForGrid |
Public method | SearchActionsOfName |
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyTerminalActionsHelper Methods

The IMyTerminalActionsHelper type exposes the following members.

Methods
 | Name | Description
Public method | GetActions |
Public method | GetActionWithName |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetTerminalSystemForGrid |
Public method | SearchActionsOfName |
Top
See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.GetActions Method

IMyTerminalActionsHelperGetActions Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActions(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetActions(
    Type blockType,
    List<ITerminalAction> resultList,
    Func<ITerminalAction, bool> collect = null
)
Sub GetActions (
    blockType As Type,
    resultList As List(Of ITerminalAction),
    Optional collect As Func(Of ITerminalAction, Boolean) = Nothing
)
void GetActions(
    Type^ blockType,
    List<ITerminalAction^>^ resultList,
    Func<ITerminalAction^, bool>^ collect = nullptr
)
abstract GetActions :
        blockType : Type *
        resultList : List<ITerminalAction> *
        ?collect : Func<ITerminalAction, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blockType
Type: SystemType

[Missing <param name="blockType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActions(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

resultList
Type: System.Collections.GenericList ITerminalAction

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActions(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalAction, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActions(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.GetActionWithName Method

IMyTerminalActionsHelperGetActionWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActionWithName(System.String,System.Type)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ITerminalAction GetActionWithName(
    string nameType,
    Type blockType
)
Function GetActionWithName (
    nameType As String,
    blockType As Type
) As ITerminalAction
ITerminalAction^ GetActionWithName(
    String^ nameType,
    Type^ blockType
)
abstract GetActionWithName :
        nameType : string *
        blockType : Type -> ITerminalAction

Parameters

nameType
Type: SystemString

[Missing <param name="nameType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActionWithName(System.String,System.Type)"]

blockType
Type: SystemType

[Missing <param name="blockType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActionWithName(System.String,System.Type)"]

Return Value

Type: ITerminalAction

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetActionWithName(System.String,System.Type)"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.GetProperties Method

IMyTerminalActionsHelperGetProperties Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperties(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetProperties(
    Type blockType,
    List<ITerminalProperty> resultList,
    Func<ITerminalProperty, bool> collect = null
)
Sub GetProperties (
    blockType As Type,
    resultList As List(Of ITerminalProperty),
    Optional collect As Func(Of ITerminalProperty, Boolean) = Nothing
)
void GetProperties(
    Type^ blockType,
    List<ITerminalProperty^>^ resultList,
    Func<ITerminalProperty^, bool>^ collect = nullptr
)
abstract GetProperties :
        blockType : Type *
        resultList : List<ITerminalProperty> *
        ?collect : Func<ITerminalProperty, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blockType
Type: SystemType

[Missing <param name="blockType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperties(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

resultList
Type: System.Collections.GenericList ITerminalProperty

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperties(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalProperty, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperties(System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.GetProperty Method

IMyTerminalActionsHelperGetProperty Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperty(System.String,System.Type)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ITerminalProperty GetProperty(
    string id,
    Type blockType
)
Function GetProperty (
    id As String,
    blockType As Type
) As ITerminalProperty
ITerminalProperty^ GetProperty(
    String^ id,
    Type^ blockType
)
abstract GetProperty :
        id : string *
        blockType : Type -> ITerminalProperty

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperty(System.String,System.Type)"]

blockType
Type: SystemType

[Missing <param name="blockType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperty(System.String,System.Type)"]

Return Value

Type: ITerminalProperty

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetProperty(System.String,System.Type)"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.GetTerminalSystemForGrid Method

IMyTerminalActionsHelperGetTerminalSystemForGrid Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetTerminalSystemForGrid(VRage.Game.ModAPI.IMyCubeGrid)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyGridTerminalSystem GetTerminalSystemForGrid(
    IMyCubeGrid grid
)
Function GetTerminalSystemForGrid (
    grid As IMyCubeGrid
) As IMyGridTerminalSystem
IMyGridTerminalSystem^ GetTerminalSystemForGrid(
    IMyCubeGrid^ grid
)
abstract GetTerminalSystemForGrid :
        grid : IMyCubeGrid -> IMyGridTerminalSystem

Parameters

grid
Type: IMyCubeGrid

[Missing <param name="grid"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetTerminalSystemForGrid(VRage.Game.ModAPI.IMyCubeGrid)"]

Return Value

Type: IMyGridTerminalSystem

[Missing <returns> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.GetTerminalSystemForGrid(VRage.Game.ModAPI.IMyCubeGrid)"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalActionsHelper.SearchActionsOfName Method

IMyTerminalActionsHelperSearchActionsOfName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.SearchActionsOfName(System.String,System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SearchActionsOfName(
    string name,
    Type blockType,
    List<ITerminalAction> resultList,
    Func<ITerminalAction, bool> collect = null
)
Sub SearchActionsOfName (
    name As String,
    blockType As Type,
    resultList As List(Of ITerminalAction),
    Optional collect As Func(Of ITerminalAction, Boolean) = Nothing
)
void SearchActionsOfName(
    String^ name,
    Type^ blockType,
    List<ITerminalAction^>^ resultList,
    Func<ITerminalAction^, bool>^ collect = nullptr
)
abstract SearchActionsOfName :
        name : string *
        blockType : Type *
        resultList : List<ITerminalAction> *
        ?collect : Func<ITerminalAction, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.SearchActionsOfName(System.String,System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

blockType
Type: SystemType

[Missing <param name="blockType"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.SearchActionsOfName(System.String,System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

resultList
Type: System.Collections.GenericList ITerminalAction

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.SearchActionsOfName(System.String,System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalAction, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.IMyTerminalActionsHelper.SearchActionsOfName(System.String,System.Type,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

See Also

Reference

IMyTerminalActionsHelper Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyTerminalBlock"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalBlock : IMyCubeBlock,
    IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyTerminalBlock
    Inherits IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyTerminalBlock : IMyCubeBlock,
    IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyTerminalBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyTerminalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info.
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info.
Public event | CustomNameChanged |
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged |
Public event | PropertiesChanged |
Public event | ShowOnHUDChanged |
Public event | VisibilityChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyTerminalBlock Properties

The IMyTerminalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock Methods

The IMyTerminalBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info.
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.RefreshCustomInfo Method

IMyTerminalBlockRefreshCustomInfo Method

Raises AppendingCustomInfo so every subscriber can append custom info.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshCustomInfo()
Sub RefreshCustomInfo
void RefreshCustomInfo()
abstract RefreshCustomInfo : unit -> unit
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock Events

The IMyTerminalBlock type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info.
Public event | CustomNameChanged |
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged |
Public event | PropertiesChanged |
Public event | ShowOnHUDChanged |
Public event | VisibilityChanged |
Top
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.AppendingCustomInfo Event

IMyTerminalBlockAppendingCustomInfo Event

Event to append custom info.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock, StringBuilder> AppendingCustomInfo
Event AppendingCustomInfo As Action(Of IMyTerminalBlock, StringBuilder)
 event Action<IMyTerminalBlock^, StringBuilder^>^ AppendingCustomInfo {
    void add (Action<IMyTerminalBlock^, StringBuilder^>^ value);
    void remove (Action<IMyTerminalBlock^, StringBuilder^>^ value);
}
abstract AppendingCustomInfo : IEvent<Action<IMyTerminalBlock, StringBuilder>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock, StringBuilder
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.CustomNameChanged Event

IMyTerminalBlockCustomNameChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyTerminalBlock.CustomNameChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> CustomNameChanged
Event CustomNameChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ CustomNameChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract CustomNameChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.OwnershipChanged Event

IMyTerminalBlockOwnershipChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyTerminalBlock.OwnershipChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> OwnershipChanged
Event OwnershipChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ OwnershipChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract OwnershipChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.PropertiesChanged Event

IMyTerminalBlockPropertiesChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyTerminalBlock.PropertiesChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> PropertiesChanged
Event PropertiesChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ PropertiesChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract PropertiesChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.ShowOnHUDChanged Event

IMyTerminalBlockShowOnHUDChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyTerminalBlock.ShowOnHUDChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> ShowOnHUDChanged
Event ShowOnHUDChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ ShowOnHUDChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract ShowOnHUDChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalBlock.VisibilityChanged Event

IMyTerminalBlockVisibilityChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyTerminalBlock.VisibilityChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyTerminalBlock> VisibilityChanged
Event VisibilityChanged As Action(Of IMyTerminalBlock)
 event Action<IMyTerminalBlock^>^ VisibilityChanged {
    void add (Action<IMyTerminalBlock^>^ value);
    void remove (Action<IMyTerminalBlock^>^ value);
}
abstract VisibilityChanged : IEvent<Action<IMyTerminalBlock>,
    EventArgs>

Value

Type: SystemAction IMyTerminalBlock
See Also

Reference

IMyTerminalBlock Interface
Sandbox.ModAPI Namespace


IMyTerminalControls Interface

This interface allows you to query, add or remove terminal controls for a block. The terminal controls are the controls that appear in the terminal screen when you select a block. You may add new controls, remove existing controls, or modify existing controls.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControls
Public Interface IMyTerminalControls
public interface class IMyTerminalControls
type IMyTerminalControls =  interface end

The IMyTerminalControls type exposes the following members.

Methods
 | Name | Description
Public method | AddActionTBlock | This allows you to add an action to an assocated block
Public method | AddControlTBlock | Adds a terminal control to a block.
Public method | CreateActionTBlock | This allows you to create an action to associate with a block
Public method | CreateControlTControl, TBlock | This creates a control that can be added to a block.
Public method | CreatePropertyTValue, TBlock | This creates a property that can be added to a block. A property is not visible on the terminal screen but can hold a value that can be used in programmable blocks.
Public method | GetActionsTBlock | This allows you to get all actions associated with this block.
Public method | GetControlsTBlock | Gets the controls associated with a block.
Public method | RemoveActionTBlock | This allows you to remove an action from a block
Public method | RemoveControlTBlock | Removes a terminal control from a block.
Top
Events
 | Name | Description
Public event | CustomActionGetter | This event allows you to modify the list of actions available when a user wants to select an action for a block in the toolbar. Modifying the list in this event modifies the list displayed to the user so that you can customize it in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)
Public event | CustomControlGetter | This event allows you to modify the list of controls that the game displays when a user selects a block. Each time terminal controls are enumerated for a block, this delegate is called, which allows you to modify the control list directly, and remove/add as you see fit before the controls are dispalyed. This is to allow fine grain control of the controls being displayed, so you can display only controls you want to in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyTerminalControls Methods

The IMyTerminalControls type exposes the following members.

Methods
 | Name | Description
Public method | AddActionTBlock | This allows you to add an action to an assocated block
Public method | AddControlTBlock | Adds a terminal control to a block.
Public method | CreateActionTBlock | This allows you to create an action to associate with a block
Public method | CreateControlTControl, TBlock | This creates a control that can be added to a block.
Public method | CreatePropertyTValue, TBlock | This creates a property that can be added to a block. A property is not visible on the terminal screen but can hold a value that can be used in programmable blocks.
Public method | GetActionsTBlock | This allows you to get all actions associated with this block.
Public method | GetControlsTBlock | Gets the controls associated with a block.
Public method | RemoveActionTBlock | This allows you to remove an action from a block
Public method | RemoveControlTBlock | Removes a terminal control from a block.
Top
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.AddAction(TBlock) Method

IMyTerminalControlsAddActionTBlock Method

This allows you to add an action to an assocated block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddAction<TBlock>(
    IMyTerminalAction action
)

Sub AddAction(Of TBlock) (
    action As IMyTerminalAction
)
generic<typename TBlock>
void AddAction(
    IMyTerminalAction^ action
)
abstract AddAction :
        action : IMyTerminalAction -> unit

Parameters

action
Type: Sandbox.ModAPI.Interfaces.TerminalIMyTerminalAction
An IMyTerminalAction object returned from CreateAction

Type Parameters

TBlock
The ModAPI interface of the associated block
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.AddControl(TBlock) Method

IMyTerminalControlsAddControlTBlock Method

Adds a terminal control to a block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddControl<TBlock>(
    IMyTerminalControl item
)

Sub AddControl(Of TBlock) (
    item As IMyTerminalControl
)
generic<typename TBlock>
void AddControl(
    IMyTerminalControl^ item
)
abstract AddControl :
        item : IMyTerminalControl -> unit

Parameters

item
Type: Sandbox.ModAPI.Interfaces.TerminalIMyTerminalControl
This is the control you're adding, created with CreateControl or CreateProperty

Type Parameters

TBlock
This is the ModAPI interface of the associated block you want to add a terminal control to
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.CreateAction(TBlock) Method

IMyTerminalControlsCreateActionTBlock Method

This allows you to create an action to associate with a block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyTerminalAction CreateAction<TBlock>(
    string id
)

Function CreateAction(Of TBlock) (
    id As String
) As IMyTerminalAction
generic<typename TBlock>
IMyTerminalAction^ CreateAction(
    String^ id
)
abstract CreateAction :
        id : string -> IMyTerminalAction

Parameters

id
Type: SystemString
A unique identifier for this action

Type Parameters

TBlock
The ModAPI interface of the associated block

Return Value

Type: IMyTerminalAction
An IMyTerminalAction object
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.CreateControl(TControl, TBlock) Method

IMyTerminalControlsCreateControlTControl, TBlock Method

This creates a control that can be added to a block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TControl CreateControl<TControl, TBlock>(
    string id
)

Function CreateControl(Of TControl, TBlock) (
    id As String
) As TControl
generic<typename TControl, typename TBlock>
TControl CreateControl(
    String^ id
)
abstract CreateControl :
        id : string -> 'TControl

Parameters

id
Type: SystemString
A unique identifier for this control

Type Parameters

TControl
The type of control you're creating
TBlock
The ModAPI interface of the associated block

Return Value

Type: TControl
Returns an interface to the control you've created depending on TControl
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.CreateProperty(TValue, TBlock) Method

IMyTerminalControlsCreatePropertyTValue, TBlock Method

This creates a property that can be added to a block. A property is not visible on the terminal screen but can hold a value that can be used in programmable blocks.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyTerminalControlProperty<TValue> CreateProperty<TValue, TBlock>(
    string id
)

Function CreateProperty(Of TValue, TBlock) (
    id As String
) As IMyTerminalControlProperty(Of TValue)
generic<typename TValue, typename TBlock>
IMyTerminalControlProperty<TValue>^ CreateProperty(
    String^ id
)
abstract CreateProperty :
        id : string -> IMyTerminalControlProperty<'TValue>

Parameters

id
Type: SystemString
A unique identifier for this property

Type Parameters

TValue
The type of property you're creating
TBlock
The ModAPI interface of the associated block

Return Value

Type: IMyTerminalControlProperty TValue
Returns an IMyTerminalControlProperty that can be added to a block via AddControl
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.GetActions(TBlock) Method

IMyTerminalControlsGetActionsTBlock Method

This allows you to get all actions associated with this block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetActions<TBlock>(
    out List<IMyTerminalAction> items
)

Sub GetActions(Of TBlock) (
    <OutAttribute> ByRef items As List(Of IMyTerminalAction)
)
generic<typename TBlock>
void GetActions(
    [OutAttribute] List<IMyTerminalAction^>^% items
)
abstract GetActions :
        items : List<IMyTerminalAction> byref -> unit

Parameters

items
Type: System.Collections.GenericList IMyTerminalAction
The list that contains the actions associated with this block

Type Parameters

TBlock
The ModAPI interface of the associated block
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.GetControls(TBlock) Method

IMyTerminalControlsGetControlsTBlock Method

Gets the controls associated with a block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetControls<TBlock>(
    out List<IMyTerminalControl> items
)

Sub GetControls(Of TBlock) (
    <OutAttribute> ByRef items As List(Of IMyTerminalControl)
)
generic<typename TBlock>
void GetControls(
    [OutAttribute] List<IMyTerminalControl^>^% items
)
abstract GetControls :
        items : List<IMyTerminalControl> byref -> unit

Parameters

items
Type: System.Collections.GenericList IMyTerminalControl
The list that contains the terminal controls for this block

Type Parameters

TBlock
This is the object builder type of the associated block you want to get terminal controls for
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.RemoveAction(TBlock) Method

IMyTerminalControlsRemoveActionTBlock Method

This allows you to remove an action from a block

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveAction<TBlock>(
    IMyTerminalAction action
)

Sub RemoveAction(Of TBlock) (
    action As IMyTerminalAction
)
generic<typename TBlock>
void RemoveAction(
    IMyTerminalAction^ action
)
abstract RemoveAction :
        action : IMyTerminalAction -> unit

Parameters

action
Type: Sandbox.ModAPI.Interfaces.TerminalIMyTerminalAction
An IMyTerminalAction object

Type Parameters

TBlock
The ModAPI interface of the associated block
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.RemoveControl(TBlock) Method

IMyTerminalControlsRemoveControlTBlock Method

Removes a terminal control from a block.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveControl<TBlock>(
    IMyTerminalControl item
)

Sub RemoveControl(Of TBlock) (
    item As IMyTerminalControl
)
generic<typename TBlock>
void RemoveControl(
    IMyTerminalControl^ item
)
abstract RemoveControl :
        item : IMyTerminalControl -> unit

Parameters

item
Type: Sandbox.ModAPI.Interfaces.TerminalIMyTerminalControl
This is the control you're removing. Use GetControls to get the item itself.

Type Parameters

TBlock
This is the ModAPI interface of the associated block you want to remove a terminal control from
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls Events

The IMyTerminalControls type exposes the following members.

Events
 | Name | Description
Public event | CustomActionGetter | This event allows you to modify the list of actions available when a user wants to select an action for a block in the toolbar. Modifying the list in this event modifies the list displayed to the user so that you can customize it in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)
Public event | CustomControlGetter | This event allows you to modify the list of controls that the game displays when a user selects a block. Each time terminal controls are enumerated for a block, this delegate is called, which allows you to modify the control list directly, and remove/add as you see fit before the controls are dispalyed. This is to allow fine grain control of the controls being displayed, so you can display only controls you want to in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)
Top
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.CustomActionGetter Event

IMyTerminalControlsCustomActionGetter Event

This event allows you to modify the list of actions available when a user wants to select an action for a block in the toolbar. Modifying the list in this event modifies the list displayed to the user so that you can customize it in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event CustomActionGetDelegate CustomActionGetter
Event CustomActionGetter As CustomActionGetDelegate
 event CustomActionGetDelegate^ CustomActionGetter {
    void add (CustomActionGetDelegate^ value);
    void remove (CustomActionGetDelegate^ value);
}
abstract CustomActionGetter : IEvent<CustomActionGetDelegate,
    EventArgs>

Value

Type: Sandbox.ModAPICustomActionGetDelegate
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTerminalControls.CustomControlGetter Event

IMyTerminalControlsCustomControlGetter Event

This event allows you to modify the list of controls that the game displays when a user selects a block. Each time terminal controls are enumerated for a block, this delegate is called, which allows you to modify the control list directly, and remove/add as you see fit before the controls are dispalyed. This is to allow fine grain control of the controls being displayed, so you can display only controls you want to in specific situations (like blocks with different subtypes, or even on specific blocks by entityId)

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event CustomControlGetDelegate CustomControlGetter
Event CustomControlGetter As CustomControlGetDelegate
 event CustomControlGetDelegate^ CustomControlGetter {
    void add (CustomControlGetDelegate^ value);
    void remove (CustomControlGetDelegate^ value);
}
abstract CustomControlGetter : IEvent<CustomControlGetDelegate,
    EventArgs>

Value

Type: Sandbox.ModAPICustomControlGetDelegate
See Also

Reference

IMyTerminalControls Interface
Sandbox.ModAPI Namespace


IMyTextPanel Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyTextPanel"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTextPanel : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyTextPanel, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyTextPanel
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTextPanel, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyTextPanel : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyTextPanel, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyTextPanel =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTextPanel
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyTextPanel type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentlyShownImage | The image that is currently shown on the screen. Returns NULL if there are no images selected OR the screen is in text mode. (Inherited from IMyTextPanel.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowOnScreen | Indicates what should be shown on the screen, none being an image. (Inherited from IMyTextPanel.)
Public property | ShowText | Returns true if the ShowOnScreen flag is set to either PUBLIC or PRIVATE (Inherited from IMyTextPanel.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddImagesToSelection | (Inherited from IMyTextPanel.)
Public method | AddImageToSelection | (Inherited from IMyTextPanel.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | ClearImagesFromSelection | (Inherited from IMyTextPanel.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetPrivateText | Obsolete. (Inherited from IMyTextPanel.)
Public method | GetPrivateTitle | Obsolete. (Inherited from IMyTextPanel.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetPublicText | (Inherited from IMyTextPanel.)
Public method | GetPublicTitle | (Inherited from IMyTextPanel.)
Public method | GetSelectedImages | Outputs the selected image ids to the specified list. NOTE: List is not cleared internally. (Inherited from IMyTextPanel.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReadPublicText | (Inherited from IMyTextPanel.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveImageFromSelection | (Inherited from IMyTextPanel.)
Public method | RemoveImagesFromSelection | (Inherited from IMyTextPanel.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetShowOnScreen | (Inherited from IMyTextPanel.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowPrivateTextOnScreen | Obsolete. (Inherited from IMyTextPanel.)
Public method | ShowPublicTextOnScreen | (Inherited from IMyTextPanel.)
Public method | ShowTextureOnScreen | (Inherited from IMyTextPanel.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | WritePrivateText | Obsolete. (Inherited from IMyTextPanel.)
Public method | WritePrivateTitle | Obsolete. (Inherited from IMyTextPanel.)
Public method | WritePublicText(String, Boolean) | (Inherited from IMyTextPanel.)
Public method | WritePublicText(StringBuilder, Boolean) | (Inherited from IMyTextPanel.)
Public method | WritePublicTitle | (Inherited from IMyTextPanel.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyTextPanel Properties

The IMyTextPanel type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentlyShownImage | The image that is currently shown on the screen. Returns NULL if there are no images selected OR the screen is in text mode. (Inherited from IMyTextPanel.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowOnScreen | Indicates what should be shown on the screen, none being an image. (Inherited from IMyTextPanel.)
Public property | ShowText | Returns true if the ShowOnScreen flag is set to either PUBLIC or PRIVATE (Inherited from IMyTextPanel.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyTextPanel Interface
Sandbox.ModAPI Namespace


IMyTextPanel Methods

The IMyTextPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddImagesToSelection | (Inherited from IMyTextPanel.)
Public method | AddImageToSelection | (Inherited from IMyTextPanel.)
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | ClearImagesFromSelection | (Inherited from IMyTextPanel.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetPrivateText | Obsolete. (Inherited from IMyTextPanel.)
Public method | GetPrivateTitle | Obsolete. (Inherited from IMyTextPanel.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetPublicText | (Inherited from IMyTextPanel.)
Public method | GetPublicTitle | (Inherited from IMyTextPanel.)
Public method | GetSelectedImages | Outputs the selected image ids to the specified list. NOTE: List is not cleared internally. (Inherited from IMyTextPanel.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReadPublicText | (Inherited from IMyTextPanel.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RemoveImageFromSelection | (Inherited from IMyTextPanel.)
Public method | RemoveImagesFromSelection | (Inherited from IMyTextPanel.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetShowOnScreen | (Inherited from IMyTextPanel.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | ShowPrivateTextOnScreen | Obsolete. (Inherited from IMyTextPanel.)
Public method | ShowPublicTextOnScreen | (Inherited from IMyTextPanel.)
Public method | ShowTextureOnScreen | (Inherited from IMyTextPanel.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Public method | WritePrivateText | Obsolete. (Inherited from IMyTextPanel.)
Public method | WritePrivateTitle | Obsolete. (Inherited from IMyTextPanel.)
Public method | WritePublicText(String, Boolean) | (Inherited from IMyTextPanel.)
Public method | WritePublicText(StringBuilder, Boolean) | (Inherited from IMyTextPanel.)
Public method | WritePublicTitle | (Inherited from IMyTextPanel.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTextPanel Interface
Sandbox.ModAPI Namespace


IMyTextPanel Events

The IMyTextPanel type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyTextPanel Interface
Sandbox.ModAPI Namespace


IMyThrust Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyThrust"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyThrust : IMyThrust,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyThrust
    Inherits IMyThrust, IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyThrust : IMyThrust,
    IMyFunctionalBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyThrust =
    interface
        interface IMyThrust
        interface IMyFunctionalBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyThrust type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentThrust | Gets the current thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | GridThrustDirection | Gets the direction of thrust, relative to ship controller (cockpit). (Inherited from IMyThrust.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxEffectiveThrust | Gets the maximum effective thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxThrust | Gets the maximum thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | ThrustMultiplier |
Public property | ThrustOverride | Gets the override thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | ThrustOverrideChanged |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyThrust Properties

The IMyThrust type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentThrust | Gets the current thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | GridThrustDirection | Gets the direction of thrust, relative to ship controller (cockpit). (Inherited from IMyThrust.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxEffectiveThrust | Gets the maximum effective thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | MaxThrust | Gets the maximum thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | PowerConsumptionMultiplier |
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | ThrustMultiplier |
Public property | ThrustOverride | Gets the override thrust amount, in Newtons (N) (Inherited from IMyThrust.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyThrust.PowerConsumptionMultiplier Property

IMyThrustPowerConsumptionMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyThrust.PowerConsumptionMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PowerConsumptionMultiplier { get; set; }
Property PowerConsumptionMultiplier As Single
    Get
    Set
property float PowerConsumptionMultiplier {
    float get ();
    void set (float value);
}
abstract PowerConsumptionMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyThrust.ThrustMultiplier Property

IMyThrustThrustMultiplier Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.IMyThrust.ThrustMultiplier"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float ThrustMultiplier { get; set; }
Property ThrustMultiplier As Single
    Get
    Set
property float ThrustMultiplier {
    float get ();
    void set (float value);
}
abstract ThrustMultiplier : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyThrust Methods

The IMyThrust type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyThrust Events

The IMyThrust type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | ThrustOverrideChanged |
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyThrust.ThrustOverrideChanged Event

IMyThrustThrustOverrideChanged Event

[Missing <summary> documentation for "E:Sandbox.ModAPI.IMyThrust.ThrustOverrideChanged"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event Action<IMyThrust, float> ThrustOverrideChanged
Event ThrustOverrideChanged As Action(Of IMyThrust, Single)
 event Action<IMyThrust^, float>^ ThrustOverrideChanged {
    void add (Action<IMyThrust^, float>^ value);
    void remove (Action<IMyThrust^, float>^ value);
}
abstract ThrustOverrideChanged : IEvent<Action<IMyThrust, float32>,
    EventArgs>

Value

Type: SystemAction IMyThrust, Single
See Also

Reference

IMyThrust Interface
Sandbox.ModAPI Namespace


IMyUpgradableBlock Interface

interface to retrieve upgrade effects from block IMyUpgradableBlock

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyUpgradableBlock : IMyCubeBlock,
    IMyEntity, IMyUpgradableBlock, IMyCubeBlock, IMyEntity
Public Interface IMyUpgradableBlock
    Inherits IMyCubeBlock, IMyEntity, IMyUpgradableBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyUpgradableBlock : IMyCubeBlock,
    IMyEntity, IMyUpgradableBlock, IMyCubeBlock, IMyEntity
type IMyUpgradableBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyUpgradableBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyUpgradableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeCount | number of upgrades applied (Inherited from IMyUpgradableBlock.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUpgrades | get list of upgrades (r/o); string - upgrade type, float - effect value as float (1 = 100%) (Inherited from IMyUpgradableBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyUpgradableBlock Properties

The IMyUpgradableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeCount | number of upgrades applied (Inherited from IMyUpgradableBlock.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyUpgradableBlock Interface
Sandbox.ModAPI Namespace


IMyUpgradableBlock Methods

The IMyUpgradableBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUpgrades | get list of upgrades (r/o); string - upgrade type, float - effect value as float (1 = 100%) (Inherited from IMyUpgradableBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyUpgradableBlock Interface
Sandbox.ModAPI Namespace


IMyUpgradableBlock Events

The IMyUpgradableBlock type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyUpgradableBlock Interface
Sandbox.ModAPI Namespace


IMyUserControllableGun Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyUserControllableGun"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyUserControllableGun : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyUserControllableGun, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyUserControllableGun
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyUserControllableGun : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyUserControllableGun, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyUserControllableGun =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyUserControllableGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyUserControllableGun Properties

The IMyUserControllableGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyUserControllableGun Interface
Sandbox.ModAPI Namespace


IMyUserControllableGun Methods

The IMyUserControllableGun type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyUserControllableGun Interface
Sandbox.ModAPI Namespace


IMyUserControllableGun Events

The IMyUserControllableGun type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | EnabledChanged | (Inherited from IMyFunctionalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyUserControllableGun Interface
Sandbox.ModAPI Namespace


IMyWarhead Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyWarhead"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyWarhead : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyWarhead, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyDestroyableObject
Public Interface IMyWarhead
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyWarhead,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity, IMyDestroyableObject
public interface class IMyWarhead : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity, IMyWarhead, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity, IMyDestroyableObject
type IMyWarhead =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyWarhead
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyDestroyableObject
    end

The IMyWarhead type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetonationTime | (Inherited from IMyWarhead.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Integrity | (Inherited from IMyDestroyableObject.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsCountingDown | (Inherited from IMyWarhead.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseDamageSystem | (Inherited from IMyDestroyableObject.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoDamage | (Inherited from IMyDestroyableObject.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyWarhead Properties

The IMyWarhead type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetonationTime | (Inherited from IMyWarhead.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | Integrity | (Inherited from IMyDestroyableObject.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsCountingDown | (Inherited from IMyWarhead.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | UseDamageSystem | (Inherited from IMyDestroyableObject.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyWarhead Interface
Sandbox.ModAPI Namespace


IMyWarhead Methods

The IMyWarhead type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoDamage | (Inherited from IMyDestroyableObject.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | RefreshCustomInfo | Raises AppendingCustomInfo so every subscriber can append custom info. (Inherited from IMyTerminalBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyWarhead Interface
Sandbox.ModAPI Namespace


IMyWarhead Events

The IMyWarhead type exposes the following members.

Events
 | Name | Description
Public event | AppendingCustomInfo | Event to append custom info. (Inherited from IMyTerminalBlock.)
Public event | CustomNameChanged | (Inherited from IMyTerminalBlock.)
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Public event | OwnershipChanged | (Inherited from IMyTerminalBlock.)
Public event | PropertiesChanged | (Inherited from IMyTerminalBlock.)
Public event | ShowOnHUDChanged | (Inherited from IMyTerminalBlock.)
Public event | VisibilityChanged | (Inherited from IMyTerminalBlock.)
Top
See Also

Reference

IMyWarhead Interface
Sandbox.ModAPI Namespace


IMyWheel Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.IMyWheel"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyWheel : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyWheel, IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
Public Interface IMyWheel
    Inherits IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity,
    IMyWheel, IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyWheel : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity, IMyWheel, IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
type IMyWheel =
    interface
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
        interface IMyWheel
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyWheel type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

Sandbox.ModAPI Namespace


IMyWheel Properties

The IMyWheel type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CastShadows | (Inherited from IMyEntity.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Closed | (Inherited from IMyEntity.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DebugAsyncLoading | (Inherited from IMyEntity.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FastCastShadowResolve | (Inherited from IMyEntity.)
Public property | Flags | (Inherited from IMyEntity.)
Public property | GameLogic | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Hierarchy | (Inherited from IMyEntity.)
Public property | InScene | (Inherited from IMyEntity.)
Public property | InvalidateOnMove | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCCDForProjectiles | Obsolete. (Inherited from IMyEntity.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsVolumetric | (Inherited from IMyEntity.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LocalMatrix | (Inherited from IMyEntity.)
Public property | LocalVolume | (Inherited from IMyEntity.)
Public property | LocalVolumeOffset | (Inherited from IMyEntity.)
Public property | LocalAABB | (Inherited from IMyEntity.)
Public property | LocalAABBHr | (Inherited from IMyEntity.)
Public property | LocationForHudMarker | Obsolete. (Inherited from IMyEntity.)
Public property | MarkedForClose | (Inherited from IMyEntity.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxGlassDistSq | (Inherited from IMyEntity.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Model | (Inherited from IMyEntity.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NearFlag | (Inherited from IMyEntity.)
Public property | NeedsDraw | (Inherited from IMyEntity.)
Public property | NeedsDrawFromParent | (Inherited from IMyEntity.)
Public property | NeedsResolveCastShadow | (Inherited from IMyEntity.)
Public property | NeedsUpdate | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Parent | (Inherited from IMyEntity.)
Public property | PersistentFlags | (Inherited from IMyEntity.)
Public property | Physics | (Inherited from IMyEntity.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PositionComp | (Inherited from IMyEntity.)
Public property | Render | (Inherited from IMyEntity.)
Public property | ResourceSink | (Inherited from IMyCubeBlock.)
Public property | Save | (Inherited from IMyEntity.)
Public property | ShadowBoxLod | (Inherited from IMyEntity.)
Public property | SkipIfTooSmall | (Inherited from IMyEntity.)
Public property | SlimBlock | (Inherited from IMyCubeBlock.)
Public property | Stator | Obsolete. Gets the attached stator/suspension block (Inherited from IMyMotorRotor.)
Public property | Storage | (Inherited from IMyEntity.)
Public property | Synchronized | (Inherited from IMyEntity.)
Public property | SyncObject | (Inherited from IMyEntity.)
Public property | Transparent | (Inherited from IMyEntity.)
Public property | UpgradeValues | (Inherited from IMyCubeBlock.)
Public property | Visible | (Inherited from IMyEntity.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldMatrixInvScaled | (Inherited from IMyEntity.)
Public property | WorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyWheel Interface
Sandbox.ModAPI Namespace


IMyWheel Methods

The IMyWheel type exposes the following members.

Methods
 | Name | Description
Public method | AddToGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | AddUpgradeValue | (Inherited from IMyCubeBlock.)
Public method | BeforeSave | (Inherited from IMyEntity.)
Public method | CalcLocalMatrix | (Inherited from IMyCubeBlock.)
Public method | CalculateCurrentModel | (Inherited from IMyCubeBlock.)
Public method | Close | (Inherited from IMyEntity.)
Public method | DebugDraw | (Inherited from IMyCubeBlock.)
Public method | DebugDrawInvalidTriangles | (Inherited from IMyEntity.)
Public method | Delete | (Inherited from IMyEntity.)
Public method | DoOverlapSphereTest | (Inherited from IMyEntity.)
Public method | EnableColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | GetChildren | (Inherited from IMyEntity.)
Public method | GetDiffuseColor | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetDistanceBetweenCameraAndPosition | (Inherited from IMyEntity.)
Public method | GetFriendlyName | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLine | (Inherited from IMyEntity.)
Public method | GetIntersectionWithLineAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetIntersectionWithSphere | (Inherited from IMyEntity.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetLargestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetObjectBuilder | (Inherited from IMyEntity.)
Public method | GetObjectBuilderCubeBlock | (Inherited from IMyCubeBlock.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetSmallestDistanceBetweenCameraAndBoundingSphere | (Inherited from IMyEntity.)
Public method | GetSubpart | (Inherited from IMyEntity.)
Public method | GetTopMostParent | (Inherited from IMyEntity.)
Public method | GetTrianglesIntersectingSphere | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetViewMatrix | (Inherited from IMyEntity.)
Public method | GetWorldMatrixNormalizedInv | (Inherited from IMyEntity.)
Public method | Init | (Inherited from IMyCubeBlock.)
Public method | Init(MyObjectBuilder_CubeBlock, IMyCubeGrid) | (Inherited from IMyCubeBlock.)
Public method | IsVisible | (Inherited from IMyEntity.)
Public method | OnAddedToScene | (Inherited from IMyEntity.)
Public method | OnBuildSuccess | (Inherited from IMyCubeBlock.)
Public method | OnDestroy | (Inherited from IMyCubeBlock.)
Public method | OnModelChange | (Inherited from IMyCubeBlock.)
Public method | OnRegisteredToGridSystems | (Inherited from IMyCubeBlock.)
Public method | OnRemovedByCubeBuilder | (Inherited from IMyCubeBlock.)
Public method | OnRemovedFromScene | (Inherited from IMyEntity.)
Public method | OnUnregisteredFromGridSystems | (Inherited from IMyCubeBlock.)
Public method | RaycastDetectors | (Inherited from IMyCubeBlock.)
Public method | ReloadDetectors | (Inherited from IMyCubeBlock.)
Public method | RemoveEffect | (Inherited from IMyCubeBlock.)
Public method | RemoveFromGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | SetColorMaskForSubparts | (Inherited from IMyEntity.)
Public method | SetDamageEffect | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEffect(String, Single, Boolean, Boolean, Boolean) | (Inherited from IMyCubeBlock.)
Public method | SetEmissiveParts | (Inherited from IMyEntity.)
Public method | SetEmissivePartsForSubparts | (Inherited from IMyEntity.)
Public method | SetLocalMatrix | (Inherited from IMyEntity.)
Public method | SetPosition | (Inherited from IMyEntity.)
Public method | SetWorldMatrix | (Inherited from IMyEntity.)
Public method | TryGetSubpart | (Inherited from IMyEntity.)
Public method | UpdateGamePruningStructure | Obsolete. (Inherited from IMyEntity.)
Public method | UpdateIsWorking | (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyWheel Interface
Sandbox.ModAPI Namespace


IMyWheel Events

The IMyWheel type exposes the following members.

Events
 | Name | Description
Public event | IsWorkingChanged | (Inherited from IMyCubeBlock.)
Public event | OnClose | (Inherited from IMyEntity.)
Public event | OnClosing | (Inherited from IMyEntity.)
Public event | OnMarkForClose | (Inherited from IMyEntity.)
Public event | OnPhysicsChanged | (Inherited from IMyEntity.)
Public event | OnUpgradeValuesChanged | (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyWheel Interface
Sandbox.ModAPI Namespace


MyAPIGateway Class

This is entry point for entire scripting possibilities in game
Inheritance Hierarchy
SystemObject
Sandbox.ModAPIMyAPIGateway

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MyAPIGateway
Public NotInheritable Class MyAPIGateway
public ref class MyAPIGateway abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MyAPIGateway =  class end

The MyAPIGateway type exposes the following members.

Properties
Name | Description
Entities | IMyEntities represents all objects that currently in world
Session | IMySession represents session object e.g. current world and its settings
Top
Methods
Name | Description
Clean | Obsolete.
DoorBase | Obsolete.
GetMessageBoxPointer | Obsolete.
Top
Fields
Name | Description
CubeBuilder | IMyCubeBuilder represents building hand
Gui | IMyGui exposes some useful values from the GUI systems
GuiControlCreated | Obsolete. Event triggered on gui control created.
IngameScripting | Provides mod access to control compilation of ingame scripts
Input | IMyInput allows accessing direct input device states
Multiplayer | IMyMultiplayer contains multiplayer related things
Parallel | IMyParallelTask allows to run tasks on background threads
Physics | IMyPhysics contains physics related things (CastRay, etc.)
Players | IMyPlayerCollection contains all players that are in world
PrefabManager |
TerminalActionsHelper | IMyTerminalActionsHelper is helper for terminal actions and allows to access terminal
TerminalControls | IMyTerminalControls allows access to adding and removing controls from a block's terminal screen
Utilities |
Top
See Also

Reference

Sandbox.ModAPI Namespace


MyAPIGateway Properties

The MyAPIGateway type exposes the following members.

Properties
Name | Description
Entities | IMyEntities represents all objects that currently in world
Session | IMySession represents session object e.g. current world and its settings
Top
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Entities Property

MyAPIGatewayEntities Property

IMyEntities represents all objects that currently in world

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyEntities Entities { get; set; }
Public Shared Property Entities As IMyEntities
    Get
    Set
public:
static property IMyEntities^ Entities {
    IMyEntities^ get ();
    void set (IMyEntities^ value);
}
static member Entities : IMyEntities with get, set

Property Value

Type: IMyEntities
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Session Property

MyAPIGatewaySession Property

IMySession represents session object e.g. current world and its settings

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMySession Session { get; set; }
Public Shared Property Session As IMySession
    Get
    Set
public:
static property IMySession^ Session {
    IMySession^ get ();
    void set (IMySession^ value);
}
static member Session : IMySession with get, set

Property Value

Type: IMySession
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway Methods

The MyAPIGateway type exposes the following members.

Methods
Name | Description
Clean | Obsolete.
DoorBase | Obsolete.
GetMessageBoxPointer | Obsolete.
Top
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Clean Method

MyAPIGatewayClean Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.MyAPIGateway.Clean"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static void Clean()
<ObsoleteAttribute>
Public Shared Sub Clean
public:
[ObsoleteAttribute]
static void Clean()
[<ObsoleteAttribute>]
static member Clean : unit -> unit
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.DoorBase Method

MyAPIGatewayDoorBase Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.MyAPIGateway.DoorBase(System.String)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static StringBuilder DoorBase(
    string name
)
<ObsoleteAttribute>
Public Shared Function DoorBase (
    name As String
) As StringBuilder
public:
[ObsoleteAttribute]
static StringBuilder^ DoorBase(
    String^ name
)
[<ObsoleteAttribute>]
static member DoorBase :
        name : string -> StringBuilder

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.MyAPIGateway.DoorBase(System.String)"]

Return Value

Type: StringBuilder

[Missing <returns> documentation for "M:Sandbox.ModAPI.MyAPIGateway.DoorBase(System.String)"]

See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.GetMessageBoxPointer Method

MyAPIGatewayGetMessageBoxPointer Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.MyAPIGateway.GetMessageBoxPointer(System.IntPtr@)"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static void GetMessageBoxPointer(
    ref IntPtr pointer
)
<ObsoleteAttribute>
Public Shared Sub GetMessageBoxPointer (
    ByRef pointer As IntPtr
)
public:
[ObsoleteAttribute]
static void GetMessageBoxPointer(
    IntPtr% pointer
)
[<ObsoleteAttribute>]
static member GetMessageBoxPointer :
        pointer : IntPtr byref -> unit

Parameters

pointer
Type: SystemIntPtr

[Missing <param name="pointer"/> documentation for "M:Sandbox.ModAPI.MyAPIGateway.GetMessageBoxPointer(System.IntPtr@)"]

See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway Fields

The MyAPIGateway type exposes the following members.

Fields
Name | Description
CubeBuilder | IMyCubeBuilder represents building hand
Gui | IMyGui exposes some useful values from the GUI systems
GuiControlCreated | Obsolete. Event triggered on gui control created.
IngameScripting | Provides mod access to control compilation of ingame scripts
Input | IMyInput allows accessing direct input device states
Multiplayer | IMyMultiplayer contains multiplayer related things
Parallel | IMyParallelTask allows to run tasks on background threads
Physics | IMyPhysics contains physics related things (CastRay, etc.)
Players | IMyPlayerCollection contains all players that are in world
PrefabManager |
TerminalActionsHelper | IMyTerminalActionsHelper is helper for terminal actions and allows to access terminal
TerminalControls | IMyTerminalControls allows access to adding and removing controls from a block's terminal screen
Utilities |
Top
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.CubeBuilder Field

MyAPIGatewayCubeBuilder Field

IMyCubeBuilder represents building hand

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyCubeBuilder CubeBuilder
Public Shared CubeBuilder As IMyCubeBuilder
public:
static IMyCubeBuilder^ CubeBuilder
static val mutable CubeBuilder: IMyCubeBuilder

Field Value

Type: IMyCubeBuilder
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Gui Field

MyAPIGatewayGui Field

IMyGui exposes some useful values from the GUI systems

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyGui Gui
Public Shared Gui As IMyGui
public:
static IMyGui^ Gui
static val mutable Gui: IMyGui

Field Value

Type: IMyGui
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.GuiControlCreated Field

MyAPIGatewayGuiControlCreated Field

Note: This API is now obsolete.

Event triggered on gui control created.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGui.GuiControlCreated")]
public static Action<Object> GuiControlCreated
<ObsoleteAttribute("Use IMyGui.GuiControlCreated")>
Public Shared GuiControlCreated As Action(Of Object)
public:
[ObsoleteAttribute(L"Use IMyGui.GuiControlCreated")]
static Action<Object^>^ GuiControlCreated
[<ObsoleteAttribute("Use IMyGui.GuiControlCreated")>]
static val mutable GuiControlCreated: Action<Object>

Field Value

Type: Action Object
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.IngameScripting Field

MyAPIGatewayIngameScripting Field

Provides mod access to control compilation of ingame scripts

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyIngameScripting IngameScripting
Public Shared IngameScripting As IMyIngameScripting
public:
static IMyIngameScripting^ IngameScripting
static val mutable IngameScripting: IMyIngameScripting

Field Value

Type: IMyIngameScripting
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Input Field

MyAPIGatewayInput Field

IMyInput allows accessing direct input device states

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyInput Input
Public Shared Input As IMyInput
public:
static IMyInput^ Input
static val mutable Input: IMyInput

Field Value

Type: IMyInput
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Multiplayer Field

MyAPIGatewayMultiplayer Field

IMyMultiplayer contains multiplayer related things

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyMultiplayer Multiplayer
Public Shared Multiplayer As IMyMultiplayer
public:
static IMyMultiplayer^ Multiplayer
static val mutable Multiplayer: IMyMultiplayer

Field Value

Type: IMyMultiplayer
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Parallel Field

MyAPIGatewayParallel Field

IMyParallelTask allows to run tasks on background threads

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyParallelTask Parallel
Public Shared Parallel As IMyParallelTask
public:
static IMyParallelTask^ Parallel
static val mutable Parallel: IMyParallelTask

Field Value

Type: IMyParallelTask
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Physics Field

MyAPIGatewayPhysics Field

IMyPhysics contains physics related things (CastRay, etc.)

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyPhysics Physics
Public Shared Physics As IMyPhysics
public:
static IMyPhysics^ Physics
static val mutable Physics: IMyPhysics

Field Value

Type: IMyPhysics
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Players Field

MyAPIGatewayPlayers Field

IMyPlayerCollection contains all players that are in world

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyPlayerCollection Players
Public Shared Players As IMyPlayerCollection
public:
static IMyPlayerCollection^ Players
static val mutable Players: IMyPlayerCollection

Field Value

Type: IMyPlayerCollection
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.PrefabManager Field

MyAPIGatewayPrefabManager Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.MyAPIGateway.PrefabManager"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyPrefabManager PrefabManager
Public Shared PrefabManager As IMyPrefabManager
public:
static IMyPrefabManager^ PrefabManager
static val mutable PrefabManager: IMyPrefabManager

Field Value

Type: IMyPrefabManager
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.TerminalActionsHelper Field

MyAPIGatewayTerminalActionsHelper Field

IMyTerminalActionsHelper is helper for terminal actions and allows to access terminal

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyTerminalActionsHelper TerminalActionsHelper
Public Shared TerminalActionsHelper As IMyTerminalActionsHelper
public:
static IMyTerminalActionsHelper^ TerminalActionsHelper
static val mutable TerminalActionsHelper: IMyTerminalActionsHelper

Field Value

Type: IMyTerminalActionsHelper
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.TerminalControls Field

MyAPIGatewayTerminalControls Field

IMyTerminalControls allows access to adding and removing controls from a block's terminal screen

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyTerminalControls TerminalControls
Public Shared TerminalControls As IMyTerminalControls
public:
static IMyTerminalControls^ TerminalControls
static val mutable TerminalControls: IMyTerminalControls

Field Value

Type: IMyTerminalControls
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyAPIGateway.Utilities Field

MyAPIGatewayUtilities Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.MyAPIGateway.Utilities"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IMyUtilities Utilities
Public Shared Utilities As IMyUtilities
public:
static IMyUtilities^ Utilities
static val mutable Utilities: IMyUtilities

Field Value

Type: IMyUtilities
See Also

Reference

MyAPIGateway Class
Sandbox.ModAPI Namespace


MyProductionQueueItem Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.MyProductionQueueItem"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyProductionQueueItem
Public Structure MyProductionQueueItem
public value class MyProductionQueueItem
[<SealedAttribute>]
type MyProductionQueueItem =  struct end

The MyProductionQueueItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Amount |
Public field | Blueprint |
Public field | ItemId |
Top
See Also

Reference

Sandbox.ModAPI Namespace


MyProductionQueueItem Methods

The MyProductionQueueItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyProductionQueueItem Structure
Sandbox.ModAPI Namespace


MyProductionQueueItem Fields

The MyProductionQueueItem type exposes the following members.

Fields
 | Name | Description
Public field | Amount |
Public field | Blueprint |
Public field | ItemId |
Top
See Also

Reference

MyProductionQueueItem Structure
Sandbox.ModAPI Namespace


MyProductionQueueItem.Amount Field

MyProductionQueueItemAmount Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.MyProductionQueueItem.Amount"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyFixedPoint Amount
Public Amount As MyFixedPoint
public:
MyFixedPoint Amount
val mutable Amount: MyFixedPoint

Field Value

Type: MyFixedPoint
See Also

Reference

MyProductionQueueItem Structure
Sandbox.ModAPI Namespace


MyProductionQueueItem.Blueprint Field

MyProductionQueueItemBlueprint Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.MyProductionQueueItem.Blueprint"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyDefinitionBase Blueprint
Public Blueprint As MyDefinitionBase
public:
MyDefinitionBase^ Blueprint
val mutable Blueprint: MyDefinitionBase

Field Value

Type: MyDefinitionBase
See Also

Reference

MyProductionQueueItem Structure
Sandbox.ModAPI Namespace


MyProductionQueueItem.ItemId Field

MyProductionQueueItemItemId Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.MyProductionQueueItem.ItemId"]

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ItemId
Public ItemId As UInteger
public:
unsigned int ItemId
val mutable ItemId: uint32

Field Value

Type: UInt32
See Also

Reference

MyProductionQueueItem Structure
Sandbox.ModAPI Namespace


MyWhitelistTarget Enumeration

Determines what target a whitelisting entry does or should support.

Namespace: Sandbox.ModAPI
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MyWhitelistTarget
<FlagsAttribute>
Public Enumeration MyWhitelistTarget
[FlagsAttribute]
public enum class MyWhitelistTarget
[<FlagsAttribute>]
type MyWhitelistTarget
Members
Member name | Value | Description
None | 0 | No target. Depending on the context, this may mean no support at all or unrestricted support.
ModApi | 1 | The entry supports or must support ModAPI level entry.
Ingame | 2 | The entry supports or must support Ingame level entry.
Both | 3 | A shortcut flag meaning the entry supports or must support both ModAPI and Ingame level entries.
See Also

Reference

Sandbox.ModAPI Namespace


Sandbox.ModAPI.Ingame Namespace

[Missing <summary> documentation for "N:Sandbox.ModAPI.Ingame"]

Classes
 | Class | Description
 | MyGridProgram | All programmable block scripts derive from this class, meaning that all properties in this class are directly available for use in your scripts. If you use Visual Studio or other external editors to write your scripts, you can derive directly from this class and have a compatible script template.
Public class | TerminalBlockExtentions |
Structures
 | Structure | Description
Public structure | MyDetectedEntityInfo |
Public structure | MyInventoryItemFilter |
Public structure | MyProductionItem |
Public structure | MyShipMass |
Public structure | MyShipVelocities |
Public structure | MyWaypointInfo | Provides basic information about a waypoint.
Public structure | TerminalActionParameter |
Interfaces
 | Interface | Description
Public interface | IMyAdvancedDoor |
Public interface | IMyAirtightDoorBase |
Public interface | IMyAirtightHangarDoor |
Public interface | IMyAirtightSlideDoor |
Public interface | IMyAssembler |
Public interface | IMyAttachableTopBlock |
Public interface | IMyBatteryBlock |
Public interface | IMyBeacon |
Public interface | IMyBlockGroup |
Public interface | IMyCameraBlock |
Public interface | IMyCargoContainer |
Public interface | IMyCockpit |
Public interface | IMyCollector |
Public interface | IMyConveyor |
Public interface | IMyConveyorSorter |
Public interface | IMyConveyorTube |
Public interface | IMyCryoChamber |
Public interface | IMyDecoy |
Public interface | IMyDoor |
Public interface | IMyExtendedPistonBase |
Public interface | IMyFunctionalBlock |
Public interface | IMyGasGenerator | Gas generator interface
Public interface | IMyGasTank |
Public interface | IMyGridProgramRuntimeInfo | Provides runtime info for a running grid program.
Public interface | IMyGridTerminalSystem |
Public interface | IMyGyro |
Public interface | IMyJumpDrive |
Public interface | IMyLargeTurretBase |
Public interface | IMyLaserAntenna | Laser antenna block interface
Public interface | IMyLightingBlock |
Public interface | IMyMechanicalConnectionBlock |
Public interface | IMyMotorAdvancedRotor |
Public interface | IMyMotorAdvancedStator |
Public interface | IMyMotorBase |
Public interface | IMyMotorRotor |
Public interface | IMyMotorStator |
Public interface | IMyMotorSuspension |
Public interface | IMyOreDetector |
Public interface | IMyOxygenGenerator | Obsolete.
Public interface | IMyOxygenTank | Obsolete.
Public interface | IMyPassage |
Public interface | IMyPistonBase |
Public interface | IMyPistonTop |
Public interface | IMyProductionBlock |
Public interface | IMyProgrammableBlock |
Public interface | IMyProjector |
Public interface | IMyRadioAntenna | Antenna block interface
Public interface | IMyReactor |
Public interface | IMyRefinery |
Public interface | IMyReflectorLight |
Public interface | IMyRemoteControl |
Public interface | IMySensorBlock |
Public interface | IMyShipConnector |
Public interface | IMyShipController |
Public interface | IMyShipDrill |
Public interface | IMyShipGrinder |
Public interface | IMyShipToolBase |
Public interface | IMyShipWelder | Ship welder interface
Public interface | IMySmallGatlingGun |
Public interface | IMySmallMissileLauncher |
Public interface | IMySmallMissileLauncherReload |
Public interface | IMyTerminalBlock |
Public interface | IMyTextPanel |
Public interface | IMyThrust |
Public interface | IMyUpgradableBlock | interface to retrieve upgrade effects on block
Public interface | IMyUserControllableGun |
Public interface | IMyWarhead |
Public interface | IMyWheel |
Enumerations
 | Enumeration | Description
Public enumeration | DoorStatus | Describes the current status of the door.
Public enumeration | MyAssemblerMode | Determines what mode an assembler is in.
Public enumeration | MyConveyorSorterMode | Determines the current mode of a conveyor sorter.
Public enumeration | MyDetectedEntityType |
Public enumeration | MyJumpDriveStatus |
Public enumeration | MyLaserAntennaStatus | Describes the current status of a laser antenna.
Public enumeration | MyPlanetElevation | Describes what detail level to retrieve the planet elevation for.
Public enumeration | MyShipConnectorStatus | Describes the current status of the connector.
Public enumeration | MyTransmitTarget |
Public enumeration | PistonStatus | Describes the current status of the piston.


DoorStatus Enumeration

Describes the current status of the door.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DoorStatus
Public Enumeration DoorStatus
public enum class DoorStatus
type DoorStatus
Members
Member name | Value | Description
Opening | 0 | The door is in the process of being opened.
Open | 1 | The door is fully open.
Closing | 2 | The door is in the process of being closed.
Closed | 3 | The door is fully closed.
See Also

Reference

Sandbox.ModAPI.Ingame Namespace


IMyAdvancedDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAdvancedDoor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAdvancedDoor : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAdvancedDoor
    Inherits IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyAdvancedDoor : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAdvancedDoor =
    interface
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAdvancedDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyAdvancedDoor Properties

The IMyAdvancedDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAdvancedDoor Interface


IMyAdvancedDoor Methods

The IMyAdvancedDoor type exposes the following members.

Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAdvancedDoor Interface


IMyAirtightDoorBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAirtightDoorBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightDoorBase : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAirtightDoorBase
    Inherits IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyAirtightDoorBase : IMyDoor,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAirtightDoorBase =
    interface
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightDoorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyAirtightDoorBase Properties

The IMyAirtightDoorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightDoorBase Interface


IMyAirtightDoorBase Methods

The IMyAirtightDoorBase type exposes the following members.

Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightDoorBase Interface


IMyAirtightHangarDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAirtightHangarDoor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightHangarDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAirtightHangarDoor
    Inherits IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyAirtightHangarDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAirtightHangarDoor =
    interface
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightHangarDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyAirtightHangarDoor Properties

The IMyAirtightHangarDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightHangarDoor Interface


IMyAirtightHangarDoor Methods

The IMyAirtightHangarDoor type exposes the following members.

Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightHangarDoor Interface


IMyAirtightSlideDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAirtightSlideDoor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAirtightSlideDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAirtightSlideDoor
    Inherits IMyAirtightDoorBase, IMyDoor, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyAirtightSlideDoor : IMyAirtightDoorBase,
    IMyDoor, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAirtightSlideDoor =
    interface
        interface IMyAirtightDoorBase
        interface IMyDoor
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAirtightSlideDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyAirtightSlideDoor Properties

The IMyAirtightSlideDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened. (Inherited from IMyDoor.)
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open. (Inherited from IMyDoor.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door. (Inherited from IMyDoor.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAirtightSlideDoor Interface


IMyAirtightSlideDoor Methods

The IMyAirtightSlideDoor type exposes the following members.

Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status. (Inherited from IMyDoor.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAirtightSlideDoor Interface


IMyAssembler Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAssembler"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAssembler : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyAssembler
    Inherits IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyAssembler : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyAssembler =
    interface
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAssembler type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CooperativeMode | Gets or sets whether this assembler should cooperate with other assemblers by adopting parts of their work queue.
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentProgress | Gets the progress for the item currently in production.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleEnabled | Obsolete.
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory. (Inherited from IMyProductionBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Gets or sets the current work mode of this assembly, whether it's assembling or disassembling.
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory. (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Repeating | Gets or sets whether this assembler should be perpetually repeating its work queue.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyAssembler Properties

The IMyAssembler type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CooperativeMode | Gets or sets whether this assembler should cooperate with other assemblers by adopting parts of their work queue.
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentProgress | Gets the progress for the item currently in production.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleEnabled | Obsolete.
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory. (Inherited from IMyProductionBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Gets or sets the current work mode of this assembly, whether it's assembling or disassembling.
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory. (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Repeating | Gets or sets whether this assembler should be perpetually repeating its work queue.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAssembler Interface


IMyAssembler.CooperativeMode Property

IMyAssemblerCooperativeMode Property

Gets or sets whether this assembler should cooperate with other assemblers by adopting parts of their work queue.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CooperativeMode { get; set; }
Property CooperativeMode As Boolean
    Get
    Set
property bool CooperativeMode {
    bool get ();
    void set (bool value);
}
abstract CooperativeMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyAssembler Interface


IMyAssembler.CurrentProgress Property

IMyAssemblerCurrentProgress Property

Gets the progress for the item currently in production.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentProgress { get; }
ReadOnly Property CurrentProgress As Single
    Get
property float CurrentProgress {
    float get ();
}
abstract CurrentProgress : float32 with get

Property Value

Type: Single
See Also

Reference

IMyAssembler Interface


IMyAssembler.DisassembleEnabled Property

IMyAssemblerDisassembleEnabled Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyAssembler.DisassembleEnabled"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the Mode property")]
bool DisassembleEnabled { get; }
<ObsoleteAttribute("Use the Mode property")>
ReadOnly Property DisassembleEnabled As Boolean
    Get
[ObsoleteAttribute(L"Use the Mode property")]
property bool DisassembleEnabled {
    bool get ();
}
[<ObsoleteAttribute("Use the Mode property")>]
abstract DisassembleEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyAssembler Interface


IMyAssembler.Mode Property

IMyAssemblerMode Property

Gets or sets the current work mode of this assembly, whether it's assembling or disassembling.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyAssemblerMode Mode { get; set; }
Property Mode As MyAssemblerMode
    Get
    Set
property MyAssemblerMode Mode {
    MyAssemblerMode get ();
    void set (MyAssemblerMode value);
}
abstract Mode : MyAssemblerMode with get, set

Property Value

Type: MyAssemblerMode
See Also

Reference

IMyAssembler Interface


IMyAssembler.Repeating Property

IMyAssemblerRepeating Property

Gets or sets whether this assembler should be perpetually repeating its work queue.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Repeating { get; set; }
Property Repeating As Boolean
    Get
    Set
property bool Repeating {
    bool get ();
    void set (bool value);
}
abstract Repeating : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyAssembler Interface


IMyAssembler Methods

The IMyAssembler type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyAssembler Interface


IMyAttachableTopBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyAttachableTopBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyAttachableTopBlock : IMyCubeBlock,
    IMyEntity
Public Interface IMyAttachableTopBlock
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyAttachableTopBlock : IMyCubeBlock,
    IMyEntity
type IMyAttachableTopBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyAttachableTopBlock type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyAttachableTopBlock Properties

The IMyAttachableTopBlock type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyAttachableTopBlock Interface


IMyAttachableTopBlock.Base Property

IMyAttachableTopBlockBase Property

Gets the attached base block

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyMechanicalConnectionBlock Base { get; }
ReadOnly Property Base As IMyMechanicalConnectionBlock
    Get
property IMyMechanicalConnectionBlock^ Base {
    IMyMechanicalConnectionBlock^ get ();
}
abstract Base : IMyMechanicalConnectionBlock with get

Property Value

Type: IMyMechanicalConnectionBlock
See Also

Reference

IMyAttachableTopBlock Interface


IMyAttachableTopBlock.IsAttached Property

IMyAttachableTopBlockIsAttached Property

Gets whether the top part is attached to a base block

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAttached { get; }
ReadOnly Property IsAttached As Boolean
    Get
property bool IsAttached {
    bool get ();
}
abstract IsAttached : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyAttachableTopBlock Interface


IMyAttachableTopBlock Methods

The IMyAttachableTopBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyAttachableTopBlock Interface


IMyBatteryBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyBatteryBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBatteryBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyBatteryBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyBatteryBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyBatteryBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyBatteryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentInput |
Public property | CurrentOutput |
Public property | CurrentStoredPower |
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasCapacityRemaining |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCharging |
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxStoredPower |
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | OnlyDischarge |
Public property | OnlyRecharge |
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SemiautoEnabled |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyBatteryBlock Properties

The IMyBatteryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentInput |
Public property | CurrentOutput |
Public property | CurrentStoredPower |
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasCapacityRemaining |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCharging |
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxStoredPower |
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | OnlyDischarge |
Public property | OnlyRecharge |
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SemiautoEnabled |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.CurrentInput Property

IMyBatteryBlockCurrentInput Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.CurrentInput"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentInput { get; }
ReadOnly Property CurrentInput As Single
    Get
property float CurrentInput {
    float get ();
}
abstract CurrentInput : float32 with get

Property Value

Type: Single
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.CurrentOutput Property

IMyBatteryBlockCurrentOutput Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.CurrentOutput"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentOutput { get; }
ReadOnly Property CurrentOutput As Single
    Get
property float CurrentOutput {
    float get ();
}
abstract CurrentOutput : float32 with get

Property Value

Type: Single
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.CurrentStoredPower Property

IMyBatteryBlockCurrentStoredPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.CurrentStoredPower"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentStoredPower { get; }
ReadOnly Property CurrentStoredPower As Single
    Get
property float CurrentStoredPower {
    float get ();
}
abstract CurrentStoredPower : float32 with get

Property Value

Type: Single
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.HasCapacityRemaining Property

IMyBatteryBlockHasCapacityRemaining Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.HasCapacityRemaining"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasCapacityRemaining { get; }
ReadOnly Property HasCapacityRemaining As Boolean
    Get
property bool HasCapacityRemaining {
    bool get ();
}
abstract HasCapacityRemaining : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.IsCharging Property

IMyBatteryBlockIsCharging Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.IsCharging"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCharging { get; }
ReadOnly Property IsCharging As Boolean
    Get
property bool IsCharging {
    bool get ();
}
abstract IsCharging : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.MaxStoredPower Property

IMyBatteryBlockMaxStoredPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.MaxStoredPower"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxStoredPower { get; }
ReadOnly Property MaxStoredPower As Single
    Get
property float MaxStoredPower {
    float get ();
}
abstract MaxStoredPower : float32 with get

Property Value

Type: Single
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.OnlyDischarge Property

IMyBatteryBlockOnlyDischarge Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.OnlyDischarge"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnlyDischarge { get; set; }
Property OnlyDischarge As Boolean
    Get
    Set
property bool OnlyDischarge {
    bool get ();
    void set (bool value);
}
abstract OnlyDischarge : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.OnlyRecharge Property

IMyBatteryBlockOnlyRecharge Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.OnlyRecharge"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnlyRecharge { get; set; }
Property OnlyRecharge As Boolean
    Get
    Set
property bool OnlyRecharge {
    bool get ();
    void set (bool value);
}
abstract OnlyRecharge : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock.SemiautoEnabled Property

IMyBatteryBlockSemiautoEnabled Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBatteryBlock.SemiautoEnabled"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SemiautoEnabled { get; set; }
Property SemiautoEnabled As Boolean
    Get
    Set
property bool SemiautoEnabled {
    bool get ();
    void set (bool value);
}
abstract SemiautoEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyBatteryBlock Interface


IMyBatteryBlock Methods

The IMyBatteryBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyBatteryBlock Interface


IMyBeacon Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyBeacon"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBeacon : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyBeacon
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyBeacon : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyBeacon =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyBeacon type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyBeacon Properties

The IMyBeacon type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyBeacon Interface


IMyBeacon.Radius Property

IMyBeaconRadius Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBeacon.Radius"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Radius { get; }
ReadOnly Property Radius As Single
    Get
property float Radius {
    float get ();
}
abstract Radius : float32 with get

Property Value

Type: Single
See Also

Reference

IMyBeacon Interface


IMyBeacon Methods

The IMyBeacon type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyBeacon Interface


IMyBlockGroup Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyBlockGroup"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyBlockGroup
Public Interface IMyBlockGroup
public interface class IMyBlockGroup
type IMyBlockGroup =  interface end

The IMyBlockGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetBlocks |
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Top
See Also

Reference


IMyBlockGroup Properties

The IMyBlockGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IMyBlockGroup Interface


IMyBlockGroup.Name Property

IMyBlockGroupName Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyBlockGroup.Name"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IMyBlockGroup Interface


IMyBlockGroup Methods

The IMyBlockGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetBlocks |
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Top
See Also

Reference

IMyBlockGroup Interface


IMyBlockGroup.GetBlocks Method

IMyBlockGroupGetBlocks Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocks(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
Sub GetBlocks (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
void GetBlocks(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocks :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyBlockGroup Interface


IMyBlockGroup.GetBlocksOfType Method

IMyBlockGroupGetBlocksOfType Method

Overload List
 | Name | Description
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Top
See Also

Reference

IMyBlockGroup Interface


IMyBlockGroup.GetBlocksOfType(T) Method (List(T), Func(T, Boolean))

IMyBlockGroupGetBlocksOfTypeT Method (ListT, FuncT, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<T> blocks,
    Func<T, bool> collect = null
)
where T : class

Sub GetBlocksOfType(Of T As Class) (
    blocks As List(Of T),
    Optional collect As Func(Of T, Boolean) = Nothing
)
generic<typename T>
where T : ref class
void GetBlocksOfType(
    List<T>^ blocks,
    Func<T, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<'T> *
        ?collect : Func<'T, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit  when 'T : not struct

Parameters

blocks
Type: System.Collections.GenericList T

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

collect (Optional)
Type: SystemFunc T, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

See Also

Reference

IMyBlockGroup Interface
GetBlocksOfType Overload


IMyBlockGroup.GetBlocksOfType(T) Method (List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyBlockGroupGetBlocksOfTypeT Method (ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
where T : class

Sub GetBlocksOfType(Of T As Class) (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
generic<typename T>
where T : ref class
void GetBlocksOfType(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit  when 'T : not struct

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyBlockGroup.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyBlockGroup Interface
GetBlocksOfType Overload


IMyCameraBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyCameraBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCameraBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyCameraBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCameraBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyCameraBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCameraBlock type exposes the following members.

Properties
 | Name | Description
Public property | AvailableScanRange | The maximum distance that this camera can scan, based on the time since the last scan.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableRaycast | When this is true, the available raycast distance will count up, and power usage is increased.
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Determines whether this camera is currently in use.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RaycastConeLimit | Returns the maximum positive angle you can apply for pitch and yaw.
Public property | RaycastDistanceLimit | Returns the maximum distance you can request a raycast. -1 means infinite.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CanScan(Double) | Checks if the camera can scan the given distance.
Public method | CanScan(Vector3D) | Checks if the camera can scan to the given target
Public method | CanScan(Double, Vector3D) | Checks if the camera can scan to the given direction and distance.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Raycast(Vector3D) | Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Vector3D) | Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Single, Single) | Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TimeUntilScan | Returns the number of milliseconds until the camera can do a raycast of the given distance.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyCameraBlock Properties

The IMyCameraBlock type exposes the following members.

Properties
 | Name | Description
Public property | AvailableScanRange | The maximum distance that this camera can scan, based on the time since the last scan.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableRaycast | When this is true, the available raycast distance will count up, and power usage is increased.
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Determines whether this camera is currently in use.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RaycastConeLimit | Returns the maximum positive angle you can apply for pitch and yaw.
Public property | RaycastDistanceLimit | Returns the maximum distance you can request a raycast. -1 means infinite.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.AvailableScanRange Property

IMyCameraBlockAvailableScanRange Property

The maximum distance that this camera can scan, based on the time since the last scan.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double AvailableScanRange { get; }
ReadOnly Property AvailableScanRange As Double
    Get
property double AvailableScanRange {
    double get ();
}
abstract AvailableScanRange : float with get

Property Value

Type: Double
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.EnableRaycast Property

IMyCameraBlockEnableRaycast Property

When this is true, the available raycast distance will count up, and power usage is increased.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EnableRaycast { get; set; }
Property EnableRaycast As Boolean
    Get
    Set
property bool EnableRaycast {
    bool get ();
    void set (bool value);
}
abstract EnableRaycast : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.IsActive Property

IMyCameraBlockIsActive Property

Determines whether this camera is currently in use.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsActive { get; }
ReadOnly Property IsActive As Boolean
    Get
property bool IsActive {
    bool get ();
}
abstract IsActive : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.RaycastConeLimit Property

IMyCameraBlockRaycastConeLimit Property

Returns the maximum positive angle you can apply for pitch and yaw.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float RaycastConeLimit { get; }
ReadOnly Property RaycastConeLimit As Single
    Get
property float RaycastConeLimit {
    float get ();
}
abstract RaycastConeLimit : float32 with get

Property Value

Type: Single
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.RaycastDistanceLimit Property

IMyCameraBlockRaycastDistanceLimit Property

Returns the maximum distance you can request a raycast. -1 means infinite.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double RaycastDistanceLimit { get; }
ReadOnly Property RaycastDistanceLimit As Double
    Get
property double RaycastDistanceLimit {
    double get ();
}
abstract RaycastDistanceLimit : float with get

Property Value

Type: Double
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock Methods

The IMyCameraBlock type exposes the following members.

Methods
 | Name | Description
Public method | CanScan(Double) | Checks if the camera can scan the given distance.
Public method | CanScan(Vector3D) | Checks if the camera can scan to the given target
Public method | CanScan(Double, Vector3D) | Checks if the camera can scan to the given direction and distance.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | Raycast(Vector3D) | Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Vector3D) | Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Single, Single) | Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TimeUntilScan | Returns the number of milliseconds until the camera can do a raycast of the given distance.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.CanScan Method

IMyCameraBlockCanScan Method

Overload List
 | Name | Description
Public method | CanScan(Double) | Checks if the camera can scan the given distance.
Public method | CanScan(Vector3D) | Checks if the camera can scan to the given target
Public method | CanScan(Double, Vector3D) | Checks if the camera can scan to the given direction and distance.
Top
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.CanScan Method (Double)

IMyCameraBlockCanScan Method (Double)

Checks if the camera can scan the given distance.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanScan(
    double distance
)
Function CanScan (
    distance As Double
) As Boolean
bool CanScan(
    double distance
)
abstract CanScan :
        distance : float -> bool

Parameters

distance
Type: SystemDouble

[Missing <param name="distance"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(System.Double)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(System.Double)"]

See Also

Reference

IMyCameraBlock Interface
CanScan Overload


IMyCameraBlock.CanScan Method (Vector3D)

IMyCameraBlockCanScan Method (Vector3D)

Checks if the camera can scan to the given target

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanScan(
    Vector3D target
)
Function CanScan (
    target As Vector3D
) As Boolean
bool CanScan(
    Vector3D target
)
abstract CanScan :
        target : Vector3D -> bool

Parameters

target
Type: Vector3D

[Missing <param name="target"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(VRageMath.Vector3D)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(VRageMath.Vector3D)"]

See Also

Reference

IMyCameraBlock Interface
CanScan Overload


IMyCameraBlock.CanScan Method (Double, Vector3D)

IMyCameraBlockCanScan Method (Double, Vector3D)

Checks if the camera can scan to the given direction and distance.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanScan(
    double distance,
    Vector3D direction
)
Function CanScan (
    distance As Double,
    direction As Vector3D
) As Boolean
bool CanScan(
    double distance,
    Vector3D direction
)
abstract CanScan :
        distance : float *
        direction : Vector3D -> bool

Parameters

distance
Type: SystemDouble

[Missing <param name="distance"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(System.Double,VRageMath.Vector3D)"]

direction
Type: Vector3D

[Missing <param name="direction"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(System.Double,VRageMath.Vector3D)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.CanScan(System.Double,VRageMath.Vector3D)"]

See Also

Reference

IMyCameraBlock Interface
CanScan Overload


IMyCameraBlock.Raycast Method

IMyCameraBlockRaycast Method

Overload List
 | Name | Description
Public method | Raycast(Vector3D) | Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Vector3D) | Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds.
Public method | Raycast(Double, Single, Single) | Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds.
Top
See Also

Reference

IMyCameraBlock Interface


IMyCameraBlock.Raycast Method (Vector3D)

IMyCameraBlockRaycast Method (Vector3D)

Does a raycast to the given point. Will return an empty struct if distance or angle are out of bounds.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyDetectedEntityInfo Raycast(
    Vector3D targetPos
)
Function Raycast (
    targetPos As Vector3D
) As MyDetectedEntityInfo
MyDetectedEntityInfo Raycast(
    Vector3D targetPos
)
abstract Raycast :
        targetPos : Vector3D -> MyDetectedEntityInfo

Parameters

targetPos
Type: Vector3D

[Missing <param name="targetPos"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(VRageMath.Vector3D)"]

Return Value

Type: MyDetectedEntityInfo

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(VRageMath.Vector3D)"]

See Also

Reference

IMyCameraBlock Interface
Raycast Overload


IMyCameraBlock.Raycast Method (Double, Vector3D)

IMyCameraBlockRaycast Method (Double, Vector3D)

Does a raycast in the given direction. Will return an empty struct if distance or angle are out of bounds.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyDetectedEntityInfo Raycast(
    double distance,
    Vector3D targetDirection
)
Function Raycast (
    distance As Double,
    targetDirection As Vector3D
) As MyDetectedEntityInfo
MyDetectedEntityInfo Raycast(
    double distance,
    Vector3D targetDirection
)
abstract Raycast :
        distance : float *
        targetDirection : Vector3D -> MyDetectedEntityInfo

Parameters

distance
Type: SystemDouble

[Missing <param name="distance"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,VRageMath.Vector3D)"]

targetDirection
Type: Vector3D

[Missing <param name="targetDirection"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,VRageMath.Vector3D)"]

Return Value

Type: MyDetectedEntityInfo

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,VRageMath.Vector3D)"]

See Also

Reference

IMyCameraBlock Interface
Raycast Overload


IMyCameraBlock.Raycast Method (Double, Single, Single)

IMyCameraBlockRaycast Method (Double, Single, Single)

Does a raycast in the direction the camera is facing. Pitch and Yaw are in degrees. Will return an empty struct if distance or angle are out of bounds.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyDetectedEntityInfo Raycast(
    double distance,
    float pitch = 0f,
    float yaw = 0f
)
Function Raycast (
    distance As Double,
    Optional pitch As Single = 0F,
    Optional yaw As Single = 0F
) As MyDetectedEntityInfo
MyDetectedEntityInfo Raycast(
    double distance,
    float pitch = 0f,
    float yaw = 0f
)
abstract Raycast :
        distance : float *
        ?pitch : float32 *
        ?yaw : float32
(* Defaults:
        let _pitch = defaultArg pitch 0f
        let _yaw = defaultArg yaw 0f
*)
-> MyDetectedEntityInfo

Parameters

distance
Type: SystemDouble

[Missing <param name="distance"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,System.Single,System.Single)"]

pitch (Optional)
Type: SystemSingle

[Missing <param name="pitch"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,System.Single,System.Single)"]

yaw (Optional)
Type: SystemSingle

[Missing <param name="yaw"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,System.Single,System.Single)"]

Return Value

Type: MyDetectedEntityInfo

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.Raycast(System.Double,System.Single,System.Single)"]

See Also

Reference

IMyCameraBlock Interface
Raycast Overload


IMyCameraBlock.TimeUntilScan Method

IMyCameraBlockTimeUntilScan Method

Returns the number of milliseconds until the camera can do a raycast of the given distance.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int TimeUntilScan(
    double distance
)
Function TimeUntilScan (
    distance As Double
) As Integer
int TimeUntilScan(
    double distance
)
abstract TimeUntilScan :
        distance : float -> int

Parameters

distance
Type: SystemDouble

[Missing <param name="distance"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.TimeUntilScan(System.Double)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyCameraBlock.TimeUntilScan(System.Double)"]

See Also

Reference

IMyCameraBlock Interface


IMyCargoContainer Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyCargoContainer"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCargoContainer : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyCargoContainer
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCargoContainer : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyCargoContainer =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCargoContainer type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyCargoContainer Properties

The IMyCargoContainer type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCargoContainer Interface


IMyCargoContainer Methods

The IMyCargoContainer type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCargoContainer Interface


IMyCockpit Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyCockpit"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCockpit : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyCockpit
    Inherits IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCockpit : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyCockpit =
    interface
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCockpit type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here.
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit.
Public property | OxygenFilledRatio | Gets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyCockpit Properties

The IMyCockpit type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here.
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit.
Public property | OxygenFilledRatio | Gets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCockpit Interface


IMyCockpit.IsMainCockpit Property

IMyCockpitIsMainCockpit Property

Determines whether this controller is the main cockpit of the shit this doesn't belong here.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMainCockpit { get; set; }
Property IsMainCockpit As Boolean
    Get
    Set
property bool IsMainCockpit {
    bool get ();
    void set (bool value);
}
abstract IsMainCockpit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyCockpit Interface


IMyCockpit.OxygenCapacity Property

IMyCockpitOxygenCapacity Property

Gets the maximum oxygen capacity of this cockpit.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float OxygenCapacity { get; }
ReadOnly Property OxygenCapacity As Single
    Get
property float OxygenCapacity {
    float get ();
}
abstract OxygenCapacity : float32 with get

Property Value

Type: Single
See Also

Reference

IMyCockpit Interface


IMyCockpit.OxygenFilledRatio Property

IMyCockpitOxygenFilledRatio Property

Gets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float OxygenFilledRatio { get; }
ReadOnly Property OxygenFilledRatio As Single
    Get
property float OxygenFilledRatio {
    float get ();
}
abstract OxygenFilledRatio : float32 with get

Return Value

Type: Single
See Also

Reference

IMyCockpit Interface


IMyCockpit Methods

The IMyCockpit type exposes the following members.

Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCockpit Interface


IMyCollector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyCollector"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCollector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyCollector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyCollector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyCollector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCollector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyCollector Properties

The IMyCollector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCollector Interface


IMyCollector.UseConveyorSystem Property

IMyCollectorUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyCollector.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyCollector Interface


IMyCollector Methods

The IMyCollector type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCollector Interface


IMyConveyor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyConveyor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyor : IMyCubeBlock,
    IMyEntity
Public Interface IMyConveyor
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyConveyor : IMyCubeBlock,
    IMyEntity
type IMyConveyor =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyConveyor Properties

The IMyConveyor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyor Interface


IMyConveyor Methods

The IMyConveyor type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyor Interface


IMyConveyorSorter Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyConveyorSorter"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyorSorter : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyConveyorSorter
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyConveyorSorter : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyConveyorSorter =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyorSorter type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrainAll | Determines whether the sorter should drain any inventories connected to it and push them to the other side - as long as the items passes the filtering as defined by the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Determines the current mode of this sorter. Use [!:SetWhitelist] or [!:SetBlacklist] to change the mode.
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddItem | Adds a single item to the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or fill the entire list in one go.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetFilterList | Gets the items currently being allowed through or rejected, depending on the Mode.
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | IsAllowed | Determines whether a given item type is allowed through the sorter, depending on the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.
Public method | RemoveItem | Removes a single item from the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or clear the entire list in one go.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetFilter | Changes the sorter to desired mode and filters the provided items. You can pass in null to empty the list.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyConveyorSorter Properties

The IMyConveyorSorter type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DrainAll | Determines whether the sorter should drain any inventories connected to it and push them to the other side - as long as the items passes the filtering as defined by the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Mode | Determines the current mode of this sorter. Use [!:SetWhitelist] or [!:SetBlacklist] to change the mode.
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.DrainAll Property

IMyConveyorSorterDrainAll Property

Determines whether the sorter should drain any inventories connected to it and push them to the other side - as long as the items passes the filtering as defined by the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DrainAll { get; set; }
Property DrainAll As Boolean
    Get
    Set
property bool DrainAll {
    bool get ();
    void set (bool value);
}
abstract DrainAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.Mode Property

IMyConveyorSorterMode Property

Determines the current mode of this sorter. Use [!:SetWhitelist] or [!:SetBlacklist] to change the mode.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyConveyorSorterMode Mode { get; }
ReadOnly Property Mode As MyConveyorSorterMode
    Get
property MyConveyorSorterMode Mode {
    MyConveyorSorterMode get ();
}
abstract Mode : MyConveyorSorterMode with get

Property Value

Type: MyConveyorSorterMode
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter Methods

The IMyConveyorSorter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds a single item to the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or fill the entire list in one go.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetFilterList | Gets the items currently being allowed through or rejected, depending on the Mode.
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | IsAllowed | Determines whether a given item type is allowed through the sorter, depending on the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.
Public method | RemoveItem | Removes a single item from the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or clear the entire list in one go.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetFilter | Changes the sorter to desired mode and filters the provided items. You can pass in null to empty the list.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.AddItem Method

IMyConveyorSorterAddItem Method

Adds a single item to the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or fill the entire list in one go.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddItem(
    MyInventoryItemFilter item
)
Sub AddItem (
    item As MyInventoryItemFilter
)
void AddItem(
    MyInventoryItemFilter item
)
abstract AddItem :
        item : MyInventoryItemFilter -> unit

Parameters

item
Type: Sandbox.ModAPI.IngameMyInventoryItemFilter
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.GetFilterList Method

IMyConveyorSorterGetFilterList Method

Gets the items currently being allowed through or rejected, depending on the Mode.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetFilterList(
    List<MyInventoryItemFilter> items
)
Sub GetFilterList (
    items As List(Of MyInventoryItemFilter)
)
void GetFilterList(
    List<MyInventoryItemFilter>^ items
)
abstract GetFilterList :
        items : List<MyInventoryItemFilter> -> unit

Parameters

items
Type: System.Collections.GenericList MyInventoryItemFilter
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.IsAllowed Method

IMyConveyorSorterIsAllowed Method

Determines whether a given item type is allowed through the sorter, depending on the filter list (GetFilterList(ListMyInventoryItemFilter)) and Mode.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAllowed(
    MyDefinitionId id
)
Function IsAllowed (
    id As MyDefinitionId
) As Boolean
bool IsAllowed(
    MyDefinitionId id
)
abstract IsAllowed :
        id : MyDefinitionId -> bool

Parameters

id
Type: MyDefinitionId

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyConveyorSorter.IsAllowed(VRage.Game.MyDefinitionId)"]

See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.RemoveItem Method

IMyConveyorSorterRemoveItem Method

Removes a single item from the filter list. See SetFilter(MyConveyorSorterMode, ListMyInventoryItemFilter) to change the filter mode and/or clear the entire list in one go.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveItem(
    MyInventoryItemFilter item
)
Sub RemoveItem (
    item As MyInventoryItemFilter
)
void RemoveItem(
    MyInventoryItemFilter item
)
abstract RemoveItem :
        item : MyInventoryItemFilter -> unit

Parameters

item
Type: Sandbox.ModAPI.IngameMyInventoryItemFilter
See Also

Reference

IMyConveyorSorter Interface


IMyConveyorSorter.SetFilter Method

IMyConveyorSorterSetFilter Method

Changes the sorter to desired mode and filters the provided items. You can pass in null to empty the list.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetFilter(
    MyConveyorSorterMode mode,
    List<MyInventoryItemFilter> items
)
Sub SetFilter (
    mode As MyConveyorSorterMode,
    items As List(Of MyInventoryItemFilter)
)
void SetFilter(
    MyConveyorSorterMode mode,
    List<MyInventoryItemFilter>^ items
)
abstract SetFilter :
        mode : MyConveyorSorterMode *
        items : List<MyInventoryItemFilter> -> unit

Parameters

mode
Type: Sandbox.ModAPI.IngameMyConveyorSorterMode

[Missing <param name="mode"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyConveyorSorter.SetFilter(Sandbox.ModAPI.Ingame.MyConveyorSorterMode,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyInventoryItemFilter})"]

items
Type: System.Collections.GenericList MyInventoryItemFilter

[Missing <param name="items"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyConveyorSorter.SetFilter(Sandbox.ModAPI.Ingame.MyConveyorSorterMode,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyInventoryItemFilter})"]

See Also

Reference

IMyConveyorSorter Interface


IMyConveyorTube Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyConveyorTube"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyConveyorTube : IMyCubeBlock,
    IMyEntity
Public Interface IMyConveyorTube
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyConveyorTube : IMyCubeBlock,
    IMyEntity
type IMyConveyorTube =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyConveyorTube type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyConveyorTube Properties

The IMyConveyorTube type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyConveyorTube Interface


IMyConveyorTube Methods

The IMyConveyorTube type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyConveyorTube Interface


IMyCryoChamber Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyCryoChamber"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyCryoChamber : IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyCryoChamber
    Inherits IMyCockpit, IMyShipController, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyCryoChamber : IMyCockpit,
    IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyCryoChamber =
    interface
        interface IMyCockpit
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyCryoChamber type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full). (Inherited from IMyCockpit.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyCryoChamber Properties

The IMyCryoChamber type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsMainCockpit | Determines whether this controller is the main cockpit of the shit this doesn't belong here. (Inherited from IMyCockpit.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | OxygenCapacity | Gets the maximum oxygen capacity of this cockpit. (Inherited from IMyCockpit.)
Public property | OxygenFilledRatio | Gets the current oxygen level of this cockpit, as a value between 0 (empty) and 1 (full). (Inherited from IMyCockpit.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyCryoChamber Interface


IMyCryoChamber Methods

The IMyCryoChamber type exposes the following members.

Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyCryoChamber Interface


IMyDecoy Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyDecoy"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyDecoy : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyDecoy
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyDecoy : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyDecoy =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyDecoy type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyDecoy Properties

The IMyDecoy type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyDecoy Interface


IMyDecoy Methods

The IMyDecoy type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyDecoy Interface


IMyDoor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyDoor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyDoor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyDoor
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyDoor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyDoor =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened.
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open.
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyDoor Properties

The IMyDoor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Open | Obsolete. Indicates whether door is opened or closed. True when door is opened.
Public property | OpenRatio | The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open.
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current general status of the door.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyDoor Interface


IMyDoor.Open Property

IMyDoorOpen Property

Note: This API is now obsolete.

Indicates whether door is opened or closed. True when door is opened.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the Status property instead")]
bool Open { get; }
<ObsoleteAttribute("Use the Status property instead")>
ReadOnly Property Open As Boolean
    Get
[ObsoleteAttribute(L"Use the Status property instead")]
property bool Open {
    bool get ();
}
[<ObsoleteAttribute("Use the Status property instead")>]
abstract Open : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyDoor Interface


IMyDoor.OpenRatio Property

IMyDoorOpenRatio Property

The current, accurate ratio of the door's current state where 0 is fully closed and 1 is fully open.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float OpenRatio { get; }
ReadOnly Property OpenRatio As Single
    Get
property float OpenRatio {
    float get ();
}
abstract OpenRatio : float32 with get

Property Value

Type: Single
See Also

Reference

IMyDoor Interface


IMyDoor.Status Property

IMyDoorStatus Property

Determines the current general status of the door.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DoorStatus Status { get; }
ReadOnly Property Status As DoorStatus
    Get
property DoorStatus Status {
    DoorStatus get ();
}
abstract Status : DoorStatus with get

Property Value

Type: DoorStatus
See Also

Reference

IMyDoor Interface


IMyDoor Methods

The IMyDoor type exposes the following members.

Methods
 | Name | Description
Public method | CloseDoor | Closes the door. See Status to get the current status.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | OpenDoor | Opens the door. See Status to get the current status.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleDoor | Toggles the open state of this door. See Status to get the current status.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyDoor Interface


IMyDoor.CloseDoor Method

IMyDoorCloseDoor Method

Closes the door. See Status to get the current status.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CloseDoor()
Sub CloseDoor
void CloseDoor()
abstract CloseDoor : unit -> unit
See Also

Reference

IMyDoor Interface


IMyDoor.OpenDoor Method

IMyDoorOpenDoor Method

Opens the door. See Status to get the current status.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OpenDoor()
Sub OpenDoor
void OpenDoor()
abstract OpenDoor : unit -> unit
See Also

Reference

IMyDoor Interface


IMyDoor.ToggleDoor Method

IMyDoorToggleDoor Method

Toggles the open state of this door. See Status to get the current status.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleDoor()
Sub ToggleDoor
void ToggleDoor()
abstract ToggleDoor : unit -> unit
See Also

Reference

IMyDoor Interface


IMyExtendedPistonBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyExtendedPistonBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyExtendedPistonBase : IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyExtendedPistonBase
    Inherits IMyPistonBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyExtendedPistonBase : IMyPistonBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyExtendedPistonBase =
    interface
        interface IMyPistonBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyExtendedPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyExtendedPistonBase Properties

The IMyExtendedPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base. (Inherited from IMyPistonBase.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to. (Inherited from IMyPistonBase.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at. (Inherited from IMyPistonBase.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value. (Inherited from IMyPistonBase.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status. (Inherited from IMyPistonBase.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity. (Inherited from IMyPistonBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyExtendedPistonBase Interface


IMyExtendedPistonBase Methods

The IMyExtendedPistonBase type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Extend | Extends the piston. (Inherited from IMyPistonBase.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston. (Inherited from IMyPistonBase.)
Public method | Reverse | Reverses the direction of the piston. (Inherited from IMyPistonBase.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyExtendedPistonBase Interface


IMyFunctionalBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyFunctionalBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyFunctionalBlock : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyFunctionalBlock
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyFunctionalBlock : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyFunctionalBlock =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyFunctionalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled |
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete.
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyFunctionalBlock Properties

The IMyFunctionalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled |
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyFunctionalBlock Interface


IMyFunctionalBlock.Enabled Property

IMyFunctionalBlockEnabled Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyFunctionalBlock.Enabled"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyFunctionalBlock Interface


IMyFunctionalBlock Methods

The IMyFunctionalBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete.
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyFunctionalBlock Interface


IMyFunctionalBlock.RequestEnable Method

IMyFunctionalBlockRequestEnable Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyFunctionalBlock.RequestEnable(System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the setter of Enabled")]
void RequestEnable(
    bool enable
)
<ObsoleteAttribute("Use the setter of Enabled")>
Sub RequestEnable (
    enable As Boolean
)
[ObsoleteAttribute(L"Use the setter of Enabled")]
void RequestEnable(
    bool enable
)
[<ObsoleteAttribute("Use the setter of Enabled")>]
abstract RequestEnable :
        enable : bool -> unit

Parameters

enable
Type: SystemBoolean

[Missing <param name="enable"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyFunctionalBlock.RequestEnable(System.Boolean)"]

See Also

Reference

IMyFunctionalBlock Interface


IMyGasGenerator Interface

Gas generator interface

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGasGenerator : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGasGenerator
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGasGenerator : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGasGenerator =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGasGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyGasGenerator Properties

The IMyGasGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyGasGenerator Interface


IMyGasGenerator.AutoRefill Property

IMyGasGeneratorAutoRefill Property

Autorefill enabled

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoRefill { get; }
ReadOnly Property AutoRefill As Boolean
    Get
property bool AutoRefill {
    bool get ();
}
abstract AutoRefill : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyGasGenerator Interface


IMyGasGenerator Methods

The IMyGasGenerator type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGasGenerator Interface


IMyGasTank Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyGasTank"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGasTank : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGasTank
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGasTank : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGasTank =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGasTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full).
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RefillBottles | Refills any stored storage bottles.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyGasTank Properties

The IMyGasTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full).
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyGasTank Interface


IMyGasTank.AutoRefillBottles Property

IMyGasTankAutoRefillBottles Property

Gets or sets whether storage bottles will be filled automatically when placed within this tank.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoRefillBottles { get; set; }
Property AutoRefillBottles As Boolean
    Get
    Set
property bool AutoRefillBottles {
    bool get ();
    void set (bool value);
}
abstract AutoRefillBottles : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyGasTank Interface


IMyGasTank.Capacity Property

IMyGasTankCapacity Property

Gets the gas capacity of this tank.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Capacity { get; }
ReadOnly Property Capacity As Single
    Get
property float Capacity {
    float get ();
}
abstract Capacity : float32 with get

Property Value

Type: Single
See Also

Reference

IMyGasTank Interface


IMyGasTank.FilledRatio Property

IMyGasTankFilledRatio Property

Gets the current fill level of this tank as a value between 0 (empty) and 1 (full).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float FilledRatio { get; }
ReadOnly Property FilledRatio As Single
    Get
property float FilledRatio {
    float get ();
}
abstract FilledRatio : float32 with get

Property Value

Type: Single
See Also

Reference

IMyGasTank Interface


IMyGasTank.Stockpile Property

IMyGasTankStockpile Property

Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Stockpile { get; set; }
Property Stockpile As Boolean
    Get
    Set
property bool Stockpile {
    bool get ();
    void set (bool value);
}
abstract Stockpile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyGasTank Interface


IMyGasTank Methods

The IMyGasTank type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RefillBottles | Refills any stored storage bottles.
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGasTank Interface


IMyGasTank.RefillBottles Method

IMyGasTankRefillBottles Method

Refills any stored storage bottles.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefillBottles()
Sub RefillBottles
void RefillBottles()
abstract RefillBottles : unit -> unit
See Also

Reference

IMyGasTank Interface


IMyGridProgramRuntimeInfo Interface

Provides runtime info for a running grid program.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGridProgramRuntimeInfo
Public Interface IMyGridProgramRuntimeInfo
public interface class IMyGridProgramRuntimeInfo
type IMyGridProgramRuntimeInfo =  interface end

The IMyGridProgramRuntimeInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentInstructionCount | Gets the current number of significant instructions executed.
Public property | CurrentMethodCallCount | Obsolete. Gets the current number of method calls.
Public property | LastRunTimeMs | Gets the number of milliseconds it took to execute the Main method the last time it was run. This property returns no valid data neither in the constructor nor the Save method.
Public property | MaxInstructionCount | Gets the maximum number of significant instructions that can be executing during a single run, including any other programmable blocks invoked immediately.
Public property | MaxMethodCallCount | Obsolete. Gets the maximum number of method calls that can be executed during a single run, including any other programmable blocks invoked immediately.
Public property | TimeSinceLastRun | Gets the time elapsed since the last time the Main method of this program was run. This property returns no valid data neither in the constructor nor the Save method.
Top
See Also

Reference


IMyGridProgramRuntimeInfo Properties

The IMyGridProgramRuntimeInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentInstructionCount | Gets the current number of significant instructions executed.
Public property | CurrentMethodCallCount | Obsolete. Gets the current number of method calls.
Public property | LastRunTimeMs | Gets the number of milliseconds it took to execute the Main method the last time it was run. This property returns no valid data neither in the constructor nor the Save method.
Public property | MaxInstructionCount | Gets the maximum number of significant instructions that can be executing during a single run, including any other programmable blocks invoked immediately.
Public property | MaxMethodCallCount | Obsolete. Gets the maximum number of method calls that can be executed during a single run, including any other programmable blocks invoked immediately.
Public property | TimeSinceLastRun | Gets the time elapsed since the last time the Main method of this program was run. This property returns no valid data neither in the constructor nor the Save method.
Top
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.CurrentInstructionCount Property

IMyGridProgramRuntimeInfoCurrentInstructionCount Property

Gets the current number of significant instructions executed.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CurrentInstructionCount { get; }
ReadOnly Property CurrentInstructionCount As Integer
    Get
property int CurrentInstructionCount {
    int get ();
}
abstract CurrentInstructionCount : int with get

Property Value

Type: Int32
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.CurrentMethodCallCount Property

IMyGridProgramRuntimeInfoCurrentMethodCallCount Property

Note: This API is now obsolete.

Gets the current number of method calls.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property no longer holds any meaning.")]
int CurrentMethodCallCount { get; }
<ObsoleteAttribute("This property no longer holds any meaning.")>
ReadOnly Property CurrentMethodCallCount As Integer
    Get
[ObsoleteAttribute(L"This property no longer holds any meaning.")]
property int CurrentMethodCallCount {
    int get ();
}
[<ObsoleteAttribute("This property no longer holds any meaning.")>]
abstract CurrentMethodCallCount : int with get

Property Value

Type: Int32
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.LastRunTimeMs Property

IMyGridProgramRuntimeInfoLastRunTimeMs Property

Gets the number of milliseconds it took to execute the Main method the last time it was run. This property returns no valid data neither in the constructor nor the Save method.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double LastRunTimeMs { get; }
ReadOnly Property LastRunTimeMs As Double
    Get
property double LastRunTimeMs {
    double get ();
}
abstract LastRunTimeMs : float with get

Property Value

Type: Double
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.MaxInstructionCount Property

IMyGridProgramRuntimeInfoMaxInstructionCount Property

Gets the maximum number of significant instructions that can be executing during a single run, including any other programmable blocks invoked immediately.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxInstructionCount { get; }
ReadOnly Property MaxInstructionCount As Integer
    Get
property int MaxInstructionCount {
    int get ();
}
abstract MaxInstructionCount : int with get

Property Value

Type: Int32
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.MaxMethodCallCount Property

IMyGridProgramRuntimeInfoMaxMethodCallCount Property

Note: This API is now obsolete.

Gets the maximum number of method calls that can be executed during a single run, including any other programmable blocks invoked immediately.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property no longer holds any meaning.")]
int MaxMethodCallCount { get; }
<ObsoleteAttribute("This property no longer holds any meaning.")>
ReadOnly Property MaxMethodCallCount As Integer
    Get
[ObsoleteAttribute(L"This property no longer holds any meaning.")]
property int MaxMethodCallCount {
    int get ();
}
[<ObsoleteAttribute("This property no longer holds any meaning.")>]
abstract MaxMethodCallCount : int with get

Property Value

Type: Int32
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridProgramRuntimeInfo.TimeSinceLastRun Property

IMyGridProgramRuntimeInfoTimeSinceLastRun Property

Gets the time elapsed since the last time the Main method of this program was run. This property returns no valid data neither in the constructor nor the Save method.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TimeSpan TimeSinceLastRun { get; }
ReadOnly Property TimeSinceLastRun As TimeSpan
    Get
property TimeSpan TimeSinceLastRun {
    TimeSpan get ();
}
abstract TimeSinceLastRun : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IMyGridProgramRuntimeInfo Interface


IMyGridTerminalSystem Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGridTerminalSystem
Public Interface IMyGridTerminalSystem
public interface class IMyGridTerminalSystem
type IMyGridTerminalSystem =  interface end

The IMyGridTerminalSystem type exposes the following members.

Methods
 | Name | Description
Public method | GetBlockGroups |
Public method | GetBlockGroupWithName |
Public method | GetBlocks |
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlockWithId |
Public method | GetBlockWithName |
Public method | SearchBlocksOfName |
Top
See Also

Reference


IMyGridTerminalSystem Methods

The IMyGridTerminalSystem type exposes the following members.

Methods
 | Name | Description
Public method | GetBlockGroups |
Public method | GetBlockGroupWithName |
Public method | GetBlocks |
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Public method | GetBlockWithId |
Public method | GetBlockWithName |
Public method | SearchBlocksOfName |
Top
See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlockGroups Method

IMyGridTerminalSystemGetBlockGroups Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroups(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyBlockGroup},System.Func{Sandbox.ModAPI.Ingame.IMyBlockGroup,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlockGroups(
    List<IMyBlockGroup> blockGroups,
    Func<IMyBlockGroup, bool> collect = null
)
Sub GetBlockGroups (
    blockGroups As List(Of IMyBlockGroup),
    Optional collect As Func(Of IMyBlockGroup, Boolean) = Nothing
)
void GetBlockGroups(
    List<IMyBlockGroup^>^ blockGroups,
    Func<IMyBlockGroup^, bool>^ collect = nullptr
)
abstract GetBlockGroups :
        blockGroups : List<IMyBlockGroup> *
        ?collect : Func<IMyBlockGroup, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

blockGroups
Type: System.Collections.GenericList IMyBlockGroup

[Missing <param name="blockGroups"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroups(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyBlockGroup},System.Func{Sandbox.ModAPI.Ingame.IMyBlockGroup,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyBlockGroup, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroups(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyBlockGroup},System.Func{Sandbox.ModAPI.Ingame.IMyBlockGroup,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlockGroupWithName Method

IMyGridTerminalSystemGetBlockGroupWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyBlockGroup GetBlockGroupWithName(
    string name
)
Function GetBlockGroupWithName (
    name As String
) As IMyBlockGroup
IMyBlockGroup^ GetBlockGroupWithName(
    String^ name
)
abstract GetBlockGroupWithName :
        name : string -> IMyBlockGroup

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

Return Value

Type: IMyBlockGroup

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockGroupWithName(System.String)"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlocks Method

IMyGridTerminalSystemGetBlocks Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocks(
    List<IMyTerminalBlock> blocks
)
Sub GetBlocks (
    blocks As List(Of IMyTerminalBlock)
)
void GetBlocks(
    List<IMyTerminalBlock^>^ blocks
)
abstract GetBlocks :
        blocks : List<IMyTerminalBlock> -> unit

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocks(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock})"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlocksOfType Method

IMyGridTerminalSystemGetBlocksOfType Method

Overload List
 | Name | Description
Public method | GetBlocksOfTypeT(ListT, FuncT, Boolean) |
Public method | GetBlocksOfTypeT(ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean) |
Top
See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlocksOfType(T) Method (List(T), Func(T, Boolean))

IMyGridTerminalSystemGetBlocksOfTypeT Method (ListT, FuncT, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<T> blocks,
    Func<T, bool> collect = null
)
where T : class

Sub GetBlocksOfType(Of T As Class) (
    blocks As List(Of T),
    Optional collect As Func(Of T, Boolean) = Nothing
)
generic<typename T>
where T : ref class
void GetBlocksOfType(
    List<T>^ blocks,
    Func<T, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<'T> *
        ?collect : Func<'T, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit  when 'T : not struct

Parameters

blocks
Type: System.Collections.GenericList T

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

collect (Optional)
Type: SystemFunc T, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{``0},System.Func{``0,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface
GetBlocksOfType Overload


IMyGridTerminalSystem.GetBlocksOfType(T) Method (List(IMyTerminalBlock), Func(IMyTerminalBlock, Boolean))

IMyGridTerminalSystemGetBlocksOfTypeT Method (ListIMyTerminalBlock, FuncIMyTerminalBlock, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetBlocksOfType<T>(
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
where T : class

Sub GetBlocksOfType(Of T As Class) (
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
generic<typename T>
where T : ref class
void GetBlocksOfType(
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract GetBlocksOfType :
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit  when 'T : not struct

Parameters

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlocksOfType``1(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface
GetBlocksOfType Overload


IMyGridTerminalSystem.GetBlockWithId Method

IMyGridTerminalSystemGetBlockWithId Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithId(System.Int64)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyTerminalBlock GetBlockWithId(
    long id
)
Function GetBlockWithId (
    id As Long
) As IMyTerminalBlock
IMyTerminalBlock^ GetBlockWithId(
    long long id
)
abstract GetBlockWithId :
        id : int64 -> IMyTerminalBlock

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithId(System.Int64)"]

Return Value

Type: IMyTerminalBlock

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithId(System.Int64)"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.GetBlockWithName Method

IMyGridTerminalSystemGetBlockWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyTerminalBlock GetBlockWithName(
    string name
)
Function GetBlockWithName (
    name As String
) As IMyTerminalBlock
IMyTerminalBlock^ GetBlockWithName(
    String^ name
)
abstract GetBlockWithName :
        name : string -> IMyTerminalBlock

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

Return Value

Type: IMyTerminalBlock

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.GetBlockWithName(System.String)"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGridTerminalSystem.SearchBlocksOfName Method

IMyGridTerminalSystemSearchBlocksOfName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SearchBlocksOfName(
    string name,
    List<IMyTerminalBlock> blocks,
    Func<IMyTerminalBlock, bool> collect = null
)
Sub SearchBlocksOfName (
    name As String,
    blocks As List(Of IMyTerminalBlock),
    Optional collect As Func(Of IMyTerminalBlock, Boolean) = Nothing
)
void SearchBlocksOfName(
    String^ name,
    List<IMyTerminalBlock^>^ blocks,
    Func<IMyTerminalBlock^, bool>^ collect = nullptr
)
abstract SearchBlocksOfName :
        name : string *
        blocks : List<IMyTerminalBlock> *
        ?collect : Func<IMyTerminalBlock, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

blocks
Type: System.Collections.GenericList IMyTerminalBlock

[Missing <param name="blocks"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

collect (Optional)
Type: SystemFunc IMyTerminalBlock, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyGridTerminalSystem.SearchBlocksOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.IMyTerminalBlock},System.Func{Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean})"]

See Also

Reference

IMyGridTerminalSystem Interface


IMyGyro Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyGyro"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyGyro : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyGyro
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyGyro : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyGyro =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyGyro type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | GyroOverride |
Public property | GyroPower |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Pitch |
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Roll |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Public property | Yaw |
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyGyro Properties

The IMyGyro type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | GyroOverride |
Public property | GyroPower |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Pitch |
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Roll |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Public property | Yaw |
Top
See Also

Reference

IMyGyro Interface


IMyGyro.GyroOverride Property

IMyGyroGyroOverride Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyGyro.GyroOverride"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GyroOverride { get; set; }
Property GyroOverride As Boolean
    Get
    Set
property bool GyroOverride {
    bool get ();
    void set (bool value);
}
abstract GyroOverride : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyGyro Interface


IMyGyro.GyroPower Property

IMyGyroGyroPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyGyro.GyroPower"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float GyroPower { get; set; }
Property GyroPower As Single
    Get
    Set
property float GyroPower {
    float get ();
    void set (float value);
}
abstract GyroPower : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface


IMyGyro.Pitch Property

IMyGyroPitch Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyGyro.Pitch"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Pitch { get; set; }
Property Pitch As Single
    Get
    Set
property float Pitch {
    float get ();
    void set (float value);
}
abstract Pitch : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface


IMyGyro.Roll Property

IMyGyroRoll Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyGyro.Roll"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Roll { get; set; }
Property Roll As Single
    Get
    Set
property float Roll {
    float get ();
    void set (float value);
}
abstract Roll : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface


IMyGyro.Yaw Property

IMyGyroYaw Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyGyro.Yaw"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Yaw { get; set; }
Property Yaw As Single
    Get
    Set
property float Yaw {
    float get ();
    void set (float value);
}
abstract Yaw : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyGyro Interface


IMyGyro Methods

The IMyGyro type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyGyro Interface


IMyJumpDrive Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyJumpDrive"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyJumpDrive : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyJumpDrive
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyJumpDrive : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyJumpDrive =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyJumpDrive type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentStoredPower |
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxStoredPower |
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyJumpDrive Properties

The IMyJumpDrive type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentStoredPower |
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxStoredPower |
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyJumpDrive Interface


IMyJumpDrive.CurrentStoredPower Property

IMyJumpDriveCurrentStoredPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyJumpDrive.CurrentStoredPower"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentStoredPower { get; }
ReadOnly Property CurrentStoredPower As Single
    Get
property float CurrentStoredPower {
    float get ();
}
abstract CurrentStoredPower : float32 with get

Property Value

Type: Single
See Also

Reference

IMyJumpDrive Interface


IMyJumpDrive.MaxStoredPower Property

IMyJumpDriveMaxStoredPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyJumpDrive.MaxStoredPower"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxStoredPower { get; }
ReadOnly Property MaxStoredPower As Single
    Get
property float MaxStoredPower {
    float get ();
}
abstract MaxStoredPower : float32 with get

Property Value

Type: Single
See Also

Reference

IMyJumpDrive Interface


IMyJumpDrive.Status Property

IMyJumpDriveStatus Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyJumpDrive.Status"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyJumpDriveStatus Status { get; }
ReadOnly Property Status As MyJumpDriveStatus
    Get
property MyJumpDriveStatus Status {
    MyJumpDriveStatus get ();
}
abstract Status : MyJumpDriveStatus with get

Property Value

Type: MyJumpDriveStatus
See Also

Reference

IMyJumpDrive Interface


IMyJumpDrive Methods

The IMyJumpDrive type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyJumpDrive Interface


IMyLargeTurretBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyLargeTurretBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLargeTurretBase : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyLargeTurretBase
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyLargeTurretBase : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyLargeTurretBase =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyLargeTurretBase type exposes the following members.

Properties
 | Name | Description
Public property | AIEnabled | Checks is AI is enabled for turret
Public property | Azimuth | Sets/gets azimuth of turret, this method is not synced, you need to sync azimuth manually
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControl |
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Elevation | Sets/gets elevation of turret, this method is not synced, you need to sync elevation manually
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableIdleRotation | enable/disable idle rotation for turret, this method is not synced, you need to sync manually
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasTarget | Checks if the turret is locked onto a target
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Range |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | ResetTargetingToDefault | resert targeting to default values
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetTarget(IMyEntity) | Tracks target without position prediction
Public method | SetTarget(Vector3D) | Targets given position
Public method | SyncAzimuth | method used to sync azimuth, you need to call it to sync azimuth for other clients/server
Public method | SyncElevation | method used to sync elevation of turret , you need to call it to sync elevation for other clients/server
Public method | SyncEnableIdleRotation | method used to sync idle rotation and elevation, you need to call it to sync rotation and elevation for other clients/server
Public method | TrackTarget(IMyEntity) | Tracks entity with enabled position prediction
Public method | TrackTarget(Vector3D, Vector3) | Tracks given target with enabled position prediction
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyLargeTurretBase Properties

The IMyLargeTurretBase type exposes the following members.

Properties
 | Name | Description
Public property | AIEnabled | Checks is AI is enabled for turret
Public property | Azimuth | Sets/gets azimuth of turret, this method is not synced, you need to sync azimuth manually
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControl |
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Elevation | Sets/gets elevation of turret, this method is not synced, you need to sync elevation manually
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EnableIdleRotation | enable/disable idle rotation for turret, this method is not synced, you need to sync manually
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasTarget | Checks if the turret is locked onto a target
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Range |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.AIEnabled Property

IMyLargeTurretBaseAIEnabled Property

Checks is AI is enabled for turret

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AIEnabled { get; }
ReadOnly Property AIEnabled As Boolean
    Get
property bool AIEnabled {
    bool get ();
}
abstract AIEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.Azimuth Property

IMyLargeTurretBaseAzimuth Property

Sets/gets azimuth of turret, this method is not synced, you need to sync azimuth manually

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Azimuth { get; set; }
Property Azimuth As Single
    Get
    Set
property float Azimuth {
    float get ();
    void set (float value);
}
abstract Azimuth : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.CanControl Property

IMyLargeTurretBaseCanControl Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.CanControl"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanControl { get; }
ReadOnly Property CanControl As Boolean
    Get
property bool CanControl {
    bool get ();
}
abstract CanControl : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.Elevation Property

IMyLargeTurretBaseElevation Property

Sets/gets elevation of turret, this method is not synced, you need to sync elevation manually

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Elevation { get; set; }
Property Elevation As Single
    Get
    Set
property float Elevation {
    float get ();
    void set (float value);
}
abstract Elevation : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.EnableIdleRotation Property

IMyLargeTurretBaseEnableIdleRotation Property

enable/disable idle rotation for turret, this method is not synced, you need to sync manually

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EnableIdleRotation { get; set; }
Property EnableIdleRotation As Boolean
    Get
    Set
property bool EnableIdleRotation {
    bool get ();
    void set (bool value);
}
abstract EnableIdleRotation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.HasTarget Property

IMyLargeTurretBaseHasTarget Property

Checks if the turret is locked onto a target

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasTarget { get; }
ReadOnly Property HasTarget As Boolean
    Get
property bool HasTarget {
    bool get ();
}
abstract HasTarget : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.IsUnderControl Property

IMyLargeTurretBaseIsUnderControl Property

Indicates whether a block is locally or remotely controlled.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUnderControl { get; }
ReadOnly Property IsUnderControl As Boolean
    Get
property bool IsUnderControl {
    bool get ();
}
abstract IsUnderControl : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.Range Property

IMyLargeTurretBaseRange Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.Range"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Range { get; }
ReadOnly Property Range As Single
    Get
property float Range {
    float get ();
}
abstract Range : float32 with get

Property Value

Type: Single
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase Methods

The IMyLargeTurretBase type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | ResetTargetingToDefault | resert targeting to default values
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetTarget(IMyEntity) | Tracks target without position prediction
Public method | SetTarget(Vector3D) | Targets given position
Public method | SyncAzimuth | method used to sync azimuth, you need to call it to sync azimuth for other clients/server
Public method | SyncElevation | method used to sync elevation of turret , you need to call it to sync elevation for other clients/server
Public method | SyncEnableIdleRotation | method used to sync idle rotation and elevation, you need to call it to sync rotation and elevation for other clients/server
Public method | TrackTarget(IMyEntity) | Tracks entity with enabled position prediction
Public method | TrackTarget(Vector3D, Vector3) | Tracks given target with enabled position prediction
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.ResetTargetingToDefault Method

IMyLargeTurretBaseResetTargetingToDefault Method

resert targeting to default values

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetTargetingToDefault()
Sub ResetTargetingToDefault
void ResetTargetingToDefault()
abstract ResetTargetingToDefault : unit -> unit
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.SetTarget Method

IMyLargeTurretBaseSetTarget Method

Overload List
 | Name | Description
Public method | SetTarget(IMyEntity) | Tracks target without position prediction
Public method | SetTarget(Vector3D) | Targets given position
Top
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.SetTarget Method (IMyEntity)

IMyLargeTurretBaseSetTarget Method (IMyEntity)

Tracks target without position prediction

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetTarget(
    IMyEntity Entity
)
Sub SetTarget (
    Entity As IMyEntity
)
void SetTarget(
    IMyEntity^ Entity
)
abstract SetTarget :
        Entity : IMyEntity -> unit

Parameters

Entity
Type: IMyEntity

[Missing <param name="Entity"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.SetTarget(VRage.ModAPI.IMyEntity)"]

See Also

Reference

IMyLargeTurretBase Interface
SetTarget Overload


IMyLargeTurretBase.SetTarget Method (Vector3D)

IMyLargeTurretBaseSetTarget Method (Vector3D)

Targets given position

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetTarget(
    Vector3D pos
)
Sub SetTarget (
    pos As Vector3D
)
void SetTarget(
    Vector3D pos
)
abstract SetTarget :
        pos : Vector3D -> unit

Parameters

pos
Type: Vector3D

[Missing <param name="pos"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.SetTarget(VRageMath.Vector3D)"]

See Also

Reference

IMyLargeTurretBase Interface
SetTarget Overload


IMyLargeTurretBase.SyncAzimuth Method

IMyLargeTurretBaseSyncAzimuth Method

method used to sync azimuth, you need to call it to sync azimuth for other clients/server

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SyncAzimuth()
Sub SyncAzimuth
void SyncAzimuth()
abstract SyncAzimuth : unit -> unit
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.SyncElevation Method

IMyLargeTurretBaseSyncElevation Method

method used to sync elevation of turret , you need to call it to sync elevation for other clients/server

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SyncElevation()
Sub SyncElevation
void SyncElevation()
abstract SyncElevation : unit -> unit
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.SyncEnableIdleRotation Method

IMyLargeTurretBaseSyncEnableIdleRotation Method

method used to sync idle rotation and elevation, you need to call it to sync rotation and elevation for other clients/server

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SyncEnableIdleRotation()
Sub SyncEnableIdleRotation
void SyncEnableIdleRotation()
abstract SyncEnableIdleRotation : unit -> unit
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.TrackTarget Method

IMyLargeTurretBaseTrackTarget Method

Overload List
 | Name | Description
Public method | TrackTarget(IMyEntity) | Tracks entity with enabled position prediction
Public method | TrackTarget(Vector3D, Vector3) | Tracks given target with enabled position prediction
Top
See Also

Reference

IMyLargeTurretBase Interface


IMyLargeTurretBase.TrackTarget Method (IMyEntity)

IMyLargeTurretBaseTrackTarget Method (IMyEntity)

Tracks entity with enabled position prediction

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TrackTarget(
    IMyEntity entity
)
Sub TrackTarget (
    entity As IMyEntity
)
void TrackTarget(
    IMyEntity^ entity
)
abstract TrackTarget :
        entity : IMyEntity -> unit

Parameters

entity
Type: IMyEntity

[Missing <param name="entity"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.TrackTarget(VRage.ModAPI.IMyEntity)"]

See Also

Reference

IMyLargeTurretBase Interface
TrackTarget Overload


IMyLargeTurretBase.TrackTarget Method (Vector3D, Vector3)

IMyLargeTurretBaseTrackTarget Method (Vector3D, Vector3)

Tracks given target with enabled position prediction

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TrackTarget(
    Vector3D pos,
    Vector3 velocity
)
Sub TrackTarget (
    pos As Vector3D,
    velocity As Vector3
)
void TrackTarget(
    Vector3D pos,
    Vector3 velocity
)
abstract TrackTarget :
        pos : Vector3D *
        velocity : Vector3 -> unit

Parameters

pos
Type: Vector3D

[Missing <param name="pos"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.TrackTarget(VRageMath.Vector3D,VRageMath.Vector3)"]

velocity
Type: Vector3

[Missing <param name="velocity"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLargeTurretBase.TrackTarget(VRageMath.Vector3D,VRageMath.Vector3)"]

See Also

Reference

IMyLargeTurretBase Interface
TrackTarget Overload


IMyLaserAntenna Interface

Laser antenna block interface

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLaserAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyLaserAntenna
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyLaserAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyLaserAntenna =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyLaserAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsOutsideLimits | Obsolete. Target is outside movement limits of antenna
Public property | IsPermanent | Connection is permanent
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RequireLoS | Determines whether this particular antenna requires line of sight to function.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status of this antenna.
Public property | TargetCoords | get target coordinates
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Connect | Connect to target defined by SetTargetCoords
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetTargetCoords | Set coordinates of target
Public method | TransmitMessage | Sends a message to the programmable block associated with this antenna's partner
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyLaserAntenna Properties

The IMyLaserAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsOutsideLimits | Obsolete. Target is outside movement limits of antenna
Public property | IsPermanent | Connection is permanent
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RequireLoS | Determines whether this particular antenna requires line of sight to function.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status of this antenna.
Public property | TargetCoords | get target coordinates
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.IsOutsideLimits Property

IMyLaserAntennaIsOutsideLimits Property

Note: This API is now obsolete.

Target is outside movement limits of antenna

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Check the Status property instead.")]
bool IsOutsideLimits { get; }
<ObsoleteAttribute("Check the Status property instead.")>
ReadOnly Property IsOutsideLimits As Boolean
    Get
[ObsoleteAttribute(L"Check the Status property instead.")]
property bool IsOutsideLimits {
    bool get ();
}
[<ObsoleteAttribute("Check the Status property instead.")>]
abstract IsOutsideLimits : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.IsPermanent Property

IMyLaserAntennaIsPermanent Property

Connection is permanent

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPermanent { get; }
ReadOnly Property IsPermanent As Boolean
    Get
property bool IsPermanent {
    bool get ();
}
abstract IsPermanent : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.RequireLoS Property

IMyLaserAntennaRequireLoS Property

Determines whether this particular antenna requires line of sight to function.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RequireLoS { get; }
ReadOnly Property RequireLoS As Boolean
    Get
property bool RequireLoS {
    bool get ();
}
abstract RequireLoS : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.Status Property

IMyLaserAntennaStatus Property

Gets the current status of this antenna.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyLaserAntennaStatus Status { get; }
ReadOnly Property Status As MyLaserAntennaStatus
    Get
property MyLaserAntennaStatus Status {
    MyLaserAntennaStatus get ();
}
abstract Status : MyLaserAntennaStatus with get

Property Value

Type: MyLaserAntennaStatus
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.TargetCoords Property

IMyLaserAntennaTargetCoords Property

get target coordinates

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3D TargetCoords { get; }
ReadOnly Property TargetCoords As Vector3D
    Get
property Vector3D TargetCoords {
    Vector3D get ();
}
abstract TargetCoords : Vector3D with get

Property Value

Type: Vector3D
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna Methods

The IMyLaserAntenna type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect to target defined by SetTargetCoords
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetTargetCoords | Set coordinates of target
Public method | TransmitMessage | Sends a message to the programmable block associated with this antenna's partner
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.Connect Method

IMyLaserAntennaConnect Method

Connect to target defined by SetTargetCoords

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.SetTargetCoords Method

IMyLaserAntennaSetTargetCoords Method

Set coordinates of target

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetTargetCoords(
    string coords
)
Sub SetTargetCoords (
    coords As String
)
void SetTargetCoords(
    String^ coords
)
abstract SetTargetCoords :
        coords : string -> unit

Parameters

coords
Type: SystemString
GPS coordinates string
See Also

Reference

IMyLaserAntenna Interface


IMyLaserAntenna.TransmitMessage Method

IMyLaserAntennaTransmitMessage Method

Sends a message to the programmable block associated with this antenna's partner

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TransmitMessage(
    string message
)
Function TransmitMessage (
    message As String
) As Boolean
bool TransmitMessage(
    String^ message
)
abstract TransmitMessage :
        message : string -> bool

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyLaserAntenna.TransmitMessage(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyLaserAntenna.TransmitMessage(System.String)"]

See Also

Reference

IMyLaserAntenna Interface


IMyLightingBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyLightingBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyLightingBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyLightingBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyLightingBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyLightingBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyLightingBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds).
Public property | BlinkLenght | Obsolete.
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1.
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Color | Gets or sets the color of the light.
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Gets or sets the basic radius of the light.
Public property | ReflectorRadius | Obsolete.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyLightingBlock Properties

The IMyLightingBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds).
Public property | BlinkLenght | Obsolete.
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1.
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Color | Gets or sets the color of the light.
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Gets or sets the basic radius of the light.
Public property | ReflectorRadius | Obsolete.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.BlinkIntervalSeconds Property

IMyLightingBlockBlinkIntervalSeconds Property

Gets or sets the blinking interval of this light (in seconds).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BlinkIntervalSeconds { get; set; }
Property BlinkIntervalSeconds As Single
    Get
    Set
property float BlinkIntervalSeconds {
    float get ();
    void set (float value);
}
abstract BlinkIntervalSeconds : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.BlinkLenght Property

IMyLightingBlockBlinkLenght Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyLightingBlock.BlinkLenght"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use BlinkLength instead.")]
float BlinkLenght { get; }
<ObsoleteAttribute("Use BlinkLength instead.")>
ReadOnly Property BlinkLenght As Single
    Get
[ObsoleteAttribute(L"Use BlinkLength instead.")]
property float BlinkLenght {
    float get ();
}
[<ObsoleteAttribute("Use BlinkLength instead.")>]
abstract BlinkLenght : float32 with get

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.BlinkLength Property

IMyLightingBlockBlinkLength Property

Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BlinkLength { get; set; }
Property BlinkLength As Single
    Get
    Set
property float BlinkLength {
    float get ();
    void set (float value);
}
abstract BlinkLength : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.BlinkOffset Property

IMyLightingBlockBlinkOffset Property

Adds an offset to the blinking interval, as a value between 0 and 1.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BlinkOffset { get; set; }
Property BlinkOffset As Single
    Get
    Set
property float BlinkOffset {
    float get ();
    void set (float value);
}
abstract BlinkOffset : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.Color Property

IMyLightingBlockColor Property

Gets or sets the color of the light.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Color Color { get; set; }
Property Color As Color
    Get
    Set
property Color Color {
    Color get ();
    void set (Color value);
}
abstract Color : Color with get, set

Property Value

Type: Color
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.Falloff Property

IMyLightingBlockFalloff Property

Gets or sets the current falloff of the light.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Falloff { get; set; }
Property Falloff As Single
    Get
    Set
property float Falloff {
    float get ();
    void set (float value);
}
abstract Falloff : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.Intensity Property

IMyLightingBlockIntensity Property

Gets or sets the current intensity of the light.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Intensity { get; set; }
Property Intensity As Single
    Get
    Set
property float Intensity {
    float get ();
    void set (float value);
}
abstract Intensity : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.Radius Property

IMyLightingBlockRadius Property

Gets or sets the basic radius of the light.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Radius { get; set; }
Property Radius As Single
    Get
    Set
property float Radius {
    float get ();
    void set (float value);
}
abstract Radius : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock.ReflectorRadius Property

IMyLightingBlockReflectorRadius Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyLightingBlock.ReflectorRadius"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Radius")]
float ReflectorRadius { get; }
<ObsoleteAttribute("Use Radius")>
ReadOnly Property ReflectorRadius As Single
    Get
[ObsoleteAttribute(L"Use Radius")]
property float ReflectorRadius {
    float get ();
}
[<ObsoleteAttribute("Use Radius")>]
abstract ReflectorRadius : float32 with get

Property Value

Type: Single
See Also

Reference

IMyLightingBlock Interface


IMyLightingBlock Methods

The IMyLightingBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyLightingBlock Interface


IMyMechanicalConnectionBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMechanicalConnectionBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMechanicalConnectionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMechanicalConnectionBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyMechanicalConnectionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMechanicalConnectionBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMechanicalConnectionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked).
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Top | Gets the attached top part entity
Public property | TopGrid | Gets the grid of the attached top part
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block
Public method | Detach | Detaches the top from the base
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyMechanicalConnectionBlock Properties

The IMyMechanicalConnectionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked).
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Top | Gets the attached top part entity
Public property | TopGrid | Gets the grid of the attached top part
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.IsAttached Property

IMyMechanicalConnectionBlockIsAttached Property

Gets if the block base is attached to something

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAttached { get; }
ReadOnly Property IsAttached As Boolean
    Get
property bool IsAttached {
    bool get ();
}
abstract IsAttached : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.IsLocked Property

IMyMechanicalConnectionBlockIsLocked Property

Note: This API is now obsolete.

Gets if the block is safety locked (welded)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SafetyLock")]
bool IsLocked { get; }
<ObsoleteAttribute("Use SafetyLock")>
ReadOnly Property IsLocked As Boolean
    Get
[ObsoleteAttribute(L"Use SafetyLock")]
property bool IsLocked {
    bool get ();
}
[<ObsoleteAttribute("Use SafetyLock")>]
abstract IsLocked : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.PendingAttachment Property

IMyMechanicalConnectionBlockPendingAttachment Property

Gets if the block is looking for a top part

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PendingAttachment { get; }
ReadOnly Property PendingAttachment As Boolean
    Get
property bool PendingAttachment {
    bool get ();
}
abstract PendingAttachment : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.SafetyLock Property

IMyMechanicalConnectionBlockSafetyLock Property

Gets if the block is safety locked (welded)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SafetyLock { get; set; }
Property SafetyLock As Boolean
    Get
    Set
property bool SafetyLock {
    bool get ();
    void set (bool value);
}
abstract SafetyLock : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.SafetyLockSpeed Property

IMyMechanicalConnectionBlockSafetyLockSpeed Property

Gets or sets the speed at which this device will engage it's safety lock (IsLocked).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float SafetyLockSpeed { get; set; }
Property SafetyLockSpeed As Single
    Get
    Set
property float SafetyLockSpeed {
    float get ();
    void set (float value);
}
abstract SafetyLockSpeed : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.Top Property

IMyMechanicalConnectionBlockTop Property

Gets the attached top part entity

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyAttachableTopBlock Top { get; }
ReadOnly Property Top As IMyAttachableTopBlock
    Get
property IMyAttachableTopBlock^ Top {
    IMyAttachableTopBlock^ get ();
}
abstract Top : IMyAttachableTopBlock with get

Property Value

Type: IMyAttachableTopBlock
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.TopGrid Property

IMyMechanicalConnectionBlockTopGrid Property

Gets the grid of the attached top part

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyCubeGrid TopGrid { get; }
ReadOnly Property TopGrid As IMyCubeGrid
    Get
property IMyCubeGrid^ TopGrid {
    IMyCubeGrid^ get ();
}
abstract TopGrid : IMyCubeGrid with get

Property Value

Type: IMyCubeGrid
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock Methods

The IMyMechanicalConnectionBlock type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block
Public method | Detach | Detaches the top from the base
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.Attach Method

IMyMechanicalConnectionBlockAttach Method

Attaches a nearby top part to the block

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Attach()
Sub Attach
void Attach()
abstract Attach : unit -> unit
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMechanicalConnectionBlock.Detach Method

IMyMechanicalConnectionBlockDetach Method

Detaches the top from the base

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Detach()
Sub Detach
void Detach()
abstract Detach : unit -> unit
See Also

Reference

IMyMechanicalConnectionBlock Interface


IMyMotorAdvancedRotor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorAdvancedRotor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorAdvancedRotor : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorAdvancedRotor
    Inherits IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorAdvancedRotor : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
type IMyMotorAdvancedRotor =
    interface
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorAdvancedRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyMotorAdvancedRotor Properties

The IMyMotorAdvancedRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorAdvancedRotor Interface


IMyMotorAdvancedRotor Methods

The IMyMotorAdvancedRotor type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorAdvancedRotor Interface


IMyMotorAdvancedStator Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorAdvancedStator"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorAdvancedStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
Public Interface IMyMotorAdvancedStator
    Inherits IMyMotorStator, IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorAdvancedStator : IMyMotorStator,
    IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
type IMyMotorAdvancedStator =
    interface
        interface IMyMotorStator
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorAdvancedStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyMotorAdvancedStator Properties

The IMyMotorAdvancedStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor. (Inherited from IMyMotorStator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top (Inherited from IMyMotorStator.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top (Inherited from IMyMotorStator.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit. (Inherited from IMyMotorStator.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor (Inherited from IMyMotorStator.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top (Inherited from IMyMotorStator.)
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit. (Inherited from IMyMotorStator.)
Public property | Velocity | Obsolete. (Inherited from IMyMotorStator.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorAdvancedStator Interface


IMyMotorAdvancedStator Methods

The IMyMotorAdvancedStator type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorAdvancedStator Interface


IMyMotorBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorBase
    Inherits IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyMotorBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMotorBase =
    interface
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyMotorBase Properties

The IMyMotorBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorBase Interface


IMyMotorBase Methods

The IMyMotorBase type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorBase Interface


IMyMotorRotor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorRotor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorRotor : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyMotorRotor
    Inherits IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyMotorRotor : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity
type IMyMotorRotor =
    interface
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyMotorRotor Properties

The IMyMotorRotor type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorRotor Interface


IMyMotorRotor Methods

The IMyMotorRotor type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyMotorRotor Interface


IMyMotorStator Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorStator"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorStator : IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorStator
    Inherits IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyMotorStator : IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMotorStator =
    interface
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit.
Public property | Velocity | Obsolete.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyMotorStator Properties

The IMyMotorStator type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets the current angle of the rotor.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BrakingTorque | Gets or sets the torque applied when stopping the rotor top
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | Displacement | Gets or sets the vertical displacement of the rotor top
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowerLimit | Gets or sets the lower angle limit of the rotor. Set to -361 for no limit.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TargetVelocity | Gets or sets the desired velocity of the rotor
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Torque | Gets or sets the torque applied when moving the rotor top
Public property | UpperLimit | Gets or sets the upper angle limit of the rotor. Set to 361 for no limit.
Public property | Velocity | Obsolete.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.Angle Property

IMyMotorStatorAngle Property

Gets the current angle of the rotor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Angle { get; }
ReadOnly Property Angle As Single
    Get
property float Angle {
    float get ();
}
abstract Angle : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.BrakingTorque Property

IMyMotorStatorBrakingTorque Property

Gets or sets the torque applied when stopping the rotor top

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BrakingTorque { get; set; }
Property BrakingTorque As Single
    Get
    Set
property float BrakingTorque {
    float get ();
    void set (float value);
}
abstract BrakingTorque : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.Displacement Property

IMyMotorStatorDisplacement Property

Gets or sets the vertical displacement of the rotor top

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Displacement { get; set; }
Property Displacement As Single
    Get
    Set
property float Displacement {
    float get ();
    void set (float value);
}
abstract Displacement : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.LowerLimit Property

IMyMotorStatorLowerLimit Property

Gets or sets the lower angle limit of the rotor. Set to -361 for no limit.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float LowerLimit { get; set; }
Property LowerLimit As Single
    Get
    Set
property float LowerLimit {
    float get ();
    void set (float value);
}
abstract LowerLimit : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.TargetVelocity Property

IMyMotorStatorTargetVelocity Property

Gets or sets the desired velocity of the rotor

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float TargetVelocity { get; set; }
Property TargetVelocity As Single
    Get
    Set
property float TargetVelocity {
    float get ();
    void set (float value);
}
abstract TargetVelocity : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.Torque Property

IMyMotorStatorTorque Property

Gets or sets the torque applied when moving the rotor top

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Torque { get; set; }
Property Torque As Single
    Get
    Set
property float Torque {
    float get ();
    void set (float value);
}
abstract Torque : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.UpperLimit Property

IMyMotorStatorUpperLimit Property

Gets or sets the upper angle limit of the rotor. Set to 361 for no limit.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float UpperLimit { get; set; }
Property UpperLimit As Single
    Get
    Set
property float UpperLimit {
    float get ();
    void set (float value);
}
abstract UpperLimit : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator.Velocity Property

IMyMotorStatorVelocity Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorStator.Velocity"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use TargetVelocity")]
float Velocity { get; }
<ObsoleteAttribute("Use TargetVelocity")>
ReadOnly Property Velocity As Single
    Get
[ObsoleteAttribute(L"Use TargetVelocity")]
property float Velocity {
    float get ();
}
[<ObsoleteAttribute("Use TargetVelocity")>]
abstract Velocity : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorStator Interface


IMyMotorStator Methods

The IMyMotorStator type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorStator Interface


IMyMotorSuspension Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyMotorSuspension"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyMotorSuspension : IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyMotorSuspension
    Inherits IMyMotorBase, IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMyMotorSuspension : IMyMotorBase,
    IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyMotorSuspension =
    interface
        interface IMyMotorBase
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyMotorSuspension type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Brake | Set/get brake applied to the wheel.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | Damping |
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Friction |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Height |
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | InvertPropulsion |
Public property | InvertSteer |
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxSteerAngle | Max steering angle in radians.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Power |
Public property | Propulsion |
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SteerAngle | Wheel's current steering angle
Public property | Steering |
Public property | SteerReturnSpeed | Speed at which wheel returns from steering.
Public property | SteerSpeed | Speed at which wheel steers.
Public property | Strength |
Public property | SuspensionTravel | Suspension travel, value from 0 to 1.
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyMotorSuspension Properties

The IMyMotorSuspension type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Brake | Set/get brake applied to the wheel.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | Damping |
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Friction |
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Height |
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | InvertPropulsion |
Public property | InvertSteer |
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxSteerAngle | Max steering angle in radians.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Power |
Public property | Propulsion |
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | SteerAngle | Wheel's current steering angle
Public property | Steering |
Public property | SteerReturnSpeed | Speed at which wheel returns from steering.
Public property | SteerSpeed | Speed at which wheel steers.
Public property | Strength |
Public property | SuspensionTravel | Suspension travel, value from 0 to 1.
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Brake Property

IMyMotorSuspensionBrake Property

Set/get brake applied to the wheel.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Brake { get; set; }
Property Brake As Boolean
    Get
    Set
property bool Brake {
    bool get ();
    void set (bool value);
}
abstract Brake : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Damping Property

IMyMotorSuspensionDamping Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Damping"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Damping { get; }
ReadOnly Property Damping As Single
    Get
property float Damping {
    float get ();
}
abstract Damping : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Friction Property

IMyMotorSuspensionFriction Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Friction"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Friction { get; }
ReadOnly Property Friction As Single
    Get
property float Friction {
    float get ();
}
abstract Friction : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Height Property

IMyMotorSuspensionHeight Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Height"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Height { get; }
ReadOnly Property Height As Single
    Get
property float Height {
    float get ();
}
abstract Height : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.InvertPropulsion Property

IMyMotorSuspensionInvertPropulsion Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.InvertPropulsion"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InvertPropulsion { get; }
ReadOnly Property InvertPropulsion As Boolean
    Get
property bool InvertPropulsion {
    bool get ();
}
abstract InvertPropulsion : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.InvertSteer Property

IMyMotorSuspensionInvertSteer Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.InvertSteer"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InvertSteer { get; }
ReadOnly Property InvertSteer As Boolean
    Get
property bool InvertSteer {
    bool get ();
}
abstract InvertSteer : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.MaxSteerAngle Property

IMyMotorSuspensionMaxSteerAngle Property

Max steering angle in radians.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxSteerAngle { get; }
ReadOnly Property MaxSteerAngle As Single
    Get
property float MaxSteerAngle {
    float get ();
}
abstract MaxSteerAngle : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Power Property

IMyMotorSuspensionPower Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Power"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Power { get; }
ReadOnly Property Power As Single
    Get
property float Power {
    float get ();
}
abstract Power : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Propulsion Property

IMyMotorSuspensionPropulsion Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Propulsion"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Propulsion { get; }
ReadOnly Property Propulsion As Boolean
    Get
property bool Propulsion {
    bool get ();
}
abstract Propulsion : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.SteerAngle Property

IMyMotorSuspensionSteerAngle Property

Wheel's current steering angle

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float SteerAngle { get; }
ReadOnly Property SteerAngle As Single
    Get
property float SteerAngle {
    float get ();
}
abstract SteerAngle : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Steering Property

IMyMotorSuspensionSteering Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Steering"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Steering { get; }
ReadOnly Property Steering As Boolean
    Get
property bool Steering {
    bool get ();
}
abstract Steering : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.SteerReturnSpeed Property

IMyMotorSuspensionSteerReturnSpeed Property

Speed at which wheel returns from steering.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float SteerReturnSpeed { get; }
ReadOnly Property SteerReturnSpeed As Single
    Get
property float SteerReturnSpeed {
    float get ();
}
abstract SteerReturnSpeed : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.SteerSpeed Property

IMyMotorSuspensionSteerSpeed Property

Speed at which wheel steers.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float SteerSpeed { get; }
ReadOnly Property SteerSpeed As Single
    Get
property float SteerSpeed {
    float get ();
}
abstract SteerSpeed : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.Strength Property

IMyMotorSuspensionStrength Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyMotorSuspension.Strength"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Strength { get; }
ReadOnly Property Strength As Single
    Get
property float Strength {
    float get ();
}
abstract Strength : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension.SuspensionTravel Property

IMyMotorSuspensionSuspensionTravel Property

Suspension travel, value from 0 to 1.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float SuspensionTravel { get; }
ReadOnly Property SuspensionTravel As Single
    Get
property float SuspensionTravel {
    float get ();
}
abstract SuspensionTravel : float32 with get

Property Value

Type: Single
See Also

Reference

IMyMotorSuspension Interface


IMyMotorSuspension Methods

The IMyMotorSuspension type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyMotorSuspension Interface


IMyOreDetector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyOreDetector"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyOreDetector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyOreDetector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyOreDetector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyOreDetector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOreDetector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BroadcastUsingAntennas |
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Range |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyOreDetector Properties

The IMyOreDetector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BroadcastUsingAntennas |
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Range |
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOreDetector Interface


IMyOreDetector.BroadcastUsingAntennas Property

IMyOreDetectorBroadcastUsingAntennas Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyOreDetector.BroadcastUsingAntennas"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BroadcastUsingAntennas { get; }
ReadOnly Property BroadcastUsingAntennas As Boolean
    Get
property bool BroadcastUsingAntennas {
    bool get ();
}
abstract BroadcastUsingAntennas : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyOreDetector Interface


IMyOreDetector.Range Property

IMyOreDetectorRange Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyOreDetector.Range"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Range { get; }
ReadOnly Property Range As Single
    Get
property float Range {
    float get ();
}
abstract Range : float32 with get

Property Value

Type: Single
See Also

Reference

IMyOreDetector Interface


IMyOreDetector Methods

The IMyOreDetector type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOreDetector Interface


IMyOxygenGenerator Interface

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyOxygenGenerator"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGasGenerator")]
public interface IMyOxygenGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
<ObsoleteAttribute("Use IMyGasGenerator")>
Public Interface IMyOxygenGenerator
    Inherits IMyGasGenerator, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
[ObsoleteAttribute(L"Use IMyGasGenerator")]
public interface class IMyOxygenGenerator : IMyGasGenerator,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
[<ObsoleteAttribute("Use IMyGasGenerator")>]
type IMyOxygenGenerator =
    interface
        interface IMyGasGenerator
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOxygenGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyOxygenGenerator Properties

The IMyOxygenGenerator type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefill | Autorefill enabled (Inherited from IMyGasGenerator.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOxygenGenerator Interface


IMyOxygenGenerator Methods

The IMyOxygenGenerator type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOxygenGenerator Interface


IMyOxygenTank Interface

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyOxygenTank"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGasTank")]
public interface IMyOxygenTank : IMyGasTank,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
<ObsoleteAttribute("Use IMyGasTank")>
Public Interface IMyOxygenTank
    Inherits IMyGasTank, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
[ObsoleteAttribute(L"Use IMyGasTank")]
public interface class IMyOxygenTank : IMyGasTank,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
[<ObsoleteAttribute("Use IMyGasTank")>]
type IMyOxygenTank =
    interface
        interface IMyGasTank
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyOxygenTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetOxygenLevel | Obsolete. Gets the current oxygen level of this tank, as a value between 0 (empty) and 1 (full).
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyOxygenTank Properties

The IMyOxygenTank type exposes the following members.

Properties
 | Name | Description
Public property | AutoRefillBottles | Gets or sets whether storage bottles will be filled automatically when placed within this tank. (Inherited from IMyGasTank.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | Capacity | Gets the gas capacity of this tank. (Inherited from IMyGasTank.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FilledRatio | Gets the current fill level of this tank as a value between 0 (empty) and 1 (full). (Inherited from IMyGasTank.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Stockpile | Gets or sets the stockpiling option for this gas tank. When stockpile is on, the tank will only allow itself to be filled, it will not release any gas. (Inherited from IMyGasTank.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyOxygenTank Interface


IMyOxygenTank Methods

The IMyOxygenTank type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetOxygenLevel | Obsolete. Gets the current oxygen level of this tank, as a value between 0 (empty) and 1 (full).
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RefillBottles | Refills any stored storage bottles. (Inherited from IMyGasTank.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyOxygenTank Interface


IMyOxygenTank.GetOxygenLevel Method

IMyOxygenTankGetOxygenLevel Method

Note: This API is now obsolete.

Gets the current oxygen level of this tank, as a value between 0 (empty) and 1 (full).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IMyGasTank.FilledRatio")]
float GetOxygenLevel()
<ObsoleteAttribute("Use IMyGasTank.FilledRatio")>
Function GetOxygenLevel As Single
[ObsoleteAttribute(L"Use IMyGasTank.FilledRatio")]
float GetOxygenLevel()
[<ObsoleteAttribute("Use IMyGasTank.FilledRatio")>]
abstract GetOxygenLevel : unit -> float32

Return Value

Type: Single

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyOxygenTank.GetOxygenLevel"]

See Also

Reference

IMyOxygenTank Interface


IMyPassage Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyPassage"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPassage : IMyCubeBlock,
    IMyEntity
Public Interface IMyPassage
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyPassage : IMyCubeBlock,
    IMyEntity
type IMyPassage =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPassage type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyPassage Properties

The IMyPassage type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPassage Interface


IMyPassage Methods

The IMyPassage type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPassage Interface


IMyPistonBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyPistonBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPistonBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyPistonBase
    Inherits IMyMechanicalConnectionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyPistonBase : IMyMechanicalConnectionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyPistonBase =
    interface
        interface IMyMechanicalConnectionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value.
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value.
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status.
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Extend | Extends the piston.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston.
Public method | Reverse | Reverses the direction of the piston.
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyPistonBase Properties

The IMyPistonBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentPosition | Gets the current position of the piston head relative to the base.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HighestPosition | Gets the highest position the piston is capable of moving to.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets if the block base is attached to something (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete. Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LowestPosition | Gets the lowest position the piston is capable of moving to.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxLimit | Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value.
Public property | MaxVelocity | Gets the maximum velocity this piston is capable of moving at.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MinLimit | Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value.
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PendingAttachment | Gets if the block is looking for a top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | SafetyLock | Gets if the block is safety locked (welded) (Inherited from IMyMechanicalConnectionBlock.)
Public property | SafetyLockSpeed | Gets or sets the speed at which this device will engage it's safety lock (IsLocked). (Inherited from IMyMechanicalConnectionBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Gets the current status.
Public property | Top | Gets the attached top part entity (Inherited from IMyMechanicalConnectionBlock.)
Public property | TopGrid | Gets the grid of the attached top part (Inherited from IMyMechanicalConnectionBlock.)
Public property | Velocity | Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.CurrentPosition Property

IMyPistonBaseCurrentPosition Property

Gets the current position of the piston head relative to the base.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentPosition { get; }
ReadOnly Property CurrentPosition As Single
    Get
property float CurrentPosition {
    float get ();
}
abstract CurrentPosition : float32 with get

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.HighestPosition Property

IMyPistonBaseHighestPosition Property

Gets the highest position the piston is capable of moving to.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float HighestPosition { get; }
ReadOnly Property HighestPosition As Single
    Get
property float HighestPosition {
    float get ();
}
abstract HighestPosition : float32 with get

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.LowestPosition Property

IMyPistonBaseLowestPosition Property

Gets the lowest position the piston is capable of moving to.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float LowestPosition { get; }
ReadOnly Property LowestPosition As Single
    Get
property float LowestPosition {
    float get ();
}
abstract LowestPosition : float32 with get

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.MaxLimit Property

IMyPistonBaseMaxLimit Property

Gets or sets the maximum position the piston can extend to. See LowestPosition and HighestPosition for the limits of this value.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxLimit { get; set; }
Property MaxLimit As Single
    Get
    Set
property float MaxLimit {
    float get ();
    void set (float value);
}
abstract MaxLimit : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.MaxVelocity Property

IMyPistonBaseMaxVelocity Property

Gets the maximum velocity this piston is capable of moving at.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxVelocity { get; }
ReadOnly Property MaxVelocity As Single
    Get
property float MaxVelocity {
    float get ();
}
abstract MaxVelocity : float32 with get

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.MinLimit Property

IMyPistonBaseMinLimit Property

Gets or sets the minimum position the piston can retract to. See LowestPosition and HighestPosition for the limits of this value.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MinLimit { get; set; }
Property MinLimit As Single
    Get
    Set
property float MinLimit {
    float get ();
    void set (float value);
}
abstract MinLimit : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.Status Property

IMyPistonBaseStatus Property

Gets the current status.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PistonStatus Status { get; }
ReadOnly Property Status As PistonStatus
    Get
property PistonStatus Status {
    PistonStatus get ();
}
abstract Status : PistonStatus with get

Property Value

Type: PistonStatus
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.Velocity Property

IMyPistonBaseVelocity Property

Gets or sets the velocity of the piston as it extends or retracts. This value can be between negative and positive MaxVelocity.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Velocity { get; set; }
Property Velocity As Single
    Get
    Set
property float Velocity {
    float get ();
    void set (float value);
}
abstract Velocity : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyPistonBase Interface


IMyPistonBase Methods

The IMyPistonBase type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches a nearby top part to the block (Inherited from IMyMechanicalConnectionBlock.)
Public method | Detach | Detaches the top from the base (Inherited from IMyMechanicalConnectionBlock.)
Public method | Extend | Extends the piston.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | Retract | Retracts the piston.
Public method | Reverse | Reverses the direction of the piston.
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.Extend Method

IMyPistonBaseExtend Method

Extends the piston.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Extend()
Sub Extend
void Extend()
abstract Extend : unit -> unit
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.Retract Method

IMyPistonBaseRetract Method

Retracts the piston.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Retract()
Sub Retract
void Retract()
abstract Retract : unit -> unit
See Also

Reference

IMyPistonBase Interface


IMyPistonBase.Reverse Method

IMyPistonBaseReverse Method

Reverses the direction of the piston.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reverse()
Sub Reverse
void Reverse()
abstract Reverse : unit -> unit
See Also

Reference

IMyPistonBase Interface


IMyPistonTop Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyPistonTop"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyPistonTop : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyPistonTop
    Inherits IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyPistonTop : IMyAttachableTopBlock,
    IMyCubeBlock, IMyEntity
type IMyPistonTop =
    interface
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyPistonTop type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyPistonTop Properties

The IMyPistonTop type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyPistonTop Interface


IMyPistonTop Methods

The IMyPistonTop type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyPistonTop Interface


IMyProductionBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyProductionBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProductionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProductionBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProductionBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProductionBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProductionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing.
Public property | IsQueueEmpty | The production queue is empty.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced.
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory.
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue
Public method | CanUseBlueprint | Can this production block produce this blueprint?
Public method | ClearQueue | Clears the Queue
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue.
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyProductionBlock Properties

The IMyProductionBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing.
Public property | IsQueueEmpty | The production queue is empty.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced.
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory.
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.InputInventory Property

IMyProductionBlockInputInventory Property

Gets the input inventory.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyInventory InputInventory { get; }
ReadOnly Property InputInventory As IMyInventory
    Get
property IMyInventory^ InputInventory {
    IMyInventory^ get ();
}
abstract InputInventory : IMyInventory with get

Property Value

Type: IMyInventory
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.IsProducing Property

IMyProductionBlockIsProducing Property

The device is currently producing.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsProducing { get; }
ReadOnly Property IsProducing As Boolean
    Get
property bool IsProducing {
    bool get ();
}
abstract IsProducing : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.IsQueueEmpty Property

IMyProductionBlockIsQueueEmpty Property

The production queue is empty.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsQueueEmpty { get; }
ReadOnly Property IsQueueEmpty As Boolean
    Get
property bool IsQueueEmpty {
    bool get ();
}
abstract IsQueueEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.NextItemId Property

IMyProductionBlockNextItemId Property

Gets the queue item ID of the next item to be produced.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
uint NextItemId { get; }
ReadOnly Property NextItemId As UInteger
    Get
property unsigned int NextItemId {
    unsigned int get ();
}
abstract NextItemId : uint32 with get

Property Value

Type: UInt32
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.OutputInventory Property

IMyProductionBlockOutputInventory Property

Gets the output inventory.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyInventory OutputInventory { get; }
ReadOnly Property OutputInventory As IMyInventory
    Get
property IMyInventory^ OutputInventory {
    IMyInventory^ get ();
}
abstract OutputInventory : IMyInventory with get

Property Value

Type: IMyInventory
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.UseConveyorSystem Property

IMyProductionBlockUseConveyorSystem Property

Gets or sets whether this device should use the conveyor system to retrieve and store items.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; set; }
Property UseConveyorSystem As Boolean
    Get
    Set
property bool UseConveyorSystem {
    bool get ();
    void set (bool value);
}
abstract UseConveyorSystem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock Methods

The IMyProductionBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue
Public method | CanUseBlueprint | Can this production block produce this blueprint?
Public method | ClearQueue | Clears the Queue
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue.
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.AddQueueItem Method

IMyProductionBlockAddQueueItem Method

Overload List
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue
Top
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.AddQueueItem Method (MyDefinitionId, Decimal)

IMyProductionBlockAddQueueItem Method (MyDefinitionId, Decimal)

Adds a blueprint to the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddQueueItem(
    MyDefinitionId blueprint,
    decimal amount
)
Sub AddQueueItem (
    blueprint As MyDefinitionId,
    amount As Decimal
)
void AddQueueItem(
    MyDefinitionId blueprint,
    Decimal amount
)
abstract AddQueueItem :
        blueprint : MyDefinitionId *
        amount : decimal -> unit

Parameters

blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: SystemDecimal
Amount of items
See Also

Reference

IMyProductionBlock Interface
AddQueueItem Overload


IMyProductionBlock.AddQueueItem Method (MyDefinitionId, Double)

IMyProductionBlockAddQueueItem Method (MyDefinitionId, Double)

Adds a blueprint to the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddQueueItem(
    MyDefinitionId blueprint,
    double amount
)
Sub AddQueueItem (
    blueprint As MyDefinitionId,
    amount As Double
)
void AddQueueItem(
    MyDefinitionId blueprint,
    double amount
)
abstract AddQueueItem :
        blueprint : MyDefinitionId *
        amount : float -> unit

Parameters

blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: SystemDouble
Amount of items
See Also

Reference

IMyProductionBlock Interface
AddQueueItem Overload


IMyProductionBlock.AddQueueItem Method (MyDefinitionId, MyFixedPoint)

IMyProductionBlockAddQueueItem Method (MyDefinitionId, MyFixedPoint)

Adds a blueprint to the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddQueueItem(
    MyDefinitionId blueprint,
    MyFixedPoint amount
)
Sub AddQueueItem (
    blueprint As MyDefinitionId,
    amount As MyFixedPoint
)
void AddQueueItem(
    MyDefinitionId blueprint,
    MyFixedPoint amount
)
abstract AddQueueItem :
        blueprint : MyDefinitionId *
        amount : MyFixedPoint -> unit

Parameters

blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: MyFixedPoint
Amount of items
See Also

Reference

IMyProductionBlock Interface
AddQueueItem Overload


IMyProductionBlock.CanUseBlueprint Method

IMyProductionBlockCanUseBlueprint Method

Can this production block produce this blueprint?

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUseBlueprint(
    MyDefinitionId blueprint
)
Function CanUseBlueprint (
    blueprint As MyDefinitionId
) As Boolean
bool CanUseBlueprint(
    MyDefinitionId blueprint
)
abstract CanUseBlueprint :
        blueprint : MyDefinitionId -> bool

Parameters

blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyProductionBlock.CanUseBlueprint(VRage.Game.MyDefinitionId)"]

See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.ClearQueue Method

IMyProductionBlockClearQueue Method

Clears the Queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearQueue()
Sub ClearQueue
void ClearQueue()
abstract ClearQueue : unit -> unit
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.GetQueue Method

IMyProductionBlockGetQueue Method

Gets the current production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetQueue(
    List<MyProductionItem> items
)
Sub GetQueue (
    items As List(Of MyProductionItem)
)
void GetQueue(
    List<MyProductionItem>^ items
)
abstract GetQueue :
        items : List<MyProductionItem> -> unit

Parameters

items
Type: System.Collections.GenericList MyProductionItem

[Missing <param name="items"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProductionBlock.GetQueue(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyProductionItem})"]

Return Value

Type:
List of MyProductionQueueItems
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.InsertQueueItem Method

IMyProductionBlockInsertQueueItem Method

Overload List
 | Name | Description
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue
Top
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.InsertQueueItem Method (Int32, MyDefinitionId, Decimal)

IMyProductionBlockInsertQueueItem Method (Int32, MyDefinitionId, Decimal)

Inserts a blueprint into the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    decimal amount
)
Sub InsertQueueItem (
    idx As Integer,
    blueprint As MyDefinitionId,
    amount As Decimal
)
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    Decimal amount
)
abstract InsertQueueItem :
        idx : int *
        blueprint : MyDefinitionId *
        amount : decimal -> unit

Parameters

idx
Type: SystemInt32
Index of the item
blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: SystemDecimal
Amount of items
See Also

Reference

IMyProductionBlock Interface
InsertQueueItem Overload


IMyProductionBlock.InsertQueueItem Method (Int32, MyDefinitionId, Double)

IMyProductionBlockInsertQueueItem Method (Int32, MyDefinitionId, Double)

Inserts a blueprint into the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    double amount
)
Sub InsertQueueItem (
    idx As Integer,
    blueprint As MyDefinitionId,
    amount As Double
)
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    double amount
)
abstract InsertQueueItem :
        idx : int *
        blueprint : MyDefinitionId *
        amount : float -> unit

Parameters

idx
Type: SystemInt32
Index of the item
blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: SystemDouble
Amount of items
See Also

Reference

IMyProductionBlock Interface
InsertQueueItem Overload


IMyProductionBlock.InsertQueueItem Method (Int32, MyDefinitionId, MyFixedPoint)

IMyProductionBlockInsertQueueItem Method (Int32, MyDefinitionId, MyFixedPoint)

Inserts a blueprint into the production queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    MyFixedPoint amount
)
Sub InsertQueueItem (
    idx As Integer,
    blueprint As MyDefinitionId,
    amount As MyFixedPoint
)
void InsertQueueItem(
    int idx,
    MyDefinitionId blueprint,
    MyFixedPoint amount
)
abstract InsertQueueItem :
        idx : int *
        blueprint : MyDefinitionId *
        amount : MyFixedPoint -> unit

Parameters

idx
Type: SystemInt32
Index of the item
blueprint
Type: MyDefinitionId
A MyDefinitionId that names the blueprint
amount
Type: MyFixedPoint
Amount of items
See Also

Reference

IMyProductionBlock Interface
InsertQueueItem Overload


IMyProductionBlock.MoveQueueItemRequest Method

IMyProductionBlockMoveQueueItemRequest Method

Moves an item in the queue to a target position in the queue.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveQueueItemRequest(
    uint queueItemId,
    int targetIdx
)
Sub MoveQueueItemRequest (
    queueItemId As UInteger,
    targetIdx As Integer
)
void MoveQueueItemRequest(
    unsigned int queueItemId,
    int targetIdx
)
abstract MoveQueueItemRequest :
        queueItemId : uint32 *
        targetIdx : int -> unit

Parameters

queueItemId
Type: SystemUInt32

[Missing <param name="queueItemId"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProductionBlock.MoveQueueItemRequest(System.UInt32,System.Int32)"]

targetIdx
Type: SystemInt32

[Missing <param name="targetIdx"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProductionBlock.MoveQueueItemRequest(System.UInt32,System.Int32)"]

See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.RemoveQueueItem Method

IMyProductionBlockRemoveQueueItem Method

Overload List
 | Name | Description
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue
Top
See Also

Reference

IMyProductionBlock Interface


IMyProductionBlock.RemoveQueueItem Method (Int32, Decimal)

IMyProductionBlockRemoveQueueItem Method (Int32, Decimal)

Removes an item from the queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveQueueItem(
    int idx,
    decimal amount
)
Sub RemoveQueueItem (
    idx As Integer,
    amount As Decimal
)
void RemoveQueueItem(
    int idx,
    Decimal amount
)
abstract RemoveQueueItem :
        idx : int *
        amount : decimal -> unit

Parameters

idx
Type: SystemInt32
Index of the item
amount
Type: SystemDecimal
Amount to remove
See Also

Reference

IMyProductionBlock Interface
RemoveQueueItem Overload


IMyProductionBlock.RemoveQueueItem Method (Int32, Double)

IMyProductionBlockRemoveQueueItem Method (Int32, Double)

Removes an item from the queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveQueueItem(
    int idx,
    double amount
)
Sub RemoveQueueItem (
    idx As Integer,
    amount As Double
)
void RemoveQueueItem(
    int idx,
    double amount
)
abstract RemoveQueueItem :
        idx : int *
        amount : float -> unit

Parameters

idx
Type: SystemInt32
Index of the item
amount
Type: SystemDouble
Amount to remove
See Also

Reference

IMyProductionBlock Interface
RemoveQueueItem Overload


IMyProductionBlock.RemoveQueueItem Method (Int32, MyFixedPoint)

IMyProductionBlockRemoveQueueItem Method (Int32, MyFixedPoint)

Removes an item from the queue

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveQueueItem(
    int idx,
    MyFixedPoint amount
)
Sub RemoveQueueItem (
    idx As Integer,
    amount As MyFixedPoint
)
void RemoveQueueItem(
    int idx,
    MyFixedPoint amount
)
abstract RemoveQueueItem :
        idx : int *
        amount : MyFixedPoint -> unit

Parameters

idx
Type: SystemInt32
Index of the item
amount
Type: MyFixedPoint
Amount to remove
See Also

Reference

IMyProductionBlock Interface
RemoveQueueItem Overload


IMyProgrammableBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyProgrammableBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProgrammableBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProgrammableBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProgrammableBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProgrammableBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProgrammableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsRunning | This programmable block is currently running its program.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TerminalRunArgument | Contains the value of the default terminal argument.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryRun | Attempts to run this programmable block using the given argument. An already running programmable block cannot be run again. This is equivalent to running block.ApplyAction("Run", argumentsList); This should be called from an ingame script. Do not use in mods.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyProgrammableBlock Properties

The IMyProgrammableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsRunning | This programmable block is currently running its program.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TerminalRunArgument | Contains the value of the default terminal argument.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProgrammableBlock Interface


IMyProgrammableBlock.IsRunning Property

IMyProgrammableBlockIsRunning Property

This programmable block is currently running its program.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRunning { get; }
ReadOnly Property IsRunning As Boolean
    Get
property bool IsRunning {
    bool get ();
}
abstract IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyProgrammableBlock Interface


IMyProgrammableBlock.TerminalRunArgument Property

IMyProgrammableBlockTerminalRunArgument Property

Contains the value of the default terminal argument.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string TerminalRunArgument { get; }
ReadOnly Property TerminalRunArgument As String
    Get
property String^ TerminalRunArgument {
    String^ get ();
}
abstract TerminalRunArgument : string with get

Property Value

Type: String
See Also

Reference

IMyProgrammableBlock Interface


IMyProgrammableBlock Methods

The IMyProgrammableBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryRun | Attempts to run this programmable block using the given argument. An already running programmable block cannot be run again. This is equivalent to running block.ApplyAction("Run", argumentsList); This should be called from an ingame script. Do not use in mods.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProgrammableBlock Interface


IMyProgrammableBlock.TryRun Method

IMyProgrammableBlockTryRun Method

Attempts to run this programmable block using the given argument. An already running programmable block cannot be run again. This is equivalent to running block.ApplyAction("Run", argumentsList); This should be called from an ingame script. Do not use in mods.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TryRun(
    string argument
)
Function TryRun (
    argument As String
) As Boolean
bool TryRun(
    String^ argument
)
abstract TryRun :
        argument : string -> bool

Parameters

argument
Type: SystemString

[Missing <param name="argument"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProgrammableBlock.TryRun(System.String)"]

Return Value

Type: Boolean
true if the action was applied, false otherwise
See Also

Reference

IMyProgrammableBlock Interface


IMyProjector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyProjector"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyProjector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyProjector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyProjector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyProjector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyProjector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BuildableBlocksCount | Count of blocks which can be welded now
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProjecting | Checks if there is an active projection
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ProjectionOffset |
Public property | ProjectionOffsetX | Obsolete.
Public property | ProjectionOffsetY | Obsolete.
Public property | ProjectionOffsetZ | Obsolete.
Public property | ProjectionRotation | These values are not in degrees. 1 = 90 degrees, 2 = 180 degrees
Public property | ProjectionRotX | Obsolete.
Public property | ProjectionRotY | Obsolete.
Public property | ProjectionRotZ | Obsolete.
Public property | RemainingArmorBlocks | Number of armor blocks left to be welded
Public property | RemainingBlocks | Number of blocks left to be welded
Public property | RemainingBlocksPerType | A comprehensive list of blocks left to be welded
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TotalBlocks | Total number of blocks in the projection
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | LoadBlueprint |
Public method | LoadRandomBlueprint |
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateOffsetAndRotation | Call this after setting ProjectionOffset and ProjectionRotation to update the projection
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyProjector Properties

The IMyProjector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BuildableBlocksCount | Count of blocks which can be welded now
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProjecting | Checks if there is an active projection
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ProjectionOffset |
Public property | ProjectionOffsetX | Obsolete.
Public property | ProjectionOffsetY | Obsolete.
Public property | ProjectionOffsetZ | Obsolete.
Public property | ProjectionRotation | These values are not in degrees. 1 = 90 degrees, 2 = 180 degrees
Public property | ProjectionRotX | Obsolete.
Public property | ProjectionRotY | Obsolete.
Public property | ProjectionRotZ | Obsolete.
Public property | RemainingArmorBlocks | Number of armor blocks left to be welded
Public property | RemainingBlocks | Number of blocks left to be welded
Public property | RemainingBlocksPerType | A comprehensive list of blocks left to be welded
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TotalBlocks | Total number of blocks in the projection
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyProjector Interface


IMyProjector.BuildableBlocksCount Property

IMyProjectorBuildableBlocksCount Property

Count of blocks which can be welded now

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int BuildableBlocksCount { get; }
ReadOnly Property BuildableBlocksCount As Integer
    Get
property int BuildableBlocksCount {
    int get ();
}
abstract BuildableBlocksCount : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.IsProjecting Property

IMyProjectorIsProjecting Property

Checks if there is an active projection

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsProjecting { get; }
ReadOnly Property IsProjecting As Boolean
    Get
property bool IsProjecting {
    bool get ();
}
abstract IsProjecting : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionOffset Property

IMyProjectorProjectionOffset Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionOffset"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3I ProjectionOffset { get; set; }
Property ProjectionOffset As Vector3I
    Get
    Set
property Vector3I ProjectionOffset {
    Vector3I get ();
    void set (Vector3I value);
}
abstract ProjectionOffset : Vector3I with get, set

Property Value

Type: Vector3I
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionOffsetX Property

IMyProjectorProjectionOffsetX Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionOffsetX"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionOffset vector instead.")]
int ProjectionOffsetX { get; }
<ObsoleteAttribute("Use ProjectionOffset vector instead.")>
ReadOnly Property ProjectionOffsetX As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionOffset vector instead.")]
property int ProjectionOffsetX {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionOffset vector instead.")>]
abstract ProjectionOffsetX : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionOffsetY Property

IMyProjectorProjectionOffsetY Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionOffsetY"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionOffset vector instead.")]
int ProjectionOffsetY { get; }
<ObsoleteAttribute("Use ProjectionOffset vector instead.")>
ReadOnly Property ProjectionOffsetY As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionOffset vector instead.")]
property int ProjectionOffsetY {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionOffset vector instead.")>]
abstract ProjectionOffsetY : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionOffsetZ Property

IMyProjectorProjectionOffsetZ Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionOffsetZ"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionOffset vector instead.")]
int ProjectionOffsetZ { get; }
<ObsoleteAttribute("Use ProjectionOffset vector instead.")>
ReadOnly Property ProjectionOffsetZ As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionOffset vector instead.")]
property int ProjectionOffsetZ {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionOffset vector instead.")>]
abstract ProjectionOffsetZ : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionRotation Property

IMyProjectorProjectionRotation Property

These values are not in degrees. 1 = 90 degrees, 2 = 180 degrees

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3I ProjectionRotation { get; set; }
Property ProjectionRotation As Vector3I
    Get
    Set
property Vector3I ProjectionRotation {
    Vector3I get ();
    void set (Vector3I value);
}
abstract ProjectionRotation : Vector3I with get, set

Property Value

Type: Vector3I
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionRotX Property

IMyProjectorProjectionRotX Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionRotX"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionRotation vector instead.")]
int ProjectionRotX { get; }
<ObsoleteAttribute("Use ProjectionRotation vector instead.")>
ReadOnly Property ProjectionRotX As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionRotation vector instead.")]
property int ProjectionRotX {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionRotation vector instead.")>]
abstract ProjectionRotX : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionRotY Property

IMyProjectorProjectionRotY Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionRotY"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionRotation vector instead.")]
int ProjectionRotY { get; }
<ObsoleteAttribute("Use ProjectionRotation vector instead.")>
ReadOnly Property ProjectionRotY As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionRotation vector instead.")]
property int ProjectionRotY {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionRotation vector instead.")>]
abstract ProjectionRotY : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.ProjectionRotZ Property

IMyProjectorProjectionRotZ Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyProjector.ProjectionRotZ"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ProjectionRotation vector instead.")]
int ProjectionRotZ { get; }
<ObsoleteAttribute("Use ProjectionRotation vector instead.")>
ReadOnly Property ProjectionRotZ As Integer
    Get
[ObsoleteAttribute(L"Use ProjectionRotation vector instead.")]
property int ProjectionRotZ {
    int get ();
}
[<ObsoleteAttribute("Use ProjectionRotation vector instead.")>]
abstract ProjectionRotZ : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.RemainingArmorBlocks Property

IMyProjectorRemainingArmorBlocks Property

Number of armor blocks left to be welded

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int RemainingArmorBlocks { get; }
ReadOnly Property RemainingArmorBlocks As Integer
    Get
property int RemainingArmorBlocks {
    int get ();
}
abstract RemainingArmorBlocks : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.RemainingBlocks Property

IMyProjectorRemainingBlocks Property

Number of blocks left to be welded

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int RemainingBlocks { get; }
ReadOnly Property RemainingBlocks As Integer
    Get
property int RemainingBlocks {
    int get ();
}
abstract RemainingBlocks : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector.RemainingBlocksPerType Property

IMyProjectorRemainingBlocksPerType Property

A comprehensive list of blocks left to be welded

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<MyDefinitionBase, int> RemainingBlocksPerType { get; }
ReadOnly Property RemainingBlocksPerType As Dictionary(Of MyDefinitionBase, Integer)
    Get
property Dictionary<MyDefinitionBase^, int>^ RemainingBlocksPerType {
    Dictionary<MyDefinitionBase^, int>^ get ();
}
abstract RemainingBlocksPerType : Dictionary<MyDefinitionBase, int> with get

Property Value

Type: Dictionary MyDefinitionBase, Int32
See Also

Reference

IMyProjector Interface


IMyProjector.TotalBlocks Property

IMyProjectorTotalBlocks Property

Total number of blocks in the projection

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int TotalBlocks { get; }
ReadOnly Property TotalBlocks As Integer
    Get
property int TotalBlocks {
    int get ();
}
abstract TotalBlocks : int with get

Property Value

Type: Int32
See Also

Reference

IMyProjector Interface


IMyProjector Methods

The IMyProjector type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | LoadBlueprint |
Public method | LoadRandomBlueprint |
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateOffsetAndRotation | Call this after setting ProjectionOffset and ProjectionRotation to update the projection
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyProjector Interface


IMyProjector.LoadBlueprint Method

IMyProjectorLoadBlueprint Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadBlueprint(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadBlueprint(
    string name
)
Function LoadBlueprint (
    name As String
) As Boolean
bool LoadBlueprint(
    String^ name
)
abstract LoadBlueprint :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadBlueprint(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadBlueprint(System.String)"]

See Also

Reference

IMyProjector Interface


IMyProjector.LoadRandomBlueprint Method

IMyProjectorLoadRandomBlueprint Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadRandomBlueprint(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadRandomBlueprint(
    string searchPattern
)
Function LoadRandomBlueprint (
    searchPattern As String
) As Boolean
bool LoadRandomBlueprint(
    String^ searchPattern
)
abstract LoadRandomBlueprint :
        searchPattern : string -> bool

Parameters

searchPattern
Type: SystemString

[Missing <param name="searchPattern"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadRandomBlueprint(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyProjector.LoadRandomBlueprint(System.String)"]

See Also

Reference

IMyProjector Interface


IMyProjector.UpdateOffsetAndRotation Method

IMyProjectorUpdateOffsetAndRotation Method

Call this after setting ProjectionOffset and ProjectionRotation to update the projection

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateOffsetAndRotation()
Sub UpdateOffsetAndRotation
void UpdateOffsetAndRotation()
abstract UpdateOffsetAndRotation : unit -> unit
See Also

Reference

IMyProjector Interface


IMyRadioAntenna Interface

Antenna block interface

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRadioAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRadioAntenna
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyRadioAntenna : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRadioAntenna =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRadioAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | IgnoreAlliedBroadcast | Ignores broadcasts sent by friendly antenna that do not belong to you
Public property | IgnoreOtherBroadcast | Ignores broadcasts sent by neutral and enemy antenna
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsBroadcasting | Returns true if antena is broadcasting (read-only)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Broadcasting/Receiving range (read-only)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowShipName | Show shipname on hud (read-only)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TransmitMessage | Broadcasts a message to all PB attached to the antenna system. Broadcast is delayed until the start of the next tick, and only one transmission can be sent per tick. Returns false if broadcasting failed for any reason.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyRadioAntenna Properties

The IMyRadioAntenna type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | IgnoreAlliedBroadcast | Ignores broadcasts sent by friendly antenna that do not belong to you
Public property | IgnoreOtherBroadcast | Ignores broadcasts sent by neutral and enemy antenna
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsBroadcasting | Returns true if antena is broadcasting (read-only)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Broadcasting/Receiving range (read-only)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowShipName | Show shipname on hud (read-only)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.IgnoreAlliedBroadcast Property

IMyRadioAntennaIgnoreAlliedBroadcast Property

Ignores broadcasts sent by friendly antenna that do not belong to you

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreAlliedBroadcast { get; set; }
Property IgnoreAlliedBroadcast As Boolean
    Get
    Set
property bool IgnoreAlliedBroadcast {
    bool get ();
    void set (bool value);
}
abstract IgnoreAlliedBroadcast : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.IgnoreOtherBroadcast Property

IMyRadioAntennaIgnoreOtherBroadcast Property

Ignores broadcasts sent by neutral and enemy antenna

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreOtherBroadcast { get; set; }
Property IgnoreOtherBroadcast As Boolean
    Get
    Set
property bool IgnoreOtherBroadcast {
    bool get ();
    void set (bool value);
}
abstract IgnoreOtherBroadcast : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.IsBroadcasting Property

IMyRadioAntennaIsBroadcasting Property

Returns true if antena is broadcasting (read-only)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsBroadcasting { get; }
ReadOnly Property IsBroadcasting As Boolean
    Get
property bool IsBroadcasting {
    bool get ();
}
abstract IsBroadcasting : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.Radius Property

IMyRadioAntennaRadius Property

Broadcasting/Receiving range (read-only)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float Radius { get; }
ReadOnly Property Radius As Single
    Get
property float Radius {
    float get ();
}
abstract Radius : float32 with get

Property Value

Type: Single
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.ShowShipName Property

IMyRadioAntennaShowShipName Property

Show shipname on hud (read-only)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowShipName { get; }
ReadOnly Property ShowShipName As Boolean
    Get
property bool ShowShipName {
    bool get ();
}
abstract ShowShipName : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna Methods

The IMyRadioAntenna type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TransmitMessage | Broadcasts a message to all PB attached to the antenna system. Broadcast is delayed until the start of the next tick, and only one transmission can be sent per tick. Returns false if broadcasting failed for any reason.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRadioAntenna Interface


IMyRadioAntenna.TransmitMessage Method

IMyRadioAntennaTransmitMessage Method

Broadcasts a message to all PB attached to the antenna system. Broadcast is delayed until the start of the next tick, and only one transmission can be sent per tick. Returns false if broadcasting failed for any reason.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TransmitMessage(
    string message,
    MyTransmitTarget target = MyTransmitTarget.Default
)
Function TransmitMessage (
    message As String,
    Optional target As MyTransmitTarget = MyTransmitTarget.Default
) As Boolean
bool TransmitMessage(
    String^ message,
    MyTransmitTarget target = MyTransmitTarget::Default
)
abstract TransmitMessage :
        message : string *
        ?target : MyTransmitTarget
(* Defaults:
        let _target = defaultArg target MyTransmitTarget.Default
*)
-> bool

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRadioAntenna.TransmitMessage(System.String,Sandbox.ModAPI.Ingame.MyTransmitTarget)"]

target (Optional)
Type: Sandbox.ModAPI.IngameMyTransmitTarget

[Missing <param name="target"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRadioAntenna.TransmitMessage(System.String,Sandbox.ModAPI.Ingame.MyTransmitTarget)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyRadioAntenna.TransmitMessage(System.String,Sandbox.ModAPI.Ingame.MyTransmitTarget)"]

See Also

Reference

IMyRadioAntenna Interface


IMyReactor Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyReactor"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyReactor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyReactor
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyReactor : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyReactor =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyReactor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentOutput | Current output of reactor in Megawatts
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxOutput | Maximum output of reactor in Megawatts
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyReactor Properties

The IMyReactor type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentOutput | Current output of reactor in Megawatts
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxOutput | Maximum output of reactor in Megawatts
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyReactor Interface


IMyReactor.CurrentOutput Property

IMyReactorCurrentOutput Property

Current output of reactor in Megawatts

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentOutput { get; }
ReadOnly Property CurrentOutput As Single
    Get
property float CurrentOutput {
    float get ();
}
abstract CurrentOutput : float32 with get

Property Value

Type: Single
See Also

Reference

IMyReactor Interface


IMyReactor.MaxOutput Property

IMyReactorMaxOutput Property

Maximum output of reactor in Megawatts

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxOutput { get; }
ReadOnly Property MaxOutput As Single
    Get
property float MaxOutput {
    float get ();
}
abstract MaxOutput : float32 with get

Property Value

Type: Single
See Also

Reference

IMyReactor Interface


IMyReactor.UseConveyorSystem Property

IMyReactorUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyReactor.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyReactor Interface


IMyReactor Methods

The IMyReactor type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyReactor Interface


IMyRefinery Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyRefinery"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRefinery : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRefinery
    Inherits IMyProductionBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyRefinery : IMyProductionBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRefinery =
    interface
        interface IMyProductionBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRefinery type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory. (Inherited from IMyProductionBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory. (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyRefinery Properties

The IMyRefinery type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InputInventory | Gets the input inventory. (Inherited from IMyProductionBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsProducing | The device is currently producing. (Inherited from IMyProductionBlock.)
Public property | IsQueueEmpty | The production queue is empty. (Inherited from IMyProductionBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NextItemId | Gets the queue item ID of the next item to be produced. (Inherited from IMyProductionBlock.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OutputInventory | Gets the output inventory. (Inherited from IMyProductionBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | Gets or sets whether this device should use the conveyor system to retrieve and store items. (Inherited from IMyProductionBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRefinery Interface


IMyRefinery Methods

The IMyRefinery type exposes the following members.

Methods
 | Name | Description
Public method | AddQueueItem(MyDefinitionId, Decimal) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, Double) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | AddQueueItem(MyDefinitionId, MyFixedPoint) | Adds a blueprint to the production queue (Inherited from IMyProductionBlock.)
Public method | CanUseBlueprint | Can this production block produce this blueprint? (Inherited from IMyProductionBlock.)
Public method | ClearQueue | Clears the Queue (Inherited from IMyProductionBlock.)
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetQueue | Gets the current production queue (Inherited from IMyProductionBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Decimal) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, Double) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | InsertQueueItem(Int32, MyDefinitionId, MyFixedPoint) | Inserts a blueprint into the production queue (Inherited from IMyProductionBlock.)
Public method | MoveQueueItemRequest | Moves an item in the queue to a target position in the queue. (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Decimal) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, Double) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RemoveQueueItem(Int32, MyFixedPoint) | Removes an item from the queue (Inherited from IMyProductionBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRefinery Interface


IMyReflectorLight Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyReflectorLight"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyReflectorLight : IMyLightingBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyReflectorLight
    Inherits IMyLightingBlock, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyReflectorLight : IMyLightingBlock,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyReflectorLight =
    interface
        interface IMyLightingBlock
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyReflectorLight type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyReflectorLight Properties

The IMyReflectorLight type exposes the following members.

Properties
 | Name | Description
Public property | BlinkIntervalSeconds | Gets or sets the blinking interval of this light (in seconds). (Inherited from IMyLightingBlock.)
Public property | BlinkLenght | Obsolete. (Inherited from IMyLightingBlock.)
Public property | BlinkLength | Gets or sets how much of the blinking interval should be spent with the light on, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlinkOffset | Adds an offset to the blinking interval, as a value between 0 and 1. (Inherited from IMyLightingBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Color | Gets or sets the color of the light. (Inherited from IMyLightingBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | Falloff | Gets or sets the current falloff of the light. (Inherited from IMyLightingBlock.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | Intensity | Gets or sets the current intensity of the light. (Inherited from IMyLightingBlock.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | Radius | Gets or sets the basic radius of the light. (Inherited from IMyLightingBlock.)
Public property | ReflectorRadius | Obsolete. (Inherited from IMyLightingBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyReflectorLight Interface


IMyReflectorLight Methods

The IMyReflectorLight type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyReflectorLight Interface


IMyRemoteControl Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyRemoteControl"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyRemoteControl : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyRemoteControl
    Inherits IMyShipController, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyRemoteControl : IMyShipController,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyRemoteControl =
    interface
        interface IMyShipController
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyRemoteControl type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAutoPilotEnabled | Determines whether the autopilot is currently enabled.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddWaypoint | Adds a new waypoint.
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | ClearWaypoints | Removes all existing waypoints.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetNearestPlayer | Gets the nearest player's position. Will only work if the remote control belongs to an NPC
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetWaypointInfo | Gets basic information about the currently configured waypoints.
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetAutoPilotEnabled | Enables or disables the autopilot.
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyRemoteControl Properties

The IMyRemoteControl type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on. (Inherited from IMyShipController.)
Public property | CenterOfMass | Center of mass in grid coordinates (Inherited from IMyShipController.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller. (Inherited from IMyShipController.)
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller. (Inherited from IMyShipController.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled. (Inherited from IMyShipController.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake. (Inherited from IMyShipController.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship. (Inherited from IMyShipController.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAutoPilotEnabled | Determines whether the autopilot is currently enabled.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled. (Inherited from IMyShipController.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity (Inherited from IMyShipController.)
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block. (Inherited from IMyShipController.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.IsAutoPilotEnabled Property

IMyRemoteControlIsAutoPilotEnabled Property

Determines whether the autopilot is currently enabled.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAutoPilotEnabled { get; }
ReadOnly Property IsAutoPilotEnabled As Boolean
    Get
property bool IsAutoPilotEnabled {
    bool get ();
}
abstract IsAutoPilotEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl Methods

The IMyRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | AddWaypoint | Adds a new waypoint.
Public method | CalculateShipMass | Gets information about the current mass of the ship. (Inherited from IMyShipController.)
Public method | ClearWaypoints | Removes all existing waypoints.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location. (Inherited from IMyShipController.)
Public method | GetNearestPlayer | Gets the nearest player's position. Will only work if the remote control belongs to an NPC
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going. (Inherited from IMyShipController.)
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds. (Inherited from IMyShipController.)
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account. (Inherited from IMyShipController.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | GetWaypointInfo | Gets basic information about the currently configured waypoints.
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetAutoPilotEnabled | Enables or disables the autopilot.
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet. (Inherited from IMyShipController.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.AddWaypoint Method

IMyRemoteControlAddWaypoint Method

Adds a new waypoint.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddWaypoint(
    Vector3D coords,
    string name
)
Sub AddWaypoint (
    coords As Vector3D,
    name As String
)
void AddWaypoint(
    Vector3D coords,
    String^ name
)
abstract AddWaypoint :
        coords : Vector3D *
        name : string -> unit

Parameters

coords
Type: Vector3D

[Missing <param name="coords"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.AddWaypoint(VRageMath.Vector3D,System.String)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.AddWaypoint(VRageMath.Vector3D,System.String)"]

See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.ClearWaypoints Method

IMyRemoteControlClearWaypoints Method

Removes all existing waypoints.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearWaypoints()
Sub ClearWaypoints
void ClearWaypoints()
abstract ClearWaypoints : unit -> unit
See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.GetNearestPlayer Method

IMyRemoteControlGetNearestPlayer Method

Gets the nearest player's position. Will only work if the remote control belongs to an NPC

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetNearestPlayer(
    out Vector3D playerPosition
)
Function GetNearestPlayer (
    <OutAttribute> ByRef playerPosition As Vector3D
) As Boolean
bool GetNearestPlayer(
    [OutAttribute] Vector3D% playerPosition
)
abstract GetNearestPlayer :
        playerPosition : Vector3D byref -> bool

Parameters

playerPosition
Type: Vector3D

[Missing <param name="playerPosition"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.GetNearestPlayer(VRageMath.Vector3D@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.GetNearestPlayer(VRageMath.Vector3D@)"]

See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.GetWaypointInfo Method

IMyRemoteControlGetWaypointInfo Method

Gets basic information about the currently configured waypoints.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetWaypointInfo(
    List<MyWaypointInfo> waypoints
)
Sub GetWaypointInfo (
    waypoints As List(Of MyWaypointInfo)
)
void GetWaypointInfo(
    List<MyWaypointInfo>^ waypoints
)
abstract GetWaypointInfo :
        waypoints : List<MyWaypointInfo> -> unit

Parameters

waypoints
Type: System.Collections.GenericList MyWaypointInfo

[Missing <param name="waypoints"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.GetWaypointInfo(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyWaypointInfo})"]

See Also

Reference

IMyRemoteControl Interface


IMyRemoteControl.SetAutoPilotEnabled Method

IMyRemoteControlSetAutoPilotEnabled Method

Enables or disables the autopilot.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetAutoPilotEnabled(
    bool enabled
)
Sub SetAutoPilotEnabled (
    enabled As Boolean
)
void SetAutoPilotEnabled(
    bool enabled
)
abstract SetAutoPilotEnabled :
        enabled : bool -> unit

Parameters

enabled
Type: SystemBoolean

[Missing <param name="enabled"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyRemoteControl.SetAutoPilotEnabled(System.Boolean)"]

See Also

Reference

IMyRemoteControl Interface


IMySensorBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMySensorBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySensorBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySensorBlock
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMySensorBlock : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySensorBlock =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySensorBlock type exposes the following members.

Properties
 | Name | Description
Public property | BackExtend | Gets or sets the back range of the sensor.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BottomExtend | Gets or sets the bottom range of the sensor.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetectAsteroids | Gets or sets if the sensor should detect asteroids or planets.
Public property | DetectEnemy | Gets or sets if the sensor should detect enemy players.
Public property | DetectFloatingObjects | Gets or sets if the sensor should detect floating objects (components, rocks).
Public property | DetectFriendly | Gets or sets if the sensor should detect friendly players.
Public property | DetectLargeShips | Gets or sets if the sensor should detect large ships.
Public property | DetectNeutral | Gets or sets if the sensor should detect neutral players.
Public property | DetectOwner | Gets or sets if the sensor should detect the block owner.
Public property | DetectPlayers | Gets or sets if the sensor should detect players.
Public property | DetectSmallShips | Gets or sets if the sensor should detect small ships.
Public property | DetectStations | Gets or sets if the sensor should detect large stations.
Public property | DetectSubgrids | Gets or sets if the sensor should detect subgrids (eg. connected by connector).
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FrontExtend | Gets or sets the front range of the sensor.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Gets if there is any entity currently being detected.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastDetectedEntity |
Public property | LeftExtend | Gets or sets the left range of the sensor.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxRange | Gets the maximum range of the sensor in any direction.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PlayProximitySound | Gets or sets if the proximity sound plays when an entity is detected.
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RightExtend | Gets or sets the right range of the sensor.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TopExtend | Gets or sets the top range of the sensor.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | DetectedEntities |
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMySensorBlock Properties

The IMySensorBlock type exposes the following members.

Properties
 | Name | Description
Public property | BackExtend | Gets or sets the back range of the sensor.
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | BottomExtend | Gets or sets the bottom range of the sensor.
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetectAsteroids | Gets or sets if the sensor should detect asteroids or planets.
Public property | DetectEnemy | Gets or sets if the sensor should detect enemy players.
Public property | DetectFloatingObjects | Gets or sets if the sensor should detect floating objects (components, rocks).
Public property | DetectFriendly | Gets or sets if the sensor should detect friendly players.
Public property | DetectLargeShips | Gets or sets if the sensor should detect large ships.
Public property | DetectNeutral | Gets or sets if the sensor should detect neutral players.
Public property | DetectOwner | Gets or sets if the sensor should detect the block owner.
Public property | DetectPlayers | Gets or sets if the sensor should detect players.
Public property | DetectSmallShips | Gets or sets if the sensor should detect small ships.
Public property | DetectStations | Gets or sets if the sensor should detect large stations.
Public property | DetectSubgrids | Gets or sets if the sensor should detect subgrids (eg. connected by connector).
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | FrontExtend | Gets or sets the front range of the sensor.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsActive | Gets if there is any entity currently being detected.
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | LastDetectedEntity |
Public property | LeftExtend | Gets or sets the left range of the sensor.
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxRange | Gets the maximum range of the sensor in any direction.
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | PlayProximitySound | Gets or sets if the proximity sound plays when an entity is detected.
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RightExtend | Gets or sets the right range of the sensor.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | TopExtend | Gets or sets the top range of the sensor.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.BackExtend Property

IMySensorBlockBackExtend Property

Gets or sets the back range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BackExtend { get; set; }
Property BackExtend As Single
    Get
    Set
property float BackExtend {
    float get ();
    void set (float value);
}
abstract BackExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.BottomExtend Property

IMySensorBlockBottomExtend Property

Gets or sets the bottom range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float BottomExtend { get; set; }
Property BottomExtend As Single
    Get
    Set
property float BottomExtend {
    float get ();
    void set (float value);
}
abstract BottomExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectAsteroids Property

IMySensorBlockDetectAsteroids Property

Gets or sets if the sensor should detect asteroids or planets.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectAsteroids { get; set; }
Property DetectAsteroids As Boolean
    Get
    Set
property bool DetectAsteroids {
    bool get ();
    void set (bool value);
}
abstract DetectAsteroids : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectEnemy Property

IMySensorBlockDetectEnemy Property

Gets or sets if the sensor should detect enemy players.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectEnemy { get; set; }
Property DetectEnemy As Boolean
    Get
    Set
property bool DetectEnemy {
    bool get ();
    void set (bool value);
}
abstract DetectEnemy : bool with get, set

Property Value

Type: Boolean
Remarks
Requires DetectPlayers set to true.
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectFloatingObjects Property

IMySensorBlockDetectFloatingObjects Property

Gets or sets if the sensor should detect floating objects (components, rocks).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectFloatingObjects { get; set; }
Property DetectFloatingObjects As Boolean
    Get
    Set
property bool DetectFloatingObjects {
    bool get ();
    void set (bool value);
}
abstract DetectFloatingObjects : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectFriendly Property

IMySensorBlockDetectFriendly Property

Gets or sets if the sensor should detect friendly players.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectFriendly { get; set; }
Property DetectFriendly As Boolean
    Get
    Set
property bool DetectFriendly {
    bool get ();
    void set (bool value);
}
abstract DetectFriendly : bool with get, set

Property Value

Type: Boolean
Remarks
Requires DetectPlayers set to true.
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectLargeShips Property

IMySensorBlockDetectLargeShips Property

Gets or sets if the sensor should detect large ships.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectLargeShips { get; set; }
Property DetectLargeShips As Boolean
    Get
    Set
property bool DetectLargeShips {
    bool get ();
    void set (bool value);
}
abstract DetectLargeShips : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectNeutral Property

IMySensorBlockDetectNeutral Property

Gets or sets if the sensor should detect neutral players.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectNeutral { get; set; }
Property DetectNeutral As Boolean
    Get
    Set
property bool DetectNeutral {
    bool get ();
    void set (bool value);
}
abstract DetectNeutral : bool with get, set

Property Value

Type: Boolean
Remarks
Requires DetectPlayers set to true.
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectOwner Property

IMySensorBlockDetectOwner Property

Gets or sets if the sensor should detect the block owner.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectOwner { get; set; }
Property DetectOwner As Boolean
    Get
    Set
property bool DetectOwner {
    bool get ();
    void set (bool value);
}
abstract DetectOwner : bool with get, set

Property Value

Type: Boolean
Remarks
Requires DetectPlayers set to true.
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectPlayers Property

IMySensorBlockDetectPlayers Property

Gets or sets if the sensor should detect players.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectPlayers { get; set; }
Property DetectPlayers As Boolean
    Get
    Set
property bool DetectPlayers {
    bool get ();
    void set (bool value);
}
abstract DetectPlayers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectSmallShips Property

IMySensorBlockDetectSmallShips Property

Gets or sets if the sensor should detect small ships.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectSmallShips { get; set; }
Property DetectSmallShips As Boolean
    Get
    Set
property bool DetectSmallShips {
    bool get ();
    void set (bool value);
}
abstract DetectSmallShips : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectStations Property

IMySensorBlockDetectStations Property

Gets or sets if the sensor should detect large stations.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectStations { get; set; }
Property DetectStations As Boolean
    Get
    Set
property bool DetectStations {
    bool get ();
    void set (bool value);
}
abstract DetectStations : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectSubgrids Property

IMySensorBlockDetectSubgrids Property

Gets or sets if the sensor should detect subgrids (eg. connected by connector).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DetectSubgrids { get; set; }
Property DetectSubgrids As Boolean
    Get
    Set
property bool DetectSubgrids {
    bool get ();
    void set (bool value);
}
abstract DetectSubgrids : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.FrontExtend Property

IMySensorBlockFrontExtend Property

Gets or sets the front range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float FrontExtend { get; set; }
Property FrontExtend As Single
    Get
    Set
property float FrontExtend {
    float get ();
    void set (float value);
}
abstract FrontExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.IsActive Property

IMySensorBlockIsActive Property

Gets if there is any entity currently being detected.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsActive { get; }
ReadOnly Property IsActive As Boolean
    Get
property bool IsActive {
    bool get ();
}
abstract IsActive : bool with get

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.LastDetectedEntity Property

IMySensorBlockLastDetectedEntity Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMySensorBlock.LastDetectedEntity"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyDetectedEntityInfo LastDetectedEntity { get; }
ReadOnly Property LastDetectedEntity As MyDetectedEntityInfo
    Get
property MyDetectedEntityInfo LastDetectedEntity {
    MyDetectedEntityInfo get ();
}
abstract LastDetectedEntity : MyDetectedEntityInfo with get

Property Value

Type: MyDetectedEntityInfo
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.LeftExtend Property

IMySensorBlockLeftExtend Property

Gets or sets the left range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float LeftExtend { get; set; }
Property LeftExtend As Single
    Get
    Set
property float LeftExtend {
    float get ();
    void set (float value);
}
abstract LeftExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.MaxRange Property

IMySensorBlockMaxRange Property

Gets the maximum range of the sensor in any direction.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxRange { get; }
ReadOnly Property MaxRange As Single
    Get
property float MaxRange {
    float get ();
}
abstract MaxRange : float32 with get

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.PlayProximitySound Property

IMySensorBlockPlayProximitySound Property

Gets or sets if the proximity sound plays when an entity is detected.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PlayProximitySound { get; set; }
Property PlayProximitySound As Boolean
    Get
    Set
property bool PlayProximitySound {
    bool get ();
    void set (bool value);
}
abstract PlayProximitySound : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.RightExtend Property

IMySensorBlockRightExtend Property

Gets or sets the right range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float RightExtend { get; set; }
Property RightExtend As Single
    Get
    Set
property float RightExtend {
    float get ();
    void set (float value);
}
abstract RightExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.TopExtend Property

IMySensorBlockTopExtend Property

Gets or sets the top range of the sensor.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float TopExtend { get; set; }
Property TopExtend As Single
    Get
    Set
property float TopExtend {
    float get ();
    void set (float value);
}
abstract TopExtend : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMySensorBlock Interface


IMySensorBlock Methods

The IMySensorBlock type exposes the following members.

Methods
 | Name | Description
Public method | DetectedEntities |
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySensorBlock Interface


IMySensorBlock.DetectedEntities Method

IMySensorBlockDetectedEntities Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMySensorBlock.DetectedEntities(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyDetectedEntityInfo})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DetectedEntities(
    List<MyDetectedEntityInfo> entities
)
Sub DetectedEntities (
    entities As List(Of MyDetectedEntityInfo)
)
void DetectedEntities(
    List<MyDetectedEntityInfo>^ entities
)
abstract DetectedEntities :
        entities : List<MyDetectedEntityInfo> -> unit

Parameters

entities
Type: System.Collections.GenericList MyDetectedEntityInfo

[Missing <param name="entities"/> documentation for "M:Sandbox.ModAPI.Ingame.IMySensorBlock.DetectedEntities(System.Collections.Generic.List{Sandbox.ModAPI.Ingame.MyDetectedEntityInfo})"]

See Also

Reference

IMySensorBlock Interface


IMyShipConnector Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyShipConnector"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipConnector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipConnector
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipConnector : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipConnector =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipConnector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | CollectAll | Gets or sets whether this connector should be pulling items into its inventory.
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsConnected | Obsolete.
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OtherConnector | Gets the connector this one is connected to when Status is [!:ConnectorStatus.Connected].
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PullStrength | Gets or sets the currently configured strength of the pull when the connector is within range of another.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current status of the connector.
Public property | ThrowOut | Gets or sets whether this connector should throw out anything placed in its inventory.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | Connect | Attempts to connect. If Status is anything else but [!:ConnectorStatus.Connectable], this method does nothing.
Public method | Disconnect | Disconnects this connector.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleConnect | Toggles between [!:ConnectorStatus.Connected] and [!:ConnectorStatus.Unconnected], depending on the current status. Another connector must be in range for this method to have any effect.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipConnector Properties

The IMyShipConnector type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | CollectAll | Gets or sets whether this connector should be pulling items into its inventory.
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsConnected | Obsolete.
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsLocked | Obsolete.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OtherConnector | Gets the connector this one is connected to when Status is [!:ConnectorStatus.Connected].
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | PullStrength | Gets or sets the currently configured strength of the pull when the connector is within range of another.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | Status | Determines the current status of the connector.
Public property | ThrowOut | Gets or sets whether this connector should throw out anything placed in its inventory.
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.CollectAll Property

IMyShipConnectorCollectAll Property

Gets or sets whether this connector should be pulling items into its inventory.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CollectAll { get; set; }
Property CollectAll As Boolean
    Get
    Set
property bool CollectAll {
    bool get ();
    void set (bool value);
}
abstract CollectAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.IsConnected Property

IMyShipConnectorIsConnected Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyShipConnector.IsConnected"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the Status property")]
bool IsConnected { get; }
<ObsoleteAttribute("Use the Status property")>
ReadOnly Property IsConnected As Boolean
    Get
[ObsoleteAttribute(L"Use the Status property")]
property bool IsConnected {
    bool get ();
}
[<ObsoleteAttribute("Use the Status property")>]
abstract IsConnected : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.IsLocked Property

IMyShipConnectorIsLocked Property

Note: This API is now obsolete.

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyShipConnector.IsLocked"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the Status property")]
bool IsLocked { get; }
<ObsoleteAttribute("Use the Status property")>
ReadOnly Property IsLocked As Boolean
    Get
[ObsoleteAttribute(L"Use the Status property")]
property bool IsLocked {
    bool get ();
}
[<ObsoleteAttribute("Use the Status property")>]
abstract IsLocked : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.OtherConnector Property

IMyShipConnectorOtherConnector Property

Gets the connector this one is connected to when Status is [!:ConnectorStatus.Connected].

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMyShipConnector OtherConnector { get; }
ReadOnly Property OtherConnector As IMyShipConnector
    Get
property IMyShipConnector^ OtherConnector {
    IMyShipConnector^ get ();
}
abstract OtherConnector : IMyShipConnector with get

Property Value

Type: IMyShipConnector
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.PullStrength Property

IMyShipConnectorPullStrength Property

Gets or sets the currently configured strength of the pull when the connector is within range of another.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float PullStrength { get; set; }
Property PullStrength As Single
    Get
    Set
property float PullStrength {
    float get ();
    void set (float value);
}
abstract PullStrength : float32 with get, set

Property Value

Type: Single
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.Status Property

IMyShipConnectorStatus Property

Determines the current status of the connector.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyShipConnectorStatus Status { get; }
ReadOnly Property Status As MyShipConnectorStatus
    Get
property MyShipConnectorStatus Status {
    MyShipConnectorStatus get ();
}
abstract Status : MyShipConnectorStatus with get

Property Value

Type: MyShipConnectorStatus
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.ThrowOut Property

IMyShipConnectorThrowOut Property

Gets or sets whether this connector should throw out anything placed in its inventory.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ThrowOut { get; set; }
Property ThrowOut As Boolean
    Get
    Set
property bool ThrowOut {
    bool get ();
    void set (bool value);
}
abstract ThrowOut : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipConnector Interface


IMyShipConnector Methods

The IMyShipConnector type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Attempts to connect. If Status is anything else but [!:ConnectorStatus.Connectable], this method does nothing.
Public method | Disconnect | Disconnects this connector.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | ToggleConnect | Toggles between [!:ConnectorStatus.Connected] and [!:ConnectorStatus.Unconnected], depending on the current status. Another connector must be in range for this method to have any effect.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.Connect Method

IMyShipConnectorConnect Method

Attempts to connect. If Status is anything else but [!:ConnectorStatus.Connectable], this method does nothing.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.Disconnect Method

IMyShipConnectorDisconnect Method

Disconnects this connector.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

IMyShipConnector Interface


IMyShipConnector.ToggleConnect Method

IMyShipConnectorToggleConnect Method

Toggles between [!:ConnectorStatus.Connected] and [!:ConnectorStatus.Unconnected], depending on the current status. Another connector must be in range for this method to have any effect.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleConnect()
Sub ToggleConnect
void ToggleConnect()
abstract ToggleConnect : unit -> unit
See Also

Reference

IMyShipConnector Interface


IMyShipController Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyShipController"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipController : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyShipController
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipController : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyShipController =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipController type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on.
Public property | CenterOfMass | Center of mass in grid coordinates
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller.
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller.
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled.
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location.
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location.
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going.
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds.
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account.
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet.
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipController Properties

The IMyShipController type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CanControlShip | Determines whether this specific ship controller is capable of controlling the ship it's installed on.
Public property | CenterOfMass | Center of mass in grid coordinates
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | ControlThrusters | Gets or sets whether thrusters are being controlled by this controller.
Public property | ControlWheels | Gets or sets whether wheels are being controlled by this controller.
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DampenersOverride | Gets or sets whether dampeners are currently enabled.
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HandBrake | Gets or sets the current state of the handbrake.
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HasWheels | Determines whether there are any wheels on this ship.
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsUnderControl | Indicates whether a block is locally or remotely controlled.
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | MoveIndicator | Directional input from user/autopilot. Values can be very large with high controller sensitivity
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | RollIndicator | Roll input from user/autopilot. Values can be very large with high controller sensitivity
Public property | RotationIndicator | Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity
Public property | ShowHorizonIndicator | Gets or sets whether the horizon indicator should be displayed for this block.
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipController Interface


IMyShipController.CanControlShip Property

IMyShipControllerCanControlShip Property

Determines whether this specific ship controller is capable of controlling the ship it's installed on.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanControlShip { get; }
ReadOnly Property CanControlShip As Boolean
    Get
property bool CanControlShip {
    bool get ();
}
abstract CanControlShip : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.CenterOfMass Property

IMyShipControllerCenterOfMass Property

Center of mass in grid coordinates

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3I CenterOfMass { get; }
ReadOnly Property CenterOfMass As Vector3I
    Get
property Vector3I CenterOfMass {
    Vector3I get ();
}
abstract CenterOfMass : Vector3I with get

Property Value

Type: Vector3I
See Also

Reference

IMyShipController Interface


IMyShipController.ControlThrusters Property

IMyShipControllerControlThrusters Property

Gets or sets whether thrusters are being controlled by this controller.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ControlThrusters { get; set; }
Property ControlThrusters As Boolean
    Get
    Set
property bool ControlThrusters {
    bool get ();
    void set (bool value);
}
abstract ControlThrusters : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.ControlWheels Property

IMyShipControllerControlWheels Property

Gets or sets whether wheels are being controlled by this controller.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ControlWheels { get; set; }
Property ControlWheels As Boolean
    Get
    Set
property bool ControlWheels {
    bool get ();
    void set (bool value);
}
abstract ControlWheels : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.DampenersOverride Property

IMyShipControllerDampenersOverride Property

Gets or sets whether dampeners are currently enabled.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DampenersOverride { get; set; }
Property DampenersOverride As Boolean
    Get
    Set
property bool DampenersOverride {
    bool get ();
    void set (bool value);
}
abstract DampenersOverride : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.HandBrake Property

IMyShipControllerHandBrake Property

Gets or sets the current state of the handbrake.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HandBrake { get; set; }
Property HandBrake As Boolean
    Get
    Set
property bool HandBrake {
    bool get ();
    void set (bool value);
}
abstract HandBrake : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.HasWheels Property

IMyShipControllerHasWheels Property

Determines whether there are any wheels on this ship.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasWheels { get; }
ReadOnly Property HasWheels As Boolean
    Get
property bool HasWheels {
    bool get ();
}
abstract HasWheels : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.IsUnderControl Property

IMyShipControllerIsUnderControl Property

Indicates whether a block is locally or remotely controlled.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUnderControl { get; }
ReadOnly Property IsUnderControl As Boolean
    Get
property bool IsUnderControl {
    bool get ();
}
abstract IsUnderControl : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController.MoveIndicator Property

IMyShipControllerMoveIndicator Property

Directional input from user/autopilot. Values can be very large with high controller sensitivity

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3 MoveIndicator { get; }
ReadOnly Property MoveIndicator As Vector3
    Get
property Vector3 MoveIndicator {
    Vector3 get ();
}
abstract MoveIndicator : Vector3 with get

Property Value

Type: Vector3
See Also

Reference

IMyShipController Interface


IMyShipController.RollIndicator Property

IMyShipControllerRollIndicator Property

Roll input from user/autopilot. Values can be very large with high controller sensitivity

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float RollIndicator { get; }
ReadOnly Property RollIndicator As Single
    Get
property float RollIndicator {
    float get ();
}
abstract RollIndicator : float32 with get

Property Value

Type: Single
See Also

Reference

IMyShipController Interface


IMyShipController.RotationIndicator Property

IMyShipControllerRotationIndicator Property

Pitch, yaw input from user/autopilot. Values can be very large with high controller sensitivity

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector2 RotationIndicator { get; }
ReadOnly Property RotationIndicator As Vector2
    Get
property Vector2 RotationIndicator {
    Vector2 get ();
}
abstract RotationIndicator : Vector2 with get

Property Value

Type: Vector2
See Also

Reference

IMyShipController Interface


IMyShipController.ShowHorizonIndicator Property

IMyShipControllerShowHorizonIndicator Property

Gets or sets whether the horizon indicator should be displayed for this block.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowHorizonIndicator { get; set; }
Property ShowHorizonIndicator As Boolean
    Get
    Set
property bool ShowHorizonIndicator {
    bool get ();
    void set (bool value);
}
abstract ShowHorizonIndicator : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyShipController Interface


IMyShipController Methods

The IMyShipController type exposes the following members.

Methods
 | Name | Description
Public method | CalculateShipMass | Gets information about the current mass of the ship.
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetArtificialGravity | Gets the detected artificial gravity vector and power at the current location.
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetNaturalGravity | Gets the detected natural gravity vector and power at the current location.
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetShipSpeed | Gets the basic ship speed in meters per second, for when you just need to know how fast you're going.
Public method | GetShipVelocities | Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds.
Public method | GetTotalGravity | Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account.
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | TryGetPlanetElevation | Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet.
Public method | TryGetPlanetPosition | Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipController Interface


IMyShipController.CalculateShipMass Method

IMyShipControllerCalculateShipMass Method

Gets information about the current mass of the ship.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyShipMass CalculateShipMass()
Function CalculateShipMass As MyShipMass
MyShipMass CalculateShipMass()
abstract CalculateShipMass : unit -> MyShipMass

Return Value

Type: MyShipMass

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.CalculateShipMass"]

See Also

Reference

IMyShipController Interface


IMyShipController.GetArtificialGravity Method

IMyShipControllerGetArtificialGravity Method

Gets the detected artificial gravity vector and power at the current location.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3D GetArtificialGravity()
Function GetArtificialGravity As Vector3D
Vector3D GetArtificialGravity()
abstract GetArtificialGravity : unit -> Vector3D

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.GetArtificialGravity"]

See Also

Reference

IMyShipController Interface


IMyShipController.GetNaturalGravity Method

IMyShipControllerGetNaturalGravity Method

Gets the detected natural gravity vector and power at the current location.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3D GetNaturalGravity()
Function GetNaturalGravity As Vector3D
Vector3D GetNaturalGravity()
abstract GetNaturalGravity : unit -> Vector3D

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.GetNaturalGravity"]

See Also

Reference

IMyShipController Interface


IMyShipController.GetShipSpeed Method

IMyShipControllerGetShipSpeed Method

Gets the basic ship speed in meters per second, for when you just need to know how fast you're going.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double GetShipSpeed()
Function GetShipSpeed As Double
double GetShipSpeed()
abstract GetShipSpeed : unit -> float

Return Value

Type: Double

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.GetShipSpeed"]

See Also

Reference

IMyShipController Interface


IMyShipController.GetShipVelocities Method

IMyShipControllerGetShipVelocities Method

Determines the linear velocities in meters per second and angular velocities in radians per second. Provides a more accurate representation of the directions and axis speeds.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyShipVelocities GetShipVelocities()
Function GetShipVelocities As MyShipVelocities
MyShipVelocities GetShipVelocities()
abstract GetShipVelocities : unit -> MyShipVelocities

Return Value

Type: MyShipVelocities

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.GetShipVelocities"]

See Also

Reference

IMyShipController Interface


IMyShipController.GetTotalGravity Method

IMyShipControllerGetTotalGravity Method

Gets the total accumulated gravity vector and power at the current location, taking both natural and artificial gravity into account.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3D GetTotalGravity()
Function GetTotalGravity As Vector3D
Vector3D GetTotalGravity()
abstract GetTotalGravity : unit -> Vector3D

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.GetTotalGravity"]

See Also

Reference

IMyShipController Interface


IMyShipController.TryGetPlanetElevation Method

IMyShipControllerTryGetPlanetElevation Method

Attempts to get the elevation of the ship in relation to the nearest planet. This method is only available when a ship is within the gravity well of a planet.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TryGetPlanetElevation(
    MyPlanetElevation detail,
    out double elevation
)
Function TryGetPlanetElevation (
    detail As MyPlanetElevation,
    <OutAttribute> ByRef elevation As Double
) As Boolean
bool TryGetPlanetElevation(
    MyPlanetElevation detail,
    [OutAttribute] double% elevation
)
abstract TryGetPlanetElevation :
        detail : MyPlanetElevation *
        elevation : float byref -> bool

Parameters

detail
Type: Sandbox.ModAPI.IngameMyPlanetElevation

[Missing <param name="detail"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.TryGetPlanetElevation(Sandbox.ModAPI.Ingame.MyPlanetElevation,System.Double@)"]

elevation
Type: SystemDouble

[Missing <param name="elevation"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.TryGetPlanetElevation(Sandbox.ModAPI.Ingame.MyPlanetElevation,System.Double@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.TryGetPlanetElevation(Sandbox.ModAPI.Ingame.MyPlanetElevation,System.Double@)"]

See Also

Reference

IMyShipController Interface


IMyShipController.TryGetPlanetPosition Method

IMyShipControllerTryGetPlanetPosition Method

Attempts to get the world position of the nearest planet. This method is only available when a ship is within the gravity well of a planet.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TryGetPlanetPosition(
    out Vector3D position
)
Function TryGetPlanetPosition (
    <OutAttribute> ByRef position As Vector3D
) As Boolean
bool TryGetPlanetPosition(
    [OutAttribute] Vector3D% position
)
abstract TryGetPlanetPosition :
        position : Vector3D byref -> bool

Parameters

position
Type: Vector3D

[Missing <param name="position"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.TryGetPlanetPosition(VRageMath.Vector3D@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyShipController.TryGetPlanetPosition(VRageMath.Vector3D@)"]

See Also

Reference

IMyShipController Interface


IMyShipDrill Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyShipDrill"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipDrill : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipDrill
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipDrill : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipDrill =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipDrill type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipDrill Properties

The IMyShipDrill type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipDrill Interface


IMyShipDrill.UseConveyorSystem Property

IMyShipDrillUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyShipDrill.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipDrill Interface


IMyShipDrill Methods

The IMyShipDrill type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipDrill Interface


IMyShipGrinder Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyShipGrinder"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipGrinder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipGrinder
    Inherits IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyShipGrinder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipGrinder =
    interface
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipGrinder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipGrinder Properties

The IMyShipGrinder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipGrinder Interface


IMyShipGrinder Methods

The IMyShipGrinder type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipGrinder Interface


IMyShipToolBase Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyShipToolBase"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipToolBase : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipToolBase
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyShipToolBase : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipToolBase =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipToolBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipToolBase Properties

The IMyShipToolBase type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipToolBase Interface


IMyShipToolBase.UseConveyorSystem Property

IMyShipToolBaseUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyShipToolBase.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipToolBase Interface


IMyShipToolBase Methods

The IMyShipToolBase type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipToolBase Interface


IMyShipWelder Interface

Ship welder interface

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyShipWelder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyShipWelder
    Inherits IMyShipToolBase, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMyShipWelder : IMyShipToolBase,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyShipWelder =
    interface
        interface IMyShipToolBase
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyShipWelder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HelpOthers | True if welder is set to helper mode
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyShipWelder Properties

The IMyShipWelder type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | HelpOthers | True if welder is set to helper mode
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMyShipToolBase.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyShipWelder Interface


IMyShipWelder.HelpOthers Property

IMyShipWelderHelpOthers Property

True if welder is set to helper mode

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HelpOthers { get; }
ReadOnly Property HelpOthers As Boolean
    Get
property bool HelpOthers {
    bool get ();
}
abstract HelpOthers : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyShipWelder Interface


IMyShipWelder Methods

The IMyShipWelder type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyShipWelder Interface


IMySmallGatlingGun Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMySmallGatlingGun"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallGatlingGun : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySmallGatlingGun
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMySmallGatlingGun : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySmallGatlingGun =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallGatlingGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMySmallGatlingGun Properties

The IMySmallGatlingGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallGatlingGun Interface


IMySmallGatlingGun.UseConveyorSystem Property

IMySmallGatlingGunUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMySmallGatlingGun.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMySmallGatlingGun Interface


IMySmallGatlingGun Methods

The IMySmallGatlingGun type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallGatlingGun Interface


IMySmallMissileLauncher Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMySmallMissileLauncher"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallMissileLauncher : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySmallMissileLauncher
    Inherits IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock,
    IMyEntity
public interface class IMySmallMissileLauncher : IMyUserControllableGun,
    IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySmallMissileLauncher =
    interface
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallMissileLauncher type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMySmallMissileLauncher Properties

The IMySmallMissileLauncher type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallMissileLauncher Interface


IMySmallMissileLauncher.UseConveyorSystem Property

IMySmallMissileLauncherUseConveyorSystem Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMySmallMissileLauncher.UseConveyorSystem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseConveyorSystem { get; }
ReadOnly Property UseConveyorSystem As Boolean
    Get
property bool UseConveyorSystem {
    bool get ();
}
abstract UseConveyorSystem : bool with get

Property Value

Type: Boolean
See Also

Reference

IMySmallMissileLauncher Interface


IMySmallMissileLauncher Methods

The IMySmallMissileLauncher type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallMissileLauncher Interface


IMySmallMissileLauncherReload Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMySmallMissileLauncherReload"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMySmallMissileLauncherReload : IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMySmallMissileLauncherReload
    Inherits IMySmallMissileLauncher, IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
public interface class IMySmallMissileLauncherReload : IMySmallMissileLauncher,
    IMyUserControllableGun, IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMySmallMissileLauncherReload =
    interface
        interface IMySmallMissileLauncher
        interface IMyUserControllableGun
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMySmallMissileLauncherReload type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMySmallMissileLauncherReload Properties

The IMySmallMissileLauncherReload type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting | (Inherited from IMyUserControllableGun.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | UseConveyorSystem | (Inherited from IMySmallMissileLauncher.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMySmallMissileLauncherReload Interface


IMySmallMissileLauncherReload Methods

The IMySmallMissileLauncherReload type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMySmallMissileLauncherReload Interface


IMyTerminalBlock Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyTerminalBlock"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalBlock : IMyCubeBlock,
    IMyEntity
Public Interface IMyTerminalBlock
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyTerminalBlock : IMyCubeBlock,
    IMyEntity
type IMyTerminalBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyTerminalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent
Public property | CustomInfo |
Public property | CustomName |
Public property | CustomNameWithFaction |
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo |
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal |
Public property | ShowInToolbarConfig |
Public property | ShowOnHUD |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions |
Public method | GetActionWithName |
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties |
Public method | GetProperty |
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess |
Public method | HasPlayerAccess |
Public method | SearchActionsOfName |
Public method | SetCustomName(String) | Obsolete.
Public method | SetCustomName(StringBuilder) | Obsolete.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyTerminalBlock Properties

The IMyTerminalBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent
Public property | CustomInfo |
Public property | CustomName |
Public property | CustomNameWithFaction |
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo |
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal |
Public property | ShowInToolbarConfig |
Public property | ShowOnHUD |
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.CustomData Property

IMyTerminalBlockCustomData Property

Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CustomData { get; set; }
Property CustomData As String
    Get
    Set
property String^ CustomData {
    String^ get ();
    void set (String^ value);
}
abstract CustomData : string with get, set

Property Value

Type: String
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.CustomInfo Property

IMyTerminalBlockCustomInfo Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.CustomInfo"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CustomInfo { get; }
ReadOnly Property CustomInfo As String
    Get
property String^ CustomInfo {
    String^ get ();
}
abstract CustomInfo : string with get

Property Value

Type: String
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.CustomName Property

IMyTerminalBlockCustomName Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.CustomName"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CustomName { get; set; }
Property CustomName As String
    Get
    Set
property String^ CustomName {
    String^ get ();
    void set (String^ value);
}
abstract CustomName : string with get, set

Property Value

Type: String
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.CustomNameWithFaction Property

IMyTerminalBlockCustomNameWithFaction Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.CustomNameWithFaction"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CustomNameWithFaction { get; }
ReadOnly Property CustomNameWithFaction As String
    Get
property String^ CustomNameWithFaction {
    String^ get ();
}
abstract CustomNameWithFaction : string with get

Property Value

Type: String
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.DetailedInfo Property

IMyTerminalBlockDetailedInfo Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.DetailedInfo"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DetailedInfo { get; }
ReadOnly Property DetailedInfo As String
    Get
property String^ DetailedInfo {
    String^ get ();
}
abstract DetailedInfo : string with get

Property Value

Type: String
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.ShowInTerminal Property

IMyTerminalBlockShowInTerminal Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.ShowInTerminal"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowInTerminal { get; set; }
Property ShowInTerminal As Boolean
    Get
    Set
property bool ShowInTerminal {
    bool get ();
    void set (bool value);
}
abstract ShowInTerminal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.ShowInToolbarConfig Property

IMyTerminalBlockShowInToolbarConfig Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.ShowInToolbarConfig"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowInToolbarConfig { get; set; }
Property ShowInToolbarConfig As Boolean
    Get
    Set
property bool ShowInToolbarConfig {
    bool get ();
    void set (bool value);
}
abstract ShowInToolbarConfig : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.ShowOnHUD Property

IMyTerminalBlockShowOnHUD Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyTerminalBlock.ShowOnHUD"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowOnHUD { get; set; }
Property ShowOnHUD As Boolean
    Get
    Set
property bool ShowOnHUD {
    bool get ();
    void set (bool value);
}
abstract ShowOnHUD : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock Methods

The IMyTerminalBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetActions |
Public method | GetActionWithName |
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties |
Public method | GetProperty |
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess |
Public method | HasPlayerAccess |
Public method | SearchActionsOfName |
Public method | SetCustomName(String) | Obsolete.
Public method | SetCustomName(StringBuilder) | Obsolete.
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.GetActions Method

IMyTerminalBlockGetActions Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActions(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetActions(
    List<ITerminalAction> resultList,
    Func<ITerminalAction, bool> collect = null
)
Sub GetActions (
    resultList As List(Of ITerminalAction),
    Optional collect As Func(Of ITerminalAction, Boolean) = Nothing
)
void GetActions(
    List<ITerminalAction^>^ resultList,
    Func<ITerminalAction^, bool>^ collect = nullptr
)
abstract GetActions :
        resultList : List<ITerminalAction> *
        ?collect : Func<ITerminalAction, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

resultList
Type: System.Collections.GenericList ITerminalAction

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActions(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalAction, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActions(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.GetActionWithName Method

IMyTerminalBlockGetActionWithName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActionWithName(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ITerminalAction GetActionWithName(
    string name
)
Function GetActionWithName (
    name As String
) As ITerminalAction
ITerminalAction^ GetActionWithName(
    String^ name
)
abstract GetActionWithName :
        name : string -> ITerminalAction

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActionWithName(System.String)"]

Return Value

Type: ITerminalAction

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetActionWithName(System.String)"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.GetProperties Method

IMyTerminalBlockGetProperties Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperties(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetProperties(
    List<ITerminalProperty> resultList,
    Func<ITerminalProperty, bool> collect = null
)
Sub GetProperties (
    resultList As List(Of ITerminalProperty),
    Optional collect As Func(Of ITerminalProperty, Boolean) = Nothing
)
void GetProperties(
    List<ITerminalProperty^>^ resultList,
    Func<ITerminalProperty^, bool>^ collect = nullptr
)
abstract GetProperties :
        resultList : List<ITerminalProperty> *
        ?collect : Func<ITerminalProperty, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

resultList
Type: System.Collections.GenericList ITerminalProperty

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperties(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalProperty, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperties(System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalProperty},System.Func{Sandbox.ModAPI.Interfaces.ITerminalProperty,System.Boolean})"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.GetProperty Method

IMyTerminalBlockGetProperty Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperty(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ITerminalProperty GetProperty(
    string id
)
Function GetProperty (
    id As String
) As ITerminalProperty
ITerminalProperty^ GetProperty(
    String^ id
)
abstract GetProperty :
        id : string -> ITerminalProperty

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperty(System.String)"]

Return Value

Type: ITerminalProperty

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.GetProperty(System.String)"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.HasLocalPlayerAccess Method

IMyTerminalBlockHasLocalPlayerAccess Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.HasLocalPlayerAccess"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasLocalPlayerAccess()
Function HasLocalPlayerAccess As Boolean
bool HasLocalPlayerAccess()
abstract HasLocalPlayerAccess : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.HasLocalPlayerAccess"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.HasPlayerAccess Method

IMyTerminalBlockHasPlayerAccess Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.HasPlayerAccess(System.Int64)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasPlayerAccess(
    long playerId
)
Function HasPlayerAccess (
    playerId As Long
) As Boolean
bool HasPlayerAccess(
    long long playerId
)
abstract HasPlayerAccess :
        playerId : int64 -> bool

Parameters

playerId
Type: SystemInt64

[Missing <param name="playerId"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.HasPlayerAccess(System.Int64)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.HasPlayerAccess(System.Int64)"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.SearchActionsOfName Method

IMyTerminalBlockSearchActionsOfName Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SearchActionsOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SearchActionsOfName(
    string name,
    List<ITerminalAction> resultList,
    Func<ITerminalAction, bool> collect = null
)
Sub SearchActionsOfName (
    name As String,
    resultList As List(Of ITerminalAction),
    Optional collect As Func(Of ITerminalAction, Boolean) = Nothing
)
void SearchActionsOfName(
    String^ name,
    List<ITerminalAction^>^ resultList,
    Func<ITerminalAction^, bool>^ collect = nullptr
)
abstract SearchActionsOfName :
        name : string *
        resultList : List<ITerminalAction> *
        ?collect : Func<ITerminalAction, bool>
(* Defaults:
        let _collect = defaultArg collect null
*)
-> unit

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SearchActionsOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

resultList
Type: System.Collections.GenericList ITerminalAction

[Missing <param name="resultList"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SearchActionsOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

collect (Optional)
Type: SystemFunc ITerminalAction, Boolean

[Missing <param name="collect"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SearchActionsOfName(System.String,System.Collections.Generic.List{Sandbox.ModAPI.Interfaces.ITerminalAction},System.Func{Sandbox.ModAPI.Interfaces.ITerminalAction,System.Boolean})"]

See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.SetCustomName Method

IMyTerminalBlockSetCustomName Method

Overload List
 | Name | Description
Public method | SetCustomName(String) | Obsolete.
Public method | SetCustomName(StringBuilder) | Obsolete.
Top
See Also

Reference

IMyTerminalBlock Interface


IMyTerminalBlock.SetCustomName Method (String)

IMyTerminalBlockSetCustomName Method (String)

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SetCustomName(System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the setter of Customname")]
void SetCustomName(
    string text
)
<ObsoleteAttribute("Use the setter of Customname")>
Sub SetCustomName (
    text As String
)
[ObsoleteAttribute(L"Use the setter of Customname")]
void SetCustomName(
    String^ text
)
[<ObsoleteAttribute("Use the setter of Customname")>]
abstract SetCustomName :
        text : string -> unit

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SetCustomName(System.String)"]

See Also

Reference

IMyTerminalBlock Interface
SetCustomName Overload


IMyTerminalBlock.SetCustomName Method (StringBuilder)

IMyTerminalBlockSetCustomName Method (StringBuilder)

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SetCustomName(System.Text.StringBuilder)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the setter of Customname")]
void SetCustomName(
    StringBuilder text
)
<ObsoleteAttribute("Use the setter of Customname")>
Sub SetCustomName (
    text As StringBuilder
)
[ObsoleteAttribute(L"Use the setter of Customname")]
void SetCustomName(
    StringBuilder^ text
)
[<ObsoleteAttribute("Use the setter of Customname")>]
abstract SetCustomName :
        text : StringBuilder -> unit

Parameters

text
Type: System.TextStringBuilder

[Missing <param name="text"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTerminalBlock.SetCustomName(System.Text.StringBuilder)"]

See Also

Reference

IMyTerminalBlock Interface
SetCustomName Overload


IMyTextPanel Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyTextPanel"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTextPanel : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyTextPanel
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyTextPanel : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyTextPanel =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyTextPanel type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentlyShownImage | The image that is currently shown on the screen. Returns NULL if there are no images selected OR the screen is in text mode.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowOnScreen | Indicates what should be shown on the screen, none being an image.
Public property | ShowText | Returns true if the ShowOnScreen flag is set to either PUBLIC or PRIVATE
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | AddImagesToSelection |
Public method | AddImageToSelection |
Public method | ClearImagesFromSelection |
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetPrivateText | Obsolete.
Public method | GetPrivateTitle | Obsolete.
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetPublicText |
Public method | GetPublicTitle |
Public method | GetSelectedImages | Outputs the selected image ids to the specified list. NOTE: List is not cleared internally.
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | ReadPublicText |
Public method | RemoveImageFromSelection |
Public method | RemoveImagesFromSelection |
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetShowOnScreen |
Public method | ShowPrivateTextOnScreen | Obsolete.
Public method | ShowPublicTextOnScreen |
Public method | ShowTextureOnScreen |
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Public method | WritePrivateText | Obsolete.
Public method | WritePrivateTitle | Obsolete.
Public method | WritePublicText(String, Boolean) |
Public method | WritePublicText(StringBuilder, Boolean) |
Public method | WritePublicTitle |
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyTextPanel Properties

The IMyTextPanel type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentlyShownImage | The image that is currently shown on the screen. Returns NULL if there are no images selected OR the screen is in text mode.
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ShowOnScreen | Indicates what should be shown on the screen, none being an image.
Public property | ShowText | Returns true if the ShowOnScreen flag is set to either PUBLIC or PRIVATE
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.CurrentlyShownImage Property

IMyTextPanelCurrentlyShownImage Property

The image that is currently shown on the screen. Returns NULL if there are no images selected OR the screen is in text mode.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CurrentlyShownImage { get; }
ReadOnly Property CurrentlyShownImage As String
    Get
property String^ CurrentlyShownImage {
    String^ get ();
}
abstract CurrentlyShownImage : string with get

Property Value

Type: String
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ShowOnScreen Property

IMyTextPanelShowOnScreen Property

Indicates what should be shown on the screen, none being an image.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ShowTextOnScreenFlag ShowOnScreen { get; }
ReadOnly Property ShowOnScreen As ShowTextOnScreenFlag
    Get
property ShowTextOnScreenFlag ShowOnScreen {
    ShowTextOnScreenFlag get ();
}
abstract ShowOnScreen : ShowTextOnScreenFlag with get

Property Value

Type: ShowTextOnScreenFlag
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ShowText Property

IMyTextPanelShowText Property

Returns true if the ShowOnScreen flag is set to either PUBLIC or PRIVATE

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowText { get; }
ReadOnly Property ShowText As Boolean
    Get
property bool ShowText {
    bool get ();
}
abstract ShowText : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyTextPanel Interface


IMyTextPanel Methods

The IMyTextPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddImagesToSelection |
Public method | AddImageToSelection |
Public method | ClearImagesFromSelection |
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetPrivateText | Obsolete.
Public method | GetPrivateTitle | Obsolete.
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetPublicText |
Public method | GetPublicTitle |
Public method | GetSelectedImages | Outputs the selected image ids to the specified list. NOTE: List is not cleared internally.
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | ReadPublicText |
Public method | RemoveImageFromSelection |
Public method | RemoveImagesFromSelection |
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetShowOnScreen |
Public method | ShowPrivateTextOnScreen | Obsolete.
Public method | ShowPublicTextOnScreen |
Public method | ShowTextureOnScreen |
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Public method | WritePrivateText | Obsolete.
Public method | WritePrivateTitle | Obsolete.
Public method | WritePublicText(String, Boolean) |
Public method | WritePublicText(StringBuilder, Boolean) |
Public method | WritePublicTitle |
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.AddImagesToSelection Method

IMyTextPanelAddImagesToSelection Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImagesToSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddImagesToSelection(
    List<string> ids,
    bool checkExistence = false
)
Sub AddImagesToSelection (
    ids As List(Of String),
    Optional checkExistence As Boolean = false
)
void AddImagesToSelection(
    List<String^>^ ids,
    bool checkExistence = false
)
abstract AddImagesToSelection :
        ids : List<string> *
        ?checkExistence : bool
(* Defaults:
        let _checkExistence = defaultArg checkExistence false
*)
-> unit

Parameters

ids
Type: System.Collections.GenericList String

[Missing <param name="ids"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImagesToSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

checkExistence (Optional)
Type: SystemBoolean

[Missing <param name="checkExistence"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImagesToSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.AddImageToSelection Method

IMyTextPanelAddImageToSelection Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImageToSelection(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddImageToSelection(
    string id,
    bool checkExistence = false
)
Sub AddImageToSelection (
    id As String,
    Optional checkExistence As Boolean = false
)
void AddImageToSelection(
    String^ id,
    bool checkExistence = false
)
abstract AddImageToSelection :
        id : string *
        ?checkExistence : bool
(* Defaults:
        let _checkExistence = defaultArg checkExistence false
*)
-> unit

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImageToSelection(System.String,System.Boolean)"]

checkExistence (Optional)
Type: SystemBoolean

[Missing <param name="checkExistence"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.AddImageToSelection(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ClearImagesFromSelection Method

IMyTextPanelClearImagesFromSelection Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ClearImagesFromSelection"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearImagesFromSelection()
Sub ClearImagesFromSelection
void ClearImagesFromSelection()
abstract ClearImagesFromSelection : unit -> unit
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.GetPrivateText Method

IMyTextPanelGetPrivateText Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPrivateText"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("LCD private text is deprecated")]
string GetPrivateText()
<ObsoleteAttribute("LCD private text is deprecated")>
Function GetPrivateText As String
[ObsoleteAttribute(L"LCD private text is deprecated")]
String^ GetPrivateText()
[<ObsoleteAttribute("LCD private text is deprecated")>]
abstract GetPrivateText : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPrivateText"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.GetPrivateTitle Method

IMyTextPanelGetPrivateTitle Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPrivateTitle"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("LCD private text is deprecated")]
string GetPrivateTitle()
<ObsoleteAttribute("LCD private text is deprecated")>
Function GetPrivateTitle As String
[ObsoleteAttribute(L"LCD private text is deprecated")]
String^ GetPrivateTitle()
[<ObsoleteAttribute("LCD private text is deprecated")>]
abstract GetPrivateTitle : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPrivateTitle"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.GetPublicText Method

IMyTextPanelGetPublicText Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPublicText"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetPublicText()
Function GetPublicText As String
String^ GetPublicText()
abstract GetPublicText : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPublicText"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.GetPublicTitle Method

IMyTextPanelGetPublicTitle Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPublicTitle"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetPublicTitle()
Function GetPublicTitle As String
String^ GetPublicTitle()
abstract GetPublicTitle : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetPublicTitle"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.GetSelectedImages Method

IMyTextPanelGetSelectedImages Method

Outputs the selected image ids to the specified list. NOTE: List is not cleared internally.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetSelectedImages(
    List<string> output
)
Sub GetSelectedImages (
    output As List(Of String)
)
void GetSelectedImages(
    List<String^>^ output
)
abstract GetSelectedImages :
        output : List<string> -> unit

Parameters

output
Type: System.Collections.GenericList String

[Missing <param name="output"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.GetSelectedImages(System.Collections.Generic.List{System.String})"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ReadPublicText Method

IMyTextPanelReadPublicText Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ReadPublicText(System.Text.StringBuilder,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReadPublicText(
    StringBuilder buffer,
    bool append = false
)
Sub ReadPublicText (
    buffer As StringBuilder,
    Optional append As Boolean = false
)
void ReadPublicText(
    StringBuilder^ buffer,
    bool append = false
)
abstract ReadPublicText :
        buffer : StringBuilder *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> unit

Parameters

buffer
Type: System.TextStringBuilder

[Missing <param name="buffer"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ReadPublicText(System.Text.StringBuilder,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ReadPublicText(System.Text.StringBuilder,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.RemoveImageFromSelection Method

IMyTextPanelRemoveImageFromSelection Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImageFromSelection(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveImageFromSelection(
    string id,
    bool removeDuplicates = false
)
Sub RemoveImageFromSelection (
    id As String,
    Optional removeDuplicates As Boolean = false
)
void RemoveImageFromSelection(
    String^ id,
    bool removeDuplicates = false
)
abstract RemoveImageFromSelection :
        id : string *
        ?removeDuplicates : bool
(* Defaults:
        let _removeDuplicates = defaultArg removeDuplicates false
*)
-> unit

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImageFromSelection(System.String,System.Boolean)"]

removeDuplicates (Optional)
Type: SystemBoolean

[Missing <param name="removeDuplicates"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImageFromSelection(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.RemoveImagesFromSelection Method

IMyTextPanelRemoveImagesFromSelection Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImagesFromSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveImagesFromSelection(
    List<string> ids,
    bool removeDuplicates = false
)
Sub RemoveImagesFromSelection (
    ids As List(Of String),
    Optional removeDuplicates As Boolean = false
)
void RemoveImagesFromSelection(
    List<String^>^ ids,
    bool removeDuplicates = false
)
abstract RemoveImagesFromSelection :
        ids : List<string> *
        ?removeDuplicates : bool
(* Defaults:
        let _removeDuplicates = defaultArg removeDuplicates false
*)
-> unit

Parameters

ids
Type: System.Collections.GenericList String

[Missing <param name="ids"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImagesFromSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

removeDuplicates (Optional)
Type: SystemBoolean

[Missing <param name="removeDuplicates"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.RemoveImagesFromSelection(System.Collections.Generic.List{System.String},System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.SetShowOnScreen Method

IMyTextPanelSetShowOnScreen Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.SetShowOnScreen(VRage.Game.GUI.TextPanel.ShowTextOnScreenFlag)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetShowOnScreen(
    ShowTextOnScreenFlag set
)
Sub SetShowOnScreen (
    set As ShowTextOnScreenFlag
)
void SetShowOnScreen(
    ShowTextOnScreenFlag set
)
abstract SetShowOnScreen :
        set : ShowTextOnScreenFlag -> unit

Parameters

set
Type: ShowTextOnScreenFlag

[Missing <param name="set"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.SetShowOnScreen(VRage.Game.GUI.TextPanel.ShowTextOnScreenFlag)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ShowPrivateTextOnScreen Method

IMyTextPanelShowPrivateTextOnScreen Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ShowPrivateTextOnScreen"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("LCD private text is deprecated")]
void ShowPrivateTextOnScreen()
<ObsoleteAttribute("LCD private text is deprecated")>
Sub ShowPrivateTextOnScreen
[ObsoleteAttribute(L"LCD private text is deprecated")]
void ShowPrivateTextOnScreen()
[<ObsoleteAttribute("LCD private text is deprecated")>]
abstract ShowPrivateTextOnScreen : unit -> unit
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ShowPublicTextOnScreen Method

IMyTextPanelShowPublicTextOnScreen Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ShowPublicTextOnScreen"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowPublicTextOnScreen()
Sub ShowPublicTextOnScreen
void ShowPublicTextOnScreen()
abstract ShowPublicTextOnScreen : unit -> unit
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.ShowTextureOnScreen Method

IMyTextPanelShowTextureOnScreen Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.ShowTextureOnScreen"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowTextureOnScreen()
Sub ShowTextureOnScreen
void ShowTextureOnScreen()
abstract ShowTextureOnScreen : unit -> unit
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.WritePrivateText Method

IMyTextPanelWritePrivateText Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateText(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("LCD private text is deprecated")]
bool WritePrivateText(
    string value,
    bool append = false
)
<ObsoleteAttribute("LCD private text is deprecated")>
Function WritePrivateText (
    value As String,
    Optional append As Boolean = false
) As Boolean
[ObsoleteAttribute(L"LCD private text is deprecated")]
bool WritePrivateText(
    String^ value,
    bool append = false
)
[<ObsoleteAttribute("LCD private text is deprecated")>]
abstract WritePrivateText :
        value : string *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> bool

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateText(System.String,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateText(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateText(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.WritePrivateTitle Method

IMyTextPanelWritePrivateTitle Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateTitle(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("LCD private text is deprecated")]
bool WritePrivateTitle(
    string value,
    bool append = false
)
<ObsoleteAttribute("LCD private text is deprecated")>
Function WritePrivateTitle (
    value As String,
    Optional append As Boolean = false
) As Boolean
[ObsoleteAttribute(L"LCD private text is deprecated")]
bool WritePrivateTitle(
    String^ value,
    bool append = false
)
[<ObsoleteAttribute("LCD private text is deprecated")>]
abstract WritePrivateTitle :
        value : string *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> bool

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateTitle(System.String,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateTitle(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePrivateTitle(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyTextPanel.WritePublicText Method

IMyTextPanelWritePublicText Method

Overload List
 | Name | Description
Public method | WritePublicText(String, Boolean) |
Public method | WritePublicText(StringBuilder, Boolean) |
Top
See Also

Reference

IMyTextPanel Interface


IMyTextPanel.WritePublicText Method (String, Boolean)

IMyTextPanelWritePublicText Method (String, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WritePublicText(
    string value,
    bool append = false
)
Function WritePublicText (
    value As String,
    Optional append As Boolean = false
) As Boolean
bool WritePublicText(
    String^ value,
    bool append = false
)
abstract WritePublicText :
        value : string *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> bool

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.String,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface
WritePublicText Overload


IMyTextPanel.WritePublicText Method (StringBuilder, Boolean)

IMyTextPanelWritePublicText Method (StringBuilder, Boolean)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.Text.StringBuilder,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WritePublicText(
    StringBuilder value,
    bool append = false
)
Function WritePublicText (
    value As StringBuilder,
    Optional append As Boolean = false
) As Boolean
bool WritePublicText(
    StringBuilder^ value,
    bool append = false
)
abstract WritePublicText :
        value : StringBuilder *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> bool

Parameters

value
Type: System.TextStringBuilder

[Missing <param name="value"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.Text.StringBuilder,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.Text.StringBuilder,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicText(System.Text.StringBuilder,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface
WritePublicText Overload


IMyTextPanel.WritePublicTitle Method

IMyTextPanelWritePublicTitle Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicTitle(System.String,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WritePublicTitle(
    string value,
    bool append = false
)
Function WritePublicTitle (
    value As String,
    Optional append As Boolean = false
) As Boolean
bool WritePublicTitle(
    String^ value,
    bool append = false
)
abstract WritePublicTitle :
        value : string *
        ?append : bool
(* Defaults:
        let _append = defaultArg append false
*)
-> bool

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicTitle(System.String,System.Boolean)"]

append (Optional)
Type: SystemBoolean

[Missing <param name="append"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicTitle(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.IMyTextPanel.WritePublicTitle(System.String,System.Boolean)"]

See Also

Reference

IMyTextPanel Interface


IMyThrust Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyThrust"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyThrust : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyThrust
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyThrust : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyThrust =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyThrust type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentThrust | Gets the current thrust amount, in Newtons (N)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | GridThrustDirection | Gets the direction of thrust, relative to ship controller (cockpit).
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxEffectiveThrust | Gets the maximum effective thrust amount, in Newtons (N)
Public property | MaxThrust | Gets the maximum thrust amount, in Newtons (N)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ThrustOverride | Gets the override thrust amount, in Newtons (N)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyThrust Properties

The IMyThrust type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CurrentThrust | Gets the current thrust amount, in Newtons (N)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | GridThrustDirection | Gets the direction of thrust, relative to ship controller (cockpit).
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | MaxEffectiveThrust | Gets the maximum effective thrust amount, in Newtons (N)
Public property | MaxThrust | Gets the maximum thrust amount, in Newtons (N)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | ThrustOverride | Gets the override thrust amount, in Newtons (N)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyThrust Interface


IMyThrust.CurrentThrust Property

IMyThrustCurrentThrust Property

Gets the current thrust amount, in Newtons (N)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float CurrentThrust { get; }
ReadOnly Property CurrentThrust As Single
    Get
property float CurrentThrust {
    float get ();
}
abstract CurrentThrust : float32 with get

Property Value

Type: Single
See Also

Reference

IMyThrust Interface


IMyThrust.GridThrustDirection Property

IMyThrustGridThrustDirection Property

Gets the direction of thrust, relative to ship controller (cockpit).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Vector3I GridThrustDirection { get; }
ReadOnly Property GridThrustDirection As Vector3I
    Get
property Vector3I GridThrustDirection {
    Vector3I get ();
}
abstract GridThrustDirection : Vector3I with get

Property Value

Type: Vector3I
Remarks
For example, a value of VRageMath.Vector3I.Forward means the thruster will move the grid along the grid's forward direction. A value of Vector3D.Zero means direction is unknown (no cockpit available).
See Also

Reference

IMyThrust Interface


IMyThrust.MaxEffectiveThrust Property

IMyThrustMaxEffectiveThrust Property

Gets the maximum effective thrust amount, in Newtons (N)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxEffectiveThrust { get; }
ReadOnly Property MaxEffectiveThrust As Single
    Get
property float MaxEffectiveThrust {
    float get ();
}
abstract MaxEffectiveThrust : float32 with get

Property Value

Type: Single
See Also

Reference

IMyThrust Interface


IMyThrust.MaxThrust Property

IMyThrustMaxThrust Property

Gets the maximum thrust amount, in Newtons (N)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float MaxThrust { get; }
ReadOnly Property MaxThrust As Single
    Get
property float MaxThrust {
    float get ();
}
abstract MaxThrust : float32 with get

Property Value

Type: Single
See Also

Reference

IMyThrust Interface


IMyThrust.ThrustOverride Property

IMyThrustThrustOverride Property

Gets the override thrust amount, in Newtons (N)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float ThrustOverride { get; }
ReadOnly Property ThrustOverride As Single
    Get
property float ThrustOverride {
    float get ();
}
abstract ThrustOverride : float32 with get

Property Value

Type: Single
See Also

Reference

IMyThrust Interface


IMyThrust Methods

The IMyThrust type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyThrust Interface


IMyUpgradableBlock Interface

interface to retrieve upgrade effects on block

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyUpgradableBlock : IMyCubeBlock,
    IMyEntity
Public Interface IMyUpgradableBlock
    Inherits IMyCubeBlock, IMyEntity
public interface class IMyUpgradableBlock : IMyCubeBlock,
    IMyEntity
type IMyUpgradableBlock =
    interface
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyUpgradableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | UpgradeCount | number of upgrades applied
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUpgrades | get list of upgrades (r/o); string - upgrade type, float - effect value as float (1 = 100%)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyUpgradableBlock Properties

The IMyUpgradableBlock type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | UpgradeCount | number of upgrades applied
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyUpgradableBlock Interface


IMyUpgradableBlock.UpgradeCount Property

IMyUpgradableBlockUpgradeCount Property

number of upgrades applied

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
uint UpgradeCount { get; }
ReadOnly Property UpgradeCount As UInteger
    Get
property unsigned int UpgradeCount {
    unsigned int get ();
}
abstract UpgradeCount : uint32 with get

Property Value

Type: UInt32
See Also

Reference

IMyUpgradableBlock Interface


IMyUpgradableBlock Methods

The IMyUpgradableBlock type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUpgrades | get list of upgrades (r/o); string - upgrade type, float - effect value as float (1 = 100%)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyUpgradableBlock Interface


IMyUpgradableBlock.GetUpgrades Method

IMyUpgradableBlockGetUpgrades Method

get list of upgrades (r/o); string - upgrade type, float - effect value as float (1 = 100%)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetUpgrades(
    out Dictionary<string, float> upgrades
)
Sub GetUpgrades (
    <OutAttribute> ByRef upgrades As Dictionary(Of String, Single)
)
void GetUpgrades(
    [OutAttribute] Dictionary<String^, float>^% upgrades
)
abstract GetUpgrades :
        upgrades : Dictionary<string, float32> byref -> unit

Parameters

upgrades
Type: System.Collections.GenericDictionary String, Single

[Missing <param name="upgrades"/> documentation for "M:Sandbox.ModAPI.Ingame.IMyUpgradableBlock.GetUpgrades(System.Collections.Generic.Dictionary{System.String,System.Single}@)"]

See Also

Reference

IMyUpgradableBlock Interface


IMyUserControllableGun Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyUserControllableGun"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyUserControllableGun : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
Public Interface IMyUserControllableGun
    Inherits IMyFunctionalBlock, IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyUserControllableGun : IMyFunctionalBlock,
    IMyTerminalBlock, IMyCubeBlock, IMyEntity
type IMyUserControllableGun =
    interface
        interface IMyFunctionalBlock
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyUserControllableGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting |
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyUserControllableGun Properties

The IMyUserControllableGun type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | Enabled | (Inherited from IMyFunctionalBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsShooting |
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyUserControllableGun Interface


IMyUserControllableGun.IsShooting Property

IMyUserControllableGunIsShooting Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyUserControllableGun.IsShooting"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsShooting { get; }
ReadOnly Property IsShooting As Boolean
    Get
property bool IsShooting {
    bool get ();
}
abstract IsShooting : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyUserControllableGun Interface


IMyUserControllableGun Methods

The IMyUserControllableGun type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | RequestEnable | Obsolete. (Inherited from IMyFunctionalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyUserControllableGun Interface


IMyWarhead Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyWarhead"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyWarhead : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
Public Interface IMyWarhead
    Inherits IMyTerminalBlock, IMyCubeBlock, IMyEntity
public interface class IMyWarhead : IMyTerminalBlock,
    IMyCubeBlock, IMyEntity
type IMyWarhead =
    interface
        interface IMyTerminalBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyWarhead type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetonationTime |
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCountingDown |
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference


IMyWarhead Properties

The IMyWarhead type exposes the following members.

Properties
 | Name | Description
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | CustomData | Gets or sets the Custom Data string. NOTE: Only use this for user input. For storing large mod configs, create your own MyModStorageComponent (Inherited from IMyTerminalBlock.)
Public property | CustomInfo | (Inherited from IMyTerminalBlock.)
Public property | CustomName | (Inherited from IMyTerminalBlock.)
Public property | CustomNameWithFaction | (Inherited from IMyTerminalBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DetailedInfo | (Inherited from IMyTerminalBlock.)
Public property | DetonationTime |
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsCountingDown |
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | ShowInTerminal | (Inherited from IMyTerminalBlock.)
Public property | ShowInToolbarConfig | (Inherited from IMyTerminalBlock.)
Public property | ShowOnHUD | (Inherited from IMyTerminalBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyWarhead Interface


IMyWarhead.DetonationTime Property

IMyWarheadDetonationTime Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyWarhead.DetonationTime"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
float DetonationTime { get; }
ReadOnly Property DetonationTime As Single
    Get
property float DetonationTime {
    float get ();
}
abstract DetonationTime : float32 with get

Property Value

Type: Single
See Also

Reference

IMyWarhead Interface


IMyWarhead.IsCountingDown Property

IMyWarheadIsCountingDown Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.IMyWarhead.IsCountingDown"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCountingDown { get; }
ReadOnly Property IsCountingDown As Boolean
    Get
property bool IsCountingDown {
    bool get ();
}
abstract IsCountingDown : bool with get

Property Value

Type: Boolean
See Also

Reference

IMyWarhead Interface


IMyWarhead Methods

The IMyWarhead type exposes the following members.

Methods
 | Name | Description
Public method | GetActions | (Inherited from IMyTerminalBlock.)
Public method | GetActionWithName | (Inherited from IMyTerminalBlock.)
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetProperties | (Inherited from IMyTerminalBlock.)
Public method | GetProperty | (Inherited from IMyTerminalBlock.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | HasLocalPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | HasPlayerAccess | (Inherited from IMyTerminalBlock.)
Public method | SearchActionsOfName | (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(String) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | SetCustomName(StringBuilder) | Obsolete. (Inherited from IMyTerminalBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ApplyAction(String) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | ApplyAction(String, ListTerminalActionParameter) | Overloaded. (Defined by TerminalBlockExtentions.)
Public Extension Method | GetDefaultValueT | Returns default value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetId | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetInventoryCount | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetMaximumT | Returns maximum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMinimumT | Returns minimum value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetMininumT | Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String) (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | GetValueT | Returns value of specified property as TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueBool | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueColor | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | GetValueFloat | Returns value of specified property (Defined by TerminalPropertyExtensions.)
Public Extension Method | HasAction | (Defined by TerminalBlockExtentions.)
Public Extension Method | HasInventory | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetUseConveyorSystem | (Defined by TerminalBlockExtentions.)
Public Extension Method | SetValueT | Set value of property with type of TypeName (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueBool | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueColor | Set bool value of property (Defined by TerminalPropertyExtensions.)
Public Extension Method | SetValueFloat | Set float value of property (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyWarhead Interface


IMyWheel Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.IMyWheel"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyWheel : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
Public Interface IMyWheel
    Inherits IMyMotorRotor, IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
public interface class IMyWheel : IMyMotorRotor,
    IMyAttachableTopBlock, IMyCubeBlock, IMyEntity
type IMyWheel =
    interface
        interface IMyMotorRotor
        interface IMyAttachableTopBlock
        interface IMyCubeBlock
        interface IMyEntity
    end

The IMyWheel type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference


IMyWheel Properties

The IMyWheel type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the attached base block (Inherited from IMyAttachableTopBlock.)
Public property | BlockDefinition | (Inherited from IMyCubeBlock.)
Public property | CheckConnectionAllowed | (Inherited from IMyCubeBlock.)
Public property | Components | (Inherited from IMyEntity.)
Public property | CubeGrid | (Inherited from IMyCubeBlock.)
Public property | DefinitionDisplayNameText | (Inherited from IMyCubeBlock.)
Public property | DisassembleRatio | (Inherited from IMyCubeBlock.)
Public property | DisplayName | (Inherited from IMyEntity.)
Public property | DisplayNameText | (Inherited from IMyCubeBlock.)
Public property | EntityId | (Inherited from IMyEntity.)
Public property | HasInventory | (Inherited from IMyEntity.)
Public property | InventoryCount | (Inherited from IMyEntity.)
Public property | IsAttached | Gets whether the top part is attached to a base block (Inherited from IMyAttachableTopBlock.)
Public property | IsBeingHacked | (Inherited from IMyCubeBlock.)
Public property | IsFunctional | (Inherited from IMyCubeBlock.)
Public property | IsWorking | (Inherited from IMyCubeBlock.)
Public property | Mass | (Inherited from IMyCubeBlock.)
Public property | Max | (Inherited from IMyCubeBlock.)
Public property | Min | (Inherited from IMyCubeBlock.)
Public property | Name | (Inherited from IMyEntity.)
Public property | NumberInGrid | (Inherited from IMyCubeBlock.)
Public property | Orientation | (Inherited from IMyCubeBlock.)
Public property | OwnerId | (Inherited from IMyCubeBlock.)
Public property | Position | (Inherited from IMyCubeBlock.)
Public property | WorldMatrix | (Inherited from IMyEntity.)
Public property | WorldVolume | (Inherited from IMyEntity.)
Public property | WorldVolumeHr | (Inherited from IMyEntity.)
Public property | WorldAABB | (Inherited from IMyEntity.)
Public property | WorldAABBHr | (Inherited from IMyEntity.)
Top
See Also

Reference

IMyWheel Interface


IMyWheel Methods

The IMyWheel type exposes the following members.

Methods
 | Name | Description
Public method | GetInventory | (Inherited from IMyEntity.)
Public method | GetInventory(Int32) | (Inherited from IMyEntity.)
Public method | GetOwnerFactionTag | (Inherited from IMyCubeBlock.)
Public method | GetPlayerRelationToOwner | Obsolete. (Inherited from IMyCubeBlock.)
Public method | GetPosition | (Inherited from IMyEntity.)
Public method | GetUserRelationToOwner | (Inherited from IMyCubeBlock.)
Public method | UpdateIsWorking | Obsolete. (Inherited from IMyCubeBlock.)
Public method | UpdateVisual | Obsolete. (Inherited from IMyCubeBlock.)
Top
See Also

Reference

IMyWheel Interface


MyAssemblerMode Enumeration

Determines what mode an assembler is in.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyAssemblerMode
Public Enumeration MyAssemblerMode
public enum class MyAssemblerMode
type MyAssemblerMode
Members
Member name | Value | Description
Assembly | 0 | The assembler is currently set to assemble new items.
Disassembly | 1 | The assembler is currently set to disassemble existing items.
See Also

Reference


MyConveyorSorterMode Enumeration

Determines the current mode of a conveyor sorter.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyConveyorSorterMode
Public Enumeration MyConveyorSorterMode
public enum class MyConveyorSorterMode
type MyConveyorSorterMode
Members
Member name | Value | Description
Whitelist | 0 | The items in the filter list are the only items allowed through this sorter.
Blacklist | 1 | The items in the filter list are not allowed through this sorter.
See Also

Reference


MyDetectedEntityInfo Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyDetectedEntityInfo
Public Structure MyDetectedEntityInfo
public value class MyDetectedEntityInfo
[<SealedAttribute>]
type MyDetectedEntityInfo =  struct end

The MyDetectedEntityInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MyDetectedEntityInfo | Initializes a new instance of the MyDetectedEntityInfo class
Top
Properties
 | Name | Description
Public property | Position | The entity's position (center of the Bounding Box)
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines if this structure is empty; meaning it does not contain any meaningful data
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BoundingBox | The entity's world-aligned bounding box
Public field | EntityId | The entity's EntityId
Public field | HitPosition | Position where the raycast hit the entity. (can be null if the sensor didn't use a raycast)
Public field | Name | The entity's display name if it is friendly, or a generic descriptor if it is not
Public field | Orientation | The entity's absolute orientation at the time it was detected
Public field | Relationship | Relationship between the entity and the owner of the sensor
Public field | TimeStamp | Time when the entity was detected. This field counts milliseconds, compensated for simspeed
Public field | Type | Enum describing the type of entity
Public field | Velocity | The entity's absolute velocity at the time it was detected
Top
See Also

Reference


MyDetectedEntityInfo Constructor

Initializes a new instance of the MyDetectedEntityInfo class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyDetectedEntityInfo(
    long entityId,
    string name,
    MyDetectedEntityType type,
    Nullable<Vector3D> hitPosition,
    MatrixD orientation,
    Vector3 velocity,
    MyRelationsBetweenPlayerAndBlock relationship,
    BoundingBoxD boundingBox,
    long timeStamp
)
Public Sub New (
    entityId As Long,
    name As String,
    type As MyDetectedEntityType,
    hitPosition As Nullable(Of Vector3D),
    orientation As MatrixD,
    velocity As Vector3,
    relationship As MyRelationsBetweenPlayerAndBlock,
    boundingBox As BoundingBoxD,
    timeStamp As Long
)
public:
MyDetectedEntityInfo(
    long long entityId,
    String^ name,
    MyDetectedEntityType type,
    Nullable<Vector3D> hitPosition,
    MatrixD orientation,
    Vector3 velocity,
    MyRelationsBetweenPlayerAndBlock relationship,
    BoundingBoxD boundingBox,
    long long timeStamp
)
new :
        entityId : int64 *
        name : string *
        type : MyDetectedEntityType *
        hitPosition : Nullable<Vector3D> *
        orientation : MatrixD *
        velocity : Vector3 *
        relationship : MyRelationsBetweenPlayerAndBlock *
        boundingBox : BoundingBoxD *
        timeStamp : int64 -> MyDetectedEntityInfo

Parameters

entityId
Type: SystemInt64

[Missing <param name="entityId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

type
Type: Sandbox.ModAPI.IngameMyDetectedEntityType

[Missing <param name="type"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

hitPosition
Type: SystemNullable Vector3D

[Missing <param name="hitPosition"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

orientation
Type: MatrixD

[Missing <param name="orientation"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

velocity
Type: Vector3

[Missing <param name="velocity"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

relationship
Type: MyRelationsBetweenPlayerAndBlock

[Missing <param name="relationship"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

boundingBox
Type: BoundingBoxD

[Missing <param name="boundingBox"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

timeStamp
Type: SystemInt64

[Missing <param name="timeStamp"/> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.#ctor(System.Int64,System.String,Sandbox.ModAPI.Ingame.MyDetectedEntityType,System.Nullable{VRageMath.Vector3D},VRageMath.MatrixD,VRageMath.Vector3,VRage.Game.MyRelationsBetweenPlayerAndBlock,VRageMath.BoundingBoxD,System.Int64)"]

See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo Properties

The MyDetectedEntityInfo type exposes the following members.

Properties
 | Name | Description
Public property | Position | The entity's position (center of the Bounding Box)
Top
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Position Property

MyDetectedEntityInfoPosition Property

The entity's position (center of the Bounding Box)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Vector3D Position { get; }
Public ReadOnly Property Position As Vector3D
    Get
public:
property Vector3D Position {
    Vector3D get ();
}
member Position : Vector3D with get

Property Value

Type: Vector3D
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo Methods

The MyDetectedEntityInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines if this structure is empty; meaning it does not contain any meaningful data
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.IsEmpty Method

MyDetectedEntityInfoIsEmpty Method

Determines if this structure is empty; meaning it does not contain any meaningful data

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
member IsEmpty : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.MyDetectedEntityInfo.IsEmpty"]

See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo Fields

The MyDetectedEntityInfo type exposes the following members.

Fields
 | Name | Description
Public field | BoundingBox | The entity's world-aligned bounding box
Public field | EntityId | The entity's EntityId
Public field | HitPosition | Position where the raycast hit the entity. (can be null if the sensor didn't use a raycast)
Public field | Name | The entity's display name if it is friendly, or a generic descriptor if it is not
Public field | Orientation | The entity's absolute orientation at the time it was detected
Public field | Relationship | Relationship between the entity and the owner of the sensor
Public field | TimeStamp | Time when the entity was detected. This field counts milliseconds, compensated for simspeed
Public field | Type | Enum describing the type of entity
Public field | Velocity | The entity's absolute velocity at the time it was detected
Top
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.BoundingBox Field

MyDetectedEntityInfoBoundingBox Field

The entity's world-aligned bounding box

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly BoundingBoxD BoundingBox
Public ReadOnly BoundingBox As BoundingBoxD
public:
initonly BoundingBoxD BoundingBox
val BoundingBox: BoundingBoxD

Field Value

Type: BoundingBoxD
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.EntityId Field

MyDetectedEntityInfoEntityId Field

The entity's EntityId

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly long EntityId
Public ReadOnly EntityId As Long
public:
initonly long long EntityId
val EntityId: int64

Field Value

Type: Int64
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.HitPosition Field

MyDetectedEntityInfoHitPosition Field

Position where the raycast hit the entity. (can be null if the sensor didn't use a raycast)

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Nullable<Vector3D> HitPosition
Public ReadOnly HitPosition As Nullable(Of Vector3D)
public:
initonly Nullable<Vector3D> HitPosition
val HitPosition: Nullable<Vector3D>

Field Value

Type: Nullable Vector3D
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Name Field

MyDetectedEntityInfoName Field

The entity's display name if it is friendly, or a generic descriptor if it is not

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly string Name
Public ReadOnly Name As String
public:
initonly String^ Name
val Name: string

Field Value

Type: String
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Orientation Field

MyDetectedEntityInfoOrientation Field

The entity's absolute orientation at the time it was detected

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MatrixD Orientation
Public ReadOnly Orientation As MatrixD
public:
initonly MatrixD Orientation
val Orientation: MatrixD

Field Value

Type: MatrixD
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Relationship Field

MyDetectedEntityInfoRelationship Field

Relationship between the entity and the owner of the sensor

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MyRelationsBetweenPlayerAndBlock Relationship
Public ReadOnly Relationship As MyRelationsBetweenPlayerAndBlock
public:
initonly MyRelationsBetweenPlayerAndBlock Relationship
val Relationship: MyRelationsBetweenPlayerAndBlock

Field Value

Type: MyRelationsBetweenPlayerAndBlock
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.TimeStamp Field

MyDetectedEntityInfoTimeStamp Field

Time when the entity was detected. This field counts milliseconds, compensated for simspeed

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly long TimeStamp
Public ReadOnly TimeStamp As Long
public:
initonly long long TimeStamp
val TimeStamp: int64

Field Value

Type: Int64
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Type Field

MyDetectedEntityInfoType Field

Enum describing the type of entity

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MyDetectedEntityType Type
Public ReadOnly Type As MyDetectedEntityType
public:
initonly MyDetectedEntityType Type
val Type: MyDetectedEntityType

Field Value

Type: MyDetectedEntityType
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityInfo.Velocity Field

MyDetectedEntityInfoVelocity Field

The entity's absolute velocity at the time it was detected

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Vector3 Velocity
Public ReadOnly Velocity As Vector3
public:
initonly Vector3 Velocity
val Velocity: Vector3

Field Value

Type: Vector3
See Also

Reference

MyDetectedEntityInfo Structure


MyDetectedEntityType Enumeration

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyDetectedEntityType"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyDetectedEntityType
Public Enumeration MyDetectedEntityType
public enum class MyDetectedEntityType
type MyDetectedEntityType
Members
Member name | Value | Description
None | 0 |
Unknown | 1 |
SmallGrid | 2 |
LargeGrid | 3 |
CharacterHuman | 4 |
CharacterOther | 5 |
FloatingObject | 6 |
Asteroid | 7 |
Planet | 8 |
Meteor | 9 |
Missile | 10 |
See Also

Reference


MyGridProgram Class

All programmable block scripts derive from this class, meaning that all properties in this class are directly available for use in your scripts. If you use Visual Studio or other external editors to write your scripts, you can derive directly from this class and have a compatible script template.
Inheritance Hierarchy
SystemObject
Sandbox.ModAPI.IngameMyGridProgram

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class MyGridProgram : IMyGridProgram
Public MustInherit Class MyGridProgram
    Implements IMyGridProgram
public ref class MyGridProgram abstract : IMyGridProgram
[<AbstractClassAttribute>]
type MyGridProgram =
    class
        interface IMyGridProgram
    end

The MyGridProgram type exposes the following members.

Constructors
 | Name | Description
Protected method | MyGridProgram | Initializes a new instance of the MyGridProgram class
Top
Properties
 | Name | Description
Public property | Echo | Prints out text onto the currently running programmable block's detail info area.
Public property | ElapsedTime | Obsolete. Gets the amount of in-game time elapsed from the previous run.
Public property | GridTerminalSystem | Provides access to the grid terminal system as viewed from this programmable block.
Public property | Me | Gets a reference to the currently running programmable block.
Public property | Runtime | Gets runtime information for the running grid program.
Public property | Storage | Allows you to store data between game sessions.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
public void Main()
{
    // Print out the time elapsed since the currently running programmable block was run
    // the last time.
    Echo(Me.CustomName + " was last run " + Runtime.TimeSinceLastRun.TotalSeconds + " seconds ago.");
}
See Also

Reference


MyGridProgram Constructor

Initializes a new instance of the MyGridProgram class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected MyGridProgram()
Protected Sub New
protected:
MyGridProgram()
new : unit -> MyGridProgram
See Also

Reference

MyGridProgram Class


MyGridProgram Properties

The MyGridProgram type exposes the following members.

Properties
 | Name | Description
Public property | Echo | Prints out text onto the currently running programmable block's detail info area.
Public property | ElapsedTime | Obsolete. Gets the amount of in-game time elapsed from the previous run.
Public property | GridTerminalSystem | Provides access to the grid terminal system as viewed from this programmable block.
Public property | Me | Gets a reference to the currently running programmable block.
Public property | Runtime | Gets runtime information for the running grid program.
Public property | Storage | Allows you to store data between game sessions.
Top
See Also

Reference

MyGridProgram Class


MyGridProgram.Echo Property

MyGridProgramEcho Property

Prints out text onto the currently running programmable block's detail info area.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<string> Echo { get; protected set; }
Public Property Echo As Action(Of String)
    Get
    Protected Set
public:
property Action<String^>^ Echo {
    Action<String^>^ get ();
    protected: void set (Action<String^>^ value);
}
member Echo : Action<string> with get, set

Property Value

Type: Action String
See Also

Reference

MyGridProgram Class


MyGridProgram.ElapsedTime Property

MyGridProgramElapsedTime Property

Note: This API is now obsolete.

Gets the amount of in-game time elapsed from the previous run.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")]
public virtual TimeSpan ElapsedTime { get; protected set; }
<ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")>
Public Overridable Property ElapsedTime As TimeSpan
    Get
    Protected Set
public:
[ObsoleteAttribute(L"Use Runtime.TimeSinceLastRun instead")]
virtual property TimeSpan ElapsedTime {
    TimeSpan get ();
    protected: void set (TimeSpan value);
}
[<ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")>]
abstract ElapsedTime : TimeSpan with get, set
[<ObsoleteAttribute("Use Runtime.TimeSinceLastRun instead")>]
override ElapsedTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

MyGridProgram Class


MyGridProgram.GridTerminalSystem Property

MyGridProgramGridTerminalSystem Property

Provides access to the grid terminal system as viewed from this programmable block.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IMyGridTerminalSystem GridTerminalSystem { get; protected set; }
Public Overridable Property GridTerminalSystem As IMyGridTerminalSystem
    Get
    Protected Set
public:
virtual property IMyGridTerminalSystem^ GridTerminalSystem {
    IMyGridTerminalSystem^ get ();
    protected: void set (IMyGridTerminalSystem^ value);
}
abstract GridTerminalSystem : IMyGridTerminalSystem with get, set
override GridTerminalSystem : IMyGridTerminalSystem with get, set

Property Value

Type: IMyGridTerminalSystem
See Also

Reference

MyGridProgram Class


MyGridProgram.Me Property

MyGridProgramMe Property

Gets a reference to the currently running programmable block.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IMyProgrammableBlock Me { get; protected set; }
Public Overridable Property Me As IMyProgrammableBlock
    Get
    Protected Set
public:
virtual property IMyProgrammableBlock^ Me {
    IMyProgrammableBlock^ get ();
    protected: void set (IMyProgrammableBlock^ value);
}
abstract Me : IMyProgrammableBlock with get, set
override Me : IMyProgrammableBlock with get, set

Property Value

Type: IMyProgrammableBlock
See Also

Reference

MyGridProgram Class


MyGridProgram.Runtime Property

MyGridProgramRuntime Property

Gets runtime information for the running grid program.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IMyGridProgramRuntimeInfo Runtime { get; protected set; }
Public Overridable Property Runtime As IMyGridProgramRuntimeInfo
    Get
    Protected Set
public:
virtual property IMyGridProgramRuntimeInfo^ Runtime {
    IMyGridProgramRuntimeInfo^ get ();
    protected: void set (IMyGridProgramRuntimeInfo^ value);
}
abstract Runtime : IMyGridProgramRuntimeInfo with get, set
override Runtime : IMyGridProgramRuntimeInfo with get, set

Property Value

Type: IMyGridProgramRuntimeInfo
See Also

Reference

MyGridProgram Class


MyGridProgram.Storage Property

MyGridProgramStorage Property

Allows you to store data between game sessions.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Storage { get; protected set; }
Public Overridable Property Storage As String
    Get
    Protected Set
public:
virtual property String^ Storage {
    String^ get ();
    protected: void set (String^ value);
}
abstract Storage : string with get, set
override Storage : string with get, set

Property Value

Type: String
See Also

Reference

MyGridProgram Class


MyGridProgram Methods

The MyGridProgram type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MyGridProgram Class


MyInventoryItemFilter Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyInventoryItemFilter"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct MyInventoryItemFilter
<SerializableAttribute>
Public Structure MyInventoryItemFilter
[SerializableAttribute]
public value class MyInventoryItemFilter
[<SealedAttribute>]
[<SerializableAttribute>]
type MyInventoryItemFilter =  struct end

The MyInventoryItemFilter type exposes the following members.

Constructors
 | Name | Description
Public method | MyInventoryItemFilter(String, Boolean) | Initializes a new instance of the MyInventoryItemFilter class
Public method | MyInventoryItemFilter(MyDefinitionId, Boolean) | Initializes a new instance of the MyInventoryItemFilter class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
(MyDefinitionId to MyInventoryItemFilter) |
Top
Fields
 | Name | Description
Public field | AllSubTypes | Determines whether all subtypes of the given item ID should pass this filter check.
Public field | ItemId | Specifies an item to filter. Set AllSubTypes to true to only check the main type part of this ID.
Top
See Also

Reference


MyInventoryItemFilter Constructor

Overload List
 | Name | Description
Public method | MyInventoryItemFilter(String, Boolean) | Initializes a new instance of the MyInventoryItemFilter class
Public method | MyInventoryItemFilter(MyDefinitionId, Boolean) | Initializes a new instance of the MyInventoryItemFilter class
Top
See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter Constructor (String, Boolean)

Initializes a new instance of the MyInventoryItemFilter class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyInventoryItemFilter(
    string itemId,
    bool allSubTypes = false
)
Public Sub New (
    itemId As String,
    Optional allSubTypes As Boolean = false
)
public:
MyInventoryItemFilter(
    String^ itemId,
    bool allSubTypes = false
)
new :
        itemId : string *
        ?allSubTypes : bool
(* Defaults:
        let _allSubTypes = defaultArg allSubTypes false
*)
-> MyInventoryItemFilter

Parameters

itemId
Type: SystemString

[Missing <param name="itemId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.#ctor(System.String,System.Boolean)"]

allSubTypes (Optional)
Type: SystemBoolean

[Missing <param name="allSubTypes"/> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.#ctor(System.String,System.Boolean)"]

See Also

Reference

MyInventoryItemFilter Structure
MyInventoryItemFilter Overload


MyInventoryItemFilter Constructor (MyDefinitionId, Boolean)

Initializes a new instance of the MyInventoryItemFilter class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyInventoryItemFilter(
    MyDefinitionId itemId,
    bool allSubTypes = false
)
Public Sub New (
    itemId As MyDefinitionId,
    Optional allSubTypes As Boolean = false
)
public:
MyInventoryItemFilter(
    MyDefinitionId itemId,
    bool allSubTypes = false
)
new :
        itemId : MyDefinitionId *
        ?allSubTypes : bool
(* Defaults:
        let _allSubTypes = defaultArg allSubTypes false
*)
-> MyInventoryItemFilter

Parameters

itemId
Type: MyDefinitionId

[Missing <param name="itemId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.#ctor(VRage.Game.MyDefinitionId,System.Boolean)"]

allSubTypes (Optional)
Type: SystemBoolean

[Missing <param name="allSubTypes"/> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.#ctor(VRage.Game.MyDefinitionId,System.Boolean)"]

See Also

Reference

MyInventoryItemFilter Structure
MyInventoryItemFilter Overload


MyInventoryItemFilter Methods

The MyInventoryItemFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter Type Conversions

The MyInventoryItemFilter type exposes the following members.

Operators
Name | Description
(MyDefinitionId to MyInventoryItemFilter) |
Top
See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter Implicit Conversion (MyDefinitionId to MyInventoryItemFilter)

MyInventoryItemFilter Conversion (MyDefinitionId to MyInventoryItemFilter)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.op_Implicit(VRage.Game.MyDefinitionId)~Sandbox.ModAPI.Ingame.MyInventoryItemFilter"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator MyInventoryItemFilter (
    MyDefinitionId definitionId
)
Public Shared Widening Operator CType (
    definitionId As MyDefinitionId
) As MyInventoryItemFilter
static implicit operator MyInventoryItemFilter (
    MyDefinitionId definitionId
)
F# does not support the declaration of new casting operators.

Parameters

definitionId
Type: MyDefinitionId

[Missing <param name="definitionId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.op_Implicit(VRage.Game.MyDefinitionId)~Sandbox.ModAPI.Ingame.MyInventoryItemFilter"]

Return Value

Type: MyInventoryItemFilter

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.MyInventoryItemFilter.op_Implicit(VRage.Game.MyDefinitionId)~Sandbox.ModAPI.Ingame.MyInventoryItemFilter"]

See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter Fields

The MyInventoryItemFilter type exposes the following members.

Fields
 | Name | Description
Public field | AllSubTypes | Determines whether all subtypes of the given item ID should pass this filter check.
Public field | ItemId | Specifies an item to filter. Set AllSubTypes to true to only check the main type part of this ID.
Top
See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter.AllSubTypes Field

MyInventoryItemFilterAllSubTypes Field

Determines whether all subtypes of the given item ID should pass this filter check.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly bool AllSubTypes
Public ReadOnly AllSubTypes As Boolean
public:
initonly bool AllSubTypes
val AllSubTypes: bool

Field Value

Type: Boolean
See Also

Reference

MyInventoryItemFilter Structure


MyInventoryItemFilter.ItemId Field

MyInventoryItemFilterItemId Field

Specifies an item to filter. Set AllSubTypes to true to only check the main type part of this ID.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MyDefinitionId ItemId
Public ReadOnly ItemId As MyDefinitionId
public:
initonly MyDefinitionId ItemId
val ItemId: MyDefinitionId

Field Value

Type: MyDefinitionId
See Also

Reference

MyInventoryItemFilter Structure


MyJumpDriveStatus Enumeration

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyJumpDriveStatus"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyJumpDriveStatus
Public Enumeration MyJumpDriveStatus
public enum class MyJumpDriveStatus
type MyJumpDriveStatus
Members
Member name | Value | Description
Charging | 0 |
Ready | 1 |
Jumping | 2 |
See Also

Reference


MyLaserAntennaStatus Enumeration

Describes the current status of a laser antenna.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyLaserAntennaStatus
Public Enumeration MyLaserAntennaStatus
public enum class MyLaserAntennaStatus
type MyLaserAntennaStatus
Members
Member name | Value | Description
Idle | 0 | Not doing anything and not connected.
RotatingToTarget | 1 | Currently rotating towards the currently selected target.
SearchingTargetForAntenna | 2 | Currently searching for a laser antenna at the target.
Connecting | 3 | Currently connecting to a laser antenna.
Connected | 4 | Currently connected to a laser antenna.
OutOfRange | 5 | The target antenna is out of range.
See Also

Reference


MyPlanetElevation Enumeration

Describes what detail level to retrieve the planet elevation for.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyPlanetElevation
Public Enumeration MyPlanetElevation
public enum class MyPlanetElevation
type MyPlanetElevation
Members
Member name | Value | Description
Sealevel | 0 | Only return the distance to the planetary sealevel.
Surface | 1 | Return the distance to the closest point of the planet. This is the same value displayed in the HUD.
See Also

Reference


MyProductionItem Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyProductionItem"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyProductionItem
Public Structure MyProductionItem
public value class MyProductionItem
[<SealedAttribute>]
type MyProductionItem =  struct end

The MyProductionItem type exposes the following members.

Constructors
 | Name | Description
Public method | MyProductionItem | Initializes a new instance of the MyProductionItem class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Amount |
Public field | BlueprintId |
Public field | ItemId |
Top
See Also

Reference


MyProductionItem Constructor

Initializes a new instance of the MyProductionItem class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyProductionItem(
    uint itemId,
    MyDefinitionId blueprintId,
    MyFixedPoint amount
)
Public Sub New (
    itemId As UInteger,
    blueprintId As MyDefinitionId,
    amount As MyFixedPoint
)
public:
MyProductionItem(
    unsigned int itemId,
    MyDefinitionId blueprintId,
    MyFixedPoint amount
)
new :
        itemId : uint32 *
        blueprintId : MyDefinitionId *
        amount : MyFixedPoint -> MyProductionItem

Parameters

itemId
Type: SystemUInt32

[Missing <param name="itemId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyProductionItem.#ctor(System.UInt32,VRage.Game.MyDefinitionId,VRage.MyFixedPoint)"]

blueprintId
Type: MyDefinitionId

[Missing <param name="blueprintId"/> documentation for "M:Sandbox.ModAPI.Ingame.MyProductionItem.#ctor(System.UInt32,VRage.Game.MyDefinitionId,VRage.MyFixedPoint)"]

amount
Type: MyFixedPoint

[Missing <param name="amount"/> documentation for "M:Sandbox.ModAPI.Ingame.MyProductionItem.#ctor(System.UInt32,VRage.Game.MyDefinitionId,VRage.MyFixedPoint)"]

See Also

Reference

MyProductionItem Structure


MyProductionItem Methods

The MyProductionItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyProductionItem Structure


MyProductionItem Fields

The MyProductionItem type exposes the following members.

Fields
 | Name | Description
Public field | Amount |
Public field | BlueprintId |
Public field | ItemId |
Top
See Also

Reference

MyProductionItem Structure


MyProductionItem.Amount Field

MyProductionItemAmount Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.Ingame.MyProductionItem.Amount"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MyFixedPoint Amount
Public ReadOnly Amount As MyFixedPoint
public:
initonly MyFixedPoint Amount
val Amount: MyFixedPoint

Field Value

Type: MyFixedPoint
See Also

Reference

MyProductionItem Structure


MyProductionItem.BlueprintId Field

MyProductionItemBlueprintId Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.Ingame.MyProductionItem.BlueprintId"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly MyDefinitionId BlueprintId
Public ReadOnly BlueprintId As MyDefinitionId
public:
initonly MyDefinitionId BlueprintId
val BlueprintId: MyDefinitionId

Field Value

Type: MyDefinitionId
See Also

Reference

MyProductionItem Structure


MyProductionItem.ItemId Field

MyProductionItemItemId Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.Ingame.MyProductionItem.ItemId"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly uint ItemId
Public ReadOnly ItemId As UInteger
public:
initonly unsigned int ItemId
val ItemId: uint32

Field Value

Type: UInt32
See Also

Reference

MyProductionItem Structure


MyShipConnectorStatus Enumeration

Describes the current status of the connector.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MyShipConnectorStatus
Public Enumeration MyShipConnectorStatus
public enum class MyShipConnectorStatus
type MyShipConnectorStatus
Members
Member name | Value | Description
Unconnected | 0 | This connector is not connected to anything, nor is it near anything connectable.
Connectable | 1 | This connector is currently near something that it can connect to.
Connected | 2 | This connector is currently connected to something.
See Also

Reference


MyShipMass Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyShipMass"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyShipMass
Public Structure MyShipMass
public value class MyShipMass
[<SealedAttribute>]
type MyShipMass =  struct end

The MyShipMass type exposes the following members.

Constructors
 | Name | Description
Public method | MyShipMass | Initializes a new instance of the MyShipMass class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BaseMass | Gets the base mass of the ship.
Public field | PhysicalMass | Gets the physical mass of the ship, which accounts for inventory multiplier.
Public field | TotalMass | Gets the total mass of the ship, including cargo.
Top
See Also

Reference


MyShipMass Constructor

Initializes a new instance of the MyShipMass class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyShipMass(
    int mass,
    int totalMass,
    int physicalMass
)
Public Sub New (
    mass As Integer,
    totalMass As Integer,
    physicalMass As Integer
)
public:
MyShipMass(
    int mass,
    int totalMass,
    int physicalMass
)
new :
        mass : int *
        totalMass : int *
        physicalMass : int -> MyShipMass

Parameters

mass
Type: SystemInt32

[Missing <param name="mass"/> documentation for "M:Sandbox.ModAPI.Ingame.MyShipMass.#ctor(System.Int32,System.Int32,System.Int32)"]

totalMass
Type: SystemInt32

[Missing <param name="totalMass"/> documentation for "M:Sandbox.ModAPI.Ingame.MyShipMass.#ctor(System.Int32,System.Int32,System.Int32)"]

physicalMass
Type: SystemInt32

[Missing <param name="physicalMass"/> documentation for "M:Sandbox.ModAPI.Ingame.MyShipMass.#ctor(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

MyShipMass Structure


MyShipMass Methods

The MyShipMass type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyShipMass Structure


MyShipMass Fields

The MyShipMass type exposes the following members.

Fields
 | Name | Description
Public field | BaseMass | Gets the base mass of the ship.
Public field | PhysicalMass | Gets the physical mass of the ship, which accounts for inventory multiplier.
Public field | TotalMass | Gets the total mass of the ship, including cargo.
Top
See Also

Reference

MyShipMass Structure


MyShipMass.BaseMass Field

MyShipMassBaseMass Field

Gets the base mass of the ship.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly int BaseMass
Public ReadOnly BaseMass As Integer
public:
initonly int BaseMass
val BaseMass: int

Field Value

Type: Int32
See Also

Reference

MyShipMass Structure


MyShipMass.PhysicalMass Field

MyShipMassPhysicalMass Field

Gets the physical mass of the ship, which accounts for inventory multiplier.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly int PhysicalMass
Public ReadOnly PhysicalMass As Integer
public:
initonly int PhysicalMass
val PhysicalMass: int

Field Value

Type: Int32
See Also

Reference

MyShipMass Structure


MyShipMass.TotalMass Field

MyShipMassTotalMass Field

Gets the total mass of the ship, including cargo.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly int TotalMass
Public ReadOnly TotalMass As Integer
public:
initonly int TotalMass
val TotalMass: int

Field Value

Type: Int32
See Also

Reference

MyShipMass Structure


MyShipVelocities Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyShipVelocities"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyShipVelocities
Public Structure MyShipVelocities
public value class MyShipVelocities
[<SealedAttribute>]
type MyShipVelocities =  struct end

The MyShipVelocities type exposes the following members.

Constructors
 | Name | Description
Public method | MyShipVelocities | Initializes a new instance of the MyShipVelocities class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AngularVelocity | Gets the ship's angular velocity (rotation).
Public field | LinearVelocity | Gets the ship's linear velocity (motion).
Top
See Also

Reference


MyShipVelocities Constructor

Initializes a new instance of the MyShipVelocities class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyShipVelocities(
    Vector3D linearVelocity,
    Vector3D angularVelocity
)
Public Sub New (
    linearVelocity As Vector3D,
    angularVelocity As Vector3D
)
public:
MyShipVelocities(
    Vector3D linearVelocity,
    Vector3D angularVelocity
)
new :
        linearVelocity : Vector3D *
        angularVelocity : Vector3D -> MyShipVelocities

Parameters

linearVelocity
Type: Vector3D

[Missing <param name="linearVelocity"/> documentation for "M:Sandbox.ModAPI.Ingame.MyShipVelocities.#ctor(VRageMath.Vector3D,VRageMath.Vector3D)"]

angularVelocity
Type: Vector3D

[Missing <param name="angularVelocity"/> documentation for "M:Sandbox.ModAPI.Ingame.MyShipVelocities.#ctor(VRageMath.Vector3D,VRageMath.Vector3D)"]

See Also

Reference

MyShipVelocities Structure


MyShipVelocities Methods

The MyShipVelocities type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyShipVelocities Structure


MyShipVelocities Fields

The MyShipVelocities type exposes the following members.

Fields
 | Name | Description
Public field | AngularVelocity | Gets the ship's angular velocity (rotation).
Public field | LinearVelocity | Gets the ship's linear velocity (motion).
Top
See Also

Reference

MyShipVelocities Structure


MyShipVelocities.AngularVelocity Field

MyShipVelocitiesAngularVelocity Field

Gets the ship's angular velocity (rotation).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Vector3D AngularVelocity
Public ReadOnly AngularVelocity As Vector3D
public:
initonly Vector3D AngularVelocity
val AngularVelocity: Vector3D

Field Value

Type: Vector3D
See Also

Reference

MyShipVelocities Structure


MyShipVelocities.LinearVelocity Field

MyShipVelocitiesLinearVelocity Field

Gets the ship's linear velocity (motion).

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Vector3D LinearVelocity
Public ReadOnly LinearVelocity As Vector3D
public:
initonly Vector3D LinearVelocity
val LinearVelocity: Vector3D

Field Value

Type: Vector3D
See Also

Reference

MyShipVelocities Structure


MyTransmitTarget Enumeration

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.MyTransmitTarget"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MyTransmitTarget
<FlagsAttribute>
Public Enumeration MyTransmitTarget
[FlagsAttribute]
public enum class MyTransmitTarget
[<FlagsAttribute>]
type MyTransmitTarget
Members
Member name | Value | Description
None | 0 |
Owned | 1 |
Ally | 2 |
Neutral | 4 |
Enemy | 8 |
Everyone | 15 |
Default | 3 |
See Also

Reference


MyWaypointInfo Structure

Provides basic information about a waypoint.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct MyWaypointInfo
Public Structure MyWaypointInfo
public value class MyWaypointInfo
[<SealedAttribute>]
type MyWaypointInfo =  struct end

The MyWaypointInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MyWaypointInfo | Initializes a new instance of the MyWaypointInfo class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Coords | The coordinates of this waypoint
Public field | Name | The waypoint name
Top
See Also

Reference


MyWaypointInfo Constructor

Initializes a new instance of the MyWaypointInfo class

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyWaypointInfo(
    string name,
    Vector3D coords
)
Public Sub New (
    name As String,
    coords As Vector3D
)
public:
MyWaypointInfo(
    String^ name,
    Vector3D coords
)
new :
        name : string *
        coords : Vector3D -> MyWaypointInfo

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sandbox.ModAPI.Ingame.MyWaypointInfo.#ctor(System.String,VRageMath.Vector3D)"]

coords
Type: Vector3D

[Missing <param name="coords"/> documentation for "M:Sandbox.ModAPI.Ingame.MyWaypointInfo.#ctor(System.String,VRageMath.Vector3D)"]

See Also

Reference

MyWaypointInfo Structure


MyWaypointInfo Methods

The MyWaypointInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MyWaypointInfo Structure


MyWaypointInfo Fields

The MyWaypointInfo type exposes the following members.

Fields
 | Name | Description
Public field | Coords | The coordinates of this waypoint
Public field | Name | The waypoint name
Top
See Also

Reference

MyWaypointInfo Structure


MyWaypointInfo.Coords Field

MyWaypointInfoCoords Field

The coordinates of this waypoint

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Vector3D Coords
Public ReadOnly Coords As Vector3D
public:
initonly Vector3D Coords
val Coords: Vector3D

Field Value

Type: Vector3D
See Also

Reference

MyWaypointInfo Structure


MyWaypointInfo.Name Field

MyWaypointInfoName Field

The waypoint name

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly string Name
Public ReadOnly Name As String
public:
initonly String^ Name
val Name: string

Field Value

Type: String
See Also

Reference

MyWaypointInfo Structure


PistonStatus Enumeration

Describes the current status of the piston.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PistonStatus
Public Enumeration PistonStatus
public enum class PistonStatus
type PistonStatus
Members
Member name | Value | Description
Stopped | 0 | The piston velocity is 0 (stationary).
Extending | 1 | The piston is being extended (moving).
Extended | 2 | The piston is in its extended position (stationary).
Retracting | 3 | The piston is being retracted (moving).
Retracted | 4 | The piston is in its retracted position (stationary).
See Also

Reference


TerminalActionParameter Structure

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.TerminalActionParameter"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct TerminalActionParameter
Public Structure TerminalActionParameter
public value class TerminalActionParameter
[<SealedAttribute>]
type TerminalActionParameter =  struct end

The TerminalActionParameter type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty |
Top
Methods
 | Name | Description
 | Deserialize | Creates a TerminalActionParameter from a serialized value in a string and a type code.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Get | Creates a TerminalActionParameter from the given value.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetObjectBuilder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
 | Empty | Gets an empty parameter.
Public field | TypeCode |
Public field | Value |
Top
See Also

Reference


TerminalActionParameter Properties

The TerminalActionParameter type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty |
Top
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.IsEmpty Property

TerminalActionParameterIsEmpty Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Ingame.TerminalActionParameter.IsEmpty"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter Methods

The TerminalActionParameter type exposes the following members.

Methods
 | Name | Description
 | Deserialize | Creates a TerminalActionParameter from a serialized value in a string and a type code.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Get | Creates a TerminalActionParameter from the given value.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetObjectBuilder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.Deserialize Method

TerminalActionParameterDeserialize Method

Creates a TerminalActionParameter from a serialized value in a string and a type code.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TerminalActionParameter Deserialize(
    string serializedValue,
    TypeCode typeCode
)
Public Shared Function Deserialize (
    serializedValue As String,
    typeCode As TypeCode
) As TerminalActionParameter
public:
static TerminalActionParameter Deserialize(
    String^ serializedValue,
    TypeCode typeCode
)
static member Deserialize :
        serializedValue : string *
        typeCode : TypeCode -> TerminalActionParameter

Parameters

serializedValue
Type: SystemString
typeCode
Type: SystemTypeCode

Return Value

Type: TerminalActionParameter

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalActionParameter.Deserialize(System.String,System.TypeCode)"]

See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.Get Method

TerminalActionParameterGet Method

Creates a TerminalActionParameter from the given value.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TerminalActionParameter Get(
    Object value
)
Public Shared Function Get (
    value As Object
) As TerminalActionParameter
public:
static TerminalActionParameter Get(
    Object^ value
)
static member Get :
        value : Object -> TerminalActionParameter

Parameters

value
Type: SystemObject

Return Value

Type: TerminalActionParameter

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalActionParameter.Get(System.Object)"]

See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.GetObjectBuilder Method

TerminalActionParameterGetObjectBuilder Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalActionParameter.GetObjectBuilder"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MyObjectBuilder_ToolbarItemActionParameter GetObjectBuilder()
Public Function GetObjectBuilder As MyObjectBuilder_ToolbarItemActionParameter
public:
MyObjectBuilder_ToolbarItemActionParameter^ GetObjectBuilder()
member GetObjectBuilder : unit -> MyObjectBuilder_ToolbarItemActionParameter

Return Value

Type: MyObjectBuilder_ToolbarItemActionParameter

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalActionParameter.GetObjectBuilder"]

See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter Fields

The TerminalActionParameter type exposes the following members.

Fields
 | Name | Description
 | Empty | Gets an empty parameter.
Public field | TypeCode |
Public field | Value |
Top
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.Empty Field

TerminalActionParameterEmpty Field

Gets an empty parameter.

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly TerminalActionParameter Empty
Public Shared ReadOnly Empty As TerminalActionParameter
public:
static initonly TerminalActionParameter Empty
static val Empty: TerminalActionParameter

Field Value

Type: TerminalActionParameter
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.TypeCode Field

TerminalActionParameterTypeCode Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.Ingame.TerminalActionParameter.TypeCode"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly TypeCode TypeCode
Public ReadOnly TypeCode As TypeCode
public:
initonly TypeCode TypeCode
val TypeCode: TypeCode

Field Value

Type: TypeCode
See Also

Reference

TerminalActionParameter Structure


TerminalActionParameter.Value Field

TerminalActionParameterValue Field

[Missing <summary> documentation for "F:Sandbox.ModAPI.Ingame.TerminalActionParameter.Value"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Object Value
Public ReadOnly Value As Object
public:
initonly Object^ Value
val Value: Object

Field Value

Type: Object
See Also

Reference

TerminalActionParameter Structure


TerminalBlockExtentions Class

[Missing <summary> documentation for "T:Sandbox.ModAPI.Ingame.TerminalBlockExtentions"]

Inheritance Hierarchy
SystemObject
Sandbox.ModAPI.IngameTerminalBlockExtentions

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TerminalBlockExtentions
<ExtensionAttribute>
Public NotInheritable Class TerminalBlockExtentions
[ExtensionAttribute]
public ref class TerminalBlockExtentions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type TerminalBlockExtentions =  class end

The TerminalBlockExtentions type exposes the following members.

Methods
Name | Description
ApplyAction(IMyTerminalBlock, String) |
ApplyAction(IMyTerminalBlock, String, ListTerminalActionParameter) |
GetId |
GetInventory | Obsolete.
GetInventoryCount | Obsolete.
GetUseConveyorSystem | Obsolete.
HasAction |
HasInventory | Obsolete.
SetUseConveyorSystem | Obsolete.
Top
See Also

Reference


TerminalBlockExtentions Methods

The TerminalBlockExtentions type exposes the following members.

Methods
Name | Description
ApplyAction(IMyTerminalBlock, String) |
ApplyAction(IMyTerminalBlock, String, ListTerminalActionParameter) |
GetId |
GetInventory | Obsolete.
GetInventoryCount | Obsolete.
GetUseConveyorSystem | Obsolete.
HasAction |
HasInventory | Obsolete.
SetUseConveyorSystem | Obsolete.
Top
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.ApplyAction Method

TerminalBlockExtentionsApplyAction Method

Overload List
Name | Description
ApplyAction(IMyTerminalBlock, String) |
ApplyAction(IMyTerminalBlock, String, ListTerminalActionParameter) |
Top
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.ApplyAction Method (IMyTerminalBlock, String)

TerminalBlockExtentionsApplyAction Method (IMyTerminalBlock, String)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ApplyAction(
    this IMyTerminalBlock block,
    string actionName
)
<ExtensionAttribute>
Public Shared Sub ApplyAction (
    block As IMyTerminalBlock,
    actionName As String
)
public:
[ExtensionAttribute]
static void ApplyAction(
    IMyTerminalBlock^ block,
    String^ actionName
)
[<ExtensionAttribute>]
static member ApplyAction :
        block : IMyTerminalBlock *
        actionName : string -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

actionName
Type: SystemString

[Missing <param name="actionName"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class
ApplyAction Overload


TerminalBlockExtentions.ApplyAction Method (IMyTerminalBlock, String, List(TerminalActionParameter))

TerminalBlockExtentionsApplyAction Method (IMyTerminalBlock, String, ListTerminalActionParameter)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ApplyAction(
    this IMyTerminalBlock block,
    string actionName,
    List<TerminalActionParameter> parameters
)
<ExtensionAttribute>
Public Shared Sub ApplyAction (
    block As IMyTerminalBlock,
    actionName As String,
    parameters As List(Of TerminalActionParameter)
)
public:
[ExtensionAttribute]
static void ApplyAction(
    IMyTerminalBlock^ block,
    String^ actionName,
    List<TerminalActionParameter>^ parameters
)
[<ExtensionAttribute>]
static member ApplyAction :
        block : IMyTerminalBlock *
        actionName : string *
        parameters : List<TerminalActionParameter> -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

actionName
Type: SystemString

[Missing <param name="actionName"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

parameters
Type: System.Collections.GenericList TerminalActionParameter

[Missing <param name="parameters"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.ApplyAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String,System.Collections.Generic.List{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class
ApplyAction Overload


TerminalBlockExtentions.GetId Method

TerminalBlockExtentionsGetId Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetId(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long GetId(
    this IMyTerminalBlock block
)
<ExtensionAttribute>
Public Shared Function GetId (
    block As IMyTerminalBlock
) As Long
public:
[ExtensionAttribute]
static long long GetId(
    IMyTerminalBlock^ block
)
[<ExtensionAttribute>]
static member GetId :
        block : IMyTerminalBlock -> int64

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetId(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetId(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.GetInventory Method

TerminalBlockExtentionsGetInventory Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Int32)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the GetInventoryBase method.")]
public static IMyInventory GetInventory(
    this IMyTerminalBlock block,
    int index
)
<ExtensionAttribute>
<ObsoleteAttribute("Use the GetInventoryBase method.")>
Public Shared Function GetInventory (
    block As IMyTerminalBlock,
    index As Integer
) As IMyInventory
public:
[ExtensionAttribute]
[ObsoleteAttribute(L"Use the GetInventoryBase method.")]
static IMyInventory^ GetInventory(
    IMyTerminalBlock^ block,
    int index
)
[<ExtensionAttribute>]
[<ObsoleteAttribute("Use the GetInventoryBase method.")>]
static member GetInventory :
        block : IMyTerminalBlock *
        index : int -> IMyInventory

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Int32)"]

Return Value

Type: IMyInventory

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.GetInventoryCount Method

TerminalBlockExtentionsGetInventoryCount Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventoryCount(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the InventoryCount property.")]
public static int GetInventoryCount(
    this IMyTerminalBlock block
)
<ObsoleteAttribute("Use the InventoryCount property.")>
<ExtensionAttribute>
Public Shared Function GetInventoryCount (
    block As IMyTerminalBlock
) As Integer
public:
[ObsoleteAttribute(L"Use the InventoryCount property.")]
[ExtensionAttribute]
static int GetInventoryCount(
    IMyTerminalBlock^ block
)
[<ObsoleteAttribute("Use the InventoryCount property.")>]
[<ExtensionAttribute>]
static member GetInventoryCount :
        block : IMyTerminalBlock -> int

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventoryCount(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetInventoryCount(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.GetUseConveyorSystem Method

TerminalBlockExtentionsGetUseConveyorSystem Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")]
public static bool GetUseConveyorSystem(
    this IMyTerminalBlock block
)
<ExtensionAttribute>
<ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")>
Public Shared Function GetUseConveyorSystem (
    block As IMyTerminalBlock
) As Boolean
public:
[ExtensionAttribute]
[ObsoleteAttribute(L"Use the blocks themselves, this method is no longer reliable")]
static bool GetUseConveyorSystem(
    IMyTerminalBlock^ block
)
[<ExtensionAttribute>]
[<ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")>]
static member GetUseConveyorSystem :
        block : IMyTerminalBlock -> bool

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.GetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.HasAction Method

TerminalBlockExtentionsHasAction Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasAction(
    this IMyTerminalBlock block,
    string actionName
)
<ExtensionAttribute>
Public Shared Function HasAction (
    block As IMyTerminalBlock,
    actionName As String
) As Boolean
public:
[ExtensionAttribute]
static bool HasAction(
    IMyTerminalBlock^ block,
    String^ actionName
)
[<ExtensionAttribute>]
static member HasAction :
        block : IMyTerminalBlock *
        actionName : string -> bool

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

actionName
Type: SystemString

[Missing <param name="actionName"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasAction(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.HasInventory Method

TerminalBlockExtentionsHasInventory Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the HasInventory property.")]
public static bool HasInventory(
    this IMyTerminalBlock block
)
<ExtensionAttribute>
<ObsoleteAttribute("Use the HasInventory property.")>
Public Shared Function HasInventory (
    block As IMyTerminalBlock
) As Boolean
public:
[ExtensionAttribute]
[ObsoleteAttribute(L"Use the HasInventory property.")]
static bool HasInventory(
    IMyTerminalBlock^ block
)
[<ExtensionAttribute>]
[<ObsoleteAttribute("Use the HasInventory property.")>]
static member HasInventory :
        block : IMyTerminalBlock -> bool

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.HasInventory(Sandbox.ModAPI.Ingame.IMyTerminalBlock)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


TerminalBlockExtentions.SetUseConveyorSystem Method

TerminalBlockExtentionsSetUseConveyorSystem Method

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.SetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean)"]

Namespace: Sandbox.ModAPI.Ingame
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")]
public static void SetUseConveyorSystem(
    this IMyTerminalBlock block,
    bool use
)
<ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")>
<ExtensionAttribute>
Public Shared Sub SetUseConveyorSystem (
    block As IMyTerminalBlock,
    use As Boolean
)
public:
[ObsoleteAttribute(L"Use the blocks themselves, this method is no longer reliable")]
[ExtensionAttribute]
static void SetUseConveyorSystem(
    IMyTerminalBlock^ block,
    bool use
)
[<ObsoleteAttribute("Use the blocks themselves, this method is no longer reliable")>]
[<ExtensionAttribute>]
static member SetUseConveyorSystem :
        block : IMyTerminalBlock *
        use : bool -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.SetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean)"]

use
Type: SystemBoolean

[Missing <param name="use"/> documentation for "M:Sandbox.ModAPI.Ingame.TerminalBlockExtentions.SetUseConveyorSystem(Sandbox.ModAPI.Ingame.IMyTerminalBlock,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalBlockExtentions Class


Sandbox.ModAPI.Interfaces Namespace

[Missing <summary> documentation for "N:Sandbox.ModAPI.Interfaces"]

Classes
 | Class | Description
Public class | TerminalPropertyExtensions | Terminal block extension for property access
Interfaces
 | Interface | Description
Public interface | ITerminalAction |
Public interface | ITerminalProperty | Terminal block property definition
Public interface | ITerminalPropertyTValue | Terminal block property access


ITerminalAction Interface

[Missing <summary> documentation for "T:Sandbox.ModAPI.Interfaces.ITerminalAction"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITerminalAction
Public Interface ITerminalAction
public interface class ITerminalAction
type ITerminalAction =  interface end

The ITerminalAction type exposes the following members.

Properties
 | Name | Description
Public property | Icon |
Public property | Id |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Apply(IMyCubeBlock) |
Public method | Apply(IMyCubeBlock, ListReaderTerminalActionParameter) |
Public method | IsEnabled |
Public method | WriteValue |
Top
See Also

Reference

Sandbox.ModAPI.Interfaces Namespace


ITerminalAction Properties

The ITerminalAction type exposes the following members.

Properties
 | Name | Description
Public property | Icon |
Public property | Id |
Public property | Name |
Top
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Icon Property

ITerminalActionIcon Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Interfaces.ITerminalAction.Icon"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Icon { get; }
ReadOnly Property Icon As String
    Get
property String^ Icon {
    String^ get ();
}
abstract Icon : string with get

Property Value

Type: String
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Id Property

ITerminalActionId Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Interfaces.ITerminalAction.Id"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Id { get; }
ReadOnly Property Id As String
    Get
property String^ Id {
    String^ get ();
}
abstract Id : string with get

Property Value

Type: String
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Name Property

ITerminalActionName Property

[Missing <summary> documentation for "P:Sandbox.ModAPI.Interfaces.ITerminalAction.Name"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
StringBuilder Name { get; }
ReadOnly Property Name As StringBuilder
    Get
property StringBuilder^ Name {
    StringBuilder^ get ();
}
abstract Name : StringBuilder with get

Property Value

Type: StringBuilder
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction Methods

The ITerminalAction type exposes the following members.

Methods
 | Name | Description
Public method | Apply(IMyCubeBlock) |
Public method | Apply(IMyCubeBlock, ListReaderTerminalActionParameter) |
Public method | IsEnabled |
Public method | WriteValue |
Top
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Apply Method

ITerminalActionApply Method

Overload List
 | Name | Description
Public method | Apply(IMyCubeBlock) |
Public method | Apply(IMyCubeBlock, ListReaderTerminalActionParameter) |
Top
See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Apply Method (IMyCubeBlock)

ITerminalActionApply Method (IMyCubeBlock)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.Apply(VRage.Game.ModAPI.Ingame.IMyCubeBlock)"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Apply(
    IMyCubeBlock block
)
Sub Apply (
    block As IMyCubeBlock
)
void Apply(
    IMyCubeBlock^ block
)
abstract Apply :
        block : IMyCubeBlock -> unit

Parameters

block
Type: IMyCubeBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.Apply(VRage.Game.ModAPI.Ingame.IMyCubeBlock)"]

See Also

Reference

ITerminalAction Interface
Apply Overload
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.Apply Method (IMyCubeBlock, ListReader`1(TerminalActionParameter))

ITerminalActionApply Method (IMyCubeBlock, ListReader`1TerminalActionParameter)

[Missing <summary> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.Apply(VRage.Game.ModAPI.Ingame.IMyCubeBlock,VRage.Collections.ListReader{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Apply(
    IMyCubeBlock block,
    ListReader<TerminalActionParameter> terminalActionParameters
)
Sub Apply (
    block As IMyCubeBlock,
    terminalActionParameters As ListReader(Of TerminalActionParameter)
)
void Apply(
    IMyCubeBlock^ block,
    ListReader<TerminalActionParameter> terminalActionParameters
)
abstract Apply :
        block : IMyCubeBlock *
        terminalActionParameters : ListReader<TerminalActionParameter> -> unit

Parameters

block
Type: IMyCubeBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.Apply(VRage.Game.ModAPI.Ingame.IMyCubeBlock,VRage.Collections.ListReader{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

terminalActionParameters
Type: ListReaderTerminalActionParameter

[Missing <param name="terminalActionParameters"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.Apply(VRage.Game.ModAPI.Ingame.IMyCubeBlock,VRage.Collections.ListReader{Sandbox.ModAPI.Ingame.TerminalActionParameter})"]

See Also

Reference

ITerminalAction Interface
Apply Overload
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.IsEnabled Method

ITerminalActionIsEnabled Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.IsEnabled(VRage.Game.ModAPI.Ingame.IMyCubeBlock)"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEnabled(
    IMyCubeBlock block
)
Function IsEnabled (
    block As IMyCubeBlock
) As Boolean
bool IsEnabled(
    IMyCubeBlock^ block
)
abstract IsEnabled :
        block : IMyCubeBlock -> bool

Parameters

block
Type: IMyCubeBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.IsEnabled(VRage.Game.ModAPI.Ingame.IMyCubeBlock)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.IsEnabled(VRage.Game.ModAPI.Ingame.IMyCubeBlock)"]

See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalAction.WriteValue Method

ITerminalActionWriteValue Method

[Missing <summary> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.WriteValue(VRage.Game.ModAPI.Ingame.IMyCubeBlock,System.Text.StringBuilder)"]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void WriteValue(
    IMyCubeBlock block,
    StringBuilder appendTo
)
Sub WriteValue (
    block As IMyCubeBlock,
    appendTo As StringBuilder
)
void WriteValue(
    IMyCubeBlock^ block,
    StringBuilder^ appendTo
)
abstract WriteValue :
        block : IMyCubeBlock *
        appendTo : StringBuilder -> unit

Parameters

block
Type: IMyCubeBlock

[Missing <param name="block"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.WriteValue(VRage.Game.ModAPI.Ingame.IMyCubeBlock,System.Text.StringBuilder)"]

appendTo
Type: System.TextStringBuilder

[Missing <param name="appendTo"/> documentation for "M:Sandbox.ModAPI.Interfaces.ITerminalAction.WriteValue(VRage.Game.ModAPI.Ingame.IMyCubeBlock,System.Text.StringBuilder)"]

See Also

Reference

ITerminalAction Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty Interface

Terminal block property definition

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITerminalProperty
Public Interface ITerminalProperty
public interface class ITerminalProperty
type ITerminalProperty =  interface end

The ITerminalProperty type exposes the following members.

Properties
 | Name | Description
Public property | Id | Property Id (value name)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty Properties

The ITerminalProperty type exposes the following members.

Properties
 | Name | Description
Public property | Id | Property Id (value name)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color)
Top
See Also

Reference

ITerminalProperty Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty.Id Property

ITerminalPropertyId Property

Property Id (value name)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Id { get; }
ReadOnly Property Id As String
    Get
property String^ Id {
    String^ get ();
}
abstract Id : string with get

Property Value

Type: String
See Also

Reference

ITerminalProperty Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty.TypeName Property

ITerminalPropertyTypeName Property

Property type (bool - Boolean, float - Single, color - Color)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string TypeName { get; }
ReadOnly Property TypeName As String
    Get
property String^ TypeName {
    String^ get ();
}
abstract TypeName : string with get

Property Value

Type: String
See Also

Reference

ITerminalProperty Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty Methods

The ITerminalProperty type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

ITerminalProperty Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue) Interface

ITerminalPropertyTValue Interface

Terminal block property access

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITerminalProperty<TValue> : ITerminalProperty

Public Interface ITerminalProperty(Of TValue)
    Inherits ITerminalProperty
generic<typename TValue>
public interface class ITerminalProperty : ITerminalProperty
type ITerminalProperty<'TValue> =
    interface
        interface ITerminalProperty
    end

Type Parameters

TValue
Property type (TypeName)

The ITerminalPropertyTValue type exposes the following members.

Properties
 | Name | Description
Public property | Id | Property Id (value name) (Inherited from ITerminalProperty.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Top
Methods
 | Name | Description
Public method | GetDefaultValue | Default value of property (if value is not set, or value from block definition)
Public method | GetMaximum | Maximum value of property (value from block definition)
Public method | GetMinimum | Minimum value of property (value from block definition)
Public method | GetMininum | Obsolete. Minimum value of property (value from block definition) - this function is obsolete, because it contains typo in name, use [!:GetMinimum(Sandbox.ModAPI.Ingame.IMyCubeBlock)]
Public method | GetValue | Retrieve property value
Public method | SetValue | Set property value
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue) Properties

ITerminalPropertyTValue Properties

The ITerminalPropertyTValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Id | Property Id (value name) (Inherited from ITerminalProperty.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Top
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue) Methods

ITerminalPropertyTValue Methods

The ITerminalPropertyTValue generic type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultValue | Default value of property (if value is not set, or value from block definition)
Public method | GetMaximum | Maximum value of property (value from block definition)
Public method | GetMinimum | Minimum value of property (value from block definition)
Public method | GetMininum | Obsolete. Minimum value of property (value from block definition) - this function is obsolete, because it contains typo in name, use [!:GetMinimum(Sandbox.ModAPI.Ingame.IMyCubeBlock)]
Public method | GetValue | Retrieve property value
Public method | SetValue | Set property value
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).GetDefaultValue Method

ITerminalPropertyTValueGetDefaultValue Method

Default value of property (if value is not set, or value from block definition)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TValue GetDefaultValue(
    IMyCubeBlock block
)
Function GetDefaultValue (
    block As IMyCubeBlock
) As TValue
TValue GetDefaultValue(
    IMyCubeBlock^ block
)
abstract GetDefaultValue :
        block : IMyCubeBlock -> 'TValue

Parameters

block
Type: IMyCubeBlock
block reference

Return Value

Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).GetMaximum Method

ITerminalPropertyTValueGetMaximum Method

Maximum value of property (value from block definition)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TValue GetMaximum(
    IMyCubeBlock block
)
Function GetMaximum (
    block As IMyCubeBlock
) As TValue
TValue GetMaximum(
    IMyCubeBlock^ block
)
abstract GetMaximum :
        block : IMyCubeBlock -> 'TValue

Parameters

block
Type: IMyCubeBlock
block reference

Return Value

Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).GetMinimum Method

ITerminalPropertyTValueGetMinimum Method

Minimum value of property (value from block definition)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TValue GetMinimum(
    IMyCubeBlock block
)
Function GetMinimum (
    block As IMyCubeBlock
) As TValue
TValue GetMinimum(
    IMyCubeBlock^ block
)
abstract GetMinimum :
        block : IMyCubeBlock -> 'TValue

Parameters

block
Type: IMyCubeBlock
block reference

Return Value

Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).GetMininum Method

ITerminalPropertyTValueGetMininum Method

Note: This API is now obsolete.

Minimum value of property (value from block definition) - this function is obsolete, because it contains typo in name, use [!:GetMinimum(Sandbox.ModAPI.Ingame.IMyCubeBlock)]

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use GetMinimum instead")]
TValue GetMininum(
    IMyCubeBlock block
)
<ObsoleteAttribute("Use GetMinimum instead")>
Function GetMininum (
    block As IMyCubeBlock
) As TValue
[ObsoleteAttribute(L"Use GetMinimum instead")]
TValue GetMininum(
    IMyCubeBlock^ block
)
[<ObsoleteAttribute("Use GetMinimum instead")>]
abstract GetMininum :
        block : IMyCubeBlock -> 'TValue

Parameters

block
Type: IMyCubeBlock
block reference

Return Value

Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).GetValue Method

ITerminalPropertyTValueGetValue Method

Retrieve property value

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TValue GetValue(
    IMyCubeBlock block
)
Function GetValue (
    block As IMyCubeBlock
) As TValue
TValue GetValue(
    IMyCubeBlock^ block
)
abstract GetValue :
        block : IMyCubeBlock -> 'TValue

Parameters

block
Type: IMyCubeBlock
block reference

Return Value

Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


ITerminalProperty(TValue).SetValue Method

ITerminalPropertyTValueSetValue Method

Set property value

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetValue(
    IMyCubeBlock block,
    TValue value
)
Sub SetValue (
    block As IMyCubeBlock,
    value As TValue
)
void SetValue(
    IMyCubeBlock^ block,
    TValue value
)
abstract SetValue :
        block : IMyCubeBlock *
        value : 'TValue -> unit

Parameters

block
Type: IMyCubeBlock
block reference
value
Type: TValue
value of type TypeName
See Also

Reference

ITerminalPropertyTValue Interface
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions Class

Terminal block extension for property access
Inheritance Hierarchy
SystemObject
Sandbox.ModAPI.InterfacesTerminalPropertyExtensions

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TerminalPropertyExtensions
<ExtensionAttribute>
Public NotInheritable Class TerminalPropertyExtensions
[ExtensionAttribute]
public ref class TerminalPropertyExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type TerminalPropertyExtensions =  class end

The TerminalPropertyExtensions type exposes the following members.

Methods
Name | Description
AsTValue | Property type cast
AsBool | Property type cast
AsColor | Property type cast
AsFloat | Property type cast
CastTValue | Property type cast
GetDefaultValueT | Returns default value of specified property as TypeName
GetMaximumT | Returns maximum value of specified property as TypeName
GetMinimumT | Returns minimum value of specified property as TypeName
GetMininumT | Obsolete. Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String)
GetValueT | Returns value of specified property as TypeName
GetValueBool | Returns value of specified property
GetValueColor | Returns value of specified property
GetValueFloat | Returns value of specified property
IsTValue | Check property type
SetValueT | Set value of property with type of TypeName
SetValueBool | Set bool value of property
SetValueColor | Set bool value of property
SetValueFloat | Set float value of property
Top
See Also

Reference

Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions Methods

The TerminalPropertyExtensions type exposes the following members.

Methods
Name | Description
AsTValue | Property type cast
AsBool | Property type cast
AsColor | Property type cast
AsFloat | Property type cast
CastTValue | Property type cast
GetDefaultValueT | Returns default value of specified property as TypeName
GetMaximumT | Returns maximum value of specified property as TypeName
GetMinimumT | Returns minimum value of specified property as TypeName
GetMininumT | Obsolete. Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String)
GetValueT | Returns value of specified property as TypeName
GetValueBool | Returns value of specified property
GetValueColor | Returns value of specified property
GetValueFloat | Returns value of specified property
IsTValue | Check property type
SetValueT | Set value of property with type of TypeName
SetValueBool | Set bool value of property
SetValueColor | Set bool value of property
SetValueFloat | Set float value of property
Top
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.As(TValue) Method

TerminalPropertyExtensionsAsTValue Method

Property type cast

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITerminalProperty<TValue> As<TValue>(
    this ITerminalProperty property
)

<ExtensionAttribute>
Public Shared Function As(Of TValue) (
    property As ITerminalProperty
) As ITerminalProperty(Of TValue)
public:
[ExtensionAttribute]
generic<typename TValue>
static ITerminalProperty<TValue>^ As(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member As :
        property : ITerminalProperty -> ITerminalProperty<'TValue>

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Type Parameters

TValue
value of type TypeName

Return Value

Type: ITerminalProperty TValue
reference to ITerminalPropertyTValue value of specified type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.AsBool Method

TerminalPropertyExtensionsAsBool Method

Property type cast

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITerminalProperty<bool> AsBool(
    this ITerminalProperty property
)
<ExtensionAttribute>
Public Shared Function AsBool (
    property As ITerminalProperty
) As ITerminalProperty(Of Boolean)
public:
[ExtensionAttribute]
static ITerminalProperty<bool>^ AsBool(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member AsBool :
        property : ITerminalProperty -> ITerminalProperty<bool>

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Return Value

Type: ITerminalProperty Boolean
reference to ITerminalPropertyTValue value of specified type (bool)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.AsColor Method

TerminalPropertyExtensionsAsColor Method

Property type cast

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITerminalProperty<Color> AsColor(
    this ITerminalProperty property
)
<ExtensionAttribute>
Public Shared Function AsColor (
    property As ITerminalProperty
) As ITerminalProperty(Of Color)
public:
[ExtensionAttribute]
static ITerminalProperty<Color>^ AsColor(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member AsColor :
        property : ITerminalProperty -> ITerminalProperty<Color>

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Return Value

Type: ITerminalProperty Color
reference to ITerminalPropertyTValue value of specified type (Color)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.AsFloat Method

TerminalPropertyExtensionsAsFloat Method

Property type cast

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITerminalProperty<float> AsFloat(
    this ITerminalProperty property
)
<ExtensionAttribute>
Public Shared Function AsFloat (
    property As ITerminalProperty
) As ITerminalProperty(Of Single)
public:
[ExtensionAttribute]
static ITerminalProperty<float>^ AsFloat(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member AsFloat :
        property : ITerminalProperty -> ITerminalProperty<float32>

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Return Value

Type: ITerminalProperty Single
reference to ITerminalPropertyTValue value of specified type (float)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.Cast(TValue) Method

TerminalPropertyExtensionsCastTValue Method

Property type cast

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITerminalProperty<TValue> Cast<TValue>(
    this ITerminalProperty property
)

<ExtensionAttribute>
Public Shared Function Cast(Of TValue) (
    property As ITerminalProperty
) As ITerminalProperty(Of TValue)
public:
[ExtensionAttribute]
generic<typename TValue>
static ITerminalProperty<TValue>^ Cast(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member Cast :
        property : ITerminalProperty -> ITerminalProperty<'TValue>

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Type Parameters

TValue
value of type TypeName

Return Value

Type: ITerminalProperty TValue
reference to ITerminalPropertyTValue value of specified type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetDefaultValue(T) Method

TerminalPropertyExtensionsGetDefaultValueT Method

Returns default value of specified property as TypeName

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T GetDefaultValue<T>(
    this IMyTerminalBlock block,
    string propertyId
)

<ExtensionAttribute>
Public Shared Function GetDefaultValue(Of T) (
    block As IMyTerminalBlock,
    propertyId As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T GetDefaultValue(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetDefaultValue :
        block : IMyTerminalBlock *
        propertyId : string -> 'T

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Type Parameters

T
required value type of TypeName

Return Value

Type: T
property value as TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetMaximum(T) Method

TerminalPropertyExtensionsGetMaximumT Method

Returns maximum value of specified property as TypeName

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T GetMaximum<T>(
    this IMyTerminalBlock block,
    string propertyId
)

<ExtensionAttribute>
Public Shared Function GetMaximum(Of T) (
    block As IMyTerminalBlock,
    propertyId As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T GetMaximum(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetMaximum :
        block : IMyTerminalBlock *
        propertyId : string -> 'T

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Type Parameters

T
required value type of TypeName

Return Value

Type: T
property value as TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetMinimum(T) Method

TerminalPropertyExtensionsGetMinimumT Method

Returns minimum value of specified property as TypeName

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T GetMinimum<T>(
    this IMyTerminalBlock block,
    string propertyId
)

<ExtensionAttribute>
Public Shared Function GetMinimum(Of T) (
    block As IMyTerminalBlock,
    propertyId As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T GetMinimum(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetMinimum :
        block : IMyTerminalBlock *
        propertyId : string -> 'T

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Type Parameters

T
required value type of TypeName

Return Value

Type: T
property value as TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetMininum(T) Method

TerminalPropertyExtensionsGetMininumT Method

Note: This API is now obsolete.

Returns minimum value of specified property as TypeName - this call is obsolete due typo in name, use GetMinimumT(IMyTerminalBlock, String)

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use GetMinimum instead")]
public static T GetMininum<T>(
    this IMyTerminalBlock block,
    string propertyId
)

<ObsoleteAttribute("Use GetMinimum instead")>
<ExtensionAttribute>
Public Shared Function GetMininum(Of T) (
    block As IMyTerminalBlock,
    propertyId As String
) As T
public:
[ObsoleteAttribute(L"Use GetMinimum instead")]
[ExtensionAttribute]
generic<typename T>
static T GetMininum(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ObsoleteAttribute("Use GetMinimum instead")>]
[<ExtensionAttribute>]
static member GetMininum :
        block : IMyTerminalBlock *
        propertyId : string -> 'T

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Type Parameters

T
required value type of TypeName

Return Value

Type: T
property value as TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetValue(T) Method

TerminalPropertyExtensionsGetValueT Method

Returns value of specified property as TypeName

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T GetValue<T>(
    this IMyTerminalBlock block,
    string propertyId
)

<ExtensionAttribute>
Public Shared Function GetValue(Of T) (
    block As IMyTerminalBlock,
    propertyId As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T GetValue(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetValue :
        block : IMyTerminalBlock *
        propertyId : string -> 'T

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Type Parameters

T
required value type of TypeName

Return Value

Type: T
property value as TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetValueBool Method

TerminalPropertyExtensionsGetValueBool Method

Returns value of specified property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetValueBool(
    this IMyTerminalBlock block,
    string propertyId
)
<ExtensionAttribute>
Public Shared Function GetValueBool (
    block As IMyTerminalBlock,
    propertyId As String
) As Boolean
public:
[ExtensionAttribute]
static bool GetValueBool(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetValueBool :
        block : IMyTerminalBlock *
        propertyId : string -> bool

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Return Value

Type: Boolean
property value as bool

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetValueColor Method

TerminalPropertyExtensionsGetValueColor Method

Returns value of specified property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color GetValueColor(
    this IMyTerminalBlock block,
    string propertyId
)
<ExtensionAttribute>
Public Shared Function GetValueColor (
    block As IMyTerminalBlock,
    propertyId As String
) As Color
public:
[ExtensionAttribute]
static Color GetValueColor(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetValueColor :
        block : IMyTerminalBlock *
        propertyId : string -> Color

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Return Value

Type: Color
property value as Color

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.GetValueFloat Method

TerminalPropertyExtensionsGetValueFloat Method

Returns value of specified property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static float GetValueFloat(
    this IMyTerminalBlock block,
    string propertyId
)
<ExtensionAttribute>
Public Shared Function GetValueFloat (
    block As IMyTerminalBlock,
    propertyId As String
) As Single
public:
[ExtensionAttribute]
static float GetValueFloat(
    IMyTerminalBlock^ block,
    String^ propertyId
)
[<ExtensionAttribute>]
static member GetValueFloat :
        block : IMyTerminalBlock *
        propertyId : string -> float32

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)

Return Value

Type: Single
property value as float

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.Is(TValue) Method

TerminalPropertyExtensionsIsTValue Method

Check property type

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Is<TValue>(
    this ITerminalProperty property
)

<ExtensionAttribute>
Public Shared Function Is(Of TValue) (
    property As ITerminalProperty
) As Boolean
public:
[ExtensionAttribute]
generic<typename TValue>
static bool Is(
    ITerminalProperty^ property
)
[<ExtensionAttribute>]
static member Is :
        property : ITerminalProperty -> bool

Parameters

property
Type: Sandbox.ModAPI.InterfacesITerminalProperty
ITerminalPropertyTValue reference

Type Parameters

TValue
value of type TypeName

Return Value

Type: Boolean
true if type matches

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITerminalProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.SetValue(T) Method

TerminalPropertyExtensionsSetValueT Method

Set value of property with type of TypeName

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetValue<T>(
    this IMyTerminalBlock block,
    string propertyId,
    T value
)

<ExtensionAttribute>
Public Shared Sub SetValue(Of T) (
    block As IMyTerminalBlock,
    propertyId As String,
    value As T
)
public:
[ExtensionAttribute]
generic<typename T>
static void SetValue(
    IMyTerminalBlock^ block,
    String^ propertyId,
    T value
)
[<ExtensionAttribute>]
static member SetValue :
        block : IMyTerminalBlock *
        propertyId : string *
        value : 'T -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)
value
Type: T
value to set

Type Parameters

T
TypeName

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.SetValueBool Method

TerminalPropertyExtensionsSetValueBool Method

Set bool value of property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetValueBool(
    this IMyTerminalBlock block,
    string propertyId,
    bool value
)
<ExtensionAttribute>
Public Shared Sub SetValueBool (
    block As IMyTerminalBlock,
    propertyId As String,
    value As Boolean
)
public:
[ExtensionAttribute]
static void SetValueBool(
    IMyTerminalBlock^ block,
    String^ propertyId,
    bool value
)
[<ExtensionAttribute>]
static member SetValueBool :
        block : IMyTerminalBlock *
        propertyId : string *
        value : bool -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)
value
Type: SystemBoolean
value to set

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.SetValueColor Method

TerminalPropertyExtensionsSetValueColor Method

Set bool value of property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetValueColor(
    this IMyTerminalBlock block,
    string propertyId,
    Color value
)
<ExtensionAttribute>
Public Shared Sub SetValueColor (
    block As IMyTerminalBlock,
    propertyId As String,
    value As Color
)
public:
[ExtensionAttribute]
static void SetValueColor(
    IMyTerminalBlock^ block,
    String^ propertyId,
    Color value
)
[<ExtensionAttribute>]
static member SetValueColor :
        block : IMyTerminalBlock *
        propertyId : string *
        value : Color -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)
value
Type: Color
value to set

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


TerminalPropertyExtensions.SetValueFloat Method

TerminalPropertyExtensionsSetValueFloat Method

Set float value of property

Namespace: Sandbox.ModAPI.Interfaces
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetValueFloat(
    this IMyTerminalBlock block,
    string propertyId,
    float value
)
<ExtensionAttribute>
Public Shared Sub SetValueFloat (
    block As IMyTerminalBlock,
    propertyId As String,
    value As Single
)
public:
[ExtensionAttribute]
static void SetValueFloat(
    IMyTerminalBlock^ block,
    String^ propertyId,
    float value
)
[<ExtensionAttribute>]
static member SetValueFloat :
        block : IMyTerminalBlock *
        propertyId : string *
        value : float32 -> unit

Parameters

block
Type: Sandbox.ModAPI.IngameIMyTerminalBlock
block reference
propertyId
Type: SystemString
property id (name)
value
Type: SystemSingle
value to set

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMyTerminalBlock. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TerminalPropertyExtensions Class
Sandbox.ModAPI.Interfaces Namespace


Sandbox.ModAPI.Interfaces.Terminal Namespace

[Missing <summary> documentation for "N:Sandbox.ModAPI.Interfaces.Terminal"]

Interfaces
 | Interface | Description
Public interface | IMyTerminalAction | This is an interface wrapper for terminal actions that appear on a toolbar. An instance of this interface is created via MyAPIGateway.TerminalControls.CreateAction. Once created, you may modify various fields to control how the action behaves.
Public interface | IMyTerminalControl | This is the base terminal control interface. All controls implement this.
Public interface | IMyTerminalControlButton | This is a control button. When a button is clicked an action is performed.
Public interface | IMyTerminalControlCheckbox | This is a checkbox. A label appears and a box appears next to it
Public interface | IMyTerminalControlColor | This is a color control. This terminal controls allows you to select colors.
Public interface | IMyTerminalControlCombobox | This is a combobox control. It is a field that gives a drop down list that contains options that you can select.
Public interface | IMyTerminalControlLabel | This is a simple label control.
Public interface | IMyTerminalControlListbox | This is a list box. It contains a list of items that a user can select.
Public interface | IMyTerminalControlOnOffSwitch | This is an on / off switch or toggle button. It gives two options that a user can toggled between.
Public interface | IMyTerminalControlPropertyTValue | This is a control property. This is use to set properties on a block that can be referenced in the ProgrammableBlock.
Public interface | IMyTerminalControlSeparator | This is a simple line separator used to separate controls in a visible manner.
Public interface | IMyTerminalControlSlider | This is a value slider. A slider can be moved by a user and a value selected.
Public interface | IMyTerminalControlTextbox | This is a textbox where a user can enter values into.
Public interface | IMyTerminalControlTitleTooltip | This is a base interface for other interfaces. Almost all controls implement this, and allows you to set the label (Title) of the control and also the tooltip that appears when hovering over the control.
Public interface | IMyTerminalValueControlTValue | This is a value control interface that a few controls implement. When a value changes, the Setter action is performed. When a value is queried the Getter action is performed.


IMyTerminalAction Interface

This is an interface wrapper for terminal actions that appear on a toolbar. An instance of this interface is created via MyAPIGateway.TerminalControls.CreateAction. Once created, you may modify various fields to control how the action behaves.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalAction : ITerminalAction
Public Interface IMyTerminalAction
    Inherits ITerminalAction
public interface class IMyTerminalAction : ITerminalAction
type IMyTerminalAction =
    interface
        interface ITerminalAction
    end

The IMyTerminalAction type exposes the following members.

Properties
 | Name | Description
Public property | Action | This is the action taken when an action is performed.
Public property | Enabled | Allows you to set if this action is enabled or disabled
Public property | Icon | Allows you to set the Icon of this action. It's a link to an icon texture.
Public property | Id | (Inherited from ITerminalAction.)
Public property | InvalidToolbarTypes | Allows you to set which toolbar type this action is invalid for. Adding to this means this action may not be added to that toolbar type.
Public property | Name | Allows you to set the name of the Action
Public property | ValidForGroups | Allows you to set if this action is valid in groups
Public property | Writer | This allows you to set the "Icon Text" of an action (the text that appears under the icon in the toolbar)
Top
Methods
 | Name | Description
Public method | Apply(IMyCubeBlock) | (Inherited from ITerminalAction.)
Public method | Apply(IMyCubeBlock, ListReaderTerminalActionParameter) | (Inherited from ITerminalAction.)
Public method | IsEnabled | (Inherited from ITerminalAction.)
Public method | WriteValue | (Inherited from ITerminalAction.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction Properties

The IMyTerminalAction type exposes the following members.

Properties
 | Name | Description
Public property | Action | This is the action taken when an action is performed.
Public property | Enabled | Allows you to set if this action is enabled or disabled
Public property | Icon | Allows you to set the Icon of this action. It's a link to an icon texture.
Public property | Id | (Inherited from ITerminalAction.)
Public property | InvalidToolbarTypes | Allows you to set which toolbar type this action is invalid for. Adding to this means this action may not be added to that toolbar type.
Public property | Name | Allows you to set the name of the Action
Public property | ValidForGroups | Allows you to set if this action is valid in groups
Public property | Writer | This allows you to set the "Icon Text" of an action (the text that appears under the icon in the toolbar)
Top
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.Action Property

IMyTerminalActionAction Property

This is the action taken when an action is performed.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock> Action { get; set; }
Property Action As Action(Of IMyTerminalBlock)
    Get
    Set
property Action<IMyTerminalBlock^>^ Action {
    Action<IMyTerminalBlock^>^ get ();
    void set (Action<IMyTerminalBlock^>^ value);
}
abstract Action : Action<IMyTerminalBlock> with get, set

Property Value

Type: Action IMyTerminalBlock
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.Enabled Property

IMyTerminalActionEnabled Property

Allows you to set if this action is enabled or disabled

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<IMyTerminalBlock, bool> Enabled { get; set; }
Property Enabled As Func(Of IMyTerminalBlock, Boolean)
    Get
    Set
property Func<IMyTerminalBlock^, bool>^ Enabled {
    Func<IMyTerminalBlock^, bool>^ get ();
    void set (Func<IMyTerminalBlock^, bool>^ value);
}
abstract Enabled : Func<IMyTerminalBlock, bool> with get, set

Property Value

Type: Func IMyTerminalBlock, Boolean
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.Icon Property

IMyTerminalActionIcon Property

Allows you to set the Icon of this action. It's a link to an icon texture.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Icon { get; set; }
Property Icon As String
    Get
    Set
property String^ Icon {
    String^ get ();
    void set (String^ value);
}
abstract Icon : string with get, set

Property Value

Type: String

Implements

ITerminalActionIcon
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.InvalidToolbarTypes Property

IMyTerminalActionInvalidToolbarTypes Property

Allows you to set which toolbar type this action is invalid for. Adding to this means this action may not be added to that toolbar type.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<MyToolbarType> InvalidToolbarTypes { get; set; }
Property InvalidToolbarTypes As List(Of MyToolbarType)
    Get
    Set
property List<MyToolbarType>^ InvalidToolbarTypes {
    List<MyToolbarType>^ get ();
    void set (List<MyToolbarType>^ value);
}
abstract InvalidToolbarTypes : List<MyToolbarType> with get, set

Property Value

Type: List MyToolbarType
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.Name Property

IMyTerminalActionName Property

Allows you to set the name of the Action

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
StringBuilder Name { get; set; }
Property Name As StringBuilder
    Get
    Set
property StringBuilder^ Name {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}
abstract Name : StringBuilder with get, set

Property Value

Type: StringBuilder

Implements

ITerminalActionName
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.ValidForGroups Property

IMyTerminalActionValidForGroups Property

Allows you to set if this action is valid in groups

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ValidForGroups { get; set; }
Property ValidForGroups As Boolean
    Get
    Set
property bool ValidForGroups {
    bool get ();
    void set (bool value);
}
abstract ValidForGroups : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction.Writer Property

IMyTerminalActionWriter Property

This allows you to set the "Icon Text" of an action (the text that appears under the icon in the toolbar)

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock, StringBuilder> Writer { get; set; }
Property Writer As Action(Of IMyTerminalBlock, StringBuilder)
    Get
    Set
property Action<IMyTerminalBlock^, StringBuilder^>^ Writer {
    Action<IMyTerminalBlock^, StringBuilder^>^ get ();
    void set (Action<IMyTerminalBlock^, StringBuilder^>^ value);
}
abstract Writer : Action<IMyTerminalBlock, StringBuilder> with get, set

Property Value

Type: Action IMyTerminalBlock, StringBuilder
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalAction Methods

The IMyTerminalAction type exposes the following members.

Methods
 | Name | Description
Public method | Apply(IMyCubeBlock) | (Inherited from ITerminalAction.)
Public method | Apply(IMyCubeBlock, ListReaderTerminalActionParameter) | (Inherited from ITerminalAction.)
Public method | IsEnabled | (Inherited from ITerminalAction.)
Public method | WriteValue | (Inherited from ITerminalAction.)
Top
See Also

Reference

IMyTerminalAction Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl Interface

This is the base terminal control interface. All controls implement this.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControl
Public Interface IMyTerminalControl
public interface class IMyTerminalControl
type IMyTerminalControl =  interface end

The IMyTerminalControl type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled
Public property | Id | Identifier of control
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group
Public property | Visible | Allows you to set if the control is visible
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls.
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl Properties

The IMyTerminalControl type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled
Public property | Id | Identifier of control
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group
Public property | Visible | Allows you to set if the control is visible
Top
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.Enabled Property

IMyTerminalControlEnabled Property

Allows you to set if the control is enabled

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<IMyTerminalBlock, bool> Enabled { get; set; }
Property Enabled As Func(Of IMyTerminalBlock, Boolean)
    Get
    Set
property Func<IMyTerminalBlock^, bool>^ Enabled {
    Func<IMyTerminalBlock^, bool>^ get ();
    void set (Func<IMyTerminalBlock^, bool>^ value);
}
abstract Enabled : Func<IMyTerminalBlock, bool> with get, set

Property Value

Type: Func IMyTerminalBlock, Boolean
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.Id Property

IMyTerminalControlId Property

Identifier of control

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Id { get; }
ReadOnly Property Id As String
    Get
property String^ Id {
    String^ get ();
}
abstract Id : string with get

Property Value

Type: String
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.SupportsMultipleBlocks Property

IMyTerminalControlSupportsMultipleBlocks Property

Allows you to set if the control is visible when the block is selected as a group

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsMultipleBlocks { get; set; }
Property SupportsMultipleBlocks As Boolean
    Get
    Set
property bool SupportsMultipleBlocks {
    bool get ();
    void set (bool value);
}
abstract SupportsMultipleBlocks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.Visible Property

IMyTerminalControlVisible Property

Allows you to set if the control is visible

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<IMyTerminalBlock, bool> Visible { get; set; }
Property Visible As Func(Of IMyTerminalBlock, Boolean)
    Get
    Set
property Func<IMyTerminalBlock^, bool>^ Visible {
    Func<IMyTerminalBlock^, bool>^ get ();
    void set (Func<IMyTerminalBlock^, bool>^ value);
}
abstract Visible : Func<IMyTerminalBlock, bool> with get, set

Property Value

Type: Func IMyTerminalBlock, Boolean
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl Methods

The IMyTerminalControl type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls.
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state
Top
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.RedrawControl Method

IMyTerminalControlRedrawControl Method

Recreates the control GUI. This allows you to update the Title of some controls.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RedrawControl()
Sub RedrawControl
void RedrawControl()
abstract RedrawControl : unit -> unit
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControl.UpdateVisual Method

IMyTerminalControlUpdateVisual Method

This updates a control that is currently displayed, allowing you to refresh it's state

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateVisual()
Sub UpdateVisual
void UpdateVisual()
abstract UpdateVisual : unit -> unit
See Also

Reference

IMyTerminalControl Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlButton Interface

This is a control button. When a button is clicked an action is performed.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlButton : IMyTerminalControl,
    IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlButton
    Inherits IMyTerminalControl, IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlButton : IMyTerminalControl,
    IMyTerminalControlTitleTooltip
type IMyTerminalControlButton =
    interface
        interface IMyTerminalControl
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlButton type exposes the following members.

Properties
 | Name | Description
Public property | Action | The action taken when a button is clicked
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlButton Properties

The IMyTerminalControlButton type exposes the following members.

Properties
 | Name | Description
Public property | Action | The action taken when a button is clicked
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlButton Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlButton.Action Property

IMyTerminalControlButtonAction Property

The action taken when a button is clicked

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock> Action { get; set; }
Property Action As Action(Of IMyTerminalBlock)
    Get
    Set
property Action<IMyTerminalBlock^>^ Action {
    Action<IMyTerminalBlock^>^ get ();
    void set (Action<IMyTerminalBlock^>^ value);
}
abstract Action : Action<IMyTerminalBlock> with get, set

Property Value

Type: Action IMyTerminalBlock
See Also

Reference

IMyTerminalControlButton Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlButton Methods

The IMyTerminalControlButton type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlButton Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCheckbox Interface

This is a checkbox. A label appears and a box appears next to it

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlCheckbox : IMyTerminalControl,
    IMyTerminalValueControl<bool>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlCheckbox
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of Boolean), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlCheckbox : IMyTerminalControl,
    IMyTerminalValueControl<bool>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlCheckbox =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<bool>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlCheckbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | OffText | The "off" label text
Public property | OnText | The "on" label text
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCheckbox Properties

The IMyTerminalControlCheckbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | OffText | The "off" label text
Public property | OnText | The "on" label text
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlCheckbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCheckbox.OffText Property

IMyTerminalControlCheckboxOffText Property

The "off" label text

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId OffText { get; set; }
Property OffText As MyStringId
    Get
    Set
property MyStringId OffText {
    MyStringId get ();
    void set (MyStringId value);
}
abstract OffText : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlCheckbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCheckbox.OnText Property

IMyTerminalControlCheckboxOnText Property

The "on" label text

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId OnText { get; set; }
Property OnText As MyStringId
    Get
    Set
property MyStringId OnText {
    MyStringId get ();
    void set (MyStringId value);
}
abstract OnText : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlCheckbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCheckbox Methods

The IMyTerminalControlCheckbox type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlCheckbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlColor Interface

This is a color control. This terminal controls allows you to select colors.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlColor : IMyTerminalControl,
    IMyTerminalValueControl<Color>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlColor
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of Color), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlColor : IMyTerminalControl,
    IMyTerminalValueControl<Color>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlColor =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<Color>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlColor type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlColor Properties

The IMyTerminalControlColor type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlColor Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlColor Methods

The IMyTerminalControlColor type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlColor Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCombobox Interface

This is a combobox control. It is a field that gives a drop down list that contains options that you can select.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlCombobox : IMyTerminalControl,
    IMyTerminalValueControl<long>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlCombobox
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of Long), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlCombobox : IMyTerminalControl,
    IMyTerminalValueControl<long long>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlCombobox =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<int64>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlCombobox type exposes the following members.

Properties
 | Name | Description
Public property | ComboBoxContent | This allows you to set the content of the combo box itself.
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCombobox Properties

The IMyTerminalControlCombobox type exposes the following members.

Properties
 | Name | Description
Public property | ComboBoxContent | This allows you to set the content of the combo box itself.
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlCombobox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCombobox.ComboBoxContent Property

IMyTerminalControlComboboxComboBoxContent Property

This allows you to set the content of the combo box itself.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<List<MyTerminalControlComboBoxItem>> ComboBoxContent { get; set; }
Property ComboBoxContent As Action(Of List(Of MyTerminalControlComboBoxItem))
    Get
    Set
property Action<List<MyTerminalControlComboBoxItem>^>^ ComboBoxContent {
    Action<List<MyTerminalControlComboBoxItem>^>^ get ();
    void set (Action<List<MyTerminalControlComboBoxItem>^>^ value);
}
abstract ComboBoxContent : Action<List<MyTerminalControlComboBoxItem>> with get, set

Property Value

Type: Action List MyTerminalControlComboBoxItem
See Also

Reference

IMyTerminalControlCombobox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlCombobox Methods

The IMyTerminalControlCombobox type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlCombobox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlLabel Interface

This is a simple label control.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlLabel : IMyTerminalControl
Public Interface IMyTerminalControlLabel
    Inherits IMyTerminalControl
public interface class IMyTerminalControlLabel : IMyTerminalControl
type IMyTerminalControlLabel =
    interface
        interface IMyTerminalControl
    end

The IMyTerminalControlLabel type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Label | The text on the label
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlLabel Properties

The IMyTerminalControlLabel type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Label | The text on the label
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlLabel Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlLabel.Label Property

IMyTerminalControlLabelLabel Property

The text on the label

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId Label { get; set; }
Property Label As MyStringId
    Get
    Set
property MyStringId Label {
    MyStringId get ();
    void set (MyStringId value);
}
abstract Label : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlLabel Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlLabel Methods

The IMyTerminalControlLabel type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlLabel Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox Interface

This is a list box. It contains a list of items that a user can select.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlListbox : IMyTerminalControl,
    IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlListbox
    Inherits IMyTerminalControl, IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlListbox : IMyTerminalControl,
    IMyTerminalControlTitleTooltip
type IMyTerminalControlListbox =
    interface
        interface IMyTerminalControl
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlListbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | ItemSelected | This is triggered when an item is selected. Can contain more than one item if Multiselect is true.
Public property | ListContent | This is triggered when you need to populate the list with list items. The first list is the items in the list box, and the second list is the selected items in the list.
Public property | Multiselect | This allows you to enable/disable multiple item selection
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Public property | VisibleRowsCount | This allows you to set how many rows are visible in the list box.
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox Properties

The IMyTerminalControlListbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | ItemSelected | This is triggered when an item is selected. Can contain more than one item if Multiselect is true.
Public property | ListContent | This is triggered when you need to populate the list with list items. The first list is the items in the list box, and the second list is the selected items in the list.
Public property | Multiselect | This allows you to enable/disable multiple item selection
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Public property | VisibleRowsCount | This allows you to set how many rows are visible in the list box.
Top
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox.ItemSelected Property

IMyTerminalControlListboxItemSelected Property

This is triggered when an item is selected. Can contain more than one item if Multiselect is true.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock, List<MyTerminalControlListBoxItem>> ItemSelected { set; }
WriteOnly Property ItemSelected As Action(Of IMyTerminalBlock, List(Of MyTerminalControlListBoxItem))
    Set
property Action<IMyTerminalBlock^, List<MyTerminalControlListBoxItem^>^>^ ItemSelected {
    void set (Action<IMyTerminalBlock^, List<MyTerminalControlListBoxItem^>^>^ value);
}
abstract ItemSelected : Action<IMyTerminalBlock, List<MyTerminalControlListBoxItem>> with set

Property Value

Type: Action IMyTerminalBlock, List MyTerminalControlListBoxItem
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox.ListContent Property

IMyTerminalControlListboxListContent Property

This is triggered when you need to populate the list with list items. The first list is the items in the list box, and the second list is the selected items in the list.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock, List<MyTerminalControlListBoxItem>, List<MyTerminalControlListBoxItem>> ListContent { set; }
WriteOnly Property ListContent As Action(Of IMyTerminalBlock, List(Of MyTerminalControlListBoxItem), List(Of MyTerminalControlListBoxItem))
    Set
property Action<IMyTerminalBlock^, List<MyTerminalControlListBoxItem^>^, List<MyTerminalControlListBoxItem^>^>^ ListContent {
    void set (Action<IMyTerminalBlock^, List<MyTerminalControlListBoxItem^>^, List<MyTerminalControlListBoxItem^>^>^ value);
}
abstract ListContent : Action<IMyTerminalBlock, List<MyTerminalControlListBoxItem>, List<MyTerminalControlListBoxItem>> with set

Property Value

Type: Action IMyTerminalBlock, List MyTerminalControlListBoxItem, List MyTerminalControlListBoxItem
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox.Multiselect Property

IMyTerminalControlListboxMultiselect Property

This allows you to enable/disable multiple item selection

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Multiselect { get; set; }
Property Multiselect As Boolean
    Get
    Set
property bool Multiselect {
    bool get ();
    void set (bool value);
}
abstract Multiselect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox.VisibleRowsCount Property

IMyTerminalControlListboxVisibleRowsCount Property

This allows you to set how many rows are visible in the list box.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int VisibleRowsCount { get; set; }
Property VisibleRowsCount As Integer
    Get
    Set
property int VisibleRowsCount {
    int get ();
    void set (int value);
}
abstract VisibleRowsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlListbox Methods

The IMyTerminalControlListbox type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlListbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlOnOffSwitch Interface

This is an on / off switch or toggle button. It gives two options that a user can toggled between.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlOnOffSwitch : IMyTerminalControl,
    IMyTerminalValueControl<bool>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlOnOffSwitch
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of Boolean), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlOnOffSwitch : IMyTerminalControl,
    IMyTerminalValueControl<bool>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlOnOffSwitch =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<bool>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlOnOffSwitch type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | OffText | The label for the "off" switch
Public property | OnText | The label for the "on" switch
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlOnOffSwitch Properties

The IMyTerminalControlOnOffSwitch type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | OffText | The label for the "off" switch
Public property | OnText | The label for the "on" switch
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlOnOffSwitch Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlOnOffSwitch.OffText Property

IMyTerminalControlOnOffSwitchOffText Property

The label for the "off" switch

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId OffText { get; set; }
Property OffText As MyStringId
    Get
    Set
property MyStringId OffText {
    MyStringId get ();
    void set (MyStringId value);
}
abstract OffText : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlOnOffSwitch Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlOnOffSwitch.OnText Property

IMyTerminalControlOnOffSwitchOnText Property

The label for the "on" switch

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId OnText { get; set; }
Property OnText As MyStringId
    Get
    Set
property MyStringId OnText {
    MyStringId get ();
    void set (MyStringId value);
}
abstract OnText : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlOnOffSwitch Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlOnOffSwitch Methods

The IMyTerminalControlOnOffSwitch type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlOnOffSwitch Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlProperty(TValue) Interface

IMyTerminalControlPropertyTValue Interface

This is a control property. This is use to set properties on a block that can be referenced in the ProgrammableBlock.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlProperty<TValue> : IMyTerminalControl,
    IMyTerminalValueControl<TValue>, ITerminalProperty

Public Interface IMyTerminalControlProperty(Of TValue)
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of TValue), ITerminalProperty
generic<typename TValue>
public interface class IMyTerminalControlProperty : IMyTerminalControl,
    IMyTerminalValueControl<TValue>, ITerminalProperty
type IMyTerminalControlProperty<'TValue> =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<'TValue>
        interface ITerminalProperty
    end

Type Parameters

TValue

The IMyTerminalControlPropertyTValue type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlProperty(TValue) Properties

IMyTerminalControlPropertyTValue Properties

The IMyTerminalControlPropertyTValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlPropertyTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlProperty(TValue) Methods

IMyTerminalControlPropertyTValue Methods

The IMyTerminalControlPropertyTValue generic type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlPropertyTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSeparator Interface

This is a simple line separator used to separate controls in a visible manner.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlSeparator : IMyTerminalControl
Public Interface IMyTerminalControlSeparator
    Inherits IMyTerminalControl
public interface class IMyTerminalControlSeparator : IMyTerminalControl
type IMyTerminalControlSeparator =
    interface
        interface IMyTerminalControl
    end

The IMyTerminalControlSeparator type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSeparator Properties

The IMyTerminalControlSeparator type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlSeparator Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSeparator Methods

The IMyTerminalControlSeparator type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlSeparator Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider Interface

This is a value slider. A slider can be moved by a user and a value selected.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlSlider : IMyTerminalControl,
    IMyTerminalValueControl<float>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlSlider
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of Single), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlSlider : IMyTerminalControl,
    IMyTerminalValueControl<float>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlSlider =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<float32>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlSlider type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Public property | Writer | This is triggered when a slider value is modified. Appending to the stringbuilder allows you to modify the text that is displayed along side the slider when it updates.
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | SetDualLogLimits(Single, Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale at both ends
Public method | SetDualLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale at both ends
Public method | SetLimits(Single, Single) | Allows you to set the upper and lower limits of the slider
Public method | SetLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates
Public method | SetLogLimits(Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale
Public method | SetLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider Properties

The IMyTerminalControlSlider type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Public property | Writer | This is triggered when a slider value is modified. Appending to the stringbuilder allows you to modify the text that is displayed along side the slider when it updates.
Top
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.Writer Property

IMyTerminalControlSliderWriter Property

This is triggered when a slider value is modified. Appending to the stringbuilder allows you to modify the text that is displayed along side the slider when it updates.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock, StringBuilder> Writer { get; set; }
Property Writer As Action(Of IMyTerminalBlock, StringBuilder)
    Get
    Set
property Action<IMyTerminalBlock^, StringBuilder^>^ Writer {
    Action<IMyTerminalBlock^, StringBuilder^>^ get ();
    void set (Action<IMyTerminalBlock^, StringBuilder^>^ value);
}
abstract Writer : Action<IMyTerminalBlock, StringBuilder> with get, set

Property Value

Type: Action IMyTerminalBlock, StringBuilder
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider Methods

The IMyTerminalControlSlider type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | SetDualLogLimits(Single, Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale at both ends
Public method | SetDualLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale at both ends
Public method | SetLimits(Single, Single) | Allows you to set the upper and lower limits of the slider
Public method | SetLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates
Public method | SetLogLimits(Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale
Public method | SetLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetDualLogLimits Method

IMyTerminalControlSliderSetDualLogLimits Method

Overload List
 | Name | Description
Public method | SetDualLogLimits(Single, Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale at both ends
Public method | SetDualLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale at both ends
Top
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetDualLogLimits Method (Single, Single, Single)

IMyTerminalControlSliderSetDualLogLimits Method (Single, Single, Single)

Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale at both ends

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetDualLogLimits(
    float absMin,
    float absMax,
    float centerBand
)
Sub SetDualLogLimits (
    absMin As Single,
    absMax As Single,
    centerBand As Single
)
void SetDualLogLimits(
    float absMin,
    float absMax,
    float centerBand
)
abstract SetDualLogLimits :
        absMin : float32 *
        absMax : float32 *
        centerBand : float32 -> unit

Parameters

absMin
Type: SystemSingle

[Missing <param name="absMin"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Single,System.Single,System.Single)"]

absMax
Type: SystemSingle

[Missing <param name="absMax"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Single,System.Single,System.Single)"]

centerBand
Type: SystemSingle

[Missing <param name="centerBand"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Single,System.Single,System.Single)"]

See Also

Reference

IMyTerminalControlSlider Interface
SetDualLogLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetDualLogLimits Method (Func(IMyTerminalBlock, Single), Func(IMyTerminalBlock, Single), Single)

IMyTerminalControlSliderSetDualLogLimits Method (FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single, Single)

Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale at both ends

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetDualLogLimits(
    Func<IMyTerminalBlock, float> minGetter,
    Func<IMyTerminalBlock, float> maxGetter,
    float centerBand
)
Sub SetDualLogLimits (
    minGetter As Func(Of IMyTerminalBlock, Single),
    maxGetter As Func(Of IMyTerminalBlock, Single),
    centerBand As Single
)
void SetDualLogLimits(
    Func<IMyTerminalBlock^, float>^ minGetter,
    Func<IMyTerminalBlock^, float>^ maxGetter,
    float centerBand
)
abstract SetDualLogLimits :
        minGetter : Func<IMyTerminalBlock, float32> *
        maxGetter : Func<IMyTerminalBlock, float32> *
        centerBand : float32 -> unit

Parameters

minGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="minGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Single)"]

maxGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="maxGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Single)"]

centerBand
Type: SystemSingle

[Missing <param name="centerBand"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetDualLogLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Single)"]

See Also

Reference

IMyTerminalControlSlider Interface
SetDualLogLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLimits Method

IMyTerminalControlSliderSetLimits Method

Overload List
 | Name | Description
Public method | SetLimits(Single, Single) | Allows you to set the upper and lower limits of the slider
Public method | SetLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates
Top
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLimits Method (Single, Single)

IMyTerminalControlSliderSetLimits Method (Single, Single)

Allows you to set the upper and lower limits of the slider

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLimits(
    float min,
    float max
)
Sub SetLimits (
    min As Single,
    max As Single
)
void SetLimits(
    float min,
    float max
)
abstract SetLimits :
        min : float32 *
        max : float32 -> unit

Parameters

min
Type: SystemSingle
Minimum value
max
Type: SystemSingle
Maximum value
See Also

Reference

IMyTerminalControlSlider Interface
SetLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLimits Method (Func(IMyTerminalBlock, Single), Func(IMyTerminalBlock, Single))

IMyTerminalControlSliderSetLimits Method (FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single)

Allows you to set the upper and lower limits of the slider with delegates

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLimits(
    Func<IMyTerminalBlock, float> minGetter,
    Func<IMyTerminalBlock, float> maxGetter
)
Sub SetLimits (
    minGetter As Func(Of IMyTerminalBlock, Single),
    maxGetter As Func(Of IMyTerminalBlock, Single)
)
void SetLimits(
    Func<IMyTerminalBlock^, float>^ minGetter,
    Func<IMyTerminalBlock^, float>^ maxGetter
)
abstract SetLimits :
        minGetter : Func<IMyTerminalBlock, float32> *
        maxGetter : Func<IMyTerminalBlock, float32> -> unit

Parameters

minGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="minGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single})"]

maxGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="maxGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single})"]

See Also

Reference

IMyTerminalControlSlider Interface
SetLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLogLimits Method

IMyTerminalControlSliderSetLogLimits Method

Overload List
 | Name | Description
Public method | SetLogLimits(Single, Single) | Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale
Public method | SetLogLimits(FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single) | Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale
Top
See Also

Reference

IMyTerminalControlSlider Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLogLimits Method (Single, Single)

IMyTerminalControlSliderSetLogLimits Method (Single, Single)

Allows you to set the upper and lower limits of the slider, interpolating on a logarithmic scale

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLogLimits(
    float min,
    float max
)
Sub SetLogLimits (
    min As Single,
    max As Single
)
void SetLogLimits(
    float min,
    float max
)
abstract SetLogLimits :
        min : float32 *
        max : float32 -> unit

Parameters

min
Type: SystemSingle

[Missing <param name="min"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLogLimits(System.Single,System.Single)"]

max
Type: SystemSingle

[Missing <param name="max"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLogLimits(System.Single,System.Single)"]

See Also

Reference

IMyTerminalControlSlider Interface
SetLogLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlSlider.SetLogLimits Method (Func(IMyTerminalBlock, Single), Func(IMyTerminalBlock, Single))

IMyTerminalControlSliderSetLogLimits Method (FuncIMyTerminalBlock, Single, FuncIMyTerminalBlock, Single)

Allows you to set the upper and lower limits of the slider with delegates, interpolating on a logarithmic scale

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLogLimits(
    Func<IMyTerminalBlock, float> minGetter,
    Func<IMyTerminalBlock, float> maxGetter
)
Sub SetLogLimits (
    minGetter As Func(Of IMyTerminalBlock, Single),
    maxGetter As Func(Of IMyTerminalBlock, Single)
)
void SetLogLimits(
    Func<IMyTerminalBlock^, float>^ minGetter,
    Func<IMyTerminalBlock^, float>^ maxGetter
)
abstract SetLogLimits :
        minGetter : Func<IMyTerminalBlock, float32> *
        maxGetter : Func<IMyTerminalBlock, float32> -> unit

Parameters

minGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="minGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLogLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single})"]

maxGetter
Type: SystemFunc IMyTerminalBlock, Single

[Missing <param name="maxGetter"/> documentation for "M:Sandbox.ModAPI.Interfaces.Terminal.IMyTerminalControlSlider.SetLogLimits(System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single},System.Func{Sandbox.ModAPI.IMyTerminalBlock,System.Single})"]

See Also

Reference

IMyTerminalControlSlider Interface
SetLogLimits Overload
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTextbox Interface

This is a textbox where a user can enter values into.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlTextbox : IMyTerminalControl,
    IMyTerminalValueControl<StringBuilder>, ITerminalProperty, IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlTextbox
    Inherits IMyTerminalControl, IMyTerminalValueControl(Of StringBuilder), ITerminalProperty,
    IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlTextbox : IMyTerminalControl,
    IMyTerminalValueControl<StringBuilder^>, ITerminalProperty, IMyTerminalControlTitleTooltip
type IMyTerminalControlTextbox =
    interface
        interface IMyTerminalControl
        interface IMyTerminalValueControl<StringBuilder>
        interface ITerminalProperty
        interface IMyTerminalControlTitleTooltip
    end

The IMyTerminalControlTextbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTextbox Properties

The IMyTerminalControlTextbox type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Allows you to set if the control is enabled (Inherited from IMyTerminalControl.)
Public property | Getter | This is triggered when the value of the control is required. (Inherited from IMyTerminalValueControlTValue.)
Public property | Id | Identifier of control (Inherited from IMyTerminalControl.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot. (Inherited from IMyTerminalValueControlTValue.)
Public property | SupportsMultipleBlocks | Allows you to set if the control is visible when the block is selected as a group (Inherited from IMyTerminalControl.)
Public property | Title | Allows you to get or set the Label that appears on the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control (Inherited from IMyTerminalControlTitleTooltip.)
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Public property | Visible | Allows you to set if the control is visible (Inherited from IMyTerminalControl.)
Top
See Also

Reference

IMyTerminalControlTextbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTextbox Methods

The IMyTerminalControlTextbox type exposes the following members.

Methods
 | Name | Description
Public method | RedrawControl | Recreates the control GUI. This allows you to update the Title of some controls. (Inherited from IMyTerminalControl.)
Public method | UpdateVisual | This updates a control that is currently displayed, allowing you to refresh it's state (Inherited from IMyTerminalControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalControlTextbox Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTitleTooltip Interface

This is a base interface for other interfaces. Almost all controls implement this, and allows you to set the label (Title) of the control and also the tooltip that appears when hovering over the control.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalControlTitleTooltip
Public Interface IMyTerminalControlTitleTooltip
public interface class IMyTerminalControlTitleTooltip
type IMyTerminalControlTitleTooltip =  interface end

The IMyTerminalControlTitleTooltip type exposes the following members.

Properties
 | Name | Description
Public property | Title | Allows you to get or set the Label that appears on the control
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTitleTooltip Properties

The IMyTerminalControlTitleTooltip type exposes the following members.

Properties
 | Name | Description
Public property | Title | Allows you to get or set the Label that appears on the control
Public property | Tooltip | Allows you to get or set the tooltip that appears when you hover over the control
Top
See Also

Reference

IMyTerminalControlTitleTooltip Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTitleTooltip.Title Property

IMyTerminalControlTitleTooltipTitle Property

Allows you to get or set the Label that appears on the control

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId Title { get; set; }
Property Title As MyStringId
    Get
    Set
property MyStringId Title {
    MyStringId get ();
    void set (MyStringId value);
}
abstract Title : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlTitleTooltip Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalControlTitleTooltip.Tooltip Property

IMyTerminalControlTitleTooltipTooltip Property

Allows you to get or set the tooltip that appears when you hover over the control

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MyStringId Tooltip { get; set; }
Property Tooltip As MyStringId
    Get
    Set
property MyStringId Tooltip {
    MyStringId get ();
    void set (MyStringId value);
}
abstract Tooltip : MyStringId with get, set

Property Value

Type: MyStringId
See Also

Reference

IMyTerminalControlTitleTooltip Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalValueControl(TValue) Interface

IMyTerminalValueControlTValue Interface

This is a value control interface that a few controls implement. When a value changes, the Setter action is performed. When a value is queried the Getter action is performed.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMyTerminalValueControl<TValue> : ITerminalProperty

Public Interface IMyTerminalValueControl(Of TValue)
    Inherits ITerminalProperty
generic<typename TValue>
public interface class IMyTerminalValueControl : ITerminalProperty
type IMyTerminalValueControl<'TValue> =
    interface
        interface ITerminalProperty
    end

Type Parameters

TValue

The IMyTerminalValueControlTValue type exposes the following members.

Properties
 | Name | Description
Public property | Getter | This is triggered when the value of the control is required.
Public property | Id | Property Id (value name) (Inherited from ITerminalProperty.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot.
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalValueControl(TValue) Properties

IMyTerminalValueControlTValue Properties

The IMyTerminalValueControlTValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Getter | This is triggered when the value of the control is required.
Public property | Id | Property Id (value name) (Inherited from ITerminalProperty.)
Public property | Setter | This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot.
Public property | TypeName | Property type (bool - Boolean, float - Single, color - Color) (Inherited from ITerminalProperty.)
Top
See Also

Reference

IMyTerminalValueControlTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalValueControl(TValue).Getter Property

IMyTerminalValueControlTValueGetter Property

This is triggered when the value of the control is required.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<IMyTerminalBlock, TValue> Getter { get; set; }
Property Getter As Func(Of IMyTerminalBlock, TValue)
    Get
    Set
property Func<IMyTerminalBlock^, TValue>^ Getter {
    Func<IMyTerminalBlock^, TValue>^ get ();
    void set (Func<IMyTerminalBlock^, TValue>^ value);
}
abstract Getter : Func<IMyTerminalBlock, 'TValue> with get, set

Property Value

Type: Func IMyTerminalBlock, TValue
See Also

Reference

IMyTerminalValueControlTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalValueControl(TValue).Setter Property

IMyTerminalValueControlTValueSetter Property

This is triggered when the value of the control is set by the user. Depending on the control, this may be called a lot.

Namespace: Sandbox.ModAPI.Interfaces.Terminal
Assembly: Sandbox.Common (in Sandbox.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<IMyTerminalBlock, TValue> Setter { get; set; }
Property Setter As Action(Of IMyTerminalBlock, TValue)
    Get
    Set
property Action<IMyTerminalBlock^, TValue>^ Setter {
    Action<IMyTerminalBlock^, TValue>^ get ();
    void set (Action<IMyTerminalBlock^, TValue>^ value);
}
abstract Setter : Action<IMyTerminalBlock, 'TValue> with get, set

Property Value

Type: Action IMyTerminalBlock, TValue
See Also

Reference

IMyTerminalValueControlTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace


IMyTerminalValueControl(TValue) Methods

IMyTerminalValueControlTValue Methods

The IMyTerminalValueControlTValue generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | AsTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsBool | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsColor | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | AsFloat | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | CastTValue | Property type cast (Defined by TerminalPropertyExtensions.)
Public Extension Method | IsTValue | Check property type (Defined by TerminalPropertyExtensions.)
Top
See Also

Reference

IMyTerminalValueControlTValue Interface
Sandbox.ModAPI.Interfaces.Terminal Namespace